Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

4 - Toutes les autres applications, les émulateurs...

> Forums de discussion > 4 - Toutes les autres applications, les émulateurs... > [résolu] Plugins Calf impossible à ajouter dans Qtractor
Dernier post
Page : 1/2   -   Aller directement à la page : 1  2 

[résolu] Plugins Calf impossible à ajouter dans Qtractor

darkpassenger Articles : 144 utilisateur non connecté
Salut,

En testant Qtractor et en fesant un tuto , je me rend compte qu'il ne "voit" pas les plugin calf pourtant installé (dans /ust/lib/calf)

- Je peux pas, dans le "connect" de "Calf Jack Host", Qtractor est grisé confused
- J'ai essayé d'ajouter le chemin /usr/lib/calf dans les propriétés des greffons, mais il ne les voit pas

Une idée ?

Merci

Fabrice
Ubuntu 16.04 LTS

sub26nico Articles : 1782 utilisateur non connecté France
Quelle distribution?
Je comprend pas ta question, tu parles de rosegarden avec un tuto sur Qtractor?

darkpassenger Articles : 144 utilisateur non connecté
Oui, Qtractor, oui pardon. Je modifie :-(

sub26nico Articles : 1782 utilisateur non connecté France
je crois tu fais erreur, jack calf host est un hébergeur de greffons pour utiliser
ces greffons en dehors d'un séquenceur. Dans le tuto, c'est calf fluidsynth qui
est utilisé.

darkpassenger Articles : 144 utilisateur non connecté
Je sais :-), seulement dans le tuto il se sert d'un plugin de Calf (que j'ai déjà, et que j'utilise).

Donc, dans ce tuto, dans la liste des greffons, il y en a (comme ZynAddSubFX) qui marche tres bien.

Seulement, le "lien" de Qtractor vers ce plugin "calf fluidsynth" n'est pas vu, ou reconnu, je sais pas sad

sub26nico Articles : 1782 utilisateur non connecté France
je viens de le faire chez moi, tout fonctionne.
J'insère calf fluidsynth sur ma piste midi, je lui colle une sf2 et j'ai du son.
Peux tu détailler plus précisément ta procédure( peut être en mettant des captures d'écrans)?

darkpassenger Articles : 144 utilisateur non connecté
Je viens de tester avec ZynAddSubFX et cela fonctionne.

Par contre, dans la liste des greffons, ceux de calf ne sont pas visible ! : Image

sub26nico Articles : 1782 utilisateur non connecté France
Dans la fenetre des greffons, en haut à droite (donc cachée par zynadd dans ta capture),
tu as bien sélectionné 'LV2' ?

sub26nico Articles : 1782 utilisateur non connecté France
Tu n'as pas répondu non plus sur ta distro...

darkpassenger Articles : 144 utilisateur non connecté
oui, je fais "Tous" dans la liste déroulante de toute façon.

Si, j'ai modifié le premier message, en pied-de-page :-) : 16.04 LTS

sub26nico Articles : 1782 utilisateur non connecté France
ok, autant pour moi redface

Chez moi, dans les préférences, greffons, je n'ai rien d'indiqué dans le champs
pour les répertoires des lv2 ou autres types de greffons.
Pourtant il les trouve.

sub26nico Articles : 1782 utilisateur non connecté France
Et si tu rajoutes le chemin vers
user/lib/lv2
?

darkpassenger Articles : 144 utilisateur non connecté
non, il est bloqué sur ses 2 types de greffons, dans la liste déroulante "Chemins" : LADSPA et VST

Image

J'ai rajouté des chemins, mais il ne les prends pas en compte :-(

sub26nico Articles : 1782 utilisateur non connecté France
Bizarre ce comportement. Tu l'as installé comment Qtractor, compilation ou via Synaptic ?

darkpassenger Articles : 144 utilisateur non connecté
Je l'ai compilé pour avoir la derniere version.

sub26nico Articles : 1782 utilisateur non connecté France
Peut être qu'il y a eu une erreur ou un oubli lors de la compilation,
c'est bizarre que tu n'aies pas accès aux lv2, pourtant ZynAddSubFx est bien en lv2, non ?

darkpassenger Articles : 144 utilisateur non connecté
ZynAddSubFx est das les VST.

olinuxx Articles : 12343 utilisateur non connecté France
darlpassenger écrit :
non, il est bloqué sur ses 2 types de greffons, dans la liste déroulante "Chemins" : LADSPA et VST


Il est possible (probable ?) que tu n'aies pas compilé Qtractor avec le support LV2.

darkpassenger Articles : 144 utilisateur non connecté
oui, je le pensais aussi, sauf que :
--enable-sse            enable SSE optimization (default=yes)
  --enable-ladspa         enable LADSPA plug-in support (default=yes)
  --enable-dssi           enable DSSI plug-in support (default=yes)
  --enable-vst            enable VST plug-in support (default=yes)
  --enable-vestige        enable VeSTige header support (default=yes)
  --enable-lv2            enable LV2 plug-in support (default=yes)
  --enable-lv2-event      enable LV2 plug-in MIDI/Event support (default=no)
  --enable-lv2-atom       enable LV2 plug-in MIDI/Atom support (default=yes)
  --enable-lv2-worker     enable LV2 plug-in Worker/schedule support


et
fabrice@:/opt/MAO/qtractor$ ./configure --help | grep lv2
  --enable-lv2            enable LV2 plug-in support (default=yes)
  --enable-lv2-event      enable LV2 plug-in MIDI/Event support (default=no)
  --enable-lv2-atom       enable LV2 plug-in MIDI/Atom support (default=yes)
  --enable-lv2-worker     enable LV2 plug-in Worker/schedule support
  --enable-lv2-ui         enable LV2 plug-in UI support (default=yes)
  --enable-lv2-external-ui
  --enable-lv2-state      enable LV2 plug-in State support (default=yes)
  --enable-lv2-state-files
  --enable-lv2-state-make-path
  --enable-lv2-programs   enable LV2 plug-in Programs support (default=yes)
  --enable-lv2-presets    enable LV2 plug-in Presets support (default=yes)
  --enable-lv2-patch      enable LV2 plug-in Patch support (default=yes)
  --enable-lv2-time       enable LV2 plug-in Time support (default=yes)
  --enable-lv2-time-position
  --enable-lv2-options    enable LV2 plug-in Options support (default=yes)
  --enable-lv2-buf-size   enable LV2 plug-in Buf-size support (default=yes)
  --enable-lv2-ui-touch   enable LV2 plug-in UI Touch interface support
  --enable-lv2-ui-idle    enable LV2 plug-in UI Idle interface support
  --enable-lv2-ui-show    enable LV2 plug-in UI Show interface support
  --enable-lv2-ui-gtk2    enable LV2 plug-in UI GTK2 native support
  --enable-lv2-ui-x11     enable LV2 plug-in UI X11 native support
  --with-lv2=PATH         use alternate LV2 header path


Donc, il est compilé avec par défaut. Mais je vais faire çà pour voir :
./configure --enable-dssi --enable-vst --enable-lv2 --enable-lv2-event && make && sudo make install


Fabrice

darkpassenger Articles : 144 utilisateur non connecté
Non, cela ne change rien cry

Page : 1/2  [Suivant]
1  2 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

bluedid29, 04:28, sam. 18 Nov 2017: Bon samedi musical ! :-) Je sens qu'aujourd'hui il va faire beau ;)
sub26nico, 20:38, ven. 17 Nov 2017: Salut et bienvenue à caline10mao :-)
sub26nico, 18:33, jeu. 16 Nov 2017: Salut et bienvenue à BlackVelvet :-)
sub26nico, 13:47, jeu. 16 Nov 2017: Salut et bienvenue à RnoxMadTan :-)
sub26nico, 23:32, mer. 15 Nov 2017: Salut et bienvenue à niconico :-)
sub26nico, 23:53, mar. 14 Nov 2017: Salut et bienvenue à jpcima :-)
olinuxx, 17:25, dim. 12 Nov 2017: Bonjour et bienvenue à loik56 :-)
sub26nico, 14:52, dim. 12 Nov 2017: Salut et bienvenue à NahMecl :-)
sub26nico, 01:23, dim. 12 Nov 2017: Salut et bienvenue à pitoufo3 :-)
olinuxx, 18:47, sam. 11 Nov 2017: bonjour et bienvenue à jmtrivial et à pacorabano :-)
sub26nico, 09:20, sam. 11 Nov 2017: Salut et bienvenue à sincosta et SamanTortega :-)
bluedid29, 00:04, sam. 11 Nov 2017: Merci m2v2 ;)