Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : JACK, PulseAudio et autres...

> Forums de discussion > 5 - Les serveurs son : JACK, PulseAudio et autres... > [RESOLU]Je n'ai plus de son depuis librazik 4
Dernier post
Page : 1/2   -   Aller directement à la page : 1  2 

[RESOLU]Je n'ai plus de son depuis librazik 4

calixtus06 utilisateur non connecté
hello, j'en suis à ma 4ème librazik et là je bloque. youtube tourne sans le son, ardour idem.. Tout est branché. Jack semble configuré correctement ainsi que pulseaudio. Jack est démarré. je relance le tout: idem.

Clic droit sur la jauge de son. Firefox est l'application qui utilise pulseaudio .. Je ne comprends toujours pas.

Est ce une question d'autorisation ? J'ai eu du mal à metrre jack en horloge interne dans ardour.

j'ai essayé de tourner sur la carte son du pc: idem.

Merci de vos éclairages

dlb utilisateur non connecté
Bonjour,

Ta carte son est peut-être "mutée" ? Ouvre alsamixer dans un terminal, touche "F6", et sélectionne ta carte. Vérifie que les canaux "master", "PCM" ne soient pas en sourdine "MM". Pour rendre actif chaque canal, tu le sélectionnes avec les touches -> et

dlb utilisateur non connecté
et

calixtus06 utilisateur non connecté
Salut, je regarderai ça ce soir. je n'y avais pas pensé effectivement.

sub26nico utilisateur non connecté France
dlb écrit :
Ta carte son est peut-être "mutée" ? Ouvre alsamixer dans un terminal, touche "F6", et sélectionne ta carte. Vérifie que les canaux "master", "PCM" ne soient pas en sourdine "MM". Pour rendre actif chaque canal, tu le sélectionnes avec les touches - et
tu appuies sur la touche 'M' pour démuter cool.

dlb utilisateur non connecté
Merci sub26nico !!!

calixtus06 utilisateur non connecté
Hello

Alsamixer ok


Image


Jack rien de particulier

Image

Est ce que pulse audio est bien ponté à jack ?

Image

calixtus06 utilisateur non connecté
Je crois que j'ai trouvé. alsa n'était pas connecté à ma berhinger à priori . Dans cadence il n'y avait pas de pilote lié à alsa.

Ardour saute sans arrêt . J'ouvre une nouvelle session. Il se ferme tout seul..Quand j'ouvre une ancienne session ( edition > preférence> jack) bon maintenant ça se ferme aussi tout seul..Désinstallation complète> réinstallation ça crash encore (??)

J'ai récupéré le son sur les autres applis: firefox, musescore hydrogen . je tente de trouver un journal de bugs.

sub26nico utilisateur non connecté France
Je ne suis pas sûr de comprendre, tu mets des images de QJackCtl, mais tu parles de Cadence confused. Un truc que tu pourrais faire, c'est virer (en les sauvegardant à un autre endroit au cas où) tous les fichiers de configurations de JACK (après l'avoir tué), puis relancer Cadence et uniquement Cadence, refaire tes réglages et voir si cela change la donne. Voir la documentation de LibraZiK pour Jack pour trouver ces fichiers. Voir aussi la page ALSA.

jujudusud utilisateur non connecté France
Salut, tu utilises QjackCtl et Cadence pour configurer JACK ?
Je penses que tu ne devrais pas utiliser les deux. Il serait plus sage d'utiliser soit QjackCtl, soit Cadence.
Ensuite, il faut que tu fasses fonctionner le son sur ton systeme avec ALSA et PulseAudio, sans utiliser JACK. Une fois que ça fonctionnera tu pourras commencer à te pencher sur le fait de faire fonctionner JACK.

Je te conseilles de supprimer tous les fichiers de configuration de QjackCtl et de Cadence pour commencer ils se trouvent dans ton /home... Ensuite tu dois n'utiliser qu'un seul des deux logiciels pour configurer, sinon ça va mettre le foutoir.

calixtus06 utilisateur non connecté
J'ai killé jackbus dans htop (f9 et sigkill) vérifié dans le terminal le status de jack " stopped"

Dans le dossier .config , il y a bien jack mais pas de fichier de config. C'est peut être normal d'ailleurs. Ah non il a un nom étrange conf.xml. Je le déplace sur le bureau.

Je démarre jack depuis cadence. Vérifie la config. ok

Redémarre ardour qui fonctionne mais sur l'horloge interne pas sur l'horloge M.clk. Où est passé l'horloge JACK ? Puis je pour les prochains lancements me servir de qjackctl qui m'est plus lisible ?

calixtus06 utilisateur non connecté
Bon ben ce soir même soucis, ardour s'éteind au bout d'une minute , 30 secondes. J'ai regardé la concordance d’échantillonnage . Je bloque .

sub26nico utilisateur non connecté France
Citation :
Puis je pour les prochains lancements me servir de qjackctl qui m'est plus lisible ?
C'est comme tu veux, mais il ne faut pas utiliser les 2 applications (Cadence et Qjackctl) simultanément sinon crac...
Peux tu mettre des captures d'écran de tes paramétrages de Cadence (notamment les 2 onglets 'Moteur' et 'Pilote' du bouton 'Configurer' stp ?
Autre point à vérifier, dans Synaptic, la présence des paquets 'librazik-optimisations-rtirq', 'librazik-optimisations-governor' et ''librazik-optimisations-pulse'et qu'ils soient, bien sûr, installés.

sub26nico utilisateur non connecté France
et aussi le retour du terminal pour :
ulimit -l -r


sub26nico utilisateur non connecté France
Citation :
Redémarre ardour qui fonctionne mais sur l'horloge interne pas sur l'horloge M.clk. Où est passé l'horloge JACK ?

Peut être qu'elle n'est pas activée dans les préférences d'Ardour.

jujudusud utilisateur non connecté France
"depuis LibraZiK4"...

Tu as installé LibraZiK4 à partir d'une installation toute fraîche de Bullseye et une partition personnelle toute neuve ?

calixtus06 utilisateur non connecté
Hello

Quand je lance l'ordi . Les applis utilisant le son ne produisent pas de son
Je lance alors qjackctrl et j'ai ce message:

19:04:10.074 Journalisation démarrée --- ven. sept. 16 19:04:10 2022 ---
19:04:10.145 Réinitialisation des statistiques.
19:04:10.162 Changement des connexions ALSA.
19:04:10.169 Script de démarrage…
19:04:10.170 pulseaudio --start
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=Aucun fichier ou dossier de ce type)
attempt to connect to server failed
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=Aucun fichier ou dossier de ce type)
attempt to connect to server failed
19:04:10.187 Changement du graphe des connexions ALSA.
19:04:10.742 Script de démarrage terminé avec succès.
19:04:10.742 JACK démarre…
19:04:10.742 /usr/bin/jackd -P70 -dalsa -r44100 -p512 -n2 -D -Chw:U192k -Phw:U192k
19:04:10.746 JACK a été démarré avec le PID=1670.
jackd 0.125.0
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
loading driver ..
apparent rate = 44100
creating alsa driver ... hw:U192k|hw:U192k|512|2|44100|0|0|nomon|swmeter|-|32bit
ATTENTION: The playback device "hw:U192k" is already in use. Please stop the application using it and run JACK again
cannot load driver module alsa
no message buffer overruns
19:04:11.012 JACK a été arrêté
19:04:12.956 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Incapable de se connecter au serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=Aucun fichier ou dossier de ce type)
attempt to connect to server failed
19:04:35.184 Script de démarrage…
19:04:35.185 pulseaudio --start
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=Aucun fichier ou dossier de ce type)
attempt to connect to server failed
19:04:35.596 Script de démarrage terminé avec succès.
19:04:35.596 JACK démarre…
19:04:35.596 /usr/bin/jackd -P70 -dalsa -r44100 -p512 -n2 -D -Chw:U192k -Phw:U192k
19:04:35.599 JACK a été démarré avec le PID=1719.
jackd 0.125.0
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
loading driver ..
apparent rate = 44100
creating alsa driver ... hw:U192k|hw:U192k|512|2|44100|0|0|nomon|swmeter|-|32bit
configuring for 44100Hz, period = 512 frames (11.6 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 32bit integer little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 2 periods for playback
19:04:37.680 Changement des connexions JACK.
19:04:37.680 Configuration du serveur sauvegardée dans "/home/nicolas/.jackdrc".
19:04:37.681 Réinitialisation des statistiques.
19:04:37.740 Client activé.
19:04:37.740 Baie de brassage désactivée.
19:04:37.740 Script post-démarrage…
19:04:37.740 pactl load-module module-jack-sink && pactl load-module module-jack-source && echo "set-default-sink jack_out" | pacmd && echo "set-default-source jack_in" | pacmd && a2j -e
19:04:37.741 Changement de la taille du tampon (512).
19:04:38.836 Changement du graphe des connexions JACK.
22
23
hardware ports export
--- enable export of hardware ports
--- start
19:04:38.837 Changement du graphe des connexions ALSA.
19:04:39.036 Script post-démarrage terminé avec statut de sortie=256.
19:04:39.038 Changement des connexions JACK.


Je relance jack et tout fonctionne mais c'est systématique.

Je ferme qjackctrl et lance cadence pour répondre à tes question ( Nico)
Cadence ne s'ouvre pas ( ??)

et depuis le terminal :

Using Tray Engine 'Qt'
Traceback (most recent call last):
  File "/usr/share/cadence/src/cadence.py", line 2344, in <module>
    gui = CadenceMainW()
  File "/usr/share/cadence/src/cadence.py", line 1110, in __init__
    self.DBusReconnect()
  File "/usr/share/cadence/src/cadence.py", line 1164, in DBusReconnect
    self.groupBox_bridges.setEnabled(False)
AttributeError: 'CadenceMainW' object has no attribute 'groupBox_bridges'



librazik-optimisations-rtirq : présent, librazik-optimisations-governor: présent , librazik-optimisations-pulse : présent

Mais librazik-apt fr, librazik-apt testers non installés.

ulimit -l -r


max locked memory           (kbytes, -l) unlimited
real-time priority                  (-r) 95


j'ai installé bulleyes en netinstall et les paquets librazik dessus. Je n'ai pas formaté la partition avant. Mais je n'ai pas l'impression de répondre à ta question.

calixtus06 utilisateur non connecté
autre bizarrerie :

Image

sub26nico utilisateur non connecté France
Citation :
Mais librazik-apt fr, librazik-apt testers non installés.

le paquet testers, c'est pour les tests, par contre le paquet librazik-apt fr, tu peux l'installer ça ne fera pas de mal
Pour ce qui est de ta bizarerie, est que jack n'est lancé automatiquement au démarrage ? (Par exemple par Cadence)

sub26nico utilisateur non connecté France
Citation :
Quand je lance l'ordi . Les applis utilisant le son ne produisent pas de son

Si ces applis sont paramétrées sur JACK, ça paraît logique. Si elles sont paramétrées sur PulseAudio, alors c'est lui qui met la zone. Vérifies que Pulseaudio utilise ta carte son interne, puis lance JACK, puis paramètres pulseaudio sur Jack source (pour les entrées) et Jack sink (pour les sorties.

jujudusud utilisateur non connecté France
Est ce que c'est normal que tu utilises JACK1 au lieu de JACK2 ?

Pour lancer JACK avec l'option temps réel il faut ajouter l'option '-R'

Page : 1/2  [Suivant]
1  2 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

calixtus06, 07:55, sam. 26 Nov 2022: Bonjour et bienvenue à Bob33 :-)
calixtus06, 08:54, mar. 22 Nov 2022: Bonjour et bienvenue à gadeu :-)
olinuxx, 10:02, dim. 20 Nov 2022: Bonjour et bienvenue à Neandertahl cool
sub26nico, 13:39, mer. 16 Nov 2022: Merci Samuel ;-)
Samuel, 21:17, lun. 14 Nov 2022: [Lien] C'est de la balle et c'est enregistré avec librazik
olinuxx, 18:53, dim. 13 Nov 2022: @christorbec : le mégaphone ne sert pas à se faire dépanner. Ouvre un fil dans le forum.
christorbec, 15:22, dim. 13 Nov 2022: changer de soundfont dans ToneLib-jam ?
calixtus06, 06:59, dim. 13 Nov 2022: Bonjour et bienvenue à Djefux :-)
calixtus06, 11:59, sam. 12 Nov 2022: Bonjour et bienvenue à zardoz45 :-)
calixtus06, 07:10, mer. 09 Nov 2022: Bonjour et bienvenue à majneb :-)
olinuxx, 10:34, lun. 07 Nov 2022: C'est légal, c'est génial, lève toi, met ton futal et lit l'éditorial ! cool
r1, 22:22, dim. 06 Nov 2022: Cet éditorial tombe pil-poil ! Merci de ne pas luj réserver un accueil glacial :-)