Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

Dernier post
Page : 1/2   -   Aller directement à la page : 1  2 

[Résolu] TASCAM US-122 MK II

Ubuntu_Studio_User utilisateur non connecté
Salutations à la communauté,

Je m'adresse à vous aujourd'hui, car je me trouve face à un problème pour lequel il n'y a peut-être pas de solutions d'ailleurs...

J'ai lu plus ou moins ce qu'il y à savoir à propos de cette carte son (Installer une Tascam US-122 MKII sur une Xubuntu ou une TangoStudio), et une question se pose...

Ne peut-on vraiment faire d'enregistrements sous Linux (pour ma part Ubuntu Studio) avec cette carte ?

J'ai suivi le tuto sur le site dédié celle-ci, mais rien de concret de mon côté.

J'ai fais divers essais, et le résultat était toujours le même...

À savoir, que si je lance de la musique eh bien j'ai du son dans mon casque...
Si je branche une guitare, j'entends le son de la guitare dans mon casque.

Alors, n'est-ce tout simplement pas possible d'enregistrer avec cette carte sous "Linux" ou existe-t-il une astuce que je n'aurais pas vue ?

Je vous dis merci d'avance pour vos réponses.

Cordialement.

olinuxx utilisateur non connecté France
Je ne comprends pas vraiment ta question ici. Tu sembles dire que la tascam est fonctionnelle dans ton message, non ? Enfin, c'est ce que je comprends vu que tu dis entendre la musique et le son de la guitare dans ton casque.

Ubuntu_Studio_User utilisateur non connecté
Salut,

Oui, effectivement elle est fonctionnelle. :-)

Mais mon souci, c'est lorsque je souhaite effectuer un enregistrement...

Je m'explique, sous Audacity, (après avoir lancé Jack et configuré mes entrées/sorties dans Audacity) lorsque je lance un enregistrement, je n'ai aucun signal qui apparaît à l'écran !

Donc aucun enregistrement ne se crée, mais pourtant j'entends le son de ma guitare dans mon casque.

J'ai été aussi faire un tour dans les connexions de Jack afin de vérifier les liaisons...
Il ne me semble pas qu'il y ait de problème a priori.

C'est pourquoi je me posais la question à propos de l'enregistrement via cette carte.

Voilà :-)

Cordialement.

sub26nico utilisateur non connecté France
peux tu poster des captures d'écrans d'Audacity ainsi que des connexions de Jack stp?

Ubuntu_Studio_User utilisateur non connecté
Salut sub26nico

Voici quelques captures...

Image

Image

Image

Image

Une chose que j'ai observée, c'est que si je change la sortie son dans Audacity ("system") et que je remplace par "PulseAudio Jack Source", je n'ai pas de son... Et ce, même si je fais les branchements nécessaire dans Jack.

Mais, d'après ce que j'ai lu, "system" représente la carte son externe, donc pas de souci à ce niveau.

Cordialement.

sub26nico utilisateur non connecté France
Pas de soucis côté Audacity, par contre ta carte n'apparait pas dans les entrées de Qjack,
peux tu nous filer les captures d'écrans de Qjack, de l'onglet 'Avancé' dans les
'Paramètres' de 'Réglages'.

Ubuntu_Studio_User utilisateur non connecté
Salut, me revoilà.

Je t'apporte ce que tu m'as demandé...

Image
Image

Alors, dans le périphérique de sortie j'ai :

Image

Et dans le périphérique d'entrée j'ai :

Image



Aussi entre grande parenthèse, il m'arrive quelques fois d'avoir ce message de Jack (avec une erreur ALSA)

08:40:18.384 DBUS : le serveur JACK démarre…
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock
08:40:18.458 Changement du graphique des connexions ALSA.
Fri Sep 29 08:40:17 2017: Starting jack server...
Fri Sep 29 08:40:17 2017: JACK server starting in realtime mode with priority 80
Fri Sep 29 08:40:17 2017: self-connect-mode is "Don't restrict self connect requests"
Fri Sep 29 08:40:18 2017: Acquired audio card Audio0
Fri Sep 29 08:40:18 2017: creating alsa driver ... hw:MKII|hw:MKII|512|2|44100|0|0|nomon|swmeter|-|32bit
Fri Sep 29 08:40:18 2017: ERROR: ALSA: Cannot open PCM device alsa_pcm for capture. Falling back to playback-only mode
Fri Sep 29 08:40:18 2017: configuring for 44100Hz, period = 512 frames (11.6 ms), buffer = 2 periods
Fri Sep 29 08:40:18 2017: ALSA: final selected sample format for playback: 24bit little-endian in 3bytes format
Fri Sep 29 08:40:18 2017: ALSA: use 2 periods for playback
Fri Sep 29 08:40:18 2017: port created: Midi-Through:midi/playback_1
Fri Sep 29 08:40:18 2017: port created: Midi-Through:midi/capture_1
Fri Sep 29 08:40:18 2017: graph reorder: new port 'system:playback_1'
Fri Sep 29 08:40:18 2017: New client 'system' with PID 0
Fri Sep 29 08:40:18 2017: graph reorder: new port 'system:playback_2'
Fri Sep 29 08:40:18 2017: graph reorder: new port 'system:midi_capture_1'
Fri Sep 29 08:40:18 2017: graph reorder: new port 'system:midi_playback_1'
Fri Sep 29 08:40:18 2017: New client 'PulseAudio JACK Sink' with PID 1715



Et puis après quelques relances (d'après ce que j'avais lu...), ça ne me l'affiche plus

08:40:18.501 DBUS : le serveur JACK a été démarré (org.jackaudio.service soit jackdbus).
08:40:18.528 Changement du graphique des connexions ALSA.
Fri Sep 29 08:40:18 2017: Connecting 'PulseAudio JACK Sink:front-left' to 'system:playback_1'
Fri Sep 29 08:40:18 2017: Connecting 'PulseAudio JACK Sink:front-right' to 'system:playback_2'
Fri Sep 29 08:40:18 2017: New client 'PulseAudio JACK Source' with PID 1715
Fri Sep 29 08:40:19 2017: Saving settings to "/home/j-l/.config/jack/conf.xml" ...
08:40:20.699 Changement des connexions JACK.
08:40:20.704 Configuration du serveur enregistrée dans « /home/j-l/.jackdrc ».
08:40:20.705 Réinitialisation des statistiques.
08:40:20.720 Client activé.
08:40:20.722 Baie de brassage désactivée.
08:40:20.794 Changement du graphique des connexions JACK.
Fri Sep 29 08:40:20 2017: New client 'qjackctl' with PID 32256


Mais je crois que ça ne change rien au fonctionnement, enfin je crois...

En tout cas, je te remercie pour l'attention que m'accorde :-)

Cordialement.

sub26nico utilisateur non connecté France
Merci, en fait c'est seulement la 2ème capture que je demandais cool
Dans celle ci, dans 'Périphérique de sortie' et 'Périphérique d'entrée',
met ta carte dans les champs appropriés, et dans Canaux 'E/S', tu mets ton nombre
exact d'entrées et sorties.

Ubuntu_Studio_User utilisateur non connecté
Ok !

Je vais faire ce que tu m'as demandé, et je te tiens au courant.

Par contre, que dois-je choisir dans le périphérique de sortie ?

hw:MKII US122 MKII (hw:0)
ou
hw:MKII,0 USB Audio (hw:0,0) ?

Y a-t-il une différence entre les deux ou même une préférence ?


P.S : Oui, pour les captures je sais, je me suis dis que je poste le tout au cas où ;)

Ubuntu_Studio_User utilisateur non connecté
Me revoici avec les résultats de ce que tu m'as demandé...

Voici deux captures qui parleront d'elles-mêmes

Image
et
Image

Et donc, dans les messages j'ai ceci (peu importe le périphérique de sortie choisi) :


Fri Sep 29 10:25:34 2017: ERROR: cannot register object path "/org/freedesktop/ReserveDevice1/Audio0": A handler is already registered for /org/freedesktop/ReserveDevice1/Audio0
Fri Sep 29 10:25:34 2017: ERROR: Failed to acquire device name : Audio0 error : A handler is already registered for /org/freedesktop/ReserveDevice1/Audio0
Fri Sep 29 10:25:34 2017: ERROR: Audio device hw:MKII cannot be acquired...
Fri Sep 29 10:25:34 2017: ERROR: Cannot initialize driver
Fri Sep 29 10:25:34 2017: ERROR: JackServer::Open failed with -1
Fri Sep 29 10:25:34 2017: ERROR: Failed to open server
Fri Sep 29 10:25:35 2017: Saving settings to "/home/j-l/.config/jack/conf.xml" ...
10:25:52.691 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Incapable de se connecter au serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.


olinuxx utilisateur non connecté France
Note modération : merci d'utiliser la balise CODE lorsque tu copies/colles des balises de code sur le site. Celles-ci permettent un meilleur affichage.
Image



Pour info Ubuntu_Studio_User, je viens d'éditer tes deux précédents messages.

Ubuntu_Studio_User utilisateur non connecté
Salut olinuxx,

Merci, et désolé pour cette négligence de ma part.
J'y prêterai attention à l'avenir.

sub26nico utilisateur non connecté France
Ubuntu_Studio_User, peux tu nous mettre les retours de terminal
(dans des balises code wink ) de :

uname -a


lsmod |grep snd


aplay -l


cat /proc/asound/cards


Ubuntu_Studio_User utilisateur non connecté
Re...

Voici les retours que tu m'as demandés sub26nico :

uname -a

Linux ubuntu-studio 4.10.0-35-lowlatency #39~16.04.1-Ubuntu SMP PREEMPT Wed Sep 13 10:06:25 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux


lsmod |grep snd

snd_usb_us122l         24576  0
snd_usb_audio         184320  1
snd_usbmidi_lib        32768  2 snd_usb_audio,snd_usb_us122l
snd_seq_dummy          16384  0
snd_hrtimer            16384  0
snd_hda_codec_hdmi     49152  1
snd_hda_codec_idt      57344  1
snd_hda_codec_generic    73728  1 snd_hda_codec_idt
snd_hda_intel          40960  3
snd_hda_codec         126976  4 snd_hda_intel,snd_hda_codec_idt,snd_hda_codec_hdmi,snd_hda_codec_generic
snd_hda_core           81920  5 snd_hda_intel,snd_hda_codec,snd_hda_codec_idt,snd_hda_codec_hdmi,snd_hda_codec_generic
snd_hwdep              16384  3 snd_hda_codec,snd_usb_audio,snd_usb_us122l
snd_pcm               102400  5 snd_hda_intel,snd_hda_codec,snd_usb_audio,snd_hda_core,snd_hda_codec_hdmi
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            32768  2 snd_seq_midi,snd_usbmidi_lib
snd_seq                65536  3 snd_seq_midi_event,snd_seq_dummy,snd_seq_midi
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              32768  3 snd_seq,snd_hrtimer,snd_pcm
snd                    77824  22 snd_hda_intel,snd_hwdep,snd_seq,snd_hda_codec,snd_hda_codec_idt,snd_usb_audio,snd_timer,snd_rawmidi,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_usbmidi_lib,snd_seq_device,snd_usb_us122l,snd_pcm
soundcore              16384  1 snd


aplay -l

**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: MKII [US122 MKII], périphérique 0: USB Audio [USB Audio]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 2: Intel [HDA Intel], périphérique 0: 92HD75B2X5 Analog [92HD75B2X5 Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 2: Intel [HDA Intel], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0


cat /proc/asound/cards

 0 [MKII           ]: USB-Audio - US122 MKII
                      TASCAM US122 MKII at usb-0000:00:1d.7-1, high speed
 2 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xd4500000 irq 29


allany utilisateur non connecté
U.S.U. écrit :
Par contre, que dois-je choisir dans le périphérique de sortie ?

hw:MKII US122 MKII (hw:0)
ou
hw:MKII,0 USB Audio (hw:0,0) ?

Y a-t-il une différence entre les deux ou même une préférence ?

Oui, il y a une différence. Le hw:0,0 doit être le driver générique des matériels "class-compliant" USB d'alsa. Tu devrais pouvoir fonctionner avec mais avec juste 2 entrées, 2 sorties, en 16 bits et 44,1 khz.
Le hw:0 doit intégrer un patch permettant de prendre en compte tout ou partie des spécificités de l'US122. A privilégier, donc.

A+

sub26nico utilisateur non connecté France
Apparemment, le souci vient de la carte, pas de tes réglages si j'en crois
l'article dont je te file le lien .
Elle peut donc être fonctionnelle sous Linux moyennant quelques manips
si j'en crois l'expérience d'autostatic (membre de la team MOD).

Ubuntu_Studio_User utilisateur non connecté
allany écrit :
Oui, il y a une différece. Le hw:0,0 doit être le driver générique des matériels "class-compliant" USB d'alsa. Tu devrais pouvoir fonctionner avec mais avec juste 2 entrées, 2 sorties, en 16 bits et 44,1 khz.
Le hw:0 doit intégrer un patch permettant de prendre en compte tout ou partie des spécificités de l'US122. A privilégier, donc.


Merci allany pour cette précision ;)

sub26nico, je te remercie pour les liens...
J'y vais de ce pas.

Je vous donne des retours dans très peu de temps.

Merci à vous.

Ubuntu_Studio_User utilisateur non connecté
Salut,

je m'excuse pour le temps que ça a mis, mais j'étais un peu pris... :-)

olinuxx, oui j'avais bien suivi les conseils de la page, mais le résultat était le même...

Par contre les liens que m'ont donné sub26nico sont très intéressant !
En suivant les conseils, j'ai pu effectuer mon premier enregistrement guitare :-)

D'après ce que j'ai compris, il faut blacklister la carte, puis effectivement de modifier le fichier .asoundrc

Mais j'ai préféré ce bout de code (qui est sensé remplir la même fonction je pense)

pcm.us-144mkii {
        type usb_stream
        card "US122L"
}

ctl.us-144mkii {
        type hw
        card "US122L"
}


cf. https://autostatic.com/2016/01/28/using-a-qtractor-midi-track-for-both-midi-and-audio-2/

J'ai remplacé le nom par celui de ma carte.
A priori ça fonctionne


Là, je vais retourner sur un ancien pc afin de faire fonctionner cette carte, et je reviendrai donner des nouvelles. ;)

Merci à vous pour cette avancée, super ! (y)

Page : 1/2  [Suivant]
1  2 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 21:08, jeu. 19 Oct 2017: salut et bienvenue à rosjjim :-)
olinuxx, 15:28, mer. 18 Oct 2017: bonjour et bienvenue à Gopherlechien :-)
olinuxx, 08:46, mer. 18 Oct 2017: @Respire : contacte moi à l'adresse info HATTE linuxmao POINGT org
sub26nico, 23:46, mar. 17 Oct 2017: Salut et bienvenue à Fonky62 :-)
Pascal, 21:03, mar. 17 Oct 2017: Je crois qu'on peut y aller àdonf maintenant ;)
Pascal, 21:02, mar. 17 Oct 2017: avec un coreI5 on peut faire ca sans soucis :-) crash test ben pas de crash ! renoise + ardour + reaper + bitwig + fusion + lightworks + resolve. j'ai pas réussi a planter le PC !!!!
Pascal, 21:02, mar. 17 Oct 2017: Merci sans doute à Apple qui tourne en rond...
Pascal, 21:01, mar. 17 Oct 2017: Pendant des années Linux en MAO vidéo c'était un peu la galère... et puis...
olinuxx, 18:36, mar. 17 Oct 2017: bonjour et bienvenue à Respire :-)
bluedid29, 14:28, mar. 17 Oct 2017: Perso je suis passé (au moins en MAO) sur l'excellente distribution Debian Librazik réalisé par le talentueux olinuxx ! :-)
bluedid29, 23:06, lun. 16 Oct 2017: Voilà, je ne fais que relayer l'info... ;) Inscription ici : /
bluedid29, 23:05, lun. 16 Oct 2017: Hello ! Ubuntu-fr organise une ubuntu party et recherche à Paris à la cité des sciences et de l'industrie (25 et 26 nov.) des personnes qui pourraient y proposer une conférence, un atelier