Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

> Forums de discussion > 5 - Les serveurs son : Jack, PulseAudio et autres... > [RÉSOLU] Jack, allocation de mémoire et autres Reaper
Dernier post

[RÉSOLU] Jack, allocation de mémoire et autres Reaper

thibaux utilisateur non connecté
Bonjour,

Je veux lancer Reaper avec Jack , pour l'instant quand je lance Jack, il a visiblement un problème d'allocution de mémoire ?

10:18:49.760 DBUS : le serveur JACK démarre…
10:18:49.790 DBUS : le serveur JACK a été démarré (org.jackaudio.service soit jackdbus).
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
Sun Oct  7 10:18:49 2018: Starting jack server...
Sun Oct  7 10:18:49 2018: JACK server starting in realtime mode with priority 70
Sun Oct  7 10:18:49 2018: self-connect-mode is "Don't restrict self connect requests"
Sun Oct  7 10:18:49 2018: ERROR: Cannot lock down 82280346 byte memory area (Cannot allocate memory)
Sun Oct  7 10:18:49 2018: Acquired audio card Audio0
Sun Oct  7 10:18:49 2018: creating alsa driver ... hw:0|hw:0|512|2|44100|0|0|nomon|swmeter|-|32bit
Sun Oct  7 10:18:49 2018: configuring for 44100Hz, period = 512 frames (11.6 ms), buffer = 2 periods
Sun Oct  7 10:18:49 2018: ALSA: final selected sample format for capture: 32bit integer little-endian
Sun Oct  7 10:18:49 2018: ALSA: use 2 periods for capture
Sun Oct  7 10:18:49 2018: ALSA: final selected sample format for playback: 32bit integer little-endian
Sun Oct  7 10:18:49 2018: ALSA: use 2 periods for playback
Sun Oct  7 10:18:49 2018: ERROR: Cannot use real-time scheduling (RR/70)(1: Operation not permitted)
Sun Oct  7 10:18:49 2018: ERROR: AcquireSelfRealTime error
Sun Oct  7 10:18:49 2018: graph reorder: new port 'system:capture_1'
Sun Oct  7 10:18:49 2018: New client 'system' with PID 0
Sun Oct  7 10:18:49 2018: graph reorder: new port 'system:capture_2'
Sun Oct  7 10:18:49 2018: graph reorder: new port 'system:playback_1'
Sun Oct  7 10:18:49 2018: graph reorder: new port 'system:playback_2'
10:18:51.858 Changement des connexions JACK.
10:18:51.860 Configuration du serveur enregistrée dans « /home/thibaux/.jackdrc ».
10:18:51.861 Réinitialisation des statistiques.
10:18:51.878 Client activé.
10:18:51.879 Baie de brassage désactivée.
10:18:51.942 Changement du graphique des connexions JACK.
Cannot lock down 82280346 byte memory area (Ne peut allouer de la mémoire)
Sun Oct  7 10:18:51 2018: Saving settings to "/home/thibaux/.config/jack/conf.xml" ...
Sun Oct  7 10:18:51 2018: New client 'qjackctl' with PID 1633


Si quelqu'un a des pistes ? Merci

Je suis sous Linux Mint 19 et je tourne avec un VAIO Sony avec un Dual core Intel Core2 Duo P8600 et 4 GO de Ram

thibaux utilisateur non connecté
Bon j'ai configuré le le fichier audio.conf comme expliqué ici plus de problème d'allocation mémoire visiblement dans Jack

11:13:10.270 Changement du graphique des connexions ALSA.
11:13:16.782 DBUS : le serveur JACK démarre…
11:13:16.803 DBUS : le serveur JACK a été démarré (org.jackaudio.service soit jackdbus).
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
Sun Oct  7 11:13:16 2018: Starting jack server...
Sun Oct  7 11:13:16 2018: JACK server starting in realtime mode with priority 70
Sun Oct  7 11:13:16 2018: self-connect-mode is "Don't restrict self connect requests"
Sun Oct  7 11:13:16 2018: Acquired audio card Audio0
Sun Oct  7 11:13:16 2018: creating alsa driver ... hw:0|hw:0|512|2|44100|0|0|nomon|swmeter|-|32bit
Sun Oct  7 11:13:16 2018: configuring for 44100Hz, period = 512 frames (11.6 ms), buffer = 2 periods
Sun Oct  7 11:13:16 2018: ALSA: final selected sample format for capture: 32bit integer little-endian
Sun Oct  7 11:13:16 2018: ALSA: use 2 periods for capture
Sun Oct  7 11:13:16 2018: ALSA: final selected sample format for playback: 32bit integer little-endian
Sun Oct  7 11:13:16 2018: ALSA: use 2 periods for playback
Sun Oct  7 11:13:16 2018: graph reorder: new port 'system:capture_1'
Sun Oct  7 11:13:16 2018: New client 'system' with PID 0
Sun Oct  7 11:13:16 2018: graph reorder: new port 'system:capture_2'
Sun Oct  7 11:13:16 2018: graph reorder: new port 'system:playback_1'
Sun Oct  7 11:13:16 2018: graph reorder: new port 'system:playback_2'
Sun Oct  7 11:13:17 2018: Saving settings to "/home/thibaux/.config/jack/conf.xml" ...
11:13:18.869 Changement des connexions JACK.
11:13:18.870 Configuration du serveur enregistrée dans « /home/thibaux/.jackdrc ».
11:13:18.870 Réinitialisation des statistiques.
11:13:18.883 Client activé.
11:13:18.884 Baie de brassage désactivée.
11:13:18.940 Changement du graphique des connexions JACK.
Sun Oct  7 11:13:18 2018: New client 'qjackctl' with PID 1523


Mais Reaper m'affiche toujours

"There was an error opening the audio hardware:

JACK: error creating client"

Un lien avec la baie de brassage désactivée ? Merci !

sub26nico utilisateur non connecté France
Plusieurs questions, as tu optimisé ton système pour la MAO et le temps-réel ?
Voir Temps-réel pour les applications.
Ton utilisateur est il dans le groupe 'audio' ?
Quel est ton noyau ? pour cela, dans un terminal :
uname -a


As tu essayé de lancé Reaper avec ALSA comme serveur son ?

thibaux utilisateur non connecté
Merci @Sub26nico pour tes pistes

pour l'optimisation en temps réel, j'ai suivi le tuto PAM et j'obtiens ca :

max locked memory       (kbytes, -l) unlimited
real-time priority              (-r) 95


Mon utilisateur est bien dans le groupe audio

groups
thibaux adm cdrom sudo audio dip plugdev lpadmin sambashare


Mon noyau (de cerise... Ok, je sors)

uname -a
Linux thibaux-VGN-FW21M 4.15.0-36-generic #39-Ubuntu SMP Mon Sep 24 16:16:44 UTC 2018 i686 i686 i686 GNU/Linux


J'ai essayé de démarrer Repear avec ALSA mais j'ai la même réponse

Image

Je continue à chercher, visiblement le problème vient de Reaper...

sub26nico utilisateur non connecté France
Tu peux poster des captures d'écran stp des préférences de Reaper (Ctrl+P) aux onglets :
1) du menu Audio
2) Dans ce même menu, le sous menu 'Device'

thibaux utilisateur non connecté
Jack
Image
Alsa
Image
Message d'erreur le même avec Alsa ou Jack
Image

thibaux utilisateur non connecté
visiblement le problème vient d'Alsa

Je peux lancer reaper avec Pulse audio sans problème

Quand je lance Ardour, si je lui demande de démarrer avec Alsa, il me dit que le système audio n'est pas valide :-(

thibaux utilisateur non connecté
Après quelques recherches, il s'avère, si j'ai bien compris que mon matériel n'est pas compatible avec Alsa :-(

J'ai bien essayer de modifier le fichier de config Alsa comme indiqué ici

https://doc.ubuntu-fr.org/audio_intel_hda

Mais ça ne fonctionne pas. Je reste sous Pulse audio

olinuxx utilisateur non connecté France
Si pulseaudio fonctionne, c'est que ton matériel est compatible avec ALSA.
(pulseaudio = serveur son, alsa = pilotes)

PS : le lien que tu donnes est probablement beaucoup trop long pour qu'on puisse tout lire sans savoir à quel paragraphe tu fais référence

thibaux utilisateur non connecté
Merci de ta réponse @olinuxx, il s'agit donc d'un problème spécifique à Jack ou à Reaper et non à ALSA si je comprends bien.

Refaire mon installation de Reaper proprement peut il être une piste ?

Sinon, suite au lien, J'ai modifié mon fichier de conf alsa sur cette base

> J'ai édité le fichier /etc/modprobe.d/alsa-base.conf avec les droits d'administration. et mis la ligne suivante (comme proposé plus avant dans la page sur les matériels compatibles.
>

options snd-hda-intel model=laptop-eapd


J'ai rajouté également dans le fichier les lignes suggérées dans le Wiki

alias snd-card-0 snd-hda-intel
  alias sound-slot-0 snd-hda-intel
  alias sound-slot-0 snd-card-0
  alias sound-service-0-0 snd-mixer-oss
  alias sound-service-0-1 snd-seq-oss
  alias sound-service-0-3 snd-pcm-oss
  alias sound-service-0-8 snd-seq-oss
  alias sound-service-0-12 snd-pcm-oss


Ce qui n'aidera pas car si je comprends bien mon matériel est comptatible ...

sub26nico utilisateur non connecté France
thibaux, tu n'as pas mis la capture d'écran des préférences avec juste 'Audio'.wink

Je vois 2 choses dans tes captures d'écran :

1) Dans l'onglet ALSA, tu n'as spécifié aucune carte son dans les champs 'Input device' et 'Output device'.
Ça paraît donc logique que cela ne fonctionne pas car Reaper ne sais pas quelle carte son trouver.

2) Comment lances tu Jack ? Car si tu souhaites que Reaper le fasse, il te faut cocher la case
'Auto-start jackd, launch command (blank=libjack)'. Si tu lances Jack avant Reaper, laisses cette
case décochée et mets nous des captures d'écran de QjackCtl ou de Cadence avec les réglages de Jack.

thibaux utilisateur non connecté
Merci @Subnico

Je n'ai pas mon pc à sous la main, je regarde ce soir pour le point 1 et pour les bonnes captures d'écran...confused

Pour le point 2, je n'avais pas coché la case "Auto-start jackd, launch command (blank=libjack)'" car Jack était déjà démarré

thibaux utilisateur non connecté
It works, un grand merci @Olinuxx et @Sub26nico

Je me suis replongé dans les paramètres de Jack grâce à vos questions et... j'avais paramétré une carte son externe que je n'ai pas rebranché pour mes tests redface . Bref...

Bon ça m'aura permis de comprendre quelques notions.

Je clos le sujet et je ne sais pas comment ou si j'ai les droits pour passer le topic en résolu ?

Edit : j'ai indiqué le sujet comme RESOLU dans le premier post

sub26nico utilisateur non connecté France
Bravo pour avoir trouvé la solution !
Note modération : le sujet étant résolu, merci d'ajouter un [RÉSOLU] (ou un [CONTOURNÉ], ou bien encore un [ABANDONNÉ]) dans le titre de ton premier message. Voir ce paragraphe du manuel du site pour davantage d'informations.



Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 21:39, dim. 14 Oct 2018: Salut et bienvenue à blastedpingin :-)
jipeL, 09:42, dim. 14 Oct 2018: Un petit coucou en passant !
sub26nico, 21:05, jeu. 11 Oct 2018: Salut et bienvenue à open_jobxxi et DJPaolo :-)
jipeL, 16:29, jeu. 11 Oct 2018: Bonjour, je viens de soumettre une création dans le forum, dites moi ce que vous en pensez. Merci.
olinuxx, 10:25, mer. 10 Oct 2018: Bonjour et bienvenue à Chico13, Bluedeauville, et à crap0 cool
olinuxx, 10:34, mar. 09 Oct 2018: Il reste une semaine pour tenter de remporter un Mod Duo avec : [Lien]
olinuxx, 10:33, mar. 09 Oct 2018: De la part de l'équipe de l'édito : merci Didier ! biggrin
bluedid29, 15:07, lun. 08 Oct 2018: Waou ! Super édito !!! Bravo l'équipe talentueuse ;-)
ycollet, 18:30, ven. 05 Oct 2018: Je ne vois pas où ça parle de danse dans l'édito ...
allany, 09:26, ven. 05 Oct 2018: Il est dense, l'édito d'octobre ! [Lien]
sub26nico, 23:31, jeu. 04 Oct 2018: Salut et bienvenue à shivala74 :-)
Juzic, 18:51, mer. 03 Oct 2018: Salut à tous!! Merci de m'accueillir dans cette mine d'informations que représente linuxmao. Bravo à tous pour ce travail redoutablement bien fait. Une présentation en règle et due forme de ma personne sous peu. poum-poum-tshack poum-poum-tshack