Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

Dernier post

Bcr2000 non reconnu par Jack

JM-harmo utilisateur non connecté
Je viens d'acquérir une PC portable qui doit m'accompagner sur scène....
Quand je fais un "lsusb" mon BCR2000 est bien visible.
Mais aucune trace de celui-ci dans les connections jack.
Config jack2
Ubuntu 19.10
Noyau low latency.

J'ai cherché sur internet en vain.
Alors en dernier recours je vous appel à mon secours.
Merci d'avance.

dlb utilisateur non connecté
Bonjour,

Je pense qu'il faut que tu installes a2jmidid, et que tu le lances ( après avoir démarré qjackctl/jackd ) dans un terminal avec la commande
a2j -e

Les connections de ton matériel devraient apparaître dans l'onglet "midi" de qjackctl.

JM-harmo utilisateur non connecté
ça marche pas..... avec librazik
même avec un sudo devant.

"hardware port export
... enable export of hardware ports
... start
DBus exception: org.gna.home.a2jmidid.error.generic: a2j_start() failed.

Et avec ubuntu studio a2j démarre bien.
Mais il ne voit pas mieux mon BCR2000.

Bizarre sur mon autre ordi assez ancien y'a pas le PB

dlb utilisateur non connecté
Je ne comprends pas trop ce qui se passe ... Lance quand même alsamixer dans un terminal, puis clique sur F6, normalement tu devrais voir ta Behringer listée ... mais j'ai pas vraiment de solution ...

JM-harmo utilisateur non connecté
Merci mais j'ai pas l'impression que ça vienne de jack.
Alsamixer ne vois pas non plus ma surface de contrôle.
Mais j'ai remarqué quelque chose en faisant la manip....
Sur le BCR2000 il y a un voyant USB qui reste allumé sur mon ordi ancien où il fonctionne parfaitement (une tour même noyau même OS), mais qui s'éteint dans la seconde à l'allumage du BCR sur l'ordi portable (qui est tout neuf).
Du coup je suspect un problème de pilote usb.

hhub54 utilisateur non connecté France
Bonjour,

Questions bêtes mais j'ai un BCF2000, c'est la même chose en blanc et avec des curseurs plutôt que des boutons rotatifs.
Tu es installé en USB, et non pas en midi avec un midi in et un midi out 5 broches ? Hypothèse câble usb défectueux...
Tu as branché l'alimentation secteur du BCR ? Hypothèse port usb du portable insuffisant à alimenter le BCR...
Il se peut aussi que ton BCR soit reconnu avec un autre nom, genre périphérique midi 1 ou x... Mais je n'y crois pas trop si la led s'éteint quand tu branches ou allumes.
J'ai résolu de nombreux problèmes de midi en utilisant un boitier usb/midi à 4 entrées/4 sorties midi, qui est bien reconnu partout. L'inconvénient est que les noms des périphériques disparaissent pour devenir 1, 2...4 mais aucun souci de reconnaissance ou pilote.
Sinon le BCF/BCR est un outil délicat avec différentes configurations, je dois me replonger dans le manuel à chaque fois qu'il ressort de sa boîte, il est possible qu'il y ait une manip à faire dessus pour qu'il soit reconnu par un ordi plutôt que laissé en standalone. Je creuserai cela après mon télétravail si je peux.

Bon confinement et santé à tous.

olinuxx utilisateur non connecté France
Essaie les différents ports USB dispo sur ta machine aussi.

JM-harmo utilisateur non connecté
J'avais déjà essayé....
Je suis allé aussi regarder dans le BIOS...
Et là surprise l'USB du BCR est alimenté sans toucher à rien. mais après le reboot et le chargement de la session.... nada plus rien.
Je suis de plus en plus convaincu d'un pb de pilote pas tout à fait compatible sur le PC portable et correct sur le pc de bureau.

olinuxx utilisateur non connecté France
USB 2.0 VS USB 3.0 peut être ?

JM-harmo utilisateur non connecté
Tester aussi sans succès.
De toute façon le BCR2000 est un vieux modèle je me demande même s'il ne serait pas en USB1...
Je dois pouvoir tester à coup sur.....
Et la réponse est : même motif, même punition....
je vais tenter une distri beaucoup plus ancienne pour voir...... en USB live je ne risque pas grand chose.

olinuxx utilisateur non connecté France
JM_harmo écrit :
De toute façon le BCR2000 est un vieux modèle je me demande même s'il ne serait pas en USB1...


J'ai lu à plusieurs reprise que le pilote USB3 du noyau linux entraînait des dysfonctionnements de matériel audio/MIDI USB. Sur chacune de ces lectures, blacklister le pilote USB3 permettait d'utiliser le pilote USB pour le contrôleur USB, et le matériel était alors reconnu.

C'est con, j'en ai une juste à côté de moi de BCR2000, mais je ne retrouve plus le câble d'alim'...

JM-harmo utilisateur non connecté
Reste qu'avec une configuration similaire pas de problème sur une machine et dysfonctionnement sur une autre.
Nota : j'ai désactivé le fast Boot dans le Bios sans résultat.

olinuxx utilisateur non connecté France
Ah ! Un peu au hasard, j'ai retrouvé un câble d'alimentation pour la BCR2000 !

Je te confirme qu'elle est reconnue directement sur LibraZiK-2 lorsque je la branche sur un port USB.

lsusb me donne ceci :
Bus 001 Device 028: ID 1397:00bc BEHRINGER International GmbH BCF2000



et dmesg me donne ceci :
[2060383.918275] usb 1-1.6: new full-speed USB device number 6 using ehci_hcd
[2060384.065447] usb 1-1.6: New USB device found, idVendor=1397, idProduct=00bc
[2060384.065451] usb 1-1.6: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[2060384.065453] usb 1-1.6: Product: BCR2000
[2060384.065455] usb 1-1.6: Manufacturer: BEHRINGER


Et elle devient immédiatement disponible dans Catia :

Image

Je n'ai pas été plus loin que ça.

JM-harmo utilisateur non connecté
Je sais sur ma tour ça fonctionne sans pb.
Mais pas sur mon PC portable, ce n'est pas un pb de distribution.
Juste un PB de pilote ok sur plein de bécanes mais avec des exceptions.
Et pour l'instant pas de solution...
Je continue mes recherches.....
Y'a une tango studio qui télécharge mais le serveur est hyper lent genre 10 heurs de téléchargement.

JM-harmo utilisateur non connecté
ça se confirme c'est le pilote xhci-hcd qui ne conviens pas Image

olinuxx utilisateur non connecté France
C'est pour cela que je conseillai plus haut de blacklister ce pilote (xchi-hcd, c'est le pilote USB3). Car lorsqu'on blackliste le pilote USB3, normalement (après redémarrage de la machine) c'est le pilote USB2 (ehci_hcd) qui prend la main.
Tu devrais essayais et regarder dans dmesg ce que ça dit (après blacklistage + redémarrage).

JM-harmo utilisateur non connecté
j'ai ajouté à : /etc/modprobe.d/blacklist.conf
une ligne blacklist xchi-hcd
et dans /etc/default/grub
et ajouter à la ligne GRUB_CMDLINE_LINUX_DEFAULT : modprobe.blacklist=xhci_hcd
et arrêter la bécane... au redémarrage c'est sans effets

olinuxx utilisateur non connecté France
Le dmesg devrait avoir changé. Il dit quoi maintenant avec le xhci_hcd blacklisté ?

JM-harmo utilisateur non connecté
Je sais pas comme le blacklistage a servi à rien en ce qui concerne le BCR, je suis revenu à la config précédente......
Je crois que je vais attendre le passage à la 20.04 d'ubuntu pour me replonger là-dessus.....

De toute façon tant que le confinement est de rigueur je ne ferai pas de scène.
Donc y'a pas urgence juste que j'avais le temps......

En tout cas merci à toi et à tout ceux qui se sont manifesté sur ce tread.

On en reparle dans un peu plus d'un mois sauf ..... solution tombée d'on ne sais où.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 00:52, jeu. 09 Apr 2020: Salut et bienvenue à seblac et kekedo :-)
olinuxx, 15:01, mer. 08 Apr 2020: Bonjour et bienvenue à cledefa cool
olinuxx, 17:17, mar. 07 Apr 2020: Bonjour et bienvenu à Paco, SavageWolf/Savage_Wolf, et market cool
olinuxx, 17:14, mar. 07 Apr 2020: @pierrotlo : ba... si ? 7
pierrotlo, 11:13, mar. 07 Apr 2020: tiens, il n'y a plus le nimp ?
allany, 19:56, dim. 05 Apr 2020: :-D
r1, 19:56, dim. 05 Apr 2020: @allany : ouais !!! c'est noël ! Quelle équipe hallucinante ! :-D
allany, 19:28, dim. 05 Apr 2020: L'édito, c'est le bon topo, les cocos ! [Lien]
olinuxx, 21:36, mer. 01 Apr 2020: Bonjour et bienvenue à simon_martineau, martineau_simon, et à Roland57 cool
olinuxx, 20:13, mar. 31 mars 2020: Bonjour et bienvenue à sethi1cool
Nolwen, 22:46, lun. 30 mars 2020: Sortie d'Hydrogen 1.0.0-beta 2 ce 30 mars 2020. [Lien]
olinuxx, 17:39, lun. 30 mars 2020: Bonjour et bienvenue à JulienRadio cool