Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Le home-studio, les instruments et le DIY

Dernier post

Batterie WII

saturnin51 utilisateur non connecté
Bonjour,

Je possède une batterie de console WII Guitar Hero, qui a une midi in et une midi out. Que faut-i faire pour l'utiliser comme pad pour générer la piste midi de batterie, avec MusE ou Ardout ou Rosegarden SVP ?

Doit-elle être alimentée et si oui comment ?

Mon setup: clavier maitre MIDI, UA-25 Edirol, Expander Yamaha, PC librazik et MusE.

La batterie va remplacer le clavier maitre en entrée et ça devrait fonctionner. Mais il faut sans doute alimenter la batterie ?

gopalito utilisateur non connecté
hello j'avais ce post il y a quelques temps, ça correspond ?

saturnin51 utilisateur non connecté
Le modèle de batterie que j'ai récupéré pour 10€ comporte une MIDI IN et une MIDI OUT. J'ai récupéré une manette et un chargeur que j'ai inséré dans le logement prévu. Lorsque j'actionne le bouton marche/arrêt je récupère bien des messages midi et le son qui va avec. Mais seulement quelques uns et ça s'arrête. Il faut ré appuyer sur marche/arrêt pour recommencer.

Image

Est-ce juste un problème d'alimentation ?

Sasaki utilisateur non connecté
C'est assez étrange que le signal midi se stoppe au bout d'un moment... Peut-être un problème d'alim

Le logiciel js2midi est fait pour ça à la base. Tu peux donc utiliser le port usb (il y en a un dessus ?) et ce petit bout de logiciel.

saturnin51 utilisateur non connecté
Non pas de port USB. Je penche pour un problème d'alim. La manette s'attend à recevoir un signal de la WII, il n'y en a pas et donc elle s'éteint.
Je n'ai plus qu'à trouver comment installer une alimentation de 3.3V sur la batterie.

Je précise que je n'ai pas la console elle-même. J'ai juste la batterie et une manette.

Si j'appuie régulièrement sur un bouton de la manette (les led bleues s'allument) ça fonctionne.

saturnin51 utilisateur non connecté
Problème résolu. J'ai enlevé le connecteur sur la batterie après avoir repéré les fils +3.3V et GND. J'ai soudé une prise pour alimenter avec un transfo en 3V et ça fonctionne ! Bingo!

saturnin51 utilisateur non connecté
Presque résolu. La batterie relié en midi à l'expander fonctionnne très bien. Mais je n'arrive pas à la faire fonctionner dans MusE.

Je relie le midi out batterie au midi in de l'UA-25
Le midiout de l'UA-25 au midi in de l'expander.

J'ai UA-25 canal 10 en entrée de la piste drum et UA-25 canal 10 en sortie.

L'entrée des messages MIDI semble bon, le vue-mètre réagit. Mais pas de sortie, le canal 10 de l'expander reste muet.

Lorsque je vais dans le drum edit, et que je clique sur les sons, je les ai ?????

Je ne comprends pas grand chose aux connexions dans Jack

Image

saturnin51 utilisateur non connecté
J'ai rebooté et rebranché. Le premier message midi batterie passe et puis plus de sortie, bien que le vue-mètre continue à réagir ! Grrrrrrr !

Comme je suis têtu je persèvére. En faisant finalement les bonnes connexions dans Jack, ça fonctionne .... presque.
En enregistrement seules quelques notes sont enregistrées, environ 5% à vue de nez ! Problème de latence ?

saturnin51 utilisateur non connecté
Même câblage mais avec Rosegarden. Là ça fonctionne impeccable sans aucune intervention de ma part. Enregistrement, écoute tout est OK. Idem avec Ardour !

Je vais poser le problème sur le forum MusE anglais.

olinuxx utilisateur non connecté France
Tiens nous au jus des avancées, on lit !
(en tout cas, moi je lis)

saturnin51 utilisateur non connecté
Je vous mets les deux graphes Jack de Rosegarden et de MusE. C'est quelque chose que je n'arrive pas à maîtriser. J'aurais besoin d'un bon prof !

Image

Image

Dans ces 2 exemples je n'ai qu'une seule piste midi drum canal 10.

Avec MusE ce qui est curieux, c'est que le clavier maître active bien le canal 10 de l'expander. Remplacé par la batterie, rien sauf le vu-métre qui s'agite.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 15:27, mar. 19 mars 2019: Bonjour et bienvenue à Zou biggrin
olinuxx, 19:50, sam. 16 mars 2019: Bonjour et bienvenue à ElectroCute et hexacore cool
sub26nico, 10:52, sam. 16 mars 2019: Salut et bienvenue à Cyan31 et Pima :-)
sub26nico, 18:34, ven. 15 mars 2019: Salut et bienvenue à Efflam78 :-)
olinuxx, 14:47, ven. 15 mars 2019: Bonjour et bienvenue à andrego cool
olinuxx, 14:32, mer. 13 mars 2019: Bonjour et bienvenue à natheo wink
sub26nico, 09:41, mer. 13 mars 2019: Salut et bienvenue à lublanq :-)
olinuxx, 13:13, lun. 11 mars 2019: Bonjour et bienvenue à kamilacase cool
tenryu, 11:55, lun. 11 mars 2019: @ZBP Je n'ai pas disparu, j'ai juste diminué mon activité. A l'automne, j'enregistre un CD sous Linux, avec mon groupe "Mind Your Head" !
sub26nico, 19:56, dim. 10 mars 2019: Salut et bienvenue à mrzique :-)
sub26nico, 20:17, jeu. 07 mars 2019: Salut et bienvenue à fhenryco :-)
dlb, 19:12, jeu. 07 mars 2019: Dans l'édito, on dit plutôt palier cette carence ...