Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Le home-studio, les instruments et le DIY

Dernier post

[Résolu] Batterie WII

saturnin51 utilisateur non connecté
Bonjour,

Je possède une batterie de console WII Guitar Hero, qui a une midi in et une midi out. Que faut-i faire pour l'utiliser comme pad pour générer la piste midi de batterie, avec MusE ou Ardout ou Rosegarden SVP ?

Doit-elle être alimentée et si oui comment ?

Mon setup: clavier maitre MIDI, UA-25 Edirol, Expander Yamaha, PC librazik et MusE.

La batterie va remplacer le clavier maitre en entrée et ça devrait fonctionner. Mais il faut sans doute alimenter la batterie ?

gopalito utilisateur non connecté
hello j'avais ce post il y a quelques temps, ça correspond ?

saturnin51 utilisateur non connecté
Le modèle de batterie que j'ai récupéré pour 10€ comporte une MIDI IN et une MIDI OUT. J'ai récupéré une manette et un chargeur que j'ai inséré dans le logement prévu. Lorsque j'actionne le bouton marche/arrêt je récupère bien des messages midi et le son qui va avec. Mais seulement quelques uns et ça s'arrête. Il faut ré appuyer sur marche/arrêt pour recommencer.

Image

Est-ce juste un problème d'alimentation ?

Sasaki utilisateur non connecté
C'est assez étrange que le signal midi se stoppe au bout d'un moment... Peut-être un problème d'alim

Le logiciel js2midi est fait pour ça à la base. Tu peux donc utiliser le port usb (il y en a un dessus ?) et ce petit bout de logiciel.

saturnin51 utilisateur non connecté
Non pas de port USB. Je penche pour un problème d'alim. La manette s'attend à recevoir un signal de la WII, il n'y en a pas et donc elle s'éteint.
Je n'ai plus qu'à trouver comment installer une alimentation de 3.3V sur la batterie.

Je précise que je n'ai pas la console elle-même. J'ai juste la batterie et une manette.

Si j'appuie régulièrement sur un bouton de la manette (les led bleues s'allument) ça fonctionne.

saturnin51 utilisateur non connecté
Problème résolu. J'ai enlevé le connecteur sur la batterie après avoir repéré les fils +3.3V et GND. J'ai soudé une prise pour alimenter avec un transfo en 3V et ça fonctionne ! Bingo!

saturnin51 utilisateur non connecté
Presque résolu. La batterie relié en midi à l'expander fonctionnne très bien. Mais je n'arrive pas à la faire fonctionner dans MusE.

Je relie le midi out batterie au midi in de l'UA-25
Le midiout de l'UA-25 au midi in de l'expander.

J'ai UA-25 canal 10 en entrée de la piste drum et UA-25 canal 10 en sortie.

L'entrée des messages MIDI semble bon, le vue-mètre réagit. Mais pas de sortie, le canal 10 de l'expander reste muet.

Lorsque je vais dans le drum edit, et que je clique sur les sons, je les ai ?????

Je ne comprends pas grand chose aux connexions dans Jack

Image

saturnin51 utilisateur non connecté
J'ai rebooté et rebranché. Le premier message midi batterie passe et puis plus de sortie, bien que le vue-mètre continue à réagir ! Grrrrrrr !

Comme je suis têtu je persèvére. En faisant finalement les bonnes connexions dans Jack, ça fonctionne .... presque.
En enregistrement seules quelques notes sont enregistrées, environ 5% à vue de nez ! Problème de latence ?

saturnin51 utilisateur non connecté
Même câblage mais avec Rosegarden. Là ça fonctionne impeccable sans aucune intervention de ma part. Enregistrement, écoute tout est OK. Idem avec Ardour !

Je vais poser le problème sur le forum MusE anglais.

olinuxx utilisateur non connecté France
Tiens nous au jus des avancées, on lit !
(en tout cas, moi je lis)

saturnin51 utilisateur non connecté
Je vous mets les deux graphes Jack de Rosegarden et de MusE. C'est quelque chose que je n'arrive pas à maîtriser. J'aurais besoin d'un bon prof !

Image

Image

Dans ces 2 exemples je n'ai qu'une seule piste midi drum canal 10.

Avec MusE ce qui est curieux, c'est que le clavier maître active bien le canal 10 de l'expander. Remplacé par la batterie, rien sauf le vu-métre qui s'agite.

saturnin51 utilisateur non connecté
Il semblerait que le problème vienne du fait que le pad WII n'envoie pas de note off. Cette situation n'est pas géré correctement par MusE à priori. J'ai soumis le problème au développeur depuis samedi, et depuis rien. En vacances ?

Je persiste à penser que ce logiciel est excellent notamment sur la partie midi ou l'on retrouve tous les éditeurs de Cubase en particulier le "logiacl edit" qui permet des manipulations puissantes d'une piste MIDI: Remplacement d'une note par une autre, modification diverses et variées de la vélocité, du volume, enfin de tout les contrôleurs MIDI.

Un éditeur de piste de batterie dédié, une édition de la liste des événements midi avec insertion, effacement, modification et possibilités d'insérer des sysex ! Editeur de partition, édition piano roll le tout de façon très intuitive.

A priori on ne s'occupe pas des connexions dans JAck, tout se fait en interne de MusE, sauf cas particlier.

Je viens de pratiquer Ardour et le moins que je puisse dire, c'est qu'il ne m'a pas convaincu, pour quelqu'un qui comme moi fait du home studio seul chez moi Je n'ai pu éditer ma piste de drum note par note. Pas trouvé comment effacer une note. Pas de gomme ? J'ai trouvé même que Rosegarden était plus convivial !

saturnin51 utilisateur non connecté
Problème résolu à l'instant même. C'est bien parce qu'il n'y a pas de note off envoyé que ça coinçait. Il faut faire une copie de l'instrument dans le menu MIDI - Editer l'instrument.

Faire une sauvegarde de GM (dans mon cas) sous GM-1 par exemple et paramétrer en bas à gauche de l'écran sur "no note off".

Il suffit ensuite d'utiliser ce set GM-1 et ça fonctionne parfaitement.

olinuxx utilisateur non connecté France
Bien joué !

Et merci pour le retour d'expérience.

Bonne musique à toi maintenant cool

saturnin51 utilisateur non connecté
Un complément. On peut attribuer à chaque piste MIDI un set d'instrument différent: GM, Roland, YAmaha, etc. Mais pour cela il faut attribuer à a chaque piste un port MIDI différent.
Par exemple Jack-midi-out/in-1 et Jack-midi-ou/in-2.

La je suis comblé car c'est vraiment un très chouette produit, très complet et plus facile à utiliser que Ardour et un peu plus complet en MIDI que Rosegarden. Les habitués de Cubase comprendront cela facilement.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 17:14, jeu. 23 mai 2019: Bonjour et bienvenue à Tom cool
sub26nico, 23:37, mer. 22 mai 2019: Bienvenue à adlibitom et patoche44 :-)
sub26nico, 09:48, sam. 18 mai 2019: Salut et bienvenue à Florentdu19 :-)
olinuxx, 13:18, mar. 14 mai 2019: Bonjour et bienvenue à MAOfccl cool
sub26nico, 09:20, sam. 11 mai 2019: Salut et bienvenue à Adi :-)
olinuxx, 13:06, ven. 10 mai 2019: Bonjour et bienvenue à DTSSSE cool
sub26nico, 21:51, jeu. 09 mai 2019: Salut et bienvenue à Fladmay :-)
sub26nico, 18:02, mer. 08 mai 2019: Salut et bienvenue à pvd57 :-)
diigitae, 20:02, mar. 07 mai 2019: pierrotlo beau modulaire XD
sub26nico, 23:02, dim. 05 mai 2019: Salut et bienvenue à botzaile et botzilla
allany, 19:55, dim. 05 mai 2019: Ben oui, il est là l'édito ! [Lien]
sub26nico, 23:08, jeu. 02 mai 2019: Salut et bienvenue à Mysaa :-)