Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

2 - Les distributions et les noyaux

> Forums de discussion > 2 - Les distributions et les noyaux > [Résolu] Utiliser les dépots Debian sous LibraZiK
Dernier post

[Résolu] Utiliser les dépots Debian sous LibraZiK

Le_Farfadet_Spatial utilisateur non connecté
Salut à tous !

J’ai une petite question pour les développeurs de LibraZiK : est-ce qu’il est possible d’utiliser les dépôts standard de Debian (Debian 10) sous LibraZiK (LibraZiK 3) ? Notamment les dépôts stables, mais aussi les backports ?

À l’inverse, est-ce que les dépôts de LibraZiK peuvent être utilisé sous Debian ?

À bientôt.

bda utilisateur non connecté France
Bonjour, je ne suis pas développeur de LibraZiK mais...
LibraZiK = Debian 10 + un dépôt.
Il est évidemment possible d'utiliser tous les dépôts Debian avec.

L'inverse aussi. D'ailleurs la procédure d'installation se fait depuis Debian 10 ou depuis le live.

Geis007 utilisateur non connecté France
Librazik2 --> Debian 9
Librazik3 --> Debian 10

Le_Farfadet_Spatial utilisateur non connecté
Salut à tous !

Merci pour les réponses.

bda écrit :
LibraZiK = Debian 10 + un dépôt.


Mais oui, mais comment suis-je passé à côté ? C’est expliqué en long et en large dans la documentation… C’est plutôt une bonne chose, parce que j’ai ma configuration de Debian et je préfère la conserver.

Bon, par contre, il y a deux questions – en fait trois, mais il y en a deux qui sont liées – auxquelles je n’ai pas trouvé de réponse :

— Quelles sont les versions d’Ardour et de MuseScore dans Librazik ? Je pense que c’est Ardour 6 (ce qui m’arrangerait), mais je n’en suis pas certain. Également, la version 3.2 de MuseScore est trop ancienne pour mon besoin.

— Est-ce que KXStudio est compatible avec LibraZiK ? Par exemple, lorsqu’on regarde le contenu du paquet « lsp-plugins » de KXStudio, il renvoit vers LibraZiK :

$ aptitude show lsp-plugins
Paquet : lsp-plugins                                    
Version : 5:1.1.28-1kxstudio1
État: installé
Automatiquement installé: non
Priorité : optionnel
Section : sound
Responsable : Equipe LibraZiK <librazik@tuxfamily.org>
Architecture : amd64
Taille décompressée : 42,4 M
Dépend: libc6 (>= 2.27), libcairo2 (>= 1.2.4), libgl1, libjack-jackd2-0 (>=
        1.9.10+20150825) | libjack-0.125, libstdc++6 (>= 4.1.1), libx11-6,
        lsp-plugins-data (>= 5:1.1.10-1kxstudio1)
Est en conflit: lsp-plugins-jack (< 5:1.1.10-1kxstudio1), lsp-plugins-ladspa (<
                5:1.1.10-1kxstudio1), lsp-plugins-lv2 (< 5:1.1.10-1kxstudio1),
                lsp-plugins-vst (< 5:1.1.10-1kxstudio1), lsp-plugins:i386
Casse: lsp-plugins-jack (< 5:1.1.10-1kxstudio1), lsp-plugins-ladspa (<
       5:1.1.10-1kxstudio1), lsp-plugins-lv2 (< 5:1.1.10-1kxstudio1),
       lsp-plugins-vst (< 5:1.1.10-1kxstudio1)
Fournit: ladspa-plugin, lv2-plugin, standalone-plugin, vst-plugin
Description : LSP (Linux Studio Plugins) audio-plugins package
 This package provide 91 plugins. 
 
 Audio effects: limiters, dynamic processors, expanders, gates, graphic
 equalisers, impulse responses, impulse reverbs, compressors, multiband
 compressors, parametric equalisers, phase detector, sidechain multiband
 compressors, sidechain limiters, sidechain dynamic processors, sidechain
 expanders, sidechain gates, sidechain compressors, slapback delays, delay
 compensators, triggers. 
 
 Synths: samplers, and multisamplers. 
 
 Tools: latency meters, oscillators, profiler, spectrum analyzers, and MIDI
 triggers 
 
 Available as LV2, LADSPA and jack-standalone. 
 
 Documentation page : http://librazik.tuxfamily.org/doc2/paquets 
 
 KXStudio package imported from LibraZiK


À bientôt.

bda utilisateur non connecté France
Bonjour, ça veut juste dire que le paquet source a été créé par les développeurs de LibraZiK.

Techniquement, kx-studio est compatible avec LZK mais je le déconseille à moins de vraiment savoir ce que l'on fait. Et puis quel intérêt? Avoir x version de Ardour? x version de ceci et de cela? Sans parler des problèmes de dépendances que ça peut créer. Étant donné que tu poses la question, le mieux est d'éviter ;).

Les logiciels et versions disponibles sont  ou  .

Sinon c'est bien ardour 6 et musescore 3.2 mais il doit être possible d'utiliser la dernière avec les AppImages ici . Par contre jamais essayé.

olinuxx utilisateur non connecté France
(le développeur de LibraZiK ici)

Si un logiciel ou une nouvelle version d'un logiciel manque, le mieux est d'en parler plutôt que de chercher à mixer des dépôts logiciels différents, et pas fait pour fonctionner ensemble. L'utilisation de l'appimage me paraît une piste probablement fonctionnelle de "dépannage" à première lecture.

PS : je vais être indisponible pendant les 2 semaines qui viennent

Le_Farfadet_Spatial utilisateur non connecté
Salut à tous !

olinux écrit :
(le développeur de LibraZiK ici)


Tout à fait, c’est notamment indiqué sur le Wiki de LinuxMAO. Au passage, merci pour ce travail.

olinux écrit :
Si un logiciel ou une nouvelle version d'un logiciel manque


En l’espèce, j’ai mis en évidence des bogues dans la version 3.2 de MuseScore, qui ont été corrigées depuis.

olinux écrit :
L'utilisation de l'appimage me paraît une piste probablement fonctionnelle de "dépannage" à première lecture.


Alors, j’ai testé le Flatpak, mais d’une part je ne parvenais pas alors à connecter Musescore à Jack, d’autre part il a tendance à utiliser les versions de développements et je préfère les versions stables. J’ai aussi testé le Snap, mais là encore, impossible de connecter MuseScore à Jack et par ailleurs je ne parviens plus à lui faire reconnaître mon répertoire dans lequel se trouve les greffons que j’utilise. Ce qui me gêne avec l’Appimage, c’est qu’elle ne se met pas à jour automatiquement, or tout l’avantage d’un système de gestion de paquet, c’est que ça permet de manière robuste d’assurer la cohérence de son système.

Maintenant, si en effet les développeurs de LibraZiK sont prêt à empaqueter l’actuelle version stable (la 3.6), d’une part je les remercie, d’autre part je peux parfaitement utiliser l’Appimage en attendant.

olinux écrit :
je vais être indisponible pendant les 2 semaines qui viennent


Si ce sont des vacances, je te souhaite de bonne vacances.

bda écrit :
quel intérêt?


La réponse est très simple et très évidente : j’utilise déjà KXStudio, comme le montre la copie de sortie de commande que j’ai postée dans le message précédent. Donc, le plus propre, le plus cohérent, mais aussi le plus simple, c’est de conserver ce dépôt, mais de lui donner une priorité plus faible, avant d’installer le dépôt LibraZiK, puis de laisser tranquillement le gestionnaire de paquets remplacer petit à petit les paquets KXStudio, au fur-et-à-mesure des mises à jour. Par ailleurs, cela évitera que, si jamais il s’avère que j’utilise un paquet de KXStudio qui n’est pas dans LibraZiK, il se retrouve orphelin.

C’est en tout cas beaucoup plus propre et cohérent que de supprimer sauvagement le dépôt KXStudio, ce qui peut causer des problèmes. C’est également plus cohérent que de faire une réinstallation complète. Donc, oui, il y a d’excellentes raisons pour lesquelles configurer les deux dépôts.

bda écrit :
Les logiciels et versions disponibles sont là ou là.


Ah ! Merci.

Bon, pour information, les versions sont indiquées dans le deuxième lien et il y a visiblement eut un problème de copier-coller, alors je donne la version correcte :

https://librazik.tuxfamily.org/doc3/paquets

bda écrit :
Techniquement, kx-studio est compatible avec LZK mais je le déconseille à moins de vraiment savoir ce que l'on fait. Étant donné que tu poses la question, le mieux est d'éviter :-)


Alors, je suis très heureux que tu aies pris le temps de répondre à mes questions et je ne veux pas avoir l’air agressif, ni ingrat. Cela dit, je suis très surpris que le fait de poser une question soit considéré comme une preuve de manque de compétences, pour moi c’est tout le contraire : ça fait plusieurs décennies que je pose des questions avant de faire quelque chose. Par exemple (c’est le cas actuel), avant d’ajouter un dépôt à ma distribution, je me renseigne sur sa compatibilité avec les dépôts que j’utilise déjà.

Au contraire, faire des choses sans se poser de questions, voilà qui me semble plutôt un signe de manque d’expérience…

À bientôt.

bda utilisateur non connecté France
Le_Farfadet_Spatial écrit :
La réponse est très simple et très évidente : j’utilise déjà KXStudio, comme le montre la copie de sortie de commande que j’ai postée dans le message précédent. Donc, le plus propre, le plus cohérent, mais aussi le plus simple, c’est de conserver ce dépôt, mais de lui donner une priorité plus faible, avant d’installer le dépôt LibraZiK, puis de laisser tranquillement le gestionnaire de paquets remplacer petit à petit les paquets KXStudio, au fur-et-à-mesure des mises à jour. Par ailleurs, cela évitera que, si jamais il s’avère que j’utilise un paquet de KXStudio qui n’est pas dans LibraZiK, il se retrouve orphelin.

Rien ne dit que le résultat de la commande "aptitude..." soit faite sur ta machine. Tu ne l'as pas dit non plus. Je ne suis pas devin.
Par contre, une chose importante à vérifier. kx-studio est compatible avec debian et ubuntu. Pourtant ces deux distributions n'embarquent pas forcément les mêmes version des bibliothèques par exemple. Donc soit kx ajoute certaines versions, soit certains paquets sont compilés en statique (ou partiellement).
Les deux dépôts "kx-studio" et "LibraZiK" sont compatibles avec Debian mais ils sont aussi antagonistes.

Désolé que tu te sois sentis agressé par mes propos. Ce n'était pas mon but. Mais 1, il y avait un smiley et 2, tes premières questions sont typiques des débutants puisque les réponses sont clairement indiquées dans la doc.
Pas de quoi s'énerver non plus. L'erreur est humaine et je me suis trompé sur tes compétences.

PS: ne pas confondre "se poser des questions" et "poser des questions".

À bientôt et bonne musique.

Note modération : le sujet étant résolu, merci d'ajouter un [RÉSOLU] (ou un [CONTOURNÉ], ou bien encore un [ABANDONNÉ]) dans le titre de ton premier message. Voir ce paragraphe du manuel du site pour davantage d'informations.



olinuxx utilisateur non connecté France
Quelques petites infos complémentaires rapides avant d'aller bosser :
  • il n'y a pas de "les développeurs de LibraZiK", il n'y en a qu'un, moi
  • les dépôts LibraZiK-3 sont conçus pour être compatibles uniquement avec ceux de Debian Buster - tu peux toujours bidouiller des trucs (rien n'empêche de se tirer une balle dans le pied !), mais c'est à tes risques et périls (et il n'y aura pas de support bénévole de ma part pour ça)
  • ce ne sont pas des vacances, mais merci quand même ! cool

Le_Farfadet_Spatial utilisateur non connecté
Salut à tous !

olinuxx écrit :
il n'y a pas de "les développeurs de LibraZiK", il n'y en a qu'un, moi


Ah ? Tu veux dire que tu te tapes tout seul la création des paquets et le maintien du site ? Bon, eh bien, félicitations, c’est un travail de fou !

bda écrit :
tes premières questions sont typiques des débutants puisque les réponses sont clairement indiquées dans la doc.


Oui, dans un premier temps je n’ai pas compris la logique de la documentation. Non pas qu’elle manque de clarté, je n’ai juste pas saisi le principe.

À bientôt.

olinuxx utilisateur non connecté France
Le Farfadet Spatial écrit :
Ah ? Tu veux dire que tu te tapes tout seul la création des paquets et le maintien du site ?


Oui, à 99%.

Le Farfadet Spatial écrit :
Bon, eh bien, félicitations, c’est un travail de fou !


Merci.
Sache que le financement me permet(tra) de libérer (davantage) de mon temps pour faire avancer LibraZiK arrow contribuer ici Image .

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 23:25, mar. 02 mars 2021: Salut et bienvenue à lastrodamo :-)
sub26nico, 22:45, mar. 02 mars 2021: Bonjour et bienvenue à Razmus :-)
CyrilRos, 21:43, lun. 01 mars 2021: TuxNMix 20.2.1 avec noyau 5.10 disponible
sub26nico, 23:34, dim. 28 Feb 2021: salut et bienvenue à rainbowalice et did1 :-)
r1, 21:06, ven. 26 Feb 2021: @christorbec: je te conseille d'ouvrir un fil sur le forum.
christorbec, 11:28, ven. 26 Feb 2021: bonjour,le suis embêté,car le curseur ne suis plus les notes sur la tablature de tuxguitar,depuis que je sui passer sous debian avec librazik 3....si quelequ'un a une idée?
Nolwen, 18:18, mar. 23 Feb 2021: Mise à disposition de Carla 2.3RC1 ! C'est par ici : [Lien]
sub26nico, 21:03, lun. 22 Feb 2021: Ardour 6.6 est disponible :[Lien]
Nolwen, 17:37, lun. 22 Feb 2021: Sortie de MusE 4.0pre3, dernière release avant la sortie officielle de la version 4 : [Lien] À vos tests et retours !
sub26nico, 13:34, lun. 22 Feb 2021: Bonjour et bienvenue à Inda et MarcoZik46 :-)
olinuxx, 18:42, ven. 19 Feb 2021: Bonjour et bienvenue à richerol cool
sub26nico, 22:06, jeu. 18 Feb 2021: Salut et bienvenue à ZeZombini et jonglacryl :-)