Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

2 - Les distributions et les noyaux

> Forums de discussion > 2 - Les distributions et les noyaux > librazik 2 probleme de mise à jour
Dernier post

librazik 2 probleme de mise à jour

olof utilisateur non connecté
bonjour
lors d'une tentative de mise a jour depuis synaptic (recharger/tout mettre à niveau), j'ai
ce message qui apparait :
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.


puis je y faire quelque chose ?

je signale a toute fin utile que je n'ai pas d'autres depots et n'ai jamais eu d'autre depots que ceux mis par l'installation de lbz2

Sylv_01 utilisateur non connecté
Salut,
meme constat hier soir, j'ai annulé puis relancé la mise à jour des dépôts et ensuite tout s'est déroulé correctement...
Voila voila...

olof utilisateur non connecté
c'est ce que j'ai fait 4 fois de suite, sans resultat, mais du coup a te lire , je l'ai fait une 5e...
et là ça passe eek

bon ben ça vaut donc un resolu smile

olof utilisateur non connecté
en fait c'est pas un vrai resolu : va savoir pourquoi il m'a viré kdenlive, et plus moyen de le reinstaller, j'ai de nouveau le droit à un paquet cassé et si je tente de l'installer ça me fait
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Impossible de corriger les dépendances
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Impossible de corriger les dépendances


Sylv_01 utilisateur non connecté
Ah ça j'ai pas vérifié, je n'utilise pas kdenlive...
Je ne pourrai jeter un coup d’œil que ce soir...

sub26nico utilisateur non connecté France
Ce qui pourrait être utile, c'est d'indiquer les paquets concernés par
les mises à jour (dans Synaptic, menu 'Fichier', 'Historique des opérations'.

olof utilisateur non connecté
alors voici ce que j'ai dans l'historique :
9:37
Commit Log for Tue May 15 09:37:37 2018


Les paquets suivants ont été supprimés :
eom
kdenlive
kinit
kio
libgl1-mesa-glx
libgles1-mesa
libkf5newstuff5
libkf5notifications5
libkf5notifyconfig5
libkf5parts-plugins
libkf5parts5
libkf5plasma5
libkf5runner5
libkf5wallet-bin
libkf5wallet5
libkwalletbackend5-5
libmarblewidget-qt5-25
librazik-base-all
librazik-base-logicielsaudio
librazik-logiciels-all
marble
marble-plugins
marble-qt
mesa-utils
minitube
phonon4qt5
phonon4qt5-backend-vlc
playonlinux
qml-module-org-kde-runnermodel
vlc-plugin-video-output

Les paquets suivants ont été mis à jour :
e2fslibs (1.44.0-1~bpo9+1) to 1.44.1-2~bpo9+1
e2fsprogs (1.44.0-1~bpo9+1) to 1.44.1-2~bpo9+1
e2fsprogs-l10n (1.44.0-1~bpo9+1) to 1.44.1-2~bpo9+1
exim4-base (4.90.1-5~bpo9+1) to 4.91-3~bpo9+1
exim4-config (4.90.1-5~bpo9+1) to 4.91-3~bpo9+1
exim4-daemon-light (4.90.1-5~bpo9+1) to 4.91-3~bpo9+1
f2fs-tools (1.7.0-1.1) to 1.10.0-1~bpo9+1
firefox-esr (52.7.3esr-1~deb9u1) to 52.8.0esr-1~deb9u1
firefox-esr-l10n-fr (52.7.3esr-1~deb9u1) to 52.8.0esr-1~deb9u1
fonts-opensymbol (2:102.10+LibO6.0.2-1~bpo9+1) to 2:102.10+LibO6.0.4~rc1-4~bpo9+2
google-chrome-stable (66.0.3359.117-1) to 66.0.3359.170-1
libcom-err2 (1.44.0-1~bpo9+1) to 1.44.1-2~bpo9+1
libcom-err2:i386 (1.44.0-1~bpo9+1) to 1.44.1-2~bpo9+1
libcomerr2 (1.44.0-1~bpo9+1) to 1.44.1-2~bpo9+1
libcomerr2:i386 (1.44.0-1~bpo9+1) to 1.44.1-2~bpo9+1
libdrm-amdgpu1 (2.4.89-1~bpo9+1) to 2.4.91-2~bpo9+1
libdrm-amdgpu1:i386 (2.4.89-1~bpo9+1) to 2.4.91-2~bpo9+1
libdrm-common (2.4.89-1~bpo9+1) to 2.4.91-2~bpo9+1
libdrm-intel1 (2.4.89-1~bpo9+1) to 2.4.91-2~bpo9+1
libdrm-intel1:i386 (2.4.89-1~bpo9+1) to 2.4.91-2~bpo9+1
libdrm-nouveau2 (2.4.89-1~bpo9+1) to 2.4.91-2~bpo9+1
libdrm-nouveau2:i386 (2.4.89-1~bpo9+1) to 2.4.91-2~bpo9+1
libdrm-radeon1 (2.4.89-1~bpo9+1) to 2.4.91-2~bpo9+1
libdrm-radeon1:i386 (2.4.89-1~bpo9+1) to 2.4.91-2~bpo9+1
libdrm2 (2.4.89-1~bpo9+1) to 2.4.91-2~bpo9+1
libdrm2:i386 (2.4.89-1~bpo9+1) to 2.4.91-2~bpo9+1
libegl1-mesa (13.0.6-1+b2) to 17.3.9-1~bpo9+1
libext2fs2 (1.44.0-1~bpo9+1) to 1.44.1-2~bpo9+1
libf2fs0 (1.7.0-1.1) to 1.10.0-1~bpo9+1
libgbm1 (13.0.6-1+b2) to 17.3.9-1~bpo9+1
libgl1-mesa-dri (13.0.6-1+b2) to 17.3.9-1~bpo9+1
libgl1-mesa-dri:i386 (13.0.6-1+b2) to 17.3.9-1~bpo9+1
libgl1-mesa-glx:i386 (13.0.6-1+b2) to 17.3.9-1~bpo9+1
libglapi-mesa (13.0.6-1+b2) to 17.3.9-1~bpo9+1
libglapi-mesa:i386 (13.0.6-1+b2) to 17.3.9-1~bpo9+1
libgles2-mesa (13.0.6-1+b2) to 17.3.9-1~bpo9+1
libldap-2.4-2 (2.4.45+dfsg-1~bpo9+1) to 2.4.46+dfsg-5~bpo9+1
libldap-2.4-2:i386 (2.4.45+dfsg-1~bpo9+1) to 2.4.46+dfsg-5~bpo9+1
libldap-common (2.4.45+dfsg-1~bpo9+1) to 2.4.46+dfsg-5~bpo9+1
libmad0 (0.15.1b-8) to 0.15.1b-8+deb9u1
libosmesa6 (13.0.6-1+b2) to 17.3.9-1~bpo9+1
libosmesa6:i386 (13.0.6-1+b2) to 17.3.9-1~bpo9+1
libreoffice (1:6.0.2-1~bpo9+1) to 1:6.0.4~rc1-4~bpo9+2
libreoffice-avmedia-backend-gstreamer (1:6.0.2-1~bpo9+1) to 1:6.0.4~rc1-4~bpo9+2
libreoffice-base (1:6.0.2-1~bpo9+1) to 1:6.0.4~rc1-4~bpo9+2
libreoffice-base-core (1:6.0.2-1~bpo9+1) to 1:6.0.4~rc1-4~bpo9+2
libreoffice-base-drivers (1:6.0.2-1~bpo9+1) to 1:6.0.4~rc1-4~bpo9+2
libreoffice-calc (1:6.0.2-1~bpo9+1) to 1:6.0.4~rc1-4~bpo9+2
libreoffice-common (1:6.0.2-1~bpo9+1) to 1:6.0.4~rc1-4~bpo9+2
libreoffice-core (1:6.0.2-1~bpo9+1) to 1:6.0.4~rc1-4~bpo9+2
libreoffice-draw (1:6.0.2-1~bpo9+1) to 1:6.0.4~rc1-4~bpo9+2
libreoffice-gtk3 (1:6.0.2-1~bpo9+1) to 1:6.0.4~rc1-4~bpo9+2
libreoffice-help-en-us (1:6.0.2-1~bpo9+1) to 1:6.0.4~rc1-4~bpo9+2
libreoffice-help-fr (1:6.0.2-1~bpo9+1) to 1:6.0.4~rc1-4~bpo9+2
libreoffice-impress (1:6.0.2-1~bpo9+1) to 1:6.0.4~rc1-4~bpo9+2
libreoffice-java-common (1:6.0.2-1~bpo9+1) to 1:6.0.4~rc1-4~bpo9+2
libreoffice-l10n-fr (1:6.0.2-1~bpo9+1) to 1:6.0.4~rc1-4~bpo9+2
libreoffice-librelogo (1:6.0.2-1~bpo9+1) to 1:6.0.4~rc1-4~bpo9+2
libreoffice-math (1:6.0.2-1~bpo9+1) to 1:6.0.4~rc1-4~bpo9+2
libreoffice-nlpsolver (0.9+LibO6.0.2-1~bpo9+1) to 0.9+LibO6.0.4~rc1-4~bpo9+2
libreoffice-ogltrans (1:6.0.2-1~bpo9+1) to 1:6.0.4~rc1-4~bpo9+2
libreoffice-report-builder (1:6.0.2-1~bpo9+1) to 1:6.0.4~rc1-4~bpo9+2
libreoffice-report-builder-bin (1:6.0.2-1~bpo9+1) to 1:6.0.4~rc1-4~bpo9+2
libreoffice-script-provider-bsh (1:6.0.2-1~bpo9+1) to 1:6.0.4~rc1-4~bpo9+2
libreoffice-script-provider-js (1:6.0.2-1~bpo9+1) to


9:59 (meme mise à jour, apres la 5e requete
Commit Log for Tue May 15 09:59:28 2018


Les paquets suivants ont été installés :
fonts-lyx (2.3.0-2~bpo9+1)
gir1.2-ges-1.0 (1.10.4-1)
libges-1.0-0 (1.10.4-1)
libjs-jquery-ui (1.12.1+dfsg-4)
pitivi (0.98-1.1)
python-matplotlib-data (2.0.0+dfsg1-2)
python3-cycler (0.10.0-1)
python3-dateutil (2.5.3-2)
python3-matplotlib (2.0.0+dfsg1-2)
python3-numpy (1:1.12.1-3)
python3-tk (3.5.3-1)
python3-tz (2016.7-0.3)


voici ce que j'ai comme commentaire sur un apt-get install kdenlive :
Les paquets suivants contiennent des dépendances non satisfaites :
 kdenlive : Dépend: kio mais ne sera pas installé
            Dépend: libkf5newstuff5 (>= 4.95.0) mais ne sera pas installé
            Dépend: libkf5notifications5 (>= 4.96.0) mais ne sera pas installé
            Dépend: libkf5notifyconfig5 (>= 4.96.0) mais ne sera pas installé
            Dépend: kinit mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».


olof utilisateur non connecté
bon, en tentant d'installer manuellement kdenlive, il m'a donné une liste de dependances qu'il ne pouvait honorer, et en remontant une a une ces dependances, j'ai pu installer la librairie manquante, puis une a une j'ai remonté les marches, jusqu'a pouvoir reinstaller kdeenlive et tout librazik-base-all

j'avoue ne pas trop comprendre ce qui amene a ce type de probleme, mais bon, du moment qu'on trouve comment gerer...

sub26nico utilisateur non connecté France
Cool que tu aies pu trouver la solution, mais c'est quand même bizarre ce problème,
que je n'ai pas rencontré avec une machine à jour (pour mon deuxième poste, je ne fais pas
de mises à jour ces jours ci puisque je bosse sur un projet avec KDEnlive et que je n'ai pas
envie de connaître le même sort). Juste au cas où, tu n'aurais pas les dépôts backports-debian
activés ?(tu sembles avoir déjà répondu plus haut mais au cas où, ça vaut le coup de vérifier).

olof utilisateur non connecté
non
c'est une distrib pur jus librazik2, sur laquelle je ne touche absolument jamais aux depots depuis l'install, justement pour eviter ce type de soucis.
les seules chose "exotiques" que j'aie sont des programmpes que j'ai installés en plus ou compilés, mais sans jamais mettre d'autres dépots

olinuxx utilisateur non connecté France
Tu sembles avoir le multi-arch activé aussi. Ça pourrait éventuellement venir de là.

olof utilisateur non connecté
non, à priori aucun depot n'a de nom s'approchant de ça

olinuxx utilisateur non connecté France
Le "multi-arch" n'est pas un dépôt. C'est le nom chez Debian de la capacité d'utiliser des programmes linux 32 bits sur un système linux 64 bits. (Voir la doc wiki de Debian Image ).

libcom-err2 (1.44.0-1~bpo9+1) to 1.44.1-2~bpo9+1
libcom-err2:i386 (1.44.0-1~bpo9+1) to 1.44.1-2~bpo9+1

Cette chose ressemble typiquement à l'installation sur un système 64 bits :
1) d'un paquet en version 64 bits : libcom-err2
2) du même paquet en version 32 bits : libcom-err2:i386

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]


Mégaphone [Afficher / Cacher]

sub26nico, 09:43, jeu. 16 Aug 2018: Salut et bienvenue à georges74 :-)
sub26nico, 22:36, mar. 14 Aug 2018: Salut et bienvenue à maharo :-)
sub26nico, 22:25, mar. 14 Aug 2018: En attendant la V5 de Mixbus 32C, qui devrait arriver demain...
sub26nico, 22:25, mar. 14 Aug 2018: Un nouveau greffon de chez Harrison : [Lien]
syberia303, 22:03, lun. 13 Aug 2018: Pour ceux que ça pourrait intéresser, Traktion en version 7 est gratuit: [Lien]
sub26nico, 17:53, lun. 13 Aug 2018: Salut et bienvenue à Nydoxic :-)
olinuxx, 18:27, dim. 12 Aug 2018: Bonjour et bienvenue à GhostOfBushes ! cool
sub26nico, 00:55, dim. 12 Aug 2018: Salut et bienvenue à TotoLeTroll :-)
olinuxx, 17:05, jeu. 09 Aug 2018: @jipeL : merci pour le partage d'expérience. La prochaine fois, mets un lien vers le fil de discussion stp. [Lien]
jipeL, 18:32, mer. 08 Aug 2018: Mise en garde concernant le code "ISRC" d'une oeuvre dans le forum.
jujudusud, 15:20, mer. 08 Aug 2018: un petit coup de pouce pour mon annonce : [Lien]
olinuxx, 16:56, dim. 05 Aug 2018: Bonjour et bienvenue à eleatus ! cool