Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

7 - Autres sujets : le nimp'

> Forums de discussion > 7 - Autres sujets : le nimp' > [Miraculeusement résolu...] [LZK2] Engrampa ne se ferme pas...
Dernier post

[Miraculeusement résolu...] [LZK2] Engrampa ne se ferme pas...

sri_raoul utilisateur non connecté
Bonjour,

J'ai téléchargé des version d'essais de chez OvertoneDSP.
En voulant extraire les archives, tout se passe bien.
Mais impossible de fermer Engrampa, et ce même en faisant un

killall ''n°PID''


Celui-ci me retourne :
n°PID: aucun processus trouvé

Cela rend impossible toute autre extraction. Engrampa semble tout simplement bloqué.

A noter que c'est une librazik assez récente et mise-à-jour.

Si quelqu'un à une piste, merci d'avance!

sub26nico utilisateur non connecté France
Je viens de tester avec le PTC-2A et ça fonctionne,
dans l'archive à décompresser il y a soit l'installateur (qui au final nous pond un vst en .so)
inclus, soit les binaires qui une fois décompressés livre eux aussi un fichier .so
à mettre dans ton dossier
~/.vst
.

As tu sélectionné la bonne archive (x86 pour le 32 bits ou x86-64 pour le 64 bits)?

olinuxx utilisateur non connecté France
su -c "kill -9 PID"

devrait fonctionner.

Peut être en graphique aussi : menu LZK-2 -> Applications -> Outils système -> Moniteur système MATE -> onglet "Processus" -> clic-droit sur la ligne incriminée -> plusieurs possibilités ici.

sri_raoul utilisateur non connecté
@sub26nico: oui, oui. J'ai pris le temps de bien lire le readme et de décompresser la bonne archive (64 en ce qui concerne mon ordi).
Par ailleurs, j'ai essayé de placer directement le .so qui se trouve dans leur dossier binaires, dans mon dossier /usr/lib/vst (de mémoire, possible que je me plante sur le chemin...suis pas sur mon ordi). C'est le dossier où se trouve mes vst, celui qui est de base dans librazik. A priori cela ne fonctionne pas. Carla n'a pas trouvé ce plug-in, après un scan.

@ olinuxx: merci, je vais tenter cela dès que possible. Je termine tard le boulot ce soir.
Ceci-dit, si je dois faire cette manip à chaque fichier décompressé...
Tu n'as pas eu d'autres retours à ce sujet par rapport à ta distrib?
Comment est-ce que je pourrais faire pour te faire remonter des infos pertinentes et supprimer ce soucis?

sub26nico utilisateur non connecté France
Chez moi, le greffon fonctionne dans Ardour et dans Carla.
J'ai placé le .so dans ~/.vst/, il me semble que ce dossier
a été créé en installant un greffon de chez UHE (mais pas sûr).
Je laisse usr/lib/vst/ et usr/lib/lxvst/ (les dossiers vst d'origines dans LibraZiK)
comme ils sont, et j'installe les greffons non fournis pas LZK dans mon home pour ne
pas mélanger.
Mais je suppose que ton soucis vient d'autre chose.

Tu peux essayer de re-télécharger l'archive et réessayer, en prenant soin de tout nettoyer
avant (effacer le .so existant et l'archive présente).

Pour info, j'ai simplement fait un clic-droit sur l'archive, 'Extraire ici', puis dans le dossier
décompressé, je vais jusqu'à l'archive ".tar.gz" du greffon voulu, clic-droit + 'Extraire ici',
puis je choisis le dossier 'x86-64', puis soit double clic sur '.....installer-VST,
soit clic-droit + 'Extraire ici' sur le dossier 'plugin_binaries' qui livre un .so dans le sous
dossier VST. J'ai testé les 2 façons et les 2 foncionnent.
Pas sûr que tu aies besoin de ce descriptif (tu as sûrement fait de même), mais au cas où.

sub26nico utilisateur non connecté France
Pour localiser les dossiers de tes greffons, dans un terminal :

env |grep PATH


olinuxx utilisateur non connecté France
sri_raoul écrit :
Ceci-dit, si je dois faire cette manip à chaque fichier décompressé...
Tu n'as pas eu d'autres retours à ce sujet par rapport à ta distrib?


Non. J'avais utilisé Engrampa sur un .tar.gz avant de te répondre pour être sûr et je n'ai pas eu de soucis.

sri_raoul écrit :
Comment est-ce que je pourrais faire pour te faire remonter des infos pertinentes et supprimer ce soucis?


1) dire quelle version d'engrampa tu as (Aide -> A propos, ainsi que la version dans synaptic)
2) filer un lien ou je puisse télécharger le fichier que tu veux décompresser pour que je puisse essayer de le faire.
3) lancer engrampa à partir d'un terminal et copier/coller ce qu'il dit ici, histoire que je puisse voir ce qui cloche

sub26nico utilisateur non connecté France
sri_raoul: as tu essayé avec une autre archive .zip
(format d'archive utilisé par OvertoneDSP apparemment)?

sri_raoul utilisateur non connecté
Hum...

Bon ben aujourd'hui le soucis ne se renouvelle pas. J'ai ré-essayer avec les mêmes .zip du même éditeur...
Je n'ai pas fait de mise-à-jour pourtant, ni rien de spécial...

olinuxx écrit :
1) dire quelle version d'engrampa tu as (Aide - A propos, ainsi que la version dans synaptic)

v 1.18.3
Dans Synaptic: 1.18.3-1~bpo9+1

Citation :
2) filer un lien ou je puisse télécharger le fichier que tu veux décompresser pour que je puisse essayer de le faire.

Ici

Mais vu que cela fonctionne maintenant...


@sub26nico:
J'ai aussi ré-essayé de placer le .so directement dans le dossier vst utilisé par défaut dans LZK. Techniquement il y en a 3, mais dans la pratique, je n'ai trouvé des .so que dans l'un d'entre-eux. Par commodité, je n'utilise que celui-ci. Cela m'a évité d'avoir à renseigner un chemin de plus dans Carla et Ardour par exemple. Par contre, c'est vrai que ta méthode, d'avoir un dossier spécifique pour les vst que tu rajoutes, en plus de ceux déjà présents de base dans la distri, est plus propre. Notamment pour les sauvegardes je pense.

Merci de vos réponses en tout cas!

olinuxx utilisateur non connecté France
sri_raoul écrit :
Bon ben aujourd'hui le soucis ne se renouvelle pas. J'ai ré-essayer avec les mêmes .zip du même éditeur...
Je n'ai pas fait de mise-à-jour pourtant, ni rien de spécial...


Un bogue malin, qui se cache quand on l'observe. Un bogue quantique quoi wink


sri_raoul écrit :
v 1.18.3
Dans Synaptic: 1.18.3-1~bpo9+1


OK, c'est la version de backport, ça devrait être bon. Pour info, moi j'ai 2 ordis, un système 64 bits et un 32 bits, avec la version de stretch (1.16.0-2), et un ordi, système 64 bits, avec la version de backport (1.18.3-1~bpo+1) et je n'ai pas vu de bizarrerie telle que toi sur ces 3 systèmes.


sri_raoul écrit :
Ici

Mais vu que cela fonctionne maintenant...


Exact.



Pour l'emplacement où mettre ce .so, voici quelques éléments :
  • si c'est un VST natif linux, il faut le placer dans le LXVST_PATH
  • si c'est un VST windows, il faut le placer dans le VST_PATH

Pour les deux, il y a 3 possibilités (exemple avec VST) :
  • /home/utilisateur/.vst : (qui ne sera valable que pour un utilisateur du système) pour une installation "à la main"
  • /usr/lib/vst : (qui sera valable pour tous les utilisateurs du système) pour une installation automatisée et qui ne devrait être utilisée que par synaptic (et les outils derrière : apt, dpkg,...)
  • /usr/local/lib/vst : (qui sera valable pour tous les utilisateurs du système) et qui devrait être utilisé pour les scripts d'installation ou les installations à la main

En l'occurrence, pour un celui que tu essaies d'installer (le "PTC 2a"), à en lire son README.txt, il s'agit d'un linux-vst. Tu devrais donc le placer :
  • soit dans /home/ton_utilisateur/.lxvst/ si tu veux n'y avoir accès qu'avec ton utilisateur
  • soit dans /usr/local/lib/lxvst si tu veux y avoir accès avec tous les les utilisateurs de ton système

sri_raoul utilisateur non connecté
Merci pour tes réponses olinuxx!
Pour le greffon que je voulais installer, c'est fait.
Le problème était juste que egrampa ne se fermait pas. C'est tout!

olinuxx écrit :
Un bogue quantique quoi wink

C'est un peu comme les chaussures des enfants juste avant de partir de la maison... rolleyes

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 00:45, lun. 23 Apr 2018: Salut et bienvenue à Sainteamanite :-)
sub26nico, 21:54, ven. 20 Apr 2018: Salut et bienvenue à JeanPierreDubois :-)
sub26nico, 23:53, mar. 17 Apr 2018: Salut et bienvenue à superludwig :-)
olinuxx, 11:37, mar. 17 Apr 2018: Toutafé, en plusse, "cadriciel", c'est joli à l'oreille !
sub26nico, 00:11, mar. 17 Apr 2018: @r1: "olinuxx", sors de ce corps :-)
r1, 19:54, lun. 16 Apr 2018: @sub26nico ce cadriciel, tu veux dire ? :-D
sub26nico, 16:21, lun. 16 Apr 2018: Ça a l'air terrible ce framework : http://hise.audio/
sub26nico, 16:17, lun. 16 Apr 2018: Salut et bienvenue à FredChamps :-)
sub26nico, 11:38, lun. 16 Apr 2018: Salut et bienvenue à aim_true :-)
zicstef, 10:56, sam. 14 Apr 2018: Bonjour tout le monde, j'ai fait une petite modif sur cette page. Celle-ci risque d'avoir des conséquences sur le reste de l'article. Bon week-end [Lien]
sub26nico, 23:50, ven. 13 Apr 2018: Salut et bienvenue à Mandragore77 et Atriaze :-)
sub26nico, 16:51, ven. 13 Apr 2018: Salut et bienvenue à loop45 :-)