Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

2 - Les distributions et les noyaux

> Forums de discussion > 2 - Les distributions et les noyaux > [RESOLU] Impossible de démarrer les paramètres du serveur X NVIDIA[LZK3]
Dernier post
Page : 1/2   -   Aller directement à la page : 1  2 

[RESOLU] Impossible de démarrer les paramètres du serveur X NVIDIA[LZK3]

maaou68 utilisateur non connecté
Bonjour,

Mon sujet concerne la carte graphique mais je suis sur LibraZiK3.

J'ai installé une GTX 1050ti mais je n'arrive pas à la configurer.

Quand j'ouvre le menu dans:

'Administration' --> 'Paramètres du serveur X NVIDIA'

rien ne se passe...

...et la commande avec un terminal donne:

# nvidia-settings

ERROR: NVIDIA driver is not loaded


ERROR: Unable to load info from any available system


bda utilisateur non connecté France
Bonjour,

Il faut installer le pilote nvidia officiel comme indiqué sur le wiki debian: https://wiki.debian.org/fr/NvidiaGraphicsDrivers . En suivant les indications pour "Debian 10 Buster".

Par défaut, c'est le pilote libre "nouveau" qui est activé sous Debain/LZK.

maaou68 utilisateur non connecté
C'est ce que j'ai fait, mais en réseau, parce que j'avais un écran noir.
J'ai bien l'image maintenant, mais je ne peux pas paramétrer la carte graphique.
Il y a sûrement des paquets à installer mais je ne sais pas lequel choisir pour un Lenovo m72e.

bda utilisateur non connecté France
Donc c'est un portable. Je pensai à un PC de bureau...
Si tu as installé le paquet "nvidia-driver", tout va bien.

Sur les portables avec CG nvidia, il est toujours en second GPU. Les CPU Intel en ont un d'intégré. La technologie Optimus permet d'envoyer l'affichage de la CG nvidia vers le GPU Intel. Par défaut, les applications sont exécutées par le GPU Intel, dont l'application nvidia-settings.
Désolé la doc debian n'est qu'en anglais: https://wiki.debian.org/NVIDIA%20Optimus?action=show&redirect=NvidiaGraphicsDrivers%2FOptimus

N'hésites pas si tu as le moindre soucis, j'ai l'habitude de cette techno bien que je l'ai abandonnée récemment.

maaou68 utilisateur non connecté
Non, en fait c'est une tour avec un processeur Core i5.
Avec Optimus, quel serait le meilleur choix pour que ma carte graphique gtx soit toujours en premier GPU?

bda utilisateur non connecté France
Alors il va falloir forcer le pilote nvidia.

Avant d'aller plus loin, peux tu nous donner le résultat de la commande "lsmod" stp?
J'aimerai savoir si le pilote "nouveau" est chargé ou non... Si il est présent, il faudra l'ajouter en "blacklist" et forcer le chargement du pilote officiel.
Si nouveau est chargé:
Créé un fichier /etc/modprobe.d/nvidia.conf
blacklist nouveau


Créé un fichier /etc/X11/xorg.conf.d/20-nvidia.conf avec:
Section "Device"
        Identifier "Nvidia Card"
        Driver "nvidia"
        VendorName "NVIDIA Corporation"
        BoardName "GeForce GTX 1050 Ti"
EndSection


Je sais, nvidia nous "facilite" la vie à en devenir chèvre. Linus leur avait fait un joli doigt d'honneur accompagné d'un "f..k nvidia" pour ça.

maaou68 utilisateur non connecté
Je ne m'y suis jamais vraiment attaqué...
Apparament nouveau n'est pas installé:

# lsmod
Module                  Size  Used by
rfkill                 28672  1
cpufreq_powersave      16384  0
cpufreq_userspace      16384  0
cpufreq_conservative    16384  0
binfmt_misc            20480  1
snd_hda_codec_hdmi     61440  1
intel_rapl             24576  0
x86_pkg_temp_thermal    16384  0
intel_powerclamp       16384  0
coretemp               16384  0
snd_hda_codec_realtek   122880  1
snd_hda_codec_generic    86016  1 snd_hda_codec_realtek
kvm                   757760  0
snd_hda_intel          49152  6
snd_hda_codec         151552  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
joydev                 24576  0
irqbypass              16384  1 kvm
snd_hda_core           94208  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_hwdep              16384  1 snd_hda_codec
intel_cstate           16384  0
snd_pcm_oss            61440  0
intel_uncore          135168  0
snd_mixer_oss          28672  1 snd_pcm_oss
intel_rapl_perf        16384  0
snd_pcm               114688  5 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_hda_core
snd_timer              36864  1 snd_pcm
iTCO_wdt               16384  0
snd                    94208  22 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm_oss,snd_pcm,snd_mixer_oss
wmi_bmof               16384  0
mei_me                 45056  0
soundcore              16384  1 snd
iTCO_vendor_support    16384  1 iTCO_wdt
sg                     36864  0
mei                   118784  1 mei_me
pcc_cpufreq            16384  0
evdev                  24576  7
parport_pc             32768  0
ppdev                  20480  0
lp                     20480  0
parport                57344  3 parport_pc,lp,ppdev
ip_tables              28672  0
x_tables               45056  1 ip_tables
autofs4                49152  2
ext4                  749568  3
crc16                  16384  1 ext4
mbcache                16384  1 ext4
jbd2                  126976  1 ext4
fscrypto               32768  1 ext4
ecb                    16384  0
btrfs                1400832  0
xor                    24576  1 btrfs
zstd_decompress        81920  1 btrfs
zstd_compress         172032  1 btrfs
xxhash                 16384  2 zstd_compress,zstd_decompress
raid6_pq              122880  1 btrfs
libcrc32c              16384  1 btrfs
crc32c_generic         16384  0
algif_skcipher         16384  0
af_alg                 28672  1 algif_skcipher
dm_crypt               40960  1
dm_mod                155648  12 dm_crypt
hid_generic            16384  0
usbhid                 57344  0
hid                   139264  2 usbhid,hid_generic
sr_mod                 28672  0
cdrom                  65536  1 sr_mod
sd_mod                 61440  3
crct10dif_pclmul       16384  0
crc32_pclmul           16384  0
crc32c_intel           24576  6
ghash_clmulni_intel    16384  0
pcbc                   16384  0
ahci                   40960  2
r8169                  90112  0
libahci                40960  1 ahci
realtek                20480  1
aesni_intel           200704  3
aes_x86_64             20480  1 aesni_intel
crypto_simd            16384  1 aesni_intel
ehci_pci               16384  0
libphy                 77824  2 r8169,realtek
xhci_pci               16384  0
cryptd                 28672  4 crypto_simd,ghash_clmulni_intel,aesni_intel
glue_helper            16384  1 aesni_intel
i2c_i801               28672  0
libata                270336  2 libahci,ahci
xhci_hcd              266240  1 xhci_pci
lpc_ich                28672  0
ehci_hcd               94208  1 ehci_pci
scsi_mod              249856  4 sd_mod,libata,sg,sr_mod
mfd_core               16384  1 lpc_ich
usbcore               294912  5 xhci_hcd,ehci_pci,usbhid,ehci_hcd,xhci_pci
usb_common             16384  1 usbcore
wmi                    28672  1 wmi_bmof
fan                    16384  0
thermal                20480  0
video                  49152  0
button                 20480  0


bda utilisateur non connecté France
Il n'y a ni "nouveau", ni "nvidia", ni de module pour un GPU Intel. J'imagine que ton affichage est en mode "VESA", une norme compatible avec tous les GPU mais très limité.
Possible aussi que ton CPU n'ait pas de GPU intégré (ils n'en ont pas tous et tant mieux).

Dans un terminal:
sudo modprobe nvidia
lsmod | grep nvidia

Pour voir si le module se charge bien.

Si il ne se charge pas, il est possible que tu ais besoin de la version 450.x du pilote nvidia. Voir: https://wiki.debian.org/fr/NvidiaGraphicsDrivers#Version_450.80.02_.28via_buster-backports.29

maaou68 utilisateur non connecté
Merci pour les infos.

# sudo modprobe nvidia
modprobe: FATAL: Module nvidia-current not found in directory /lib/modules/4.19.0-13-lzk-bl-amd64
modprobe: ERROR: ../libkmod/libkmod-module.c:979 command_do() Error running install command for nvidia
modprobe: ERROR: could not insert 'nvidia': Operation not permitted
# lsmod | grep nvidia
#


La dernière commande n'obtient rien.

bda utilisateur non connecté France
Le module nvidia n'a pas été installé correctement. Ou installé avec un autre noyau, probablement dû à une erreur à un moment.

Donc
sudo apt install nvidia-driver

devrait régler le soucis.

maaou68 utilisateur non connecté
En effet je l'avait installé avant le noyau LibraZiK.
Il faut sûrement que je le désinstalle avant.
Quelle est la commande pour désinstaller nvidia-driver?
Je vais sûrement avoir encore un écran noir...

# sudo apt install nvidia-driver
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
nvidia-driver est déjà la version la plus récente (418.152.00-1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.


bda utilisateur non connecté France
Oups, désolé.
Étant donné que le module nvidia n'est pas chargé, l'écran ne devrait pas redevenir noir. Au pire si il revient noir, les raccourcis CTRL+ALT+F1 (ou F2, F3, ...) permettent de retrouver un mode non graphique (et on se retrouve comme dans un terminal).

sudo apt reinstall nvidia-driver

ou
sudo apt remove nvidia-driver
sudo apt install nvidia-driver


maaou68 utilisateur non connecté
J'ai suivi le terminal qui m'a proposé d'installer 'nvidia-driver-bin' à la place du 'nvidia-driver' obsolète puis de faire 'autoremove'.

Mais j'en suis toujours au même point avec nvidia-settings, sudo modprobe nvidia ou lsmod | grep nvidia...

bda utilisateur non connecté France
Apparemment le module nvidia n'est pas compilé pour le noyau lzk. Normalement ça se fait lors de l'installation du paquet nvidia-driver pour tous les noyaux installés sur le PC.

Il faut essayer un:
sudo apt reinstall nvidia-kernel-dkms


Donnes nous le retour complet, même si il n'y a pas d'erreur apparente.
Si ça ne donne rien, j'essaierai d'installer LZK dans une machine virtuelle sur ma machine pour essayer de comprendre ce qui peut bien se passer.

maaou68 utilisateur non connecté
j'ai tapé la commande:

# sudo apt reinstall nvidia-kernel-dkms
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 1 réinstallés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/12,0 Mo dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
(Lecture de la base de données... 340627 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../nvidia-kernel-dkms_418.152.00-1_amd64.deb ...

-------- Uninstall Beginning --------
Module:  nvidia-current
Version: 418.152.00
Kernel:  4.19.0-13-amd64 (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

nvidia-current.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.19.0-13-amd64/updates/dkms/
rmdir: impossible de supprimer 'updates/dkms': Le dossier n'est pas vide
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


nvidia-current-modeset.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.19.0-13-amd64/updates/dkms/
rmdir: impossible de supprimer 'updates/dkms': Le dossier n'est pas vide
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


nvidia-current-drm.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.19.0-13-amd64/updates/dkms/
rmdir: impossible de supprimer 'updates/dkms': Le dossier n'est pas vide
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


nvidia-current-uvm.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.19.0-13-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall completed.

------------------------------
Deleting module version: 418.152.00
completely from the DKMS tree.
------------------------------
Done.
Dépaquetage de nvidia-kernel-dkms (418.152.00-1) sur (418.152.00-1) ...
Paramétrage de nvidia-kernel-dkms (418.152.00-1) ...
Loading new nvidia-current-418.152.00 DKMS files...
Building for 4.19.0-13-lzk-bl-amd64
Module build for kernel 4.19.0-13-lzk-bl-amd64 was skipped since the
kernel headers for this kernel does not seem to be installed.


maaou68 utilisateur non connecté
Il faut préciser aussi que mon écran est noir 1 démarrage sur 2. Mais ça le faisait déjà avant.
Les commandes nvidia-settings, sudo modprobe nvidia, lsmod | grep nvidia, ne fonctionnent toujours pas.

bda utilisateur non connecté France
Building for 4.19.0-13-lzk-bl-amd64
Module build for kernel 4.19.0-13-lzk-bl-amd64 was skipped since the
kernel headers for this kernel does not seem to be installed.

La réponse est là.
Les en têtes du noyau lzk ne sont pas installés.

apt search linux-headers-$(uname -r)
sudo apt install "le paquet listé avec la commande précédente"


Ensuite tu devras relancer la commande du message précédent (sudo apt reinstall nvidia-kernel-dkms)

Pour l'écran noir, je pense que ça vient du fait que tu n'ai aucun pilote graphique installé.

maaou68 utilisateur non connecté
Impeccable!! Après un redémarrage ça fonctionne à merveille avec une image nickel!

Il faut que je me familiarise avec le serveur X NVIDIA.

Néanmoins, je suis toujours intéressé par OPTIMUS.

Quelle installation me conseilles-tu?

Merci de m'avoir guidé pour installer mes pilotes!!

Je mets résolu!

Bonne soirée!

bda utilisateur non connecté France
Optimus est une techno pour les portables...

Contant que ça soit résolu. Bonne soirée à toi aussi.

Je vais discuter du soucis avec olinuxx, ce serait bien qu'il ajoute une section dans la doc de lzk au sujet des cartes nvidia, en particulier les série 10x0 qui ne fonctionne pas avec le pilote libre "nouveau"...

bda utilisateur non connecté France
@olinuxx: je vais installer lzk dans une VM pour faire un maximum d'essai et rédiger un petit bout de doc car c'est vraiment pénible avec cette série 10x0.

Page : 1/2  [Suivant]
1  2 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

CyrilRos, 21:45, mar. 27 Jul 2021: [Lien]
olinuxx, 20:54, mar. 27 Jul 2021: Bonjour et bienvenue à nick cool
olinuxx, 20:47, dim. 25 Jul 2021: Bonjour et bienvenue à GrosRems et à paulisaak cool
olinuxx, 20:05, jeu. 22 Jul 2021: Bonjour et bienvenue à labeyte07 cool
olinuxx, 21:03, mar. 20 Jul 2021: Bonjour et bienvenue à tv cool
Nolwen, 19:33, lun. 19 Jul 2021: Hola,À propos de la création de pattern (motifs) MIDI pour batterie, quelqu'un sait-il où en est la discussion ?
olinuxx, 01:28, lun. 19 Jul 2021: Lolo-Rosso : l'adresse courriel que tu as renseignée lors de ton inscription n'est pas fonctionnelle. Contacte moi pour corriger le soucis : [Lien]
calixtus06, 18:07, ven. 16 Jul 2021: Bonjour et bienvenue à titicplusplus :-)
calixtus06, 11:35, ven. 16 Jul 2021: Bonjour et bienvenue à toi lablonde ! :-)
calixtus06, 18:53, mer. 14 Jul 2021: Bonjour et bienvenue à Lolo Rosso :-)
calixtus06, 08:54, mar. 13 Jul 2021: Bonjour et Bienvenue Pieriv, scamut, AvocadoToast:)
allany, 08:50, mar. 06 Jul 2021: @r1 : ouaip, fait pas chaud, là-haut et que d'eau !