Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [RESOLU] Installation Fast Track ULTRA
Dernier post

[RESOLU] Installation Fast Track ULTRA

cuticulae utilisateur non connecté
C'est fait, dès que j'ai du temps, je fais un tuto.
Ciao

cuticulae utilisateur non connecté
Oups! Me souvenais plus qu'il y avais un post similaire ici...
Si il faut je le déplace...

Sinon quelques précisions supplémentaires :

Avec modconf, j'ai activé le controlleur AC97 dans le kernel, qui ne l'était pas...
Mais ça ne change rien. Ce doit être Alsa qu'il faut configurer pour qu'il prenne en compte les 2 cartes?...

En me promenant, j'ai trouvé dans /lib/linux-sound-base un noALSA.modprobe.conf et noOSS.modprobe.conf , avec à l'intérieur respectivement 171 (dont snd-usb-audio) et 58 modules en "blacklist".
En supprimant ces 2 fichiers (un peu bourrin non?!), tout est pareil, sauf la Fast Track Ultra qui est maintenant à l'emplacement hw:0 au lieu de hw:1

Bonne soirée

Tumulte utilisateur non connecté
Wolala courage mon gars!

J'ai acheté une FTU et je l'ai gardée 2 jours....avant de la retourner en magasin! En tout cas bon courage et merci à toi de nous faire part de tes avancées ici!

cuticulae utilisateur non connecté
C'est dur c'est dur! Merci du soutien!
J'ai trouvé une piste : appliquer le patch sur une version du kernel plus récente. J'essaie sur un linux-2.6.31.6-rt19, qui a l'air de supporter "de base" plus de matériel...
J'ai peut-être aussi fait quelques erreurs du côté d'ALSA dans mon "make menuconf"...
Je recompile et vous dit.

cuticulae utilisateur non connecté
Alors, je migre vers Karmic...
Chose (très) interessante, la carte est reconnue (ça fait classe!) dans "préférences du son" , / Conférence audio / Capture du son , sous le nom de :
"M-AUDIO Fast Track Ultra OSS Control Device (OSS)"
Cest déjà surprenant, surprenant l'est aussi la mention "non-connecté" alors qu'elle l'est...!!!(???)
Après un coup de "cat /dev/sndstat", elle est bien là, mais toujours en carte midi et non audio.
Je vais pas plus loin mais continue la migration.
A suivre...

PS:toujours preneur de conseils!

cuticulae utilisateur non connecté
Bonjour,
après beaucoup de déboires...

Kernel: Linux musicport-laptop 2.6.31.6-rt19-maudio #2 SMP PREEMPT RT Sat Nov 21 16:16:34 CET 2009 i686
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
M-Audio Fast Track Ultra at usb-0000:00:1d.7-5, high speed
Intel ICH6 with Cx20468-31 at irq 22

Audio devices:
0: USB Audio (DUPLEX)
1: Intel ICH6 (DUPLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices:
0: Fast Track Ultra

Timers:
31: system timer

Mixers:
0: mixer00
1: Conexant Cx20468-31

Elle est là et le driver USB Audio est au bon endroit! Mais je ne la trouve plus dans Jack, et dans les " préférences du son ", seules les sorties apparaissent (heureusement pour le moral, elles marchent!!!)
Mais où sont passées ces entrées?

A suivre

cuticulae utilisateur non connecté
En fait CA MARCHE!!!

Oui enfin presque...
Il fallait selectionner l'interface USB AUDIO (hw:0,0)...
J'ai donc mes 8 entrées et mes 8 sorties.

Le hic, c'est que Jack démarré, les Xruns n'en finissent plus de tomber...
J'essaie de forcer le 16 bit, remonter échantillon/periode/tampon, avec/sans RT, rien y fait...

Maintenant j'ai besoin de conseils pour ces valeurs...

Bonne soirée à tous

olinuxx utilisateur non connecté France
Bon ba content pour toi :-)

Peux-tu récapituler TOUT ce que tu as fait précisément jusque maintenant ?

Et mets nous une capture des messages d'erreurs de QJackCtl (enfin mets la capture sur un site externe et file nous le lien)

cuticulae utilisateur non connecté
Allons-y :
-Je suis passé sous Karmic

-téléchargé le kernel linux-2.6.31.6
-patché les fichiers /linux/snd/usb/usbaudio.c et /linux/snd/usb/usbquirks.h , donné sur ce forum.
-patché avec patch-2.6.31.6-rt19.bz2
-compilé le nouveau kernel avec mon ancien .config, (en activant ALSA en dur et le driver USB AUDIO en module + Complete real-time)
-installer le kernel

-édité limits.conf pour le temps réel
-"sudo apt-get remove --purge pulseaudio"
-gedit /etc/modprobe.d/alsa-base.conf , rajouté # devant "options snd-usb-audio index=-2"

-dans Qjackctl, selectionner pilote ALSA et interface hw:0,0 (USB AUDIO)

Voilà, et maintenant :

[+]

En mettant 4096frames, j'ai pu avoir 1 xrun toutes les 2sec...

Merci de ta présence!

cuticulae utilisateur non connecté
Bonjour,

je rectifie le tir!

Tout marche, mais visiblement pas en 44100...
24bit en capture et lecture en 48000 Hz

J'ai réussi à enregistrer, via Ardour, 3 pistes audio simultannées avec 3 buffers de 64.
Donc 4ms de latence sans aucun xrun... Plutôt satisfaisant!... Qualité de son impec'

Visiblement, fonctionnel avec moins de 5ms de latence jusqu'à 92000 Hz / 24bit en capture et enregistrement.

Je rappelle mes caractéristiques : PC pentium4, 1G de ram, Fast Track Ultra
Ubuntu 9.10, noyau 2.6.31.6 patché Rt-19 et "patch M-Audio Fast Track Ultra".

Le problème est donc résolu. Si il ya de la demande, je peut faire un tuto éventuellement?

En tout cas, merci linux!
Et merci Linux Mao évidemment!

cuticulae utilisateur non connecté
Par contre, pas de gestion du mixer dsp, et je n'ai pas trouvé le moyen de modifier le routage des entrées Fast Track vers les pistes Ardour (elles se connectent automatiquement)

olinuxx utilisateur non connecté France
Citation :
Si il ya de la demande, je peut faire un tuto éventuellement?

Carrément ! (Clique sur le point d'interrogation)
M-Audio Fast Track Ultra

PS: peux-tu à mettre un RESOLU dans le titre de ton message initial ? Merci !

cuticulae utilisateur non connecté
rrrrrro l'erreur de débutant!
C'est mon premier forum alors pas trop de sarcasmes!
J'ai malencontreusement supprimé le premier post, sans retrouver la copie dans mes mails...
Je ferai le tuto...

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]


Ubuntu_Studio_User

Mégaphone [Afficher / Cacher]

Ubuntu_Studio_User, 02:29, lun. 14 Jun 2021: Salut à tous...
allany, 12:12, sam. 12 Jun 2021: @tourneriff : merci pour le signalement, c'est fait !
tourneriff, 07:52, sam. 12 Jun 2021: Bonjour à tous ☺ ! Avis aux modos : pourrait-on voir la "joute 16" en cours à l'accueil du site plutôt que l'antique "joute 15"
sub26nico, 14:56, jeu. 10 Jun 2021: Salut et bienvenue à jamesonmount, freerawsound et Loop :-)
ycollet, 10:28, mer. 09 Jun 2021: Cool, un revival de rakarrak ! [Lien]
sub26nico, 22:08, lun. 07 Jun 2021: Bonjour et bienvenue à ArchLinux59, Djobi et gakgakgak :-)
olof, 09:27, lun. 07 Jun 2021: ardour 6.7 build tourne chez moi, mais pas le package 6.6
allany, 14:46, dim. 06 Jun 2021: @r1 : t'as raison : trop c'est trop, ça sature du goulot !
r1, 22:54, sam. 05 Jun 2021: Mon cerveau a bobo à force de faire le gogo sur l'annonce de l'édito !
allany, 11:49, sam. 05 Jun 2021: Z'ont encore abattu un sacré boulot, les poulbots de l'édito ! [Lien]
ycollet, 20:37, ven. 04 Jun 2021: Un article intéressant sur un truc à venir sur USB audio: [Lien]
ycollet, 21:26, mar. 01 Jun 2021: J'ai vu passer cette branche sur hydrogen: remotes/origin/H2asLV2 C'est pas mal du tout ...