Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

4 - Toutes les autres applications, les émulateurs...

> Forums de discussion > 4 - Toutes les autres applications, les émulateurs... > [CONTOURNÉ] probleme connexion hydrogen à Jack
Dernier post
Page : 3/4   -   Aller directement à la page : 1  2  3  4 

[CONTOURNÉ] probleme connexion hydrogen à Jack

avelgwalarn Articles : 30 utilisateur non connecté
Bonjour à tous,

Le lancement de Hydrogen fait planter Jack, après quelques secondes (cf ci-dessous). Avez-vous une idée pour régler ce problème ?

Un grand merci,
19:46:13.785 Changement du graphique des connexions JACK.
19:46:14.009 Changement des connexions JACK.
19:46:14.307 Changement du graphique des connexions JACK.
subgraph starting at qjackctl timed out (subgraph_wait_fd=19, status = 0, state = Running, pollret = 0 revents = 0x0)
subgraph starting at qjackctl timed out (subgraph_wait_fd=19, status = 0, state = Running, pollret = 0 revents = 0x0)
19:46:32.595 Changement du graphique des connexions JACK.
19:46:38.825 Notification d'extinction.
19:46:38.859 JACK s'arrête...
19:46:38.861 JACK est forcé...
firewire ERR: wait status < 0! (= -1)
DRIVER NT: could not run driver cycle
jack main caught signal 12
no message buffer overruns
zombified - calling shutdown handler
19:46:40.526 JACK a été arrêté avec succès.
19:46:40.529 Script post-extinction...
19:46:40.531 killall jackd
jackd: no process found
19:46:42.297 Script post-extinction terminé avec statut de sortie=256.


jy_moustache Articles : 1512 utilisateur non connecté
ok
Peux-tu vérifier si ardour est connecté à Jack ?

Dans ardour, sur le menu en haut de la fenetre, session - transport - edit - view - Jack - ..< et vérifie

merci

jy

olinuxx Articles : 17919 utilisateur non connecté France
Coucou,
je lisais ce fil hier soir, et je me disais qu'il était pas simple.
(Je me disais ça car je n'ai jamais vu ces messages d'erreur.)

Du coup, je suis aller tchatcher un peu sur le canal de FFADO sur irc (#ffado sur freenode).

J'ai montré les messages d'erreur suivant :
firewire ERR: wait status < 0! (= -1)
DRIVER NT: could not run driver cycle
jack main caught signal 12

et :
Clocksource tsc unstable (delta = -129538093 ns)


J'ai eu 2 réponses : (je vous copier/colle des notes comme un sauvage wink )

un utilisateur :
Citation :
I'm not an expert, but I'd say try larger and lower buffer size settings


et un dev :
Citation :
there could be a bit more information available. there is a reason why ppalmers wrote that nice texts about what information we need for bug-reports and supporting users. I am quite surprised that all apps except ardour make jack bail out, ardour is one of the more demanding apps. could it be that ardour only runs because it restarts its own jack using alsa on the internal soundcard?


moi :
Citation :
mm yes it's very surprise to me that only ardour works. kampfschlaefer, i don't know stuffs for ffado, sorry if my ask is not enough clear (I'm an usb's user for now). Please could you give me a link that you tell me ? (I'm just trying to help an linuxmao's user)


le dev :
Citation :
its in the README file of the source package. Basically it comes down to the full output of jackd with -v6 (redirect that to a file otherwise your system will get problems because of the slow console) and the full output of ffado-diag

always interesting where bug-reports and problems end up. the upstream devs often have to tell users that its the packagers fault while the packagers get the usage problems upstream (or forums and mailinglists) are better served with.

also sent that user to the ffado-users mailinglist.


moi :
Citation :
kampfschlaefer, i'll transmit this to this guys thanks for help :-)


J'espère que ça pourra vous aider.

De plusse, je lui ai demandé comment nous pouvions faire pour aider au report de bug, je fais une page juste après avoir posté ce message ici : ffado_bugreport

Voilou,
++ Olivier

avelgwalarn Articles : 30 utilisateur non connecté
Citation :
ok
Peux-tu vérifier si ardour est connecté à Jack ?

Dans ardour, sur le menu en haut de la fenetre, session - transport - edit - view - Jack - ..


Salut JY,
heu .. je vérifie quoi ?
En tout cas, il me semble qu'Ardour est bien connecté à Jack. J'ai bien un onglet Jack dans le menu Ardour et dans la fenêtre connexions de qjack, Ardour apparaît bien...
J'ai même fait un test d'enregistrement en branchant un micro sur ma Edirol FA66 et ça marche.

m.

avelgwalarn Articles : 30 utilisateur non connecté
Salut Olivier,

Merci d'avoir discuté de mon problème par ci par là...
J'ai du mal a comprendre dans ton copier/coller qui répond à qui mais en fin voilà:

1) la réponse de l'uitlisateur : j'ai bien tenté plusieurs réglages différents du buffer mais rien n'y fait.

2) le développeur : je ne comprend pas trop ce qu'il veut dire par ardour ne fonctionne que seulement parcequ'il redemarre son propre Jack en utilisant Alsa sur la carte son interne ? c'est clair pour toi ?

Je suis un peu dégouté là (bon je vais manger ça rechargera mes batteries)

A+

Martin

jy_moustache Articles : 1512 utilisateur non connecté
Citation :
{QUOTE()}ok
Peux-tu vérifier si ardour est connecté à Jack ?

Dans ardour, sur le menu en haut de la fenetre, session - transport - edit - view - Jack - ..

En fait ardour peut fonctionner avec ou sans jack. si tu cliques sur l'onglet jack dans ardour tu verras si tu es connecté ou déconnecté :-)

jy

avelgwalarn Articles : 30 utilisateur non connecté
Citation :
En fait Ardour 3 peut fonctionner avec ou sans jack. si tu cliques sur l'onglet jack dans ardour tu verras si tu es connecté ou déconnecté :-)

jy


salut jy,

Alors oui Ardour est bien connecté à Jack.
Une question, est-il possible d'utiliser jackd sans qjackctl ? (en ligne de commande quoi (!). J'aimerai tenter de connecter hydrogen à ma carte firewire par ce biais... pour voir ...

martin

olinuxx Articles : 17919 utilisateur non connecté France
Citation :
Une question, est-il possible d'utiliser jackd sans QJackCtl ? (en ligne de commande quoi (!). J'aimerai tenter de connecter hydrogen à ma carte firewire par ce biais... pour voir ...

oui, ça doit ressembler à un genre de truc comme ça :
/usr/bin/jackd -R -m -dalsa -dhw:1,2 -r44100 -p1024 -n2
Cette ligne de commande est disponible dans les Messages de QjackCtl. Je ne crois pas qu'on ai une explication de toutes les options sur linuxmao. Ça sera l'occasion de démarrer cela wink

++ Olivier

gostaberling Articles : 199 utilisateur non connecté
Je me permets de m'intégrer à la discussion..
Il y a un problème avec qjackctl et hydrogen quand on utilise les pilotes FFADO (et pas les pilotes Freebob)
en tous cas c'est ce qui s'est passé sur ma bestiole avec la carte son Edirol FA101

J'ai trouvé la solution, mais malheureusement je ne sais plus bien où..
J'ignore si c'est le problème dont tu nous fais part, mais bon, je donne l'info quand même
Il faut éditer à la main le fichier de configuration d'hydrogen /home/user/.hydrogen/hydrogen.conf
ça ne marche pas en passant directement par le logiciel
et modifier deux choses :
1° entrer les informations de réglage de jackd directement dans le fichier de conf. Ce qui donne dans mon cas :

/audio_driver/Jack//audio_driver/
/use_metronome/false//use_metronome/
/metronome_volume/0.5//metronome_volume/
/maxNotes/64//maxNotes/
/buffer_size/1024//buffer_size/
/samplerate/48000//samplerate/

puis entrer les noms des connexions suivants :
/jack_driver/
/jack_port_name_1/system:playback_1//jack_port_name_1/
/jack_port_name_2/system:playback_2//jack_port_name_2/
/jack_transport_mode/USE_JACK_TRANSPORT//jack_transport_mode/
/jack_connect_defaults/false//jack_connect_defaults/
/jack_track_outs/false//jack_track_outs/
//jack_driver/
et, en tous cas chez moi, le problème est réglé

Bon courage en tous cas

NB : arff, comme le fichier de config de hydrogen est en xml, mes modifs ne s'affichent pas dans le message.. je remplace les < et > par des /, si vous me suivez..

olinuxx Articles : 17919 utilisateur non connecté France
Coucou et merci de ton apport d'information wink
Citation :
J'ai trouvé la solution, mais malheureusement je ne sais plus bien où..

Ça ne serait pas ici par hasard ? hydrogen_installation

Pour ce qui est de la mise en page, faut essayer de jouer du "np" mais très intelligemment car TikiWiki a vraiment du mal avec le XML.
C'est ici !
Sinon, comme tu as fais, on comprend, le plus important c'est l'information tout de même ! wink

++ Olivier, qui va se remettre le fond et la forme de Lofofora

gostaberling Articles : 199 utilisateur non connecté
Salut olivier, ben oui c'est bien sur linuxmao que j'ai trouvé la soluce à mon problème !

Du coup, j'imagine que avelgwalarn a déjà appliqué cette stratégie, et qu'elle ne convient pas.
Ça reste une énigme dans la mesure où je dois avoir à peu près le même matériel, une edirol fa101 à la place d'un FA66, et que chez moi tout est oK. Je travaille avec hydrogen connecté à ardour etc..

avelgwalarn Articles : 30 utilisateur non connecté
Salut Gostaberling, Olivier & JY,

J'avais en effet déjà tenté de modifier le fichier hydrogen.conf comme tu l'as mentionné Gostaberling. Ce n'étais toujours pas la solution malheureusement ! mais ....
YA DU NOUVEAU (enfin)
tout à fait par hasard j'ai pu brancher pour la première fois hydrogen-jackd et ma FA66, voici comment :
1) je débranche ma carte firewire
2) je reboote
3) je lance hydrogen AVANT Qjack. Il me dit "Pilote Jack impossible d'authentifier le client" mais après démarre impec.
4) j'ouvre Qjack
5) je branche ma carte firewire et je l'allume
6) je démarre Qjack sur ma carte
7) je repasse sur hydrogen: outil-préférences-onglet système audio -> je clique sur le bouton "redémarrer la sortie" puis OK

Et ça marche !!! tout cela si je suis strictement cet ordre ... si vous pouvez m'expliquer cela ?
et plus bizarre encore ... une fois que j'ai fermé tout ce petit monde, impossible de relancer ni Qjack ni hydrogen, ni ardour ... je dois repartir du point 1 et rebooter !
Je crois que j'ai vraiment un gros problème avec la gestion de mon port firewire ... qu'en pensez-vous ? (bon je ne sais pas si on peut classer ce fil en RESOLU ??)

Martin.

olinuxx Articles : 17919 utilisateur non connecté France
Coucou, wink

oué, vraiment étrange ...
et si tu essaies :

1) démarrage carte débranchée
2) branchement et allumage de carte
3) lancement et démarrage QjackCtl sur ta Edirol FA-66
4) lancement Hydrogen avec choix sur Jack

ça marche ?
Tiens nous au jus.

++
Olivier

avelgwalarn Articles : 30 utilisateur non connecté
Salut Olivier,

non non ça c'est ce que je faisais avant. J'ai réessayé, ça plante toujours. Pas moyen de faire autrement que l'ordre posté ci-dessus.
Il faut vraiment que je lance hydrogen avant Jack ! et je ne sais pas pourquoi ...
J'en suis à me demander si je ne vais pas faire une réinstallation du système (Ubuntustudio) ...

A+

Martin.

olinuxx Articles : 17919 utilisateur non connecté France
Coucou,

plutôt que de réinstaller, fais toi une installation sur une autre partition, tu pourras ainsi faire des comparaisons. Ensuite, si tu as la même truc étrange sur ton installation fraiche, je pense qu'il sera temps de contacter l'équipe de dev de FFADO.
T'en penses quoi ?

++
Olivier

avelgwalarn Articles : 30 utilisateur non connecté
J'ai déjà une double partition linux/XP pro, mon dd étant assez leger (mon pc à quand même 5-6 ans), sais-tu s'il est possible de tenter le coup avec un live cd ... ubuntu studio en live cd ça existe ?

Martin.

olinuxx Articles : 17919 utilisateur non connecté France
Coucou Martin,

à ma connaissance, il n'existe pas de live pour ubuntustudio.
Ceci étant dit, une install de base d'ubuntustudio doit prendre environ 6G maximum. T'es court à ce point ?

++
Olivier

avelgwalarn Articles : 30 utilisateur non connecté

ben ouai quasiment plus de place (il faut dire que mon disque ne faisait que 30Go au départ). Je vais voir si je peux faire de la place sinon je remplace Xubuntu optimisé pour la MAO par Ubuntu studio 9.10.
On verra bien ...

m.

olinuxx Articles : 17919 utilisateur non connecté France
Coucou,

si tu as une clé USB de dispo sous la main, tu peux tenter la live USB de musix, c'est une famille debian, donc pas très loin de ton ubuntu. Tu peux voir ce que ça donne, la live usb de musix fait environ 3Go.

Tiens nous au jus wink
++ Olivier

jy_moustache Articles : 1512 utilisateur non connecté
bon je débarque de vacances!
content de voir que t'arrives à faire marcher le bouzin, Martin. Même si ça nécessite une petite manip'.

je vais essayer de voir si je peux pas trouver des infos sur cette histoire de démarrer hydrogen avant de brancher la carte et jack

jy

zicstef Articles : 32 utilisateur non connecté
Salut à tous
Je me trouve dans le même cas que avelgwalam: ubuntu studio 9.10 et FA66.
Je pense qu'il nous faut surement creuser du coté de cette erreur:
firewire ERR: wait status < 0! (= -1)

C'est vraiment le souci qui ressort systematiquement.
^^ Stef

Page : 3/4  [Suivant]
1  2  3  4 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

calixtus06, 09:27, lun. 17 Jan 2022: Bonjour et bienvenue à bigveuch :-)
calixtus06, 18:05, sam. 15 Jan 2022: Bonjour et bienvenue à Roobuntu :-)
calixtus06, 16:48, mer. 12 Jan 2022: Bonjour et bienvenue à Aiz_user404, cedricm,DrClick :-)
olinuxx, 12:16, sam. 08 Jan 2022: Bonjour et bienvenue à lia cool
calixtus06, 16:29, jeu. 06 Jan 2022: Bonjour et bienvenue à Youpida :-)
r1, 21:09, mer. 05 Jan 2022: Toujours de bons mots contre tous les maux dans nos éditos !
allany, 19:35, mer. 05 Jan 2022: Est-ce pour l'an nouveau qu'il s'est fait si beau, l'édito ? [Lien]
calixtus06, 10:07, lun. 03 Jan 2022: Bienvenue à Laserpithium et Iblain :-)
calixtus06, 21:31, sam. 01 Jan 2022: Bonne année en mieux pour 2022 !
SuShY, 13:18, sam. 01 Jan 2022: Belle et heureuse année 2022 à tous !
olinuxx, 12:06, ven. 31 Dec 2021: Bonjour et bienvenue à Toufik cool
calixtus06, 15:26, mar. 28 Dec 2021: Bonjour et bienvenue à 70115MAO :-)