Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [ABANDONNÉ] Petits soucis avec Jack, besoin d'un coup de pouce :o)
Dernier post

[ABANDONNÉ] Petits soucis avec Jack, besoin d'un coup de pouce :o)

tithouan utilisateur non connecté
Bonjour à tous,
j'implore humblement votre aide biggrin

Je rencontre quelques soucis avec Jack et ma carte son usb (jack fonctionne avec la carte son integrée de mon pc mais pas ma carte son externe)

J'ai parcouru depuis environ deux semaines les pages en rapport avec la MAO sous linux, essayé pas mal de choses et je n'arrive toujours pas à faire tourner Jack (enfin si j'ai réussi une fois je ne sais pas comment, le pc à été reinstallé entre temps, la preuve que ça peut fonctionner) ... J'avoue que je fatigue un peu ...

Je précise que je ne débute pas dans linux, j'ai commencé en même temps qu'ubuntu en 2004/2005 ... Les manips ligne de commande ou autre ne me rebutent pas biggrin

Alors venons en au problème :

Je suis sous ubuntustudio lucid lynx
J'ai desinstallé Pulseaudio (j'ai des gresillements avec)
ubuntu reconnait bien la carte son externe ainsi que Qjackctl.

Le message d'erreur sous Qjackctl :


[+]
S'il y a besoin d'autres éléments, je fournirais sans soucis biggrin

Merci d'avance

olinuxx utilisateur non connecté France
coucou, pour faire avancer le schmilblick, faut que tu nous donne aussi le contenu de ton .asoundrc

a+
Olivier, qui penche pour un problème de pilote alsa

tithouan utilisateur non connecté
Citation :
coucou, pour faire avancer le schmilblick, faut que tu nous donne aussi le contenu de ton .asoundrc

a+
Olivier, qui penche pour un problème de pilote alsa


Alors question bête (débutant sous linux du point de vue du son)
où trouver le .asoundrc ?

pianolivier utilisateur non connecté France
moi je sais pas ou est .asoundrc (peut etre dans /home/ton_utilisateur/ ?), mais j'aimerai bien a la place le résultat de
cat /proc/asound/cards

merci ! wink

tithouan utilisateur non connecté
Citation :
moi je sais pas ou est .asoundrc (peut etre dans /home/ton_utilisateur/ ?), mais j'aimerai bien a la place le résultat de
cat /proc/asound/cards

merci ! wink


voici :

0 [VT82xx         ]: HDA-Intel - HDA VIA VT82xx
                      HDA VIA VT82xx at 0xfeafc000 irq 17
 1 [H4             ]: USB-Audio - H4
                      ZOOM Corporation H4 at usb-0000:00:10.4-4.2, full speed


pianolivier utilisateur non connecté France
a premiere vue, je te conseille de regler jack ainsi : nombre de périodes (Period/buffer) = 3 et taux d'échantillonnage (sample rate) sur 48000

relance le tout et renvoi le log complet de jack (en selectionnant tout bien depuis le début dans la fenetre message)

tithouan utilisateur non connecté
Citation :
a premiere vue, je te conseille de regler jack ainsi : nombre de périodes (Period/buffer) = 3 et taux d'échantillonnage (sample rate) sur 48000

relance le tout et renvoi le log complet de jack (en selectionnant tout bien depuis le début dans la fenetre message)


voici :


[+]

pianolivier utilisateur non connecté France
bon, pour finir de désactiver les options qui te servent a rien a priori, dans input device et output device sélectionne default
relance juste pour voir..
mais tu devrait encore avoir ce message d'erreur :
Citation :
DRIVER NT: could not start driver

qui est d'habitude associé a des problemes de firewire
quelqu'un a recement résolu ce probleme avec une carte usb en changeant de port... a essayer
sinon, arrives tu a utiliser le H4 sans jack ?

tithouan utilisateur non connecté
en sélectionnant default il se lance avec ma carte audio intégrée au pc

pour le h4n il a fonctionné une fois sous jack il y a quelques mois, mais j'ai dû me réinstaller un système depuis ... je viens d'essayer avec audacity, ça fonctionne.

j'ai essayé de changer de port usb ... toujours pareil

pianolivier utilisateur non connecté France
ok, bonne nouvelle alors :-)

pour le réglage de jack, ce que tu veux exactement c'est :
interface : hw:1 (le H4)
input device et output device : defaut
renvois le log de jack une derniere fois quand c'est fait

ensuite je vais me coucher, je regarderai demain car tu tombe sur un probleme pas tres commun. Ca doit en effet avoir rapport avec alsa comme le dit olinuxx. vérifie que tu as bien installé toutes les bibliotheques alsa et jack qu'il faut, peut etre des -dev j'y connai rien en ubuntutu...

oliv'

tithouan utilisateur non connecté
voici le resultat :


[+]

tithouan utilisateur non connecté
Citation :
Citation :
coucou, pour faire avancer le schmilblick, faut que tu nous donne aussi le contenu de ton .asoundrc a+ Olivier, qui penche pour un problème de pilote alsa


Alors question bête (débutant sous Linux du point de vue du son)
où trouver le .asoundrc ?


Alors je viens de me renseigner un peu sur ce fichier .asoundrc ...
je ne le trouve pas du tout sur mon pc. Pas de fichier .asoundrc dans mon /home et pas de .asoundrc.conf dans /ETC

jy_moustache utilisateur non connecté
salut

peut-etre devrais-tu essayer de regler un retard au démarrage par l'intermediaire des paramètres de QjackCtl. perso, j'ai mis 2sec. ca permet d'eviter certains soucis...

jy

PS : je vous laisse continuer sur les configs de carte son... wink

olinuxx utilisateur non connecté France
Citation :
Alors je viens de me renseigner un peu sur ce fichier .asoundrc ...
je ne le trouve pas du tout sur mon pc. Pas de fichier .asoundrc dans mon /home et pas de .asoundrc.conf dans /ETC


pas grave, c'était le /proc/asound/cards auquel je pensais wink J'ai du mal à me remettre dans le bain !

sinon, pour ce qui concerne ton soucis, quel est le module alsa qui gère ta carte ? (lsmod) et si c'est une carte usb, vérifie à la connection le dmesg.
(là, je te donne les infos en vrac en espérant que tu comprennes, si c'est pas le cas, hésites pas à me le dire, je détaillerai)

a+
Olivier

tithouan utilisateur non connecté
c'est bien une carte usb ... je dois avouer qu'un peu éclaircissement est le bienvenue, j'ai tapé la commande dmesg dans le terminal ... une balle liste lol faut que je copie ? ou il y a une manip à faire avec cette commande ?

olinuxx utilisateur non connecté France
alors je détaille, pas de souci, on est là pour ça :

dmesg est une commande qui donne la parole au noyau pour qu'il te parle, du coup, tu as raison, il y a une tripotée de ligne, et tout ne nous intéresse pas.

C'est pour cela qu'on va utiliser un enchainement de commande (merci linux !!!) :

watch 'dmesg |tail'


watch va te permettre de surveiller les changements sur le dmesg
dmesg va scruter et donner la parole au noyau
tail ne va s'intéresser qu'aux 10 dernières lignes de ce qu'il se passe dans ton dmesg

voilou, pour un peu plusse d'explication, ça va ? sinon, je peux pousser encore plusse dans les détails, pas de souci.

du coup, si tu lances la commande ci dessus et que tu branches ta carte usb, tu vas observer des changements dans le noyau, normalement (en gros), le noyau va te dire :
  • 1) hey ! y'a un nouveau truc dans ma prise usb X-Y !
  • 2) hey je l'ai reconnue, c'est machine bidule truc
  • 3) tiens ! je charge tel module pour la prendre en charge

et du coup, on va bien voir si ça se passe bien de ce côté là

voilou, renvoie nous ça pour qu'on t'aide
a+
Olivier

PS : (mode admin = on)
j'ai retouché la mise ne page de tes messages car c'était dur à lire. J'ai 2 améliorations à te proposer :
Édition (admin olinuxx) : pour améliorer la mise en page, merci de mettre les log ou copies de fichiers entre des balises de code comme ceci :
{CODE()} patatati patatata {CODE} ce qui donnera ceci
patatati patatata

Quand les logs sont trop longs, n'hésitez pas à rajouter *+ devant, donc au final *+{CODE()}patatati patatata {CODE} qui permettra de masquer le log. Ce qui donnera :

[-]
  • patatati patatata

Merci ! wink
Pour des conseils sur le fonctionnement général du forum, vous pouvez voir cette page.


et aussi, ne QUOTE que ce qui est utile, sinon, pour quelqu'un qui lit le fil, ça ajoute plein de chose inutile

merci wink

(mode = off)

tithouan utilisateur non connecté

[-]
  • Citation :
    watch 'dmesg |tail'


    du coup, si tu lances la commande ci dessus et que tu branches ta carte usb, tu vas observer des changements dans le noyau, normalement (en gros), le noyau va te dire :
    *1) hey ! y'a un nouveau truc dans ma prise usb X-Y !
    *2) hey je l'ai reconnue, c'est machine bidule truc
    *3) tiens ! je charge tel module pour la prendre en charge

    et du coup, on va bien voir si ça se passe bien de ce côté là

    voilou, renvoie nous ça pour qu'on t'aide
    a+
    Olivier

Voici ce qu'il m'a indiqué :
Every 2,0s: dmesg |tail                                 Sun Sep  5 15:42:05 2010

[  925.100073] usb 1-2.2: new full speed USB device using ehci_hcd and address 1
3
[  925.116331] hub 1-2:1.0: unable to enumerate USB device on port 2
[  934.182857] usb 1-2: USB disconnect, address 12
[  961.212038] usb 2-2: new full speed USB device using uhci_hcd and address 2
[  961.351249] usb 2-2: not running at top speed; connect to a high speed hub
[  961.359423] usb 2-2: configuration #1 chosen from 1 choice
[  961.362864] hub 2-2:1.0: USB hub found
[  961.364452] hub 2-2:1.0: 4 ports detected
[  962.265764] usb 2-2.2: new full speed USB device using uhci_hcd and address 3
[  962.405025] usb 2-2.2: configuration #1 chosen from 1 choice


pianolivier utilisateur non connecté France
info supplémentaire :

le meme probleme a été repéré sur le forum linuxmusician (meme erreur, meme carte) :
http://www.linuxmusicians.com/viewtopic.php?f=27&t=2641

il n'a hélas pas encore été résolu labas non plus, mais apparement il y a une chose en commun avec le lien que j'ai posté plus haut : le H4 fonctionne en lecture seule
à essayer (dans les réglages de jack) pour voir si c'est pareil pour toi

aussi, apprement gostarberling utilise cet enregistreur sous linux, ca vaudrai le coup de lui envoyer un message privé pour savoir si ca marche bien correctement chez lui et s'il a fait une manip spéciale

ps : apparement ca marche sans manip spéciale ici avec H4 en entrée en carte son intégrée en sortie

olinuxx utilisateur non connecté France
coucou,
t'as de la chance, super pianolivier - service de dépannage et de recherche à domicile'' - s'occupe de toi cool

allez, paf ! Je crée un début de page sur ce matériel : Zoom H4.

A+ et tiens nous au jus de l'avancement du truc wink
Olivier

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

calixtus06, 07:16, mer. 30 Nov 2022: Bonjour et bienvenue à Ikben Zogroot :-)
olinuxx, 18:07, lun. 28 Nov 2022: Bonjour et bienvenue à NicolasJ cool
calixtus06, 07:55, sam. 26 Nov 2022: Bonjour et bienvenue à Bob33 :-)
calixtus06, 08:54, mar. 22 Nov 2022: Bonjour et bienvenue à gadeu :-)
olinuxx, 10:02, dim. 20 Nov 2022: Bonjour et bienvenue à Neandertahl cool
sub26nico, 13:39, mer. 16 Nov 2022: Merci Samuel ;-)
Samuel, 21:17, lun. 14 Nov 2022: [Lien] C'est de la balle et c'est enregistré avec librazik
olinuxx, 18:53, dim. 13 Nov 2022: @christorbec : le mégaphone ne sert pas à se faire dépanner. Ouvre un fil dans le forum.
christorbec, 15:22, dim. 13 Nov 2022: changer de soundfont dans ToneLib-jam ?
calixtus06, 06:59, dim. 13 Nov 2022: Bonjour et bienvenue à Djefux :-)
calixtus06, 11:59, sam. 12 Nov 2022: Bonjour et bienvenue à zardoz45 :-)
calixtus06, 07:10, mer. 09 Nov 2022: Bonjour et bienvenue à majneb :-)