Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

Dernier post
Page : 1/2   -   Aller directement à la page : 1  2 

[RÉSOLU] Live Drive IR

didi43 utilisateur non connecté
Bonjour à tous et à toutes,

Nouveau venu dans le monde de Le système GNU Linux je recherche des infos pour connecter mon synthé sur mon interface live drive IR qui est une carte fille de ma live 5.1 platinium. je suis sur une distrib TangoStudio et mon synthé reste désespérément muet.
Merci de votre aide

olinuxx utilisateur non connecté France
Coucou,

c'est quoi ton synthé ?

Olivier

pianolivier utilisateur non connecté France
tu veux brancher la sortie audio du synthé sur ta carte son c'est ca ?
ou se situe le problème exactement ?

didi43 utilisateur non connecté
alors précisions, mon synthé c'est un clavier farfisa qui marchait tres bien en midi sous windoxs via la live drive IR et bien sur je veux retrouver la possibilité de l'utiliser en midi via la live drive IR

pianolivier utilisateur non connecté France
cat /proc/asound/cards

?

Samuel utilisateur non connecté Allemagne
Salut,

pas de soucis à avoir, ça doit marche très bien sous linux.
Il faut installer le paquet alsa-firmware (de mémoire), puis comprendre et lancer jack.
L'entrée midi de ta carte doit apparaitre dans l'onglet alsa dans la fenêtre connexions de qjackctl.
Je te laisse lire un peu les menus de gauche pour comprendre comment tout ça fonctionne sous linux ok ? En cas de soucis, appelle à l'aide.

didi43 utilisateur non connecté
j'ai l'impression qu'en fait le signal arrive jusqu'a la live drive( j'en suis pratiquement sur) mais que les entrées ne sont pas reconnue. Certainement un probleme au niveau des drivers de la carte car comme entrée midi j'ai EMU10K1 MPU-401 ( UART) donc si je ne me trompe pas l'entrée MIDI sur la carte SB platinium via le port de jeux et pas les entrées de la carte fille live drive IR .....
peut etre aussi un probleme de routage dans le EMU 10K1.
Pour info:
cat /proc/asound/cards :
0 [Live           ]: EMU10K1 - SB Live! 5.1 [SB0060]
                      SB Live! 5.1 [SB0060] (rev.7, serial:0x80611102) at 0xcc00, irq 18


Pravoslavac utilisateur non connecté
Salut,

Justement as-tu essayé le port midi/gameport à l'arrière de la carte son pour vérifier qu'il n'y a pas de problème de pilote ? Regarde aussi dans Qjackctl que tu n'as pas plusieurs ports midi (dans l'onglet Alsa, j'en ai par exemple 2 sur ma Audigy 2 zs) et d'y connecter avec ton programme compatible JACK.
N'oublie pas aussi de charger une soundfont avec asfxload.
Il me semble qu'il y a Dom32 qui a une Audigy Platinum Ex et donc un rack comme toi, il pourra éventuellement te guider dessus.

didi43 utilisateur non connecté
pour la connexion sur le port arriere j'ai un probleme de cable, je peux pas tester. Dans l'onglet alsa j'ai qu'une connexion c'est un peu pour celà que je pense que le port avant n'est pas reconu

Pravoslavac utilisateur non connecté
Il faudrait voir si ton rack possède un contrôleur midi, ce que je doute. Si il n'en a pas, alors il ne fait que de router les signaux midi vers ta carte son qui elle les traitera, donc elle s'occupe de la prise midi arrière et ceux du rack. Ça se traduira par un seul port midi sous Qjackctl, et donc qu'il n'y a pas de raison que ça ne marche pas. C'est pour ça que je demande si tu peux tester la prise arrière pour voir si ce n'est pas un problème de pilote.
J'ai fait une recherche sur les liens entre les drivers Alsa et LiveDrive, il n'y a aucun problème rencontré. Donc mon avis, c'est si ça ne marche pas derrière, ça ne marchera pas devant, et vice-versa, mais on va contourner le fait que tu puisses pas tester derrière, et vérifier d'autres hypothèses.
Pense aussi à tes niveaux de volume dans le mixer, il y a une explication ici : http://alsa.opensrc.org/index.php/SBliveMixerControls

didi43 utilisateur non connecté
Comme je te l'ai dit je vais avoir du mal à tester le port arrière de la carte et effectivement d'après ce que j'ai lu sur différents forums ou article les prises MIDI de la live drive sont juste une extension de la carte et il ne semble pas y avoir de contrôleur supplémentaire. Je pense qu'il s'agit d'un problème de routage au niveau du DSP. sinon dans le mixer alsa j'ai juste un niveau appelé "synth" qui semble correspondre au MIDI ..... avec F3 j'ai normalement le niveau de sortie et avec F4 le niveau capture mais même mis à fond toujours pas de son.
Pour terminer si je lance un clavier et un synthé virtuels j'ai bien du son midi en les connectant sous jack.
Dernière chose si j'utilise Kmidinon? je vois bien la carte mais aucun évènement quant je me sert du clavier alors que tous les autres évènements MIDI réagissent

Pravoslavac utilisateur non connecté
OK, bon je ne dispose pas de rack, ton retour est intéressant. D'ailleurs je me demande si on ne devrait pas faire un lien avec le topic centralisateur ?
As-tu activé l'option ir du module Alsa ? C'est une option peu explicite à rajouter pour activer le LiveDrive pas uniquement l'infrarouge mais aussi le midi d'après les infos glânées ici : https://forums.gentoo.org/viewtopic.php?p=1712474

Si tu ne l'as pas fait, il faut rajouter "enable_ir=1" dans le fichier /etc/modprobe.d/alsa.conf de telle sorte à avoir une ligne suivante :
options snd-emu10k1 enable_ir=1


Si ce n'est pas ça, il y a des chances qu'il y a un routage qui n'est pas fait par défaut. Ça pourrait s'activer avec le programme que je suis en train de confectionner, auquel cas il faudra attendre hélas que je le termine. Je serai donc intéressé par tes retours d'expérience, n'hésite pas de faire un tour dans le topic central des cartes Creative : tiki-view_forum_thread.php?comments_parentId=13755&forumId=2
Je vais tantôt commencer des tests du programme, si tu veux tu pourras y participer.

didi43 utilisateur non connecté
Ok tu vas dire que je suis nul mais c'est vrai je débute alors je connais pas encore tout et en particulier la méthode pour modifier les fichiers. J'arrive à afficher alsa.conf mais explique moi comment faire pour ajouter ou modifier une ligne dedans car effectivement je n'y vois pas la ligne que tu me donne. Merci d'avance quand au test de ton programme pas de soucis quand il sera finalisé je regarderai ça

Pravoslavac utilisateur non connecté
OK, ce n'est rien, on a tous pataugé à un moment ou un autre. Pense juste à donner un maximum d'infos pour que tes interlocuteurs puissent t'aider le plus efficacement.

Ne connaissant pas TangoStudio, je suppose que c'est basé sur Ubuntu ? Dans ce cas, il suffit d'ouvrir une fenêtre terminal et de taper la commande suivante (ou copie-la et colle-la dans le terminal) qui ajoutera la ligne que j'ai donné :
sudo echo "options snd-emu10k1 enable_ir=1" >> /etc/modprobe.d/alsa.conf

Cela te demandera ton mot de passe administrateur, une fois fait, cela ajoutera tout seul la ligne. Ensuite, il suffira de redémarrer l'ordinateur et de tester.

didi43 utilisateur non connecté
Tangostudio est effectivement basé sur ubuntu 10.04.1 LTS j'ai effectué la commande que tu m'as donné et j'ai ce message d'erreur :
bash: /etc/modprobe.d/alsa.conf: Permission non accordée


Pravoslavac utilisateur non connecté
Ah, sudo n'existe plus ? Ca fait longtemps que je ne suis plus Ubuntu et ses dérivés, donc je ne suis pas au courant des nouvelles possibilités...
Peut-être aussi que le fichier n'existe pas. J'ai oublié l'arborescence chez les Ubuntu-like (je suis passé à d'autres OS Linux), si quelqu'un peut mieux te guider que moi...
Regarde sinon si tu as un fichier à /etc/modprobe.d/alsa-base.conf si alsa.conf n'existe pas.

Enfin, je te conseille de voir les bases sous Le système GNU Linux si tu ne maîtrises pas tout ce qu'on dit.

didi43 utilisateur non connecté
ok j'ai trouvé alsa-base.conf je suppose que j'applique ta commande pour ce fichier je tente la manip et je te tiens au courant

didi43 utilisateur non connecté
toujours rien mais demain je vais récuperer les cables qui me manquent pour tester la sortie midi arriere sur la carte son

didi43 utilisateur non connecté
BINGO!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! ça fonctionne j'ai compris aussi pour le routage je teste avec rosegarden pour voir MERCI et pour ton projet fais moi signe

Pravoslavac utilisateur non connecté
OK, bon, je ne sais pas si j'aurai le temps de te répondre demain, je te donne une autre possibilité maintenant.
Supprime cette ligne que je t'ai demandé d'insérer dans le fichier alsa-base.conf, et cherche toujours dans ce fichier une ligne qui ressemble à ceci :
install snd-emu10k1 modprobe --ignore-install snd-emu10k1 && { /lib/alsa/modprobe-post-install snd-emu10k1 ; modprobe --quiet snd-emu10k1-synth ; }


Et remplace-la (ou ajoute la partie en gras au bon endroit s'il y a une différence entre la ligne donnée et ce que tu as) :
install snd-emu10k1 modprobe --ignore-install snd-emu10k1 __enable_ir=1__ && { /lib/alsa/modprobe-post-install snd-emu10k1 ; modprobe --quiet snd-emu10k1-synth ; }


Bonne soirée.

Pravoslavac utilisateur non connecté
Ah bon, tant mieux alors, ne tiens pas compte de ce que j'ai dit précédemment.

Sinon je te conseille plutôt de venir régulièrement prendre des nouvelles, je ne peux pas contacter tout le monde, c'est fait pour. J'y signalerai lorsque j'aurai besoin de faire des tests.

Page : 1/2  [Suivant]
1  2 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 23:34, dim. 28 Feb 2021: salut et bienvenue à rainbowalice et did1 :-)
r1, 21:06, ven. 26 Feb 2021: @christorbec: je te conseille d'ouvrir un fil sur le forum.
christorbec, 11:28, ven. 26 Feb 2021: bonjour,le suis embêté,car le curseur ne suis plus les notes sur la tablature de tuxguitar,depuis que je sui passer sous debian avec librazik 3....si quelequ'un a une idée?
Nolwen, 18:18, mar. 23 Feb 2021: Mise à disposition de Carla 2.3RC1 ! C'est par ici : [Lien]
sub26nico, 21:03, lun. 22 Feb 2021: Ardour 6.6 est disponible :[Lien]
Nolwen, 17:37, lun. 22 Feb 2021: Sortie de MusE 4.0pre3, dernière release avant la sortie officielle de la version 4 : [Lien] À vos tests et retours !
sub26nico, 13:34, lun. 22 Feb 2021: Bonjour et bienvenue à Inda et MarcoZik46 :-)
olinuxx, 18:42, ven. 19 Feb 2021: Bonjour et bienvenue à richerol cool
sub26nico, 22:06, jeu. 18 Feb 2021: Salut et bienvenue à ZeZombini et jonglacryl :-)
sub26nico, 23:46, mar. 16 Feb 2021: Bienvenue à Merrick et jeje004 :-)
olinuxx, 23:25, mar. 09 Feb 2021: Bonjour et bienvenue à GilouMao, Bstn, et Talion cool
Sahaathyva, 19:22, sam. 06 Feb 2021: Ce mois ci nous utilisons KickMess, un portage VST du kicker de Linux fait en rust.