Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [Résolu] M-AUDIO Fast Track guitar mic interface
Dernier post

[Résolu] M-AUDIO Fast Track guitar mic interface

caroy utilisateur non connecté
Bonjour,

Je suis un débutant en linux-mao.

Je tente de brancher la M-AUDIO Fast Track guitar mic interface pour enregistrer à partir du microphone. Je suis sur Debian squeeze. J'ai réussi à faire fonctionner Jack.

Quand je branche la M-Audio, je ne vois rien dans Jack. J'ai pourtant déjà vu qu'elle apparaissait comme une carte audio. J'ai aussi vu sur le Web un texte à qui rapportait que cet appareil ne fonctionne pas sur Linux. Avant d'aller plus loin, je me demande si ça vaut la peine de tenter de faire fonctionner cet appareil sur Linux.

Voici le résultat de la commande aplay -l

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: Track [Fast Track], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


Merci de votre aide!

Charles

allany utilisateur non connecté
Salut,

Un bon point, déjà, ta carte est reconnue !
Il faut donc que tu la déclares, dans Jack, comme hw:1.
C'est à renseigner dans "interface".
Tu relances Jack puis tu postes le log que tu trouveras en cliquant sur "messages".
De quel modèle de Fast Track s'agit-il (MKII, Pro, Ultra, ...) ?

As-tu lu ce nouveau Tuto Jack premier lancement ?

A+

caroy utilisateur non connecté
Bonjour,

Je n'ai pas lu te tuto que tu m'as recommandé. Je le fais à l'instant.

L'appareil est un petit pré-ampli pour brancher un micro et une guitare. Voici un lien vers ses caractéristiques :

http://www.m-audio.com/products/en_us/FastTrack.html

Le boîtier de mon modèle n'est pas tout à fait le même, mais les caractéristiques semblent pareilles.

Sur cette page de M-Audio, dans les exigences du système, on dit qu'il faut les compatibilités suivantes : ASIO 2, WDM, Mac OS X Core Audio.

Le problème semble précéder jack parce que je n'obtiens aucun son non plus sous Alsa.

Dans jack, j'ai réglé l'interface à hw:1 comme tu me l'as recommandé et voici les messages obtenus.


[+]

À+

Charles

pianolivier utilisateur non connecté France
coucou caroy

tout m'a l'air correct jusqu'à présent, une fois jack lancé, que vois tu dans les onglets "audio" et "alsa" de la fenêtre "connexions" de qjackctl ?
A mon avis tu devrai t'en sortir avec le tuto suivant : connecter des applications

oliv'

allany utilisateur non connecté
Tout à fait d'accord sauf que tu devrais mettre 70 dans la case "priorité" de Jack car 10, c'est juste...
Tu peux toujours tenter de lancer :
alsamixer
dans un terminal mais le driver Alsa pour l'USB risque bien de n'afficher aucun réglage...
Sinon, essaie avec hw:0 dans "interface" de Jack et vois si tu as du son par la carte interne, cette fois-ci. Profites-en pour vérifier les niveaux et mutes ([MM]) d'alsamixer.

Je pense, au vu du modèle de Fast Track, que ça devrait fonctionner sans souci en 16bits/44100hz.

A+

caroy utilisateur non connecté
Bonsoir,

Je suis allé voir les tutos que vous m'avez recommandés. J'avais fait le premier. Je suis donc un peu moins débutant que je croyais.biggrin J'aurai un plus grand sourire encore quand ça fonctionnera, mais vous m'encouragez.

J'ai ajusté les paramètres de jack en fonction du tuto ce qui incluait mettre la priorité à 70. Quand jack démarre, j'ai un message comme quoi il ne démarre pas, mais c'est faux. Après ce message en rouge, le processus suit sont cours.

Messages de jack


[+]
Sous Connexions, les trois onglets donnent les informations suivantes :

Audio

À gauche :
System
Capture1
Capture2
À droite :
System
Playback1
Playback2

Midi

Rien n'apparaît

Alsa

À gauche :
14:Midi Through
0:Midi Through Port-0

À droite :
14:Midi Through
0:Midi Through Port-0


A+

Charles

allany utilisateur non connecté
Comme je te l'ai écrit + haut, il est fort possible que le driver USB d'Alsa ne laisse passer que du 44100hz.
Essaie avec cette valeur plutôt que 48000, dans un premier temps.
Et renvoie le log de Jack car le début du log précédent est quand même un peu chelou...

A+

caroy utilisateur non connecté
Salut!

J'ai changé le réglage à 44100 et ai redémarré jack.

J'ai encore reçu le message qu'il ne pouvait se connecter au serveur. Voici les messages reçus qui t'apparaîtront peut-être encore chelous?

Le script de démarrage ne semble pas fonctionner à cause de l'impossibilité de communiquer avec le « server socket ».

Puis JACK démarre et mon appareil M-Audio ne semble pas lui poser problème.

Voici des messages de jack!

[+]
Merci!

Charles

caroy utilisateur non connecté
caroy écrit :
Bonjour,

J'ai réussi à faire fonctionner le micro sous Alsa. J'ai bien regardé l'écran de Alsamixer et j'ai vu comment régler le micro. Il était fermé. Eh oui! Une fois ouvert, j'ai réussi à enregistrer avec arecord et à écouter avec aplay. Je sais donc maintenant que l'équipement est compatible avec Linux.

J'ai encore un problème avec jack puisque qjackctl gèle quand je l'appelle. Il faudra sans doute que je commence par réinstaller les paquets.

Salut!


Charles


allany utilisateur non connecté
Salut,

Par rapport au début du message, peux-tu nous dire ce que tu as, comme commande (exécuter un script), dans l'onglet "options" des réglages de Jack et si c'est bien coché ?

A+

caroy utilisateur non connecté
caroy écrit :
Bonjour,

Ça fonctionne!!! J'ai réussi à enregistrer, hier, avec mon micro dans Audacity sans Jack. Aujourd'hui, j'ai réussi à le faire avec Jack. J'ai compris des choses à propos des connexions.

Je viens de publier un message en réponse à celui d'allany à propos d'un script au démarrage. J'ai l'impression que mon message n'est pas passé. Je vais attendre un peu pour voir s'il n'apparaîtra pas dans quelques minutes ou quelques heures.

Le problème que je rencontre encore est l'apparition d'une boîte qui dit « Impossible de connecter le serveur JACK comme client. »

J'ai l'impression d'avoir accès à un nouveau monde maintenant, celui de Jack.

Merci!

Charles


caroy utilisateur non connecté
caroy écrit :
Bonjour,

J'ai indiqué Résolu dans le titre du message parce que j'ai réussi à faire fonctionner le micro USB. Ce qui est mon problème au départ. Il fonctionne directement avec Alsa ou dans Jack, ce qui est merveilleux.

Pour les nouveaux comme moi qui cherchent à installer un micro usb, je peux ajouter que, dans les réglages, j'ai choisi hw:0,0 pour l'interface et hw:1,0 pour le périphérique d'entrée.

Le seul petit pépin que j'ai est que je reçois toujours la boîte avec le message d'erreur :

Impossible de connecter le serveur JACK comme client.

J'ai enlevé le script qu'il y avait au démarrage en décochant la boîte sous l'onglet Options de la fenêtre des réglages. Ce script était artsshell -q terminate

Sans ce script, voici les messages émis par Jack au départ :

======

23:11:44.596 JACK démarre...
23:11:44.597 /usr/bin/jackd -P70 -dalsa -dhw:0,0 -r44100 -p512 -n3 -D -Chw:1,0
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server socket
jack server is not running or cannot be started
23:11:44.620 JACK a été démarrer avec le PID=11945.
no message buffer overruns
no message buffer overruns
jackdmp 1.9.6
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2010 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 70
23:11:44.696 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Incapable de se connecter au serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server socket
jack server is not running or cannot be started
audio_reservation_init
Acquire audio card Audio1
Acquire audio card Audio0
creating alsa driver ... hw:0,0|hw:1,0|512|3|44100|0|0|nomon|swmeter|-|32bit
Using ALSA driver HDA-Intel running on card 0 - HDA Intel at 0x501c0000 irq 22
configuring for 44100Hz, period = 512 frames (11.6 ms), buffer = 3 periods
ALSA: final selected sample format for capture: 24bit little-endian
ALSA: use 3 periods for capture
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 3 periods for playback
23:13:36.397 Configuration du serveur enregistrée dans "/home/charles/.jackdrc".
23:13:36.399 Réinitialisation des statistiques.
23:13:36.419 Client activé.
23:13:36.433 Changement des connexions JACK.
23:13:36.446 Changement du graphique des connexions JACK.

======

Je vois qu'à 23:11:44.597, la commande de lancer jackd est émise.

Je reçois tout de suite un message à l'effet que la commande ne peut être exécutée.

Puis, à 23:11:44.620, on rapporte que jack a été lancé.

Ensuite, tout de suite après qu'on rapporte que jack a été lancé comme serveur, à 23:11:44.696, on dit qu'il est impossible de connecter le serveur Jack comme client.

Questions :

On parle de jack comme serveur et comme client. Est-ce que jack agit comme les deux à la fois ? Quelles sont les conséquences qu'il ne soit pas possible de le lancer comme client ? Tout semblait bien fonctionner. Je n'ai vu aucune conséquence.

Se pourrait-it que le message d'erreur arrive trop vite et que le programme de démarrage ne donne pas assez de temps à jack pour démarrer. Si le programme patientait quelques dixièmes de seconde, le message ne serait peut-être pas produit.

Voilà les questions qui me viennent en tête en fin de parcours !

Merci de m'avoir dépanné!

Charles

Charles


Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 15:14, mar. 01 Dec 2020: Bonjour et bienvenue à Soso et gegeweb cool
calixtus06, 11:21, lun. 30 Nov 2020: Bonjour et bienvenue à n0n3m ! :-)
calixtus06, 07:29, dim. 29 Nov 2020: Bonjour et bienvenue à Iluvatar ! :-)
olinuxx, 12:35, sam. 28 Nov 2020: Nouvelles du mois de novembre pour LibraZiK : [Lien]
olinuxx, 12:34, sam. 28 Nov 2020: Bonjour et bienvenue à diogene et à klopkloc cool
olinuxx, 19:45, mer. 25 Nov 2020: Bonjour et bienvenue à endymion93 cool
calixtus06, 07:13, mar. 24 Nov 2020: Bonjour et bienvenue à Noxanera ! :-)
sub26nico, 10:40, lun. 23 Nov 2020: Ardour 6.5 est disponible, le bogue d'export a été corrigé
Houston4444, 20:35, dim. 22 Nov 2020: Ardour 6.4 a de serieux soucis selon robin gareus lui-même. Attendez la 6.5 !
sub26nico, 18:00, dim. 22 Nov 2020: Ardour 6.4 est disponible :[Lien]
olinuxx, 14:48, dim. 22 Nov 2020: Bonjour et bienvenue à ykrons cool
olinuxx, 14:47, dim. 22 Nov 2020: @diigitae : [Lien]