Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [RÉSOLU] M-Audio Fast Tack Pro : les entrées n'apparaissent plus (nouveau sujet!!)
Dernier post

[RÉSOLU] M-Audio Fast Tack Pro : les entrées n'apparaissent plus (nouveau sujet!!)

qnitech utilisateur non connecté
Salutations amis de la musique libre et du libre en musique etc ...

J'ai le souci des entrée qui n'apparaissent plus avec lafasttrack pro, comme mon honoré collègue zamanika, j'ai effectué consciencieusement les diverses manip' pour lister, tenter de détecter etc .. nib, pas l'ombre de la queue d'une avancée.

Je répugne à réinstaller mon système parce que :
1 C'est l'apanage de Micr****t !!
2 C'est plus hygiénique !!
3 C'est mieux qu'en tube !!?!

C'est donc plein d'espoir que je me tourne vers vous, tout disposeé à vous donner des copie de toutes les consoles possible et imaginables après avoir exécuté les commandes qui vont bien...

Allez, Kénavo les potos et au plaisirs de bientôt vous lire.

JOhn

pianolivier utilisateur non connecté France
quelle distribution utilise-tu ?
quelle version d'alsa aussi ?
je ne pense pas que ca aide mais envoi ton log de jack aussi au cas ou

oliv'

qnitech utilisateur non connecté
pianolivier écrit :
quelle distribution utilise-tu ?
quelle version d'alsa aussi ?
je ne pense pas que ca aide mais envoi ton log de jack aussi au cas ou

oliv'


Salut Oliv',

J'utilise Ubuntu 10,4 avec un noyau 2.6.23-32-generic, j'ai alsa en 1.0.21 et voici le log de lancement de Jack :

17:02:34.398 Baie de brassage désactivée.
17:02:34.437 Réinitialisation des statistiques.
17:02:34.439 Changement des connexions ALSA.
17:02:34.443 Script de démarrage...
17:02:34.443 artsshell -q terminate
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server socket
jack server is not running or cannot be started
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server socket
jack server is not running or cannot be started
17:02:34.449 Changement du graphique des connexions ALSA.
sh: artsshell: not found
17:02:35.009 Script de démarrage terminé avec statut de sortie=32512.
17:02:35.009 JACK démarre...
17:02:35.010 /usr/bin/jackd -r -p512 -dalsa -r48000 -p256 -n3 -D -Chw:0 -Phw:0
17:02:35.013 JACK a été démarrer avec le PID=5915.
Cannot create thread 1 Operation not permitted
Cannot create thread 1 Operation not permitted
jackdmp 1.9.7
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2011 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in non-realtime mode
Cannot lock down memory area (Cannot allocate memory)
control device hw:0
control device hw:0
audio_reservation_init
Acquire audio card Audio0
creating alsa driver ... hw:0|hw:0|256|3|48000|0|0|nomon|swmeter|-|32bit
control device hw:0
ALSA: Cannot open PCM device alsa_pcm for capture. Falling back to playback-only mode
configuring for 48000Hz, period = 256 frames (5.3 ms), buffer = 3 periods
ALSA: final selected sample format for playback: 16bit little-endian
ALSA: use 3 periods for playback
17:02:37.229 Changement des connexions JACK.
17:02:37.231 Configuration du serveur enregistrée dans « /home/john/.jackdrc ».
17:02:37.232 Réinitialisation des statistiques.
17:02:37.244 Client activé.
Cannot lock down memory area (Ne peut allouer de la mémoire)
17:02:37.298 Changement du graphique des connexions JACK.

pianolivier utilisateur non connecté France
Citation :
JACK server starting in non-realtime mode


finalement le log est peut etre pas inutile
commence par suivre le tuto PAM
puis coche dans les réglages de jack "temps-réel" (voir ce tuto là)

enfin, ramène le nouveau log

++
oliv'

qnitech utilisateur non connecté
Voila m'sieur, j'ai lu, j'ai modifiu mais rien n'y fût !biggrin

JACK server starting in realtime mode with priority 70
control device hw:0
control device hw:0
audio_reservation_init
Acquire audio card Audio0
creating alsa driver ... hw:0|hw:0|512|3|48000|0|0|nomon|swmeter|-|32bit
control device hw:0
ALSA: Cannot open PCM device alsa_pcm for capture. Falling back to playback-only mode
configuring for 48000Hz, period = 512 frames (10.7 ms), buffer = 3 periods
ALSA: final selected sample format for playback: 16bit little-endian
ALSA: use 3 periods for playback
17:35:38.414 Changement des connexions JACK.
17:35:38.415 Configuration du serveur enregistrée dans « /home/john/.jackdrc ».
17:35:38.416 Réinitialisation des statistiques.
17:35:38.433 Client activé.
17:35:38.444 Changement du graphique des connexions JACK.

pianolivier utilisateur non connecté France
coucou

ouai bon, je dois avouer que je ne vois pas pourquoi ces deux problemes auraient été liés mais lancer jack correctement est déjà une bonne base de départ wink

maintenant il va donc faloir regarder du coté des pilotes alsa
commence par regarder si synaptic te propose une version plus à jour d'alsa (onglet "versions" quand tu selectionne le paquet)
ensuite je lit sur le site officiel "Reduced functionality in class-compliant mode, patch available for more features", ca sent la re-compilation à la main.
il existe sur la page M-Audio Fast Track Pro un lien sur un tuto dispo dans le forum de tango studio, je ne sais pas si ca peut aider mais ca vaut le coup de vérifier

tu peux développer le "entrée qui n'apparaissent plus" ? ou ca ? quoi ? comment ? smile

oliv'

qnitech utilisateur non connecté
...mmm alors ... développons ... tout a commencé il y a bien longtemps, il n'y avait rien, puis le big bang, ensuite les dinosaures se sont pointés, ensuite ils se sont éteint (il étaient sous Windows ...neutral) ensuite, il c'est passé un tas de trucs qui seraient trop long à t'expliquer, en substance, après avoir installé (compilé) dans l'ordre, Hydrogen, rakarrack, le pilote line6linux (j'ai un pod GX que je peut utiliser avec Jack mais qui grésille dans l'oreille droite si je met le casque dans le bon sens et la gauche si je me trompe de sensbiggrin) guitarix, jokosher, et surtout après avoir tenté de mettre à jours (sans succès à ma grande honterolleyes) Jack.

Je me suis aperçu que dans les préférences du son, le matériel était à peu près détecté, à peu près parce que la fasttrack pro comporte selon M. Ubuntu, deux sortie et une entrée ... (fumier de lapin (!)

Avant tout ce bazard, je suis bien sur d'avoir vu les bonnes infos dans les préférences du son.

Plus j'y pense et plus je me dit qu'Alsa est dans le coup ... c'est absolument illogique de n'avoir que la moitié des e/s capitaine !twisted
Effectivement, je sent se pointer la recompil du noyau .. avant cela je vais continuer à chercher dans les forums.

Un très grand merci pour ton assistance et ta grande réactivité, je décrirais la solution que j'aurais trouvé pour remettre tout en ordre.
+ J@hn

pianolivier utilisateur non connecté France
ha en effet si tu commences par le big-bang c'est un peu long à expliquer !
ceci dit il manque quand meme pas mal de choses entre la disparition des dinosaures et la compilation d'hydrogen smile

en vrai je pense que tu viens de clairement répondre à ma question et que ca confirme donc le patchage et recompilation d'alsa (un module du Le noyau Linux, pas le noyau entier normalement)
une visite rapide sur le forum sus-cité chez tango me confirme qu'il s'agit bien exactement du meme probleme, le pilote de base n'offre que quelques E/S.

bon courage et tiens nous au jus !

oliv'

qnitech utilisateur non connecté
.... alors voila .... je suis une brelle redface, d'1m88 et 103 kilo, une grosse brelle donc ... je n'ai pas bien lu les différentes solutions que j'ai trouvé, en désespoirs de cause et après avoir lu et relu une pelle, six caisse et trois petits fûts de forum ici et la, j'ai essayé d'utiliser le hw:1,0 qui comme son nom ne l'indique pas de façon intuitive représente le deuxième groupe d'entrée de la fasttrack pro ....

Et donc ... ça marche biggrin

Malheureusement dans le process, j'ai accumulé une somme de petites choses qui ont rendu mon système instable (oups, je suis allé un peu loin)

Encore un grand merci Oliv' pour ton aide et tes conseils, I'll be back !!

J@hn

pianolivier utilisateur non connecté France
cool que ca fonctionne !

tu rajoutes cette petite info sur la page M-Audio Fast Track Pro ? wink
(et une [résolu] dans le titre de ton post initial)
merci d'avance !


oliv'

qnitech utilisateur non connecté
Ayéééé

Bonnet de continuation et a plus sur le forum smile

pianolivier utilisateur non connecté France
Citation :
Ayéééé


1000 merci ! smile

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 17:17, mar. 07 Apr 2020: Bonjour et bienvenu à Paco, SavageWolf/Savage_Wolf, et market cool
olinuxx, 17:14, mar. 07 Apr 2020: @pierrotlo : ba... si ? 7
pierrotlo, 11:13, mar. 07 Apr 2020: tiens, il n'y a plus le nimp ?
allany, 19:56, dim. 05 Apr 2020: :-D
r1, 19:56, dim. 05 Apr 2020: @allany : ouais !!! c'est noël ! Quelle équipe hallucinante ! :-D
allany, 19:28, dim. 05 Apr 2020: L'édito, c'est le bon topo, les cocos ! [Lien]
olinuxx, 21:36, mer. 01 Apr 2020: Bonjour et bienvenue à simon_martineau, martineau_simon, et à Roland57 cool
olinuxx, 20:13, mar. 31 mars 2020: Bonjour et bienvenue à sethi1cool
Nolwen, 22:46, lun. 30 mars 2020: Sortie d'Hydrogen 1.0.0-beta 2 ce 30 mars 2020. [Lien]
olinuxx, 17:39, lun. 30 mars 2020: Bonjour et bienvenue à JulienRadio cool
sub26nico, 23:48, dim. 29 mars 2020: Salut et bienvenue à Chihiro49130, Gigi, Ptilou, yudas, FF63, mimifloch, mvvl et tophque :-)
malt, 15:55, dim. 29 mars 2020: @Sahaathyva. Je n'avais pas vu ton post!