Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [RÉSOLU] carte son externe ? sortie de veille ? son muet
Dernier post

[RÉSOLU] carte son externe ? sortie de veille ? son muet

jcS utilisateur non connecté
bonsoir!

1. la distribution: ubuntu 11.10
2. la carte son externe: m-audio fast track
3. le problème: à la sortie de veille, le volume est chaque fois redevenu muet. (ça rend wakeup inopérant et j'adore être éveillé en musique;))

Qui connaît la solution qui marche? (j'en ai essayé plusieurs glanées ici ou là, mais ça n'a jamais marché)
merci!

allany utilisateur non connecté
Hello !

Petit problème intéressant...

Est-ce que la M-audio est vue comme carte-son par défaut ?
As-tu désactivé la carte interne par le setup de ton BIOS ?
La M-audio est-elle pilotée exclusivement par Jack ?
Un PC fixe ou portable ?

J'ai, personnellement, des soucis d'allumage/extinction avec la même carte. Il me faut parfois rebooter ou re-charger le driver à la main.
Parfois, même, un pêt' sur le wifi déconnecte la M-audio...
Ton souci ne m'étonne qu'à moitié, donc.
La veille dure toute la nuit, si j'ai bien pigé ?
(Tu ne crains pas pour ta carte ? Surchauffe...)

A+

jcS utilisateur non connecté
D'abord merci de ta réponse

Chouette ensuite que tu trouves ce petit problème intéressant!

la carte interne est «éteinte» dans les préférences du son depuis l'os (mais je n'ai pas regardé dans le bios) et du coup, la m-audio est sélectionnée par défaut. Mais le «mutisme» du son n’apparaissait pas tant que je n'utilisais que la carte interne.

La m-audio n'est pas exclusivement pilotée par jack

c'est un pc fixe

cette carte son (et la carte interne) disparaissent parfois des «réglages du son», remplacées par une «carte son factice». Je ne sais pas ce que c'est, de toute façon ça ne marche pas alors je reboote

la veille dure la nuit (courte mais quand même)
(je n'avais pas encore songé que ça puisse chauffer ce petit boîtier ;))

allany utilisateur non connecté
Hello !

Il faudrait peut-être, alors, regarder du côté des quelques commandes Alsa.
Un alsactrl store te permettrait peut-être de figer la M-audio comme carte par défaut lors des redémarrages ?

J'ai très rapidement zieuté du côté de wakeup mais je n'y ai pas vu de paramétrage concernant la sortie audio...

A+

jcS utilisateur non connecté
voua

bon, je vais me pencher sur cette page (ça risque de prendre un peu de temps et le plus simple serait peut-être de n'utiliser la m-audio que pour brancher mes instruments...)

merci allany

allany utilisateur non connecté
Euuuh, je n'avais pas osé te le suggérer.
De toutes façons, la M-audio pour du streaming, c'est un peu comme prendre l'Airbus pour aller faire les courses à Carrefour, non ? cool

A+

jcS utilisateur non connecté
allany écrit :
Euuuh, je n'avais pas osé te le suggérer.
De toutes façons, la M-audio pour du streaming, c'est un peu comme prendre l'Airbus pour aller faire les courses à Carrefour, non ? cool

A+


haha oui
bon, mais maintenant que la m-audio est débranchée, la carte interne reconnue par défaut, démutée... plus de son :/ voyons voyons... ha oui, quel balot, le mini jack était pas au bon endroit :-D

allany utilisateur non connecté
Bon !

Quand tu estimeras qu'on a fait le tour du sujet, le modérateur sera ravi de voir un splendide "résolu" dans les titres du 1er et du dernier messages du sujet, comme d'hab'.

Tu ne nous a pas dit si ça marchait avec la carte interne...
On laisse passer la nuit ? cool
Réveil en fanfare ? evil

A+

jcS utilisateur non connecté
avant le [résolu] je veux résoudre mon pb initial: le son se mute après la veille ou l'hibernation (ou même le redémarrage) quand c'est ma carte externe qui est choisie par défaut. La carte interne, elle, a le comportement attendu et prévisible.
Je n'aimerais pas me réveiller en fanfare (sauf si c'est des copains dans la rue), en ce moment c'est la sarabande (donc une danse très lente) de la Suite n°5 en ut mineur, BWV 1011, pour violoncelle seul de js Bach qui me tire par la manche (du pyjama) yeah

allany utilisateur non connecté
Pas de souci, y'a le temps.
C'était juste un rappel de la méthode qui fait parfois débat, en ce moment, ici.

J' en ai une très vieille version, sur vynil, de ces suites.
Oui, pour un réveil + raffiné, c'est pas mal mais va programmer la platine TD pour l'heure du lever !...
C'était bien pour la fanfare, le smiley grimaçant.

A+

jcS utilisateur non connecté
toujours pareil, tourne en rond, le passage en 12.04 n'a rien changé (contrairement à ce que j'ai cru un instant.

allany utilisateur non connecté
Ca ne m'étonne toujours pas !

Pour vérifier la faisabilité du montage, tu pourrais copier dans un fichier le résultat de la commande avant mise en veille :
lsmod | grep usb
puis même commande au sortir de la mise en veille, nous poster les deux en précisant qui est avant/après.
On aura peut-être une surprise, quand au diagnostic...

A+

jcS utilisateur non connecté
allany écrit :
puis même commande au sortir de la mise en veille, nous poster les deux en précisant qui est avant/après.
On aura peut-être une surprise, quand au diagnostic...

A+


le lsmod | grep usb est le même avant et après la mise en veille ? sauf que le volume est muté après

snd_usb_audio         100930  2 
snd_usbmidi_lib        24558  1 snd_usb_audio
snd_hwdep              13276  2 snd_usb_audio,snd_hda_codec
snd_pcm                80435  4 snd_hda_codec_hdmi,snd_usb_audio,snd_hda_intel,snd_hda_codec
snd_rawmidi            25241  2 snd_usbmidi_lib,snd_seq_midi
snd                    55902  16 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_usb_audio,snd_hda_intel,snd_usbmidi_lib,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
usb_storage            44173  1 
usbhid                 41905  0 
hid                    77367  1 usbhid


allany utilisateur non connecté
Ca n'est donc pas ce que je craignais (déchargement du driver USB) et... tant mieux !
C'est donc Alsa qui se met en "mute". Je crois qu'il y a moyen de lui attribuer un volume par défaut et de le stocker définitivement avec la commande :
alsactrl store
ou approchant...

Essaie de trouver ça dans les docs Alsa, alsactrl, peut-être ?
Je regarderai également.

A+

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

dlb, 22:15, sam. 05 Dec 2020: Très bel édito, merci !
r1, 22:02, sam. 05 Dec 2020: Mais qu'il est beau, cet édito !
allany, 11:23, sam. 05 Dec 2020: Rien de démago, c'est l'édito ! [Lien]
calixtus06, 09:54, jeu. 03 Dec 2020: Bonjour et bienvenue à 2lafru ! :-)
olinuxx, 15:14, mar. 01 Dec 2020: Bonjour et bienvenue à Soso et gegeweb cool
calixtus06, 11:21, lun. 30 Nov 2020: Bonjour et bienvenue à n0n3m ! :-)
calixtus06, 07:29, dim. 29 Nov 2020: Bonjour et bienvenue à Iluvatar ! :-)
olinuxx, 12:35, sam. 28 Nov 2020: Nouvelles du mois de novembre pour LibraZiK : [Lien]
olinuxx, 12:34, sam. 28 Nov 2020: Bonjour et bienvenue à diogene et à klopkloc cool
olinuxx, 19:45, mer. 25 Nov 2020: Bonjour et bienvenue à endymion93 cool
calixtus06, 07:13, mar. 24 Nov 2020: Bonjour et bienvenue à Noxanera ! :-)
sub26nico, 10:40, lun. 23 Nov 2020: Ardour 6.5 est disponible, le bogue d'export a été corrigé