Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [résolu] Jack refuse de démarrer avec yamaha mg166-usb.
Dernier post

[résolu] Jack refuse de démarrer avec yamaha mg166-usb.

Bilka utilisateur non connecté
Bonjour à tous,

Mon problème : Jack refuse de Démarrer lorsque je choisi comme périphérique d'entrée ou de sortie ma console yamaha mg166 usb (elle inclus un module usb avec 2 E/S en usb 1).

Or cette carte son est reconnue et fonctionne très bien avec Pulseaudio dans Ubuntu 12.04, je peux par exemple écouter de la musique via la carte son sans aucun problème.
De plus, Jack fonctionne sans problèmes avec la carte son intégrée de ma carte mère.
Comment puis-je faire fonctionner jack avec cette carte son ? Peut-on router Pulseaudio vers Jack et inversement ?

Jack version 0.3.8
Ubuntu 12.04, noyau 3.2.0-24-generic

Message d'erreur de jack :

[+]

La commande "cat /proc/asound/cards" donne :
0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfebf8000 irq 21
 1 [CODEC          ]: USB-Audio - USB Audio CODEC
                      Burr-Brown from TI USB Audio CODEC at usb-0000:00:02.0-3, full speed


La carte est donc bien reconnue.

"lusb" donne :
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 058f:6362 Alcor Micro Corp. Flash Card Reader/Writer
Bus 002 Device 002: ID 08bb:29b0 Texas Instruments Japan PCM2900B Audio CODEC


Merci d'avance
Bilka

allany utilisateur non connecté
Hum !...

A priori, pas de driver Alsa pour cette carte .

Peux-tu quand même poster un :
aplay -l
pour vérifier sa reconnaissance ?

As-tu bien configuré ton PAM ?
Tu ne sembles pas, non plus, avoir coché la case "rt" dans jack...

A+

Bilka utilisateur non connecté
En effet je n'ai pas encore pris le temps de configurer mon PAM, mais sans utiliser le "rt" ça ne sert à rien non ? Je vais le tenter quand même...
Ce qui m'intrigue c'est que la carte fonctionne très bien sans jack... le son de Ubuntu n'utiliserais pas les drivers Alsa ? Ou pas seulement ?

J'ajoute aussi que, la carte fonctionnais par intermittence sur ma Ubuntu 10.04 (des xruns faisaient tout planter et la carte devenais indisponible).

"aplay -l" donne :
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: NVidia [HDA NVidia], périphérique 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: CODEC [USB Audio CODEC], périphérique 0: USB Audio [USB Audio]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0


Merci
a+

allany utilisateur non connecté
Je n'en suis pas certain (voir lien que je t'ai filé) mais je crois que Jack, pour les applis audio devrait tout le temps être en "rt", même si ton noyau est "generic"...

Si, le son d'Ubuntu passe bien par Alsa, comme sur la plupart des distrib's, d'ailleurs.

Ton aplay ne me rend pas super-optimiste dans la mesure où n'y figure qu'un seul périphérique, à priori, celui de sortie.
As-tu déjà réussi à enregistrer, via la carte ?

Dernier point :
Jack et Pulseaudio ne font pas bon ménage. Est-ce que tu tues Pulse avant chaque lancement de Jack (pulseaudio -kill (ou -k), je crois) ?
La combinaison des deux est cependant possible comme expliqué ici.

A+

Bilka utilisateur non connecté
Après configuration du PAM (et donc ajout de l'utilisateur dans le groupe audio), tout marche "out of the box".
Je viens de faire des tests de lecture et d'enregistrement, avec ou sans l'option "rt", tout marche...

J'ai pas trop compris pourquoi jack ne voulais pas démarrer avant cette manip (sachant qu'il fonctionnais avec ma carte son intégrée), mais bon ça marche !
J'aurais du faire ce qui est dit dans la doc avant rolleyes

Merci beaucoup !

allany utilisateur non connecté
Cool !

Ca signifie que le driver Alsa de base arrive à piloter certains modèles de carte pour peu qu'elles soient, sans doute, proches du "class compliant"...

En tous cas, peux-tu éditer les titres des premier et dernier post pour y rajouter le "résolu" d'usage ?
Exit modérateur, content que ça marche !

A+

olinuxx utilisateur non connecté France
Cool! Du coup, tu (Bilka) peux mettre a jour la page Cartes son des membres avant de t'envoler vers tes univers musicaux? Et même qu'une page dediee a ce matériel serait super si tu a du temps!

Bonne zik,
Olivier

xzu utilisateur non connecté France
Oui c'est clair, on a vraiment besoin de contribution pour 'déclarer' le matos compatible.

Bilka, merci de prendre 5min pour lancer la page, le plus important étant les info. La présentation, mise en page tout ça, on peut s'en occuper si ça te saoul! wink

Merci par avance!

à plus'

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 00:01, sam. 26 Sep 2020: @louiesauvage, l'aile ou la cuisse ? :-)
louiesauvage, 17:50, ven. 25 Sep 2020: Fedora ou librazik...
sub26nico, 11:22, ven. 25 Sep 2020: Salut et bienvenue à leschapis, Bengalex, Jyves et webangel :-)
allany, 20:44, jeu. 24 Sep 2020: @Jyves : salut ! Tu devrais poster ce type de question dans "le matériel et les pilotes..." A bientôt !
Jyves, 17:44, jeu. 24 Sep 2020: Bonjour, Je suis utilisateur de Linux depuis for longtemps. Je possède 3 cartes son: Une claret 8 pre. Une Scarlet solo Une simple Maudio pci 2 entrées/ 2 sorties + numériques et midi simple. Ou est le forum, J'ai des questions?
olinuxx, 14:27, dim. 20 Sep 2020: Bonjour et bienvenue à ladyash84 cool
olinuxx, 13:45, sam. 19 Sep 2020: Bonjour et bienvenue à tpeyron cool
olinuxx, 12:02, mar. 15 Sep 2020: Bonjour et bienvenue à Exencii cool
jphaenlin, 16:01, lun. 14 Sep 2020: Nouvelle version de TX Modular : [Lien]
olinuxx, 13:43, mer. 09 Sep 2020: Bonjour et bienvenue à borbor cool
sub26nico, 11:26, mar. 08 Sep 2020: Salut et bienvenue à Exeter et amar :-)
sub26nico, 19:59, lun. 07 Sep 2020: Ardour 6.3 est disponible : [Lien]