Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [résolu] avoir du son avec ubuntu studio et ma terratec phase 22
Dernier post

[résolu] avoir du son avec ubuntu studio et ma terratec phase 22

desafinado utilisateur non connecté
bjr
config: processeur :intel core 2 duos cadencé a 2.33ghz socket 775 lga.

carte mere: gigabyte ep35
ram 4go type dd2
carte grap: geforce gt 520.
carte son: terratec phase 22 relier a une table de mix ber eurorack ub 1204 pro
ubuntu studio est sur un ssd intel de 240 go qui lui est dédié.
pas de cohabitation avec w7 qui lui est installé sur un autre disque .sachant aussi que l'ensemble tourne très bien sur w7 avec cubase4 et wavelab.

cela fait maintenant 2 jrs que j’essaye d'avoir du son en appliquant tt vos directive avec alsa et alsamixer qui est d'ailleurs reconnue.
car en ligne de commande avec le terminal elle est clairement indiqué, et je l'est mise en 1er mais pour l'instant tt les solution indiqué n'ont pas aboutis.
si vs avec qq tuyaux je suis preneur, avec a l'avance ts mes remerciements .

allany utilisateur non connecté
Hello !

Ta carte ne fait visiblement pas partie des matériels Terratec supportés .

Bon. On va quand même regarder ça de plus près.
Peux-tu donc poster les résultats des commandes :
  • aplay -l
  • cat /etc/proc/asound
  • lsmod | grep snd
Peux-tu également confirmer qu'il s'agit bien d'une carte PCI ?
Souhaîtes-tu l'utiliser en usage "standard" ou en MAO ? Histoire de savoir si tu utiliseras le serveur Jack ou non...

A+

desafinado utilisateur non connecté
desafinado@xmen:~$ aplay -l

[+]
desafinado@xmen:~$ cat /etc/proc/asound 
cat: /etc/proc/asound: Aucun fichier ou dossier de ce type



[+]
merci de ta réponse et j'espère pouvoir trouver une solution .
oui c'est une carte pci .
et mon but est de faire de la mao bien sur.
en plus une ptit précision j'ai installé ubuntu studio 64 bits .
merci a toi.

allany utilisateur non connecté
Oui, excuse-moi !
Il fallait lire :
cat /proc/asound/cards
et non :
cat /etc/proc/asound (qui, au passage, ne veut rien dire... eek)
Hum, j'ai du zapper un café, ce matin...

On regarde tout ça...
Peux-tu poster le /proc/asound, en attendant ?
Et nous dire si Jack se lance bien, sans paramétrages particuliers.

A+

allany utilisateur non connecté
Bon !

Donc résultat des premiers examens :
  • tu as bien un driver chargé pour ta carte, le snd_ice1724
  • elle est bien reconnue en carte N°1.

Simple curiosité mais as-tu également un périphérique audio connecté en USB ?
Est-ce la Terratec ou la carte intégrée qui traite du HDMI ?

Essaie de lancer Jack avec :
  • priorité=75
  • interface=hw:1
  • buffer=1024 (périodes/tampon)
et communiques-nous le log (messages).

As-tu le module alsa-tools installé sur ton système ?
Tu dois pouvoir le savoir en lançant une recherche par Synaptic (gestionnaire de paquets).

A+

desafinado utilisateur non connecté
et bien fait attention au café quand même lol
desafinado@xmen:~$ cat /proc/asound/cards
 0 [T22            ]: ICE1724 - Terratec PHASE 22
                      Terratec PHASE 22 at 0xd100, irq 19
 1 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfb100000 irq 45
 2 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf6000000 irq 17
 3 [U0x46d0x821    ]: USB-Audio - USB Device 0x46d:0x821
                      USB Device 0x46d:0x821 at usb-0000:00:1a.7-3, high speed

oui j'ai une connexion usb en hdmi il sagit d'une cam hdmi

il faut te dire que mon expérience ubuntu viens de débuter, j'ai donc un peu de mal avec certaine manip désolé.

Essaie de lancer Jack avec :

priorité=75
interface=hw:1
buffer=1024 (périodes/tampon) !!!! c'est pas mon copain celui là je le trouve ou.
j'ai bien un ((qjackctl) dans liste des applications es ce cela
oui pour alsa-tools

allany utilisateur non connecté
Oui, !

Qjackctl est le nom de l'interface graphique de Jack.
C'est donc bien ce soft qu'il te faut lancer.

Quand à alsa-tools, il te servira peut-être, à l'avenir, à disposer de contrôles "soft" pour piloter ta carte.
Mais ça, on verra plus tard, quand Jack se lancera bien.

A ce sujet, si ce n'est pas déjà fait, tu as un bon petit tuto sur le site pour t'initier à Jack.

A+

desafinado utilisateur non connecté
quand tu me demande de lancer jack avec: une fois jack lancer je fait commen
et bien fait attention au café quand même lol
desafinado@xmen:~$ cat /proc/asound/cards
 0 [T22            ]: ICE1724 - Terratec PHASE 22
                      Terratec PHASE 22 at 0xd100, irq 19
 1 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfb100000 irq 45
 2 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf6000000 irq 17
 3 [U0x46d0x821    ]: USB-Audio - USB Device 0x46d:0x821
                      USB Device 0x46d:0x821 at usb-0000:00:1a.7-3, high speed

oui j'ai une connexion usb en hdmi il sagit d'une cam hdmi

il faut te dire que mon expérience ubuntu viens de débuter, j'ai donc un peu de mal avec certaine manip désolé.

Essaie de lancer Jack avec :

priorité=75
interface=hw:1
buffer=1024 (périodes/tampon) !!!!c'est pas mon copain celui là je le trouve ou.j'ai bien un qjackctl dans liste des applications es ce cela
oui pour alsa-tools
désolé mais:
une fois que j'ai lancer jack je fait comment pour priorité=75 et les autres, avec un terminal, ou sur les onglets du jack. comme message session brassage: etc .
j'ai lu le tuto sur le jack je suis en train de le digéré.
merci encore de ta patience.

desafinado utilisateur non connecté
bjr
alors aprés un tps certain, ou peut être un certain tps.bon bref j'ai du son en lecture. et c'est déjà super merci car le tuto sur le jack ma bien aidé, j'ai mis l'ensemble des éléments en relations, et miracle de la techno ça marche.
maintenant j'aimerai pouvoir faire la même chose en enregistrement avec audacity ou ardour.
je voudrai juste savoir: il y à plusieurs options pour démarrer ubuntu studio.
ubuntu normal:
ubuntu avancé: es ce que cela change qq chose pour le son, j'ai crus comprendre qu'il y avait une meilleurs prise en charge de la latence .
merci a toi pour ts ce tps que tu as bien voulu me consacré.

allany utilisateur non connecté
Peux-tu poster ton log (messages) de Jack afin de voir où ça cloche question enregistrement ?

Je ne comprends pas trop ta question à propos de Ubuntu "normal" ou "avancé"...

La meilleure prise en charge de la latence se fera en choisissant un noyau (kernel) soit "lowlatency" soit "realtime" au lieu du noyau "generic" installé par défaut.

Tu trouveras des explications sur les atouts de ces différentes options dans ce chapitre.

Avec les distributions récentes (Ubuntu 10.04 et +), le noyau "lowlatency" convient à la plupart des utilisations en MAO.

A+

desafinado utilisateur non connecté
en faite tu as répondu a ma question avec le lien que tu ma donné. c'est effectivement le noyau lowlatency qui me posait question merci.

voilà le log message de jack

[+]a+

allany utilisateur non connecté
Je serais assez preneur d'un autre log de Jack mais en le lançant après avoir "tué" pulseaudio.
La commande (vérifie...) doit être du genre :
pulseaudio -k


Sinon, dans le log précédent, Jack semble bien reconnaitre 2 entrées et 8 sorties et parait démarrer correctement.

Enfin, si tu souhaîtes tester avec Audacity, il faut lancer ce dernier en l'ayant paramétré ("édition/préférences") pour s'interfacer avec Jack (et non alsa ou pulse) ET le mettre en "enregistrement/pause" avant de le voir apparaitre sous le nom de "portaudio".

A+

desafinado utilisateur non connecté
bjr
je ne sais pas si j'ai tué pulse audio car la manip que tu ma donné ne semble pas marché.je l'est juste déconnecté.
j'espère que cela suffira .

[+]
a+ merci

allany utilisateur non connecté
Est-ce que :
pulseaudio --kill

marcherait mieux ?

Si oui, renvoie encore un log de Jack, sans pulse...

A+

desafinado utilisateur non connecté
semble ne pas marché non plus.

[+]
en faite je suis allé dans moniteur systeme processuces et je l'est stoppé.
j'espère que cette fois c'est bon
merci

allany utilisateur non connecté
Bon, visiblement, pulse a dégagé.
Pour le reste, tout me semble bon, aussi bien en entrée qu'en sortie.

Normalement, si tu effectues la manip' que je t'ai indiquée plus haut avec Audacity, ça devrait fonctionner.

Petits conseils de modérateur :
Essaie, lorsque tu réponds, de virer le texte du message précédent, qui se met en citation et perturbe la lecture du fil.
Je viens de tout remettre en forme car ça devenait longuet à re-parcourir...
Essaie, lorsque tu inclus du code ou des messages longs, de les sélectionner pour les mettre en "code" (icône avec sup/inf) et fais précéder le premier symbole "code" des signes * et - (*-).
J'ai tout remis sous cette forme dans les posts précédents, tu verras...

A+

desafinado utilisateur non connecté
bjr allany
je tien ts d'abord a te remercier pour ta patience et l'aide des plus précieuses que tu ma apporté.

je viens de faire mon 1er enregistrement avec ardour.
audacity ne veux rien savoir il reste en maître avec alsa pas moyen de le sélectionner sur jack j'ai beau essayer de faire les connections rien n'y fait, mais pas grave je reglerai le problème plus tard.
une dernière chose peut tu m'indiquer un lien pour étudier alsa-tools.
et comment je fait pour enregistrer ma config avec jack.

merci encore
et je crois que je vais poursuivre l'aventure ubuntu studio seule.

desafinado utilisateur non connecté
re cc
eurêka audacity a cédé je viens de faire un enregistrement avec .
mauvais réglage au niveau de l’échantillonnage.
voilà l'ensemble est au top me reste plus qu'à bosser.
re re re merci.

allany utilisateur non connecté
Cool !

Bosser oui mais c'est tellement plus sympa de travailler sa musique plutôt que les paramétrages de Jack... cool

Peux-tu, alors, éditer le titre de ton 1er post et y ajouter un bien mérité "résolu" ?

Ah, j'oubliais !
Alsa-tools devrait te fournir un mixer logiciel qui s'appelle envy24control ou mudita (de mémoire...) et qui doit apparaître dans la liste de tes applications "audio".
Ils n'ont pas été conçus pour cette carte, à l'origine, mais te permettront peut-être, sans garantie, d'affiner certains de tes réglages.

Bosse bien, à+

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

calixtus06, 09:27, lun. 17 Jan 2022: Bonjour et bienvenue à bigveuch :-)
calixtus06, 18:05, sam. 15 Jan 2022: Bonjour et bienvenue à Roobuntu :-)
calixtus06, 16:48, mer. 12 Jan 2022: Bonjour et bienvenue à Aiz_user404, cedricm,DrClick :-)
olinuxx, 12:16, sam. 08 Jan 2022: Bonjour et bienvenue à lia cool
calixtus06, 16:29, jeu. 06 Jan 2022: Bonjour et bienvenue à Youpida :-)
r1, 21:09, mer. 05 Jan 2022: Toujours de bons mots contre tous les maux dans nos éditos !
allany, 19:35, mer. 05 Jan 2022: Est-ce pour l'an nouveau qu'il s'est fait si beau, l'édito ? [Lien]
calixtus06, 10:07, lun. 03 Jan 2022: Bienvenue à Laserpithium et Iblain :-)
calixtus06, 21:31, sam. 01 Jan 2022: Bonne année en mieux pour 2022 !
SuShY, 13:18, sam. 01 Jan 2022: Belle et heureuse année 2022 à tous !
olinuxx, 12:06, ven. 31 Dec 2021: Bonjour et bienvenue à Toufik cool
calixtus06, 15:26, mar. 28 Dec 2021: Bonjour et bienvenue à 70115MAO :-)