Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [RÉSOLU] Terratec 6fire USB non reconnue ,non une fois oui, mais jamais de son
Dernier post
Page : 1/2   -   Aller directement à la page : 1  2 

[RÉSOLU] Terratec 6fire USB non reconnue ,non une fois oui, mais jamais de son

ikarios utilisateur non connecté
Bonjour à toutes et tous j'espère que vous vous amusez bien en mao soit disant au apassage c'est un peu le but de composer l'esprit libre et ouvert........non?

voilà j'ai acheter il y a peu pour améliorer la qualité sonore de mon installation dematérialisée une Terratec DMX 6Fire USB mais le soucis j'ai bien installer les pilotes sous linux de sourceforge.net mais rien n'a faire la carte n'est pas reconnue sauf une fois par miracle elle est apparue mais je ne suis pas arrivé à sortir le moindre son. (j'ai téléchargé sixfireusb.tar.gz2) plus fwinst.sh
mais rien à faire toujours pas reconnue
si quelqu'un à une piste je suis preneur car sous windows (évidemment) elle marche du tonnnerre avec un très bon son ................
merci d'avance pour vos idées
ikarios
Ps je suis sous ubuntu 12.10

Édition admin Olinuxx 2014-02-02 :

Liens sur linuxmao d'éléments dont il est question dans ce fil :


allany utilisateur non connecté
Salut,

A priori, Alsa donne la carte comme étant plutôt bien (entrées/sorties, fréquences, etc...) supportée. Donc le problème ne viendrait pas du matériel.
Pourquoi, d'ailleurs, avoir installé un driver autre que celui d'Alsa ?

Peux-tu poster le résultat d'un :
aplay -l

puis d'un :
lsmod | grep usb

voir si tout est en place ?

A+

ikarios utilisateur non connecté
merci de ton soutien je poste comme je peux les résultats demandés
aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: PCH [HDA Intel PCH], périphérique 0: ALC887-VD Analog [ALC887-VD Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 1: ALC887-VD Digital [ALC887-VD Digital]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 2: NVidia [HDA NVidia], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice 
carte 2: NVidia [HDA NVidia], périphérique 7: HDMI 1 [HDMI 1]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 2: NVidia [HDA NVidia], périphérique 8: HDMI 2 [HDMI 2]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
root@Hal:~# lsmod | grep usb
snd_usb_audio         136422  0 
snd_usbmidi_lib        25397  1 snd_usb_audio
snd_usb_6fire          45161  0 
snd_hwdep              17765  2 snd_usb_audio,snd_hda_codec
btusb                  22432  0 
snd_pcm                97523  7 snd_ice1712,snd_ac97_codec,snd_usb_audio,snd_hda_codec_hdmi,snd_usb_6fire,snd_hda_intel,snd_hda_codec
bluetooth             211812  25 rfcomm,bnep,ath3k,btusb
snd_rawmidi            30750  4 snd_mpu401_uart,snd_usbmidi_lib,snd_usb_6fire,snd_seq_midi
snd                    83674  30 snd_mixer_oss,snd_ice1712,snd_ak4xxx_adda,snd_cs8427,snd_ac97_codec,snd_i2c,snd_mpu401_uart,snd_usb_audio,snd_usbmidi_lib,snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_usb_6fire,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
usb_storage            49288  0 
usbhid                 47259  1 hid_logitech_dj
hid                   100815  2 hid_logitech_dj,usbhid
root@Hal:~#


ikarios utilisateur non connecté
en recompiulant les driver sixfireusb.tar.gz2 et fwinst.sh j'ai bien la carte qui apparait dans les paramètre de la boîte "son"
mais en cliquant dessus je n'ai pas de son et même en la séléctionnant via alsamixer je n'ai toujours aucun son étrange n'est -il pas?
alors comment faire pour faire sortir du son de cette satanée boîte Terratec?
je suis toute ouïe et merci à allany pour son soutien et son aide....
aplay-l
ikarios@Hal:~$ aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: NVidia [HDA NVidia], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: NVidia [HDA NVidia], périphérique 7: HDMI 1 [HDMI 1]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: NVidia [HDA NVidia], périphérique 8: HDMI 2 [HDMI 2]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: DMX6FireUSB [TerraTec DMX6FireUSB], périphérique 0: 6fire Analog [DMX 6Fire USB Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: DMX6FireUSB [TerraTec DMX6FireUSB], périphérique 1: 6fire Digital Out [DMX 6Fire USB Digital Playback]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
ikarios@Hal:~$



après quelque manipulation j'ai de nouveau perdu la boite son terratec dans l'onglet "son"
maintenant aplay-l donne ceci
aplay -l
ikarios@Hal:~$ aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: PCH [HDA Intel PCH], périphérique 0: ALC887-VD Analog [ALC887-VD Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 1: ALC887-VD Digital [ALC887-VD Digital]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 2: NVidia [HDA NVidia], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 2: NVidia [HDA NVidia], périphérique 7: HDMI 1 [HDMI 1]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 2: NVidia [HDA NVidia], périphérique 8: HDMI 2 [HDMI 2]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
ikarios@Hal:~$


Je pense que ton problème n'est pas ton pilote ni ta carte son mais l'alimentation de ton pc.
Vu le nombre d'entrées/sorties je commencerai par brancher la carte sur une alimentation à part.
A partir du moment ou elle sera alimentée avant le démarrage du pc ça devrai changer la donne.
Il te faut pour simple un simple transfot universel avec les embouts amovibles et reversibles.
(enfin c'est à vérifier mais c'est ce expliquerai le pourquoi un coup elle apparait dans aplay-l et d'autre fois non).
Question bête c'est quoi ton pc ?
Portable? sur secteur ou batterie? Le gestionnaire d'energie? je commencerai par là.

allany utilisateur non connecté
utilisateur_anonyme a peut-être raison et, de toutes façons, alimenter via le port USB, c'est pas top pour le PC, si c'est bien un portable...
J'avais aussi eu des problèmes (tes "aplay" le prouvent) de reconnaissance d'une carte USB qu'il fallait éteindre avant de booter et n'allumer qu'une fois loggé...
Par contre, le module "driver" snd-usb-audio est bien chargé.
Peux-tu nous expliquer le pourquoi du driver spécifique ?
A priori, si on en croit Alsa, tu ne devrais pas en avoir besoin. Une subsistance ?
A+

ikarios utilisateur non connecté
merci à vous deux pour votre soutien non mon pc n'est pas un portable mais un dell xps8500 et de plus la carte est alimentée en externe par un transfo sur secteur donc je ne pense pas que ce vienne de là j'ai téléchargé le pilote alsa driver dmxsixfireusb.tar.gz2 parce que dans un forum c'était l'unique solution pour que la carte soit reconnue
donc peut-être avez vous d'autres idées merci en tout cas
bonne continuation en mao
a+

Ce que je comprend pas c'est le pourquoi ta carte semble reconnue quand elle a le temps.
Déjà désactive la carte son intégrée depuis le bios, de sorte à éliminer les problèmes.
Est ce que dans audacity tu la vois? (audacity n'a pas besoin de jack pour lire ou enregistrer et pour un simple test c'est pratique)

allany utilisateur non connecté
Si tu en as la possibilité, ça vaudrait le coup d'essayer avec juste le driver Alsa par défaut.
Est-ce qu'il y a une procédure de désinstallation de dmxsixfireusb ?

Essaie aussi l'allumage de la carte APRES le boot et vérifie qu'elle est présente avec un aplay -l.
Fais ce test (reboot/allumage carte/aplay) 3-4 fois de suite.

Comme le suggère utilisateur_anonyme, regarde dans ton setup de BIOS si tu peux désactiver l'audio interne.

A+

ikarios utilisateur non connecté
Voilà j'ai désactivé l'audio interne de la carte mère et la carte est bien reconnue dans un aplay -l par contre si je désinstalle le driver six fire usb .tar.gz2 là plus rien n'est reconnu. Avec la commande envy24control il me retourne qu'il ne trouve pas la carte son Ice1712 bizarre......en tous cas merci pour les idées je sens qu'on progresse mais ce n'est pas encore le top!
merci et à +
bonne mao a vous deux...........

allany utilisateur non connecté
Envy24control sert à piloter les cartes PCI à base de chipset Ice1712, ce qui n'est pas le cas des cartes USB...
Ca ne sert donc à rien, dans ton cas...

Par contre, j'ai vu que le module chargé (lsmod) était le snd-usb-audio alors que, dans les spec's Alsa, il faudrait avoir le driver usb-6fire .
As-tu bien installé le paquet alsa-firmware qui, toujours selon Alsa, est nécessaire au bon fonctionnement de ce modèle de carte ?
Normalement, ce paquet est installable via Synaptic.

A+

A mon avis si tu désinstalle le pilote
tu reboot
tu ouvre jack et tu devrais y voir un
[DMX 6Fire USB Analog]

ou bien quelques chose comme
USB audio CODEC

Enfin quelques chose avec au moins usb ou snd ... ???

Ensuite envy24control n'est peut être pas approprié car tu cherche une puce Ice1712 hors c'est un chipset usb non ? enfin je me trompe peut être ?
Donc le simple "Controleur de volume" (alsa mixer) devrait être plus approprié non (sauf si je dit une con##~{ tu m'arrette

ikarios utilisateur non connecté
si je désinstalle le pilote je n'ai plus rien nulle part par contre avec le pilote dans Jack j'ai bien la TerraTec 6fire USB DMX dans l'onglet alsa mais je n'ai aucun son qui sort avec audacity j'ai téléchargé une musique de Orb et j'ai bien les deux colonne vertes qui s'agitent signe que le son passe par quelque part mais je n'ai aucun retour dans mon casque ni dans mon ampli via les enceintes alors je ne comprends pas pourquoi aucun son ne sort si utilisateur_anonyme ou allany vous avez des idées je suis toute ouïe carf je commence à désespérer
allez bonne mao a vous tous et bonne zique aussi
a+

Bon alors on reprend biggrin
Est ce que dans jack tu peux selectionner ta carte son de sorte que l'es dans l'onglet "Audio".
Si c'est le cas tu le selectionne par défaut tu sauves tu ferme, puis tu ouvre de nouiveau jack et "Démarrer"
Si ça le fait :
Ensuite Audacity tu l'ouvre puis Edition => Préférences
Périphériques => hôte: (si jack est lancé) jack audio connetion kit
Image
Ensuite quand tu va ouvrir ton fichier et lancer la lecture tu devrai voir un peu de changement dans "Connecter" (PortAudio c'est Audacity)
Image

ikarios utilisateur non connecté
mmmmh ca a l'air intéressant mais j'ai pas compris grand chose mea culpa lol

Commence par regarder si tu la vois depuis cette fenêtre .

Si c'est le cas tu es proche du but, et surtout ne pense pas "comme si t'étais sur windows"
sinon tu va galérer pour piger le truc .

allany utilisateur non connecté
Je redis qu'il faudrait qu'ikarios ait bien le driver usb-6fire, d'une part, et alsa-firmware, d'autre part.
Si j'en crois la doc Alsa (lien plus haut), ce driver spécifique existe et nécessite le firmware...
Pas si fréquent, les cartes USB avec un driver Alsa spécifique...
Faut en profiter, non ?
A+

Le alsa-firmware est je suppose préinstallé non ?
En plus mettons qu'il faille qu'il réinstalle le fameux usb-6fire
Il faut après ça qu'il oublie de ce servir de envy24control car ça ne répondra pas c'est une évidence.
Dans sa version d'ubuntu il y a forcement un controleur de volume basique duquel il doit pouvoir selectionner le alsa mixer ?
Un peu comme ça:
Image
Et aussi avec la commande
alsamixer

F6 voir si elle y est ou pas . (après installation du dit pilote)

ikarios utilisateur non connecté
alsamixer y est et dans le fenêtre jack en periph. d'entrée et de sortie j'ai bien la TerraTec six usb Fire DMX et Jack avec ces cartes séléctionnée fonctionne à merveille a par qu'il n'y as pas de son génant en mao non?
merci utilisateur_anonyme pour tes explications bien plus claire maintenant
quand à allany bien d'accord avec toi

a+ et bonne zique

Citation :
fonctionne à merveille a par qu'il n'y as pas de son génant en mao non?

ok fait nous une capture de ce que tu vois dans "Connecter" depuis Jackctl?
comme ceci :
Tu peux très bien avoir du mouvement sur les vu-mètre de audacity mais si ce dernier ne se connecte pas aux sorties matérielles tu n'auras rien en retour ...
As oui ily a fort à parier que les entrées sortie soit "OFF" donc depuis la commande
alsamixer
tu devrais (f6) choisir ta carte et (F3) la lecture voir si les sortie sont activées ou pas .
Mais c'est pas tout iol va te faloir paramètrer jack (oui c'est long et ch... je ne te le fait pas dire)

allany utilisateur non connecté
Non, alsa-firmware n'est pas forcément installé par défaut. A vérifier avec un coup de Synaptic...
Est-ce que la commande :
lsmod | grep 6fire

liste quelque chose ressemblant à usb-6fire ?
A+

Page : 1/2  [Suivant]
1  2 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

calixtus06, 09:27, lun. 17 Jan 2022: Bonjour et bienvenue à bigveuch :-)
calixtus06, 18:05, sam. 15 Jan 2022: Bonjour et bienvenue à Roobuntu :-)
calixtus06, 16:48, mer. 12 Jan 2022: Bonjour et bienvenue à Aiz_user404, cedricm,DrClick :-)
olinuxx, 12:16, sam. 08 Jan 2022: Bonjour et bienvenue à lia cool
calixtus06, 16:29, jeu. 06 Jan 2022: Bonjour et bienvenue à Youpida :-)
r1, 21:09, mer. 05 Jan 2022: Toujours de bons mots contre tous les maux dans nos éditos !
allany, 19:35, mer. 05 Jan 2022: Est-ce pour l'an nouveau qu'il s'est fait si beau, l'édito ? [Lien]
calixtus06, 10:07, lun. 03 Jan 2022: Bienvenue à Laserpithium et Iblain :-)
calixtus06, 21:31, sam. 01 Jan 2022: Bonne année en mieux pour 2022 !
SuShY, 13:18, sam. 01 Jan 2022: Belle et heureuse année 2022 à tous !
olinuxx, 12:06, ven. 31 Dec 2021: Bonjour et bienvenue à Toufik cool
calixtus06, 15:26, mar. 28 Dec 2021: Bonjour et bienvenue à 70115MAO :-)