Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [Résolu] installation carte USB audio
Dernier post
Page : 1/2   -   Aller directement à la page : 1  2 

[Résolu] installation carte USB audio

bbenn utilisateur non connecté
Bonjour,

Je suis guitariste et bassiste et j'ai envie de me mettre un petit peu à la MAO.
Nottement j'aimerais pouvoir m'enregistrer sur l'ordi.
Je me suis donc procuré une petite carte USB ( Behringer UCG102 ) et j'ai installé hier Ubuntu Studio.
Cette carte est simpliste: on la branche en USB elle a une entrée pour la guitare et une sortie pour un casque. C'est tout.

Maintenant tout reste à faire.

J'ai fais un peu mumuse avec Jack et Audacity et tout ce que j'ai réussi à faire pour l'instant, c'est d'écouter un mp3 via audacity sur la sortie casque de la carte.

Par contre impossible de trouver la bonne config pour enfin entendre le son de la guitare.

J'aurai bien besoin d'un ptit de coup de main là mrgreen

Salut

Donc pour entendre le son de la guitare au travers audacity ?

Bin quand t'es dans audacity (jack démarré)
-> Edition -> Préférences -> Hote -> tu choisis " Jack Audio connexion kit"
Lecture = System
Enregistrement system

Toujours dans dans audacity (jack démarré)
-> Edition -> Préférences -> Enregistrement tu coche l'option:
"Passage audio logiciel : Ecoute durant l'enregistrement d'une nouvelle piste "

ET quand tu met audacity en pause pour qu'il soit visible dans jack tu fait les connexions dans le panneau de connexion de jackctl

Voilà !

bbenn utilisateur non connecté
bah disons que j'essaie avec audacity car je ne sais pas trop par où commencer.
Déjà j'aimerais pouvoir entendre la gratte dans le casque (avec ou sans audacity en fait)

j'ai quand mème tenté avec les infos que tu donnes mais ça ne fonctionne pas.

voici les réglages que j'ai dans jack:
Image

je n'ai touché que à périphérique d'entrée et j'ai essayé un peu toute les configs.

En théorie, est-ce que la carte son + jack sont suffisant pour s'entendre? il ne faut pas une appli supplémentaire?

Normal il faut que tu la selectionne autrement :

Depuis Interface

Et les entrées sortie / sortie tu ne met rien (tu laisse par défaut)

Image

bbenn utilisateur non connecté
J'ai tenté comme tu le proposes en modifiant dans interface et toujours aucun résultat

??? J'avoue ne pas comprendre par contre 11.2ms de latence @ 512 ça me paraît pas cohérent tu devrais avoir ce résultat à 256 non ? (quoi que ...)

Ceci dit 11.2 milli seconde c'est honorable comme temps de latence ...

bbenn utilisateur non connecté
Je ne sais pas trop où tu vois ces valeurs.
Bref je me vois confronté à un problème un peu embétant
c'est à dire que je me retrouve avec le choix de galérer et devoir réinvestir pour faire de la MAO sur Linux
ou bien choisir la facilité et la compatibilité quazi certaine en faisant ça sur Windows
je vois un tas de topic où les gens galèrent avec leur matériel, parfois payé plutôt cher et ça m'embête à l'avance de perdre du temps a faire fonctionner un truc plutot que de l'utiliser comme il se devrait
Je vais voir si il existe une solution pas trop chère mais avec la garantie d'un fonctionnement correct et simple à mettre en place sinon bah il faudrait bien que je me fasse une raison
merci utilisateur_anonyme pour ton coup de main et j'espère que je ne vous quitterai pas trop rapidement ;o)

SAlut


Je recapitule :


Citation :
bah disons que j'essaie avec audacity car je ne sais pas trop par où commencer.
...

En théorie, est-ce que la carte son + jack sont suffisant pour s'entendre? il ne faut pas une appli supplémentaire?


A partir du moment ou les préférence audio de audacity sont sur Jack audio conexion kit ça devrait marcher


Citation :
Je ne sais pas trop où tu vois ces valeurs.


Autant pour moi je confondait avec un autre post :

donc pour que ta carte son puisse fonctionner correctement il faudrait que jack soit paramètré ainsi :

(je reviens avec une capture patience)

Image

Voilà sauf qu'à la place de "USB Audio Codec" chez toi c'est "USB PnP Sound device"

Logiquement tu relance jack et c'est ok y'a pas plus basique comme carte son .

bbenn utilisateur non connecté
ça ne fonctionne pas.
j'ai demandé un remboursement.

du coup vers quel type de carte USB il faudrait que je m'oriente stp?
fast track de base ça peut convenir?
(du coup pas le droit à l'erreur car j'acheterai sans doute de l'occasion)

Comment ça ça ne fonctionne pas question

Selon ta capture d'hier ça fonctionnait donc il doit y avoir un truc qui n'est pas bien fait c'est tout.

Image

essais voir ce que te donne la commande
alsamixer


fait F6 sélectionne ta carte .

Ta carte (usb) doit etre insérée avant de mettre en route ton pc...

bbenn utilisateur non connecté
hier ça ne fonctionnait pas non plus
j'ai tenté le coup du alsamixer. voici 2 captures:
Image
Image


il y a du mieux.
Déjà j'entend un bruit de fond dans le casque (avant je n'entendais rien du tout)
En plus j'entends des interférences quand je touche une partie métallique de la guitare (les cordes typiquement)

PAr contre je n'entend pas le son des notes.

-edit-
j'ai monté le son de la carte usb via alsamixer mais ça ne donne rien non plus
d'ailleurs maintenant je n'entend plus ce bruit de fond

Oui mais regarde ton alsamixer :
USB pnP sound device

ton entrée est à 0 comment tu veux que le son entre ? tu utilise les touche < > pour naviger dans alsa mixer d'une part

Et il faut que tu selectionne ta carte depuis jack non pas par le choix d'entrée/sortie que tu laisse par defaut mais par "INTERFACE"

toi tu le met comme ça:
dl3675&display
mais c'est une erreur il faut lui indiquer l'interface par defaut comme je te le disais plus haut:
dl3687&display

Prend ton temps et regarde bien ;)

j'oubliais un détail :
Donc une foi jack configuré et démarré tu doit faire les connexions dedans sans quyoi tu n'entendra rien c'est sur !
Donc tu ouvre QJackCtl et tu auras un bouton "CONNEXIONS" qui va te donner une fenêtre du style :
dl2500&display
Et la tu connecte ce qui est en "CAPTURE" vers "PLAYBACK" et le tour est joué (du moins pour ce qui est de vérifier sans aplication,juste avec jack)

bbenn utilisateur non connecté
Je pense que ma config est exectament comme tu me l'indique (à moins que je ne vois pas un truc énorme, ça peut arriver)
Image
Image
Image

pour la dernière partie j'avoue que je ne pige pas comment ça se passe.
La config laisserait entendre que ce qui entre par la carte USB sort par System (soit la carte du PC)
Je n'arrive pas à modifier cette config (dans l'hypothèse où ça puisse m'apporter qq chose)

ha 'tain pulse audio!

Donc non je verrais plutôt ça comme ça:

Capture 1 -> system playback 1 et 2 ... (t'avais pas essayé ? )

bbenn utilisateur non connecté
je ne comprend pas trop ce que tu me proposes de faire et encore moins comment mrgreen

bbenn utilisateur non connecté
c'est bon je viens de capter que ça fonctionne en 'glissé déposé'
ça fonctionne je ne peux pas dire le contraire mais par contre au secours la qualité et la latence confused
on perd tout le feeling et le groove, c'est juste impossible
jack m'indique une latence de 46 ms ce qui semble très peu mais à l'oreille c'est inacceptable
il y a possibilité d'améliorer ça?

Surement echantillon/période : 256 ...

bbenn utilisateur non connecté
tu maitrises mrgreen
j'ai une latence carrément acceptable (je suis passé à 128 et j'ai 5.8ms) et le son est correct

par contre j'aimerais bien bien comprendre à quoi correspond cette valeur (echantillons/periode)

le son ne sort qu'à gauche dans mon casque, est-ce que c'est un réglage ou bien faut-il que je trouve un adaptateur jack mono pour que ça diffuse des 2 cotés?

pour info voici le réglage dans jack:

Image

Citation :
le son ne sort qu'à gauche dans mon casque, est-ce que c'est un réglage ou bien faut-il que je trouve un adaptateur jack mono pour que ça diffuse des 2 cotés?


TU peux directement dupliquer le signal depuis qjackctl
Tu fait un tracé avec ta souris de Capture 1 vers playback 2 c'est aussi simple :-)

Citation :
(echantillons/periode)


Alors ça c'est le nombre d'échantillon sur lesquel le système va travailler sur une période donnée . (buffer)
En gros plus c'est petit 128 plus la latence est basse mais plus la latence est basse plus tu perds en qualité .

Donc mettons que tu fasse une prise en 256 ce qui est carrément respectable comme latence à 11.2ms (inaudible)
tu pourras faire de la lecture facile mais dès que tu voudras ajouter des greffon et travailler sur un mixage et si tu ne veux pas de Xruns ilte faudra augmenter cette valeur à1024 voir 2048 si tu travaille sur des grosses sessions ...

Page : 1/2  [Suivant]
1  2 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]

tongo


Mégaphone [Afficher / Cacher]

olinuxx, 13:27, lun. 20 Jan 2020: Bonjour et bienvenue à Abilene Alfie cool
r1, 21:45, dim. 19 Jan 2020: Carla 2.1 RC1 : [Lien]
olinuxx, 23:31, sam. 18 Jan 2020: Bonjour et bienvenue à sebacross et à saintel cool
sub26nico, 12:37, ven. 17 Jan 2020: Salut et bienvenue à dawooda :-)
r1, 18:23, jeu. 16 Jan 2020: @Sylv_01: le logiciel a été ajouté ici : [Lien] n'hésite pas à te/nous faire plaisir en écrivant une page de doc si tu l'utilises :-D
Sylv_01, 10:51, jeu. 16 Jan 2020: Hello et bonne année musicale à tous... Pour info un nouveau soft midi MCMidiPlayer, détecté ici : [Lien] Je ne sais pas si quelqu'un l'avait déjà signalé, alors dans le doute...
bluedid29, 09:31, jeu. 16 Jan 2020: Felicitation olinuxx, c'est top ! :-)
sub26nico, 11:13, mer. 15 Jan 2020: Salut et bienvenue à moncopainalain,1franc50, Dremtheat et L'amiseul :-)
olinuxx, 20:12, lun. 13 Jan 2020: Cette semaine, très bonne nouvelle pour LibraZiK ! [Lien] cool
sub26nico, 10:15, lun. 13 Jan 2020: Salut et bienvenue à saimyx, SLIME et rico05 :-)
sub26nico, 16:14, sam. 11 Jan 2020: Salut et bienvenue à anamix01 :-)
olinuxx, 14:17, sam. 11 Jan 2020: Bonjour et bienvenue à Supertouffe cool