Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [½ RÉSOLU] détenteurs d'une terratec dmx 6fire usb, si vous pouviez m'aider un peu...
Dernier post

[½ RÉSOLU] détenteurs d'une terratec dmx 6fire usb, si vous pouviez m'aider un peu...

krsn utilisateur non connecté
...ça ferait mon bonheur, et peut-être aussi celui de quelques autres. biggrin

et d'abord bonjour à tous.

j'ai un petit problème à soumettre à ceux qui musouillent avec la terratec dmx 6fire usb.

voilà. j'ai installé la distrib kxstudio 12.04.3 sur ma nouvelle tour. après pluuuuuusieurs installes-désinstalles, j'ai compris que le noyau 3.5.x du disque d'installation ne faisait pas l'affaire et me causait des bugs. j'ai donc réinstallé le tout avec la version 3.11.0-11 lowlatency, accompagné d'une upgrade au kde 4.12, sans toucher à rien côté carte de son.

dans les faits, tout fonctionnait nickel (sauf un caprice au démarrage/redémarrage qui me fait un écran noir type terminal et que je n'ai toujours pas réussi à résoudre. mais c'est secondaire, car je peux contourner le problème en faisant un détour par le grub/safemode... et je peux googler le reste). la carte était reconnue automatiquement par le nouveau noyau et je pouvais réussir à faire tout ce que je voulais avec: jack démarrait sans problème ainsi que tous les autres programmes, plugins et compagnie. seul hic: j'étais incapable d'aller plus bas qu'une taille de buffer de 512 (sinon jack refusais tout simplement de démarrer), ce qui me donnait une latence autour de 11ms virgule des poils. rien de dramatique. pourtant, la dmx 6fire, selon le constructeur, peut donner des résultats de latence beeeeaaauucoup plus bas, dans le genre autour du 2 ou 3 si je ne me trompe pas. faut savoir configurer, c'est vrai. donc premier problème.

deuxième problème. j'ai dit que l'installation s'était bien passée, sans toucher à rien, pas même la carte son. ça veut dire que sans même avoir installé le driver linux de la dmx (http://sourceforge.net/projects/sixfireusb/), tout était reconnu et tout fonctionnait. bon, j'me suis dit: et si la question de la latence pouvait être améliorée en installant le driver...

réflexion très coquine, qui m'a conduit malheureusement à agir. (oui, j'aurais probablement dû me contenter de mon 11 virgule des poils...)

résultat des courses:

AVANT l'installation du driver, le voyant rouge qui brille normalement dans la sortie digital I/O de la carte était éteint. APRÈS l'installation du driver, le revoilà qui rougit de nouveau (donc le driver y est pour quelque chose, non?).

AVANT l'installation du driver, je pouvais voir le petit signe haut-parleur, dans le gestionnaire de tâches, à droite en bas, qui indique que le mixeur est reconnu. APRÈS l'installation du driver ce petit icône est remplacé par un petit rectangle blanc et lorsque je met le pointeur de la souris dessus ça me dit: "mixeur introuvable". cadence me dit que jack ne veut pas démarrer, et lorsque je clique sur un fichier audio, audacious me dit que "snd_mixer_attach failed: Aucun fichier ou dossier de ce type".

bref, je comprends pas.

dites-moi: j'ai brisé quelque chose ou quoi?rolleyes

je devrais peut-être nettoyer le tout? réinstaller alsa? faire une manip qui dépasse ma petite compétence (c'est ma 3e semaine de linux...)?

j'espère que j'ai été clair dans mes explications.

merci infiniment pour vos pistes de réflexion. et passez de bonnes fêtes.

krs.

krsn utilisateur non connecté
ok, petit retour là-dessus.
après quelques bidouilles et quelques recherches, j'ai réistallé tout ce qui concernait alsa à partir du gestionnaire de paquets, fait une petite redémarre et hop, tout est redevenu normal.

reste la question de la latence. y a-t-il moyen de la réduire? pourquoi suis-je bloqué à 512 de buffer et 11,6 ms?

Salut

Tu pourrais nous faire une capture de tes réglages de jack ?

krsn utilisateur non connecté
oilà:

Image

essais de passer buffer/période à 3 à la place de 2

Et aussi dans "Engine" voir si ta priorité temps réèl ne serait pas à 10 , si c'est le cas passe à une valeur comme 80 ...

krsn utilisateur non connecté
merci pour ta réponse. j'ai corrigé à 2 pour la période. priorité temps réel était déjà à 85. rien n'y fait...

heu attend je te disais une connerie redface :

Mets la latence d'emblée à 1024 dans jack puis utilise Claudia pour gérer ta latence à la demande :

Image

krsn utilisateur non connecté
ok, ben ça c'est nouveau pour moi. faudra que je lise un peu plus sur cette cadence suite que je connais encore très peu.
j'essaie des trucs et je reviens...

Claudia est accessible depuis Cadence ...

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

calixtus06, 09:27, lun. 17 Jan 2022: Bonjour et bienvenue à bigveuch :-)
calixtus06, 18:05, sam. 15 Jan 2022: Bonjour et bienvenue à Roobuntu :-)
calixtus06, 16:48, mer. 12 Jan 2022: Bonjour et bienvenue à Aiz_user404, cedricm,DrClick :-)
olinuxx, 12:16, sam. 08 Jan 2022: Bonjour et bienvenue à lia cool
calixtus06, 16:29, jeu. 06 Jan 2022: Bonjour et bienvenue à Youpida :-)
r1, 21:09, mer. 05 Jan 2022: Toujours de bons mots contre tous les maux dans nos éditos !
allany, 19:35, mer. 05 Jan 2022: Est-ce pour l'an nouveau qu'il s'est fait si beau, l'édito ? [Lien]
calixtus06, 10:07, lun. 03 Jan 2022: Bienvenue à Laserpithium et Iblain :-)
calixtus06, 21:31, sam. 01 Jan 2022: Bonne année en mieux pour 2022 !
SuShY, 13:18, sam. 01 Jan 2022: Belle et heureuse année 2022 à tous !
olinuxx, 12:06, ven. 31 Dec 2021: Bonjour et bienvenue à Toufik cool
calixtus06, 15:26, mar. 28 Dec 2021: Bonjour et bienvenue à 70115MAO :-)