Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [1/2 RÉSOLU] Installation de deux cartes son Digigram - VX Pocket V2 et VX222.
Dernier post
Page : 1/4   -   Aller directement à la page : 1  2  3  4 

[1/2 RÉSOLU] Installation de deux cartes son Digigram - VX Pocket V2 et VX222.

romrom78 utilisateur non connecté France
Bonjour à l'ensemble de la communauté,

Je bataille depuis plusieurs semaines pour installer deux cartes son que je possède de chez Digigram, une VX Pocket V2 connectée en PCMCIA à ma carte mère via un adaptateur PCI/PCMCIA ; et une autre directement pluggée en PCI à ma carte mère.

Je suis sur Ubuntu 13.10, alsa est installé et fonctionne avec la carte son d'origine de la carte mère ; mais ne reconnaît pas mes deux autres cartes.

J'ai téléchargé le paquet proposé directement par le site de Digigram, et m'aide de la page suivante pour l'installation des Drivers : ici
Cette page date de 2007. Je n'ai rien trouvé de plus récent.

Voilà où j'en suis face aux différentes difficultés que je rencontre :

root@romainhelo-All-Series:/usr/src/alsa/alsa-driver-1.0.3# ./configure
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for ranlib... ranlib
checking for a BSD-compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether time.h and sys/time.h may both be included... yes
checking whether gcc needs -traditional... no
checking for current directory... /usr/src/alsa/alsa-driver-1.0.3
checking cross compile... 
checking for directory with kernel source... /lib/modules/3.11.0-19-generic/build
checking for kernel version... The file /lib/modules/3.11.0-19-generic/build/include/linux/version.h does not exist.
Please, install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /usr/src/linux).


Il semblerait qu'il y ait un problème directement lié au noyau ...
Si quelqu'un peut me venir en aide car je ne vois rien sur Linux|Mao. Digigram ne semble pas répertorié dans la rubrique carte son.
Et pourtant voici la réponse que m'a adressé Digigram quant à la compatibilité matériel avec Linux :

Pascal Hannhart écrit :
Les cartes VX222 et VXPocketv2 sur LINUX utilisent le driver ALSA.

Linux a la réputation d'offrir des performances audio d'excellente qualité, au prix d'un effort de prise en main.
Les instructions d'installation sont dans le tgz du driver, fichier alsa-driver-1.0.3/INSTALL.
Les distributions récentes de LINUX ont souvent leur noyau avec le driver ALSA préinstallé.
Plus facile que les fichiers de configuration ALSA, l' interface graphique de l'utilitaire alsamixer règle confortablement les deux cartes.
Le site http://www.alsa-project.org vous apportera beaucoup d'informations utiles.

Pour plus d'informations, veuillez vous rapprocher de votre fournisseur.

Meilleures salutations,

Pascal Hannhart.


Merci par avance pour toute aide précieuse ...

À bientôt !

Salut

Fait nous voir ce que disent ces commandes : (merci d'utiliser ☛ Image pour copier le code rendu par ton terminal) biggrin

cat /proc/asound/cards


cat /proc/asound/modules



.

romrom78 utilisateur non connecté France
Bonjour utilisateur_anonyme,

Voici ce que j'obtiens :
romainhelo@romainhelo-All-Series:~$ cat /proc/asound/cards
 0 [MID            ]: HDA-Intel - HDA Intel MID
                      HDA Intel MID at 0xf2e14000 irq 47
 1 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf2e10000 irq 46
romainhelo@romainhelo-All-Series:~$ cat /proc/asound/modules
 0 snd_hda_intel
 1 snd_hda_intel


merci

Je ne suis pas expert en compilation mais vu ceci:

Citation :
Please, install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel


Je dirai qu'il te manque les sources de ton kernel et que la solution proposée consiste à recompiler le kernel ?

romrom78 utilisateur non connecté France
Oui je tique aussi sur cette phrase mais du haut de mes un mois de Linux, je ne vois pas du tout comment m'y prendre ... t'as une idée ?

Recément une procéduire d'installation à été faite pour cette carte Steinberg UR22

TU pourrais peut être t'en inspirer ?

romrom78 utilisateur non connecté France
Ok merci pour le lien, je vais regarder ça attentivement en prenant le temps nécessaire.
J'en ferai le retour dès que possible ...

À bientôt !

olinuxx utilisateur non connecté France
informationinfo


Salut romrom78,
alors, tu t'en tires bien ?

Ceci dit, je viens de lire ce fil de discussion. M'est avis est que tu n'as pas besoin du tout de compiler ALSA car le pilote pour la vxpocket est déjà intégré dans ALSA depuis belle lurette. (En plusse, là, tu essayais de compiler une version de ALSA 1.03 alors que toutes les distributions qui se respectent utilisent au minimum du minimum une version 1.23 de nos jours).

Si tu veux, je peux peut-être t'aider à y voir plus clair si tu n'as pas déjà trouvé une solution par toi-même.

romrom78 utilisateur non connecté France
Bonjour olinuxx,

je n'ai pas du tout avancé sur ce problème car après moult recherches je n'ai rien trouvé de plus pour faire reconnaître ces deux cartes son par mon système Linux ... j'en déduisais qu'il y avait peut être tout simplement une incompatibilité matérielle entre ces cartes là et mon ordi.

Cela dit, si je pouvais parvenir à les faire reconnaître ce serait top !

Si tu penses pouvoir m'aider, je suis preneur ?

Merci à toi ...

olinuxx utilisateur non connecté France
On peut essayer. Avec laquelle souhaites-tu commencer ? La VXPocket ou bien la VX222 ?

romrom78 utilisateur non connecté France
Je veux bien commencer par la VXPocket V2 ...

Comment procède t-on ?

olinuxx utilisateur non connecté France
C'est quel type de port, du PCMCIA ? (ca c'est juste pour confirmer)

Pour commencer, ce que tu vas faire, c'est me dire sous quelle distribution linux tu tournes. Au début de ce fil, tu dis être sur ubuntu 13.10, est-ce toujours le cas ? Je suppose que tu dois être en ubuntu 14 maintenant.

romrom78 utilisateur non connecté France
Alors oui, je tourne avec la distribution Ubuntu 14.04 lts.

Le port de la carte est effectivement en PCMCIA.

olinuxx utilisateur non connecté France
OK, alors on continue.

Les cartes PCMCIA, c'est du branchement a chaud, j'ai juste ?

Si non: alors dis-le moi.

Si oui: alors
  1. ouvre un terminal et entre-y la commande
    watch 'dmesg|tail'
    et garde un oeil sur ce terminal en permanence
  2. branche ta carte
  3. observe les changements sur ton terminal
  4. recopie moi les ici

romrom78 utilisateur non connecté France
Oui, le branchement se fait effectivement à chaud ...

Voilà ce que j'obtiens avec la commande que tu me proposes :

Every 2,0s: dmesg|tail                                  Wed Oct 29 14:30:32 2014

[   32.672271] type=1400 audit(1414581042.671:73): apparmor="STATUS" operation="
profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=2651 comm="appa
rmor_parser"
[ 8329.515046] pcmcia_socket pcmcia_socket0: pccard: card ejected from slot 0
[ 8375.884884] pcmcia_socket pcmcia_socket0: pccard: PCMCIA card inserted into s
lot 0
[ 8375.885118] pcmcia 0.0: pcmcia: registering new device pcmcia0.0 (IRQ: 16)
[ 8375.925202] snd-vxpocket 0.0: Direct firmware load failed with error -2
[ 8375.925206] snd-vxpocket 0.0: Falling back to user helper
[ 8375.926167] vx: can't load firmware vx/bx_1_vxp.b56
[ 8375.966042] snd-vxpocket 0.0: Direct firmware load failed with error -2
[ 8375.966045] snd-vxpocket 0.0: Falling back to user helper
[ 8375.966507] vx: can't load firmware vx/bx_1_vxp.b56


olinuxx utilisateur non connecté France
[ 8375.926167] vx: can't load firmware vx/bx_1_vxp.b56

Il te dit qu'il ne peut pas charger le Micrologiciel du nom de "bx_1_vxp.b56". Certainement parce qu'il n'est pas présent sur ton système. Entre la commande "sudo find * / -name bx_1_vxp.b56" dans un terminal pour confirmer.

Pour se faire, il te faut installer le paquet "alsa-firmware".

Pour ubuntu, il s'agissait des paquets de chez medibuntu par le passé, mais il semble qu'ils ne soient plus maintenus actuellement (source : https://launchpad.net/medibuntu ). Je te conseille donc de te renseigner sur ce point sur les forums ubuntu et de venir reporter l'information ici. À moins que tu aies la possibilité d'installer le paquet "alsa-firmware" dans ton synaptic.

romrom78 utilisateur non connecté France
Ok, je me renseigne sur ce point ... entre temps voici ce que j'obtiens dans un terminal lorsque j'entre la commande que tu me proposes.

romainhelo@romainhelo-All-Series:~$ sudo find * / -name bx_1_vxp.b56
[sudo] password for romainhelo: 
Logiciels/alsa-firmware-1.0.3/vxloader/bx_1_vxp.b56
/home/romainhelo/Logiciels/alsa-firmware-1.0.3/vxloader/bx_1_vxp.b56


merci ...

olinuxx utilisateur non connecté France
Le résultat de ta commande correspond bien à ce que je pensais. Le seul endroit où le micrologiciel est présent est dans les (très vieilles) sources d'ALSA que tu as téléchargé sur le site de Digigram.

On pourrait certainement utiliser ce fichier, mais ça serait bien dégueulasse pas très propre. Ceci ferait sauter ta config' audio à chaque mise à jour du noyau ou de la couche ALSA.

Donc, oui, renseigne-toi chez ubuntu et revient nous dire ceci ici.

romrom78 utilisateur non connecté France
Juste une petite parenthèse :

Alors effectivement, j'ai trouvé via Synaptic le paquet "alsa-firmware-loaders".
La version installée est 1.0.27-2ubuntu3.
La dernière version est identique : 1.0.27-2ubuntu3.

Le détail du paquet indique :
Ce paquet fournit une collection de chargeurs de logiciel pour du matériel
spécifique :
dont, vxloader - lanceur de firmware pour les cartes son Digigram VX.

Si je souhaite faire une mise à niveau voici l'ensemble des tâches que Synaptic modifiera ...

gnome-keyring (version 3.10.1-1ubuntu4) sera mis à niveau vers la version 3.10.1-1ubuntu4.1
libnux-4.0-0 (version 4.0.6+14.04.20140409-0ubuntu1) sera mis à niveau vers la version 4.0.6+14.04.20140930-0ubuntu1
libnux-4.0-common (version 4.0.6+14.04.20140409-0ubuntu1) sera mis à niveau vers la version 4.0.6+14.04.20140930-0ubuntu1
libp11-kit-gnome-keyring (version 3.10.1-1ubuntu4) sera mis à niveau vers la version 3.10.1-1ubuntu4.1
libpam-gnome-keyring (version 3.10.1-1ubuntu4) sera mis à niveau vers la version 3.10.1-1ubuntu4.1
libunity-core-6.0-9 (version 7.2.2+14.04.20140714-0ubuntu1.1) sera mis à niveau vers la version 7.2.3+14.04.20140826-0ubuntu1
nux-tools (version 4.0.6+14.04.20140409-0ubuntu1) sera mis à niveau vers la version 4.0.6+14.04.20140930-0ubuntu1
unity (version 7.2.2+14.04.20140714-0ubuntu1.1) sera mis à niveau vers la version 7.2.3+14.04.20140826-0ubuntu1
unity-services (version 7.2.2+14.04.20140714-0ubuntu1.1) sera mis à niveau vers la version 7.2.3+14.04.20140826-0ubuntu1
unity-settings-daemon (version 14.04.0+14.04.20140414-0ubuntu1) sera mis à niveau vers la version 14.04.0+14.04.20140606-0ubuntu1
update-notifier (version 0.154.1) sera mis à niveau vers la version 0.154.1ubuntu1
update-notifier-common (version 0.154.1) sera mis à niveau vers la version 0.154.1ubuntu1
alsa-firmware-loaders (version 1.0.27-2ubuntu3) sera réinstallé


est-ce que j'effectue la manip' ?
si oui, est-ce que je procède à une mise à jour du paquet, ou est-ce que je le réinstalle ?

olinuxx utilisateur non connecté France
(Ante-scriptum : utilise les balises de CODE la prochaine fois stp. Ça permet d'y voir plus clair lorsque l'on lit le message. Tu n'as pas besoin de le faire ce coup-ci, j'ai édité ton message.)

Alors, il te dit :
La version installée est 1.0.27-2ubuntu3.
La dernière version est identique : 1.0.27-2ubuntu3.

Ce qui veut dire que tu as la dernière version de ce paquet déjà installée sur ton système.

Ce paquet "alsa-firmware-loaders" ne contient pas les micrologiciels mais les chargeurs pour ces micrologiciels. Les chargeurs sont des logiciels qui permettent de charger les micrologiciels dans ta carte-son. Ils ne sont pas les micrologiciels eux-mêmes.

Auparavant, medibuntu fournissait un paquet avec ces fameux micro-logiciels. Ce paquet se nommait "alsa-firmware" (tout-court).

Tu vas me dire "c'est con, il pourrait fournir un paquet avec tout dedans, non ?". Oui, techniquement, c'est possible à faire, c'est au niveau légal que le bât blesse : les chargeurs de micrologiciel sont des logiciels libres, alors que les micrologiciels sont des logiciels propriétaires. Ceci empêche donc une redistribution facile de par la législation en vigueur des certains pays.

Bref, toujours la même chose, on attend les retours de chez ubuntu.

Pour le reste de ton message, ton synaptic te dit simplement que ton système n'est pas à jour. Une petite mise à jour ne lui fera pas de mal wink

romrom78 utilisateur non connecté France
OK ... à la fois je comprends tes explications mais en même temps je ne vois pas par quel bout procéder ...

olinuxx écrit :
Le seul endroit où le micrologiciel est présent est dans les (très vieilles) sources d'ALSA que tu as téléchargé sur le site de Digigram.

Est-ce que le problème ne viendrait pas directement de Digigram qui s'est arrêté à la version 1.03 d'ALSA pour ce qui est de la compatibilité matérielle de leurs cartes son avec le système Linux ?

Du coup, si je vais sur le forum Ubuntu ... qu'est-ce que je demande concrètement ?

Est-ce que le problème se retrouve avec d'autres distributions ?

Page : 1/4  [Suivant]
1  2  3  4 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 21:29, mer. 22 Sep 2021: Bonjour et bienvenue à tezere cool
funroad34, 15:50, lun. 20 Sep 2021: c est surtout lors de la connection que ça rame sinon c 'est correct niveau timming a l'ouverture des pages..
funroad34, 15:43, lun. 20 Sep 2021: slt Oui patience et perseverence...
Houston4444, 11:17, lun. 20 Sep 2021: Ici on apprend la patience, bientôt la cafetière aura terminé sa mission avant que la page soit chargée...
sub26nico, 17:50, dim. 19 Sep 2021: pas de souci ici
funroad34, 14:14, dim. 19 Sep 2021: Bonjour idem chez moi
Geis007, 18:03, sam. 18 Sep 2021: binjch, c'est très lent, en effet !
binjch, 22:51, ven. 17 Sep 2021: Salut c'est hyper lent chez tout le monde là? Ou c'est moi qui ai un problème?
olinuxx, 18:46, jeu. 16 Sep 2021: Bonjour et bienvenue à pierre2 cool
zicstef, 22:40, mer. 15 Sep 2021: Hello, il y a bien longtemps que je n'ai pas eu la joie de passer. Découvert au détour d'un surf: /
olinuxx, 18:30, lun. 13 Sep 2021: [INFO] nouveau compte Diaspora pour linuxmao : [Lien] Venez nous y rejoindre cool
Samuel, 02:44, dim. 12 Sep 2021: [Lien] C'est la video de présentation du futur de VCV RACK, un synthé modulaire