Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [½ RÉSOLU] Interface midi-usb UNO sur Ubuntu Studio 7.04
Dernier post

[½ RÉSOLU] Interface midi-usb UNO sur Ubuntu Studio 7.04

toshubuntu utilisateur non connecté
Bonjour,

je désespère de pouvoir faire fonctionner mon interface usb-midi M-AUDIO USB UNO sur ma Ubuntu Studio 7.04 installé sur un portable Toshiba M30-104 dans le but de connecter mon Clavinova midi.

J'ai pourtant installé les drivers de la page ICI en suivant les instructions du README inclus mais sans succès : Aconnectgui et Jack Control restent tous deux impassibles à mes déconnexions et reboot.

J'ai cru comprendre qu'il me fallait jouer avec le module usb audio (lien introuvable, la page ALSA a été déplacée depuis peu ! ) mais les explications datent et correspondent peu aux distributions Debian/Ubuntu et leurs gestions par paquets : je ne suis pas assez bon linuxien pour les traduire.

Merci d'avance de votre aide.

kolt utilisateur non connecté
Salut!

Sans vouloir te décourager, chez moi, ça à marcher sans rien faire, enfin, il a juste fallu brancher les cables et midi usb uno est apparu dans l'onglet midi de qjackctl.

Tout ça pour dire que tu n'as certainment pas besoin du modules "usb-audio". En fait, le support de la Uno est inclus directement dans les drivers de base (alsa ou jack?), vu que cette interface n'a "rien de particulier".

As-tu une version récente de tes drivers? Les as-tu compiler toi-même? Peut-être il manquait une option à la compilation... (j'ai besoin de la variable USE midi sous gentoo... je ne sais pas comment les paquets ont été compiler sur ton système donc...)

mon topic à ce sujet ;-)

bluedid29 utilisateur non connecté France
Bonjour, cool

Oui, effectivement, je trouve cela curieux car sur un portable siemens Amilo et Ubuntu Studio 7.04, l'interface Uno est reconnue directement chez moi dans l'onglet Midi de QJack

Encore une fantaisie d'Ubuntu ? mrgreen ou peut être un pb de reconnaissance port Usb...

toshubuntu utilisateur non connecté
Bonjour,

merci de vos réponses rapidissimes.

Je crois que j'ai eu raison de soulever le problème : les pages ALSA que j'indiquai ont été revues et j'ai trouvé un post sur le WIKI ALSA . Je regarde cela de plus près et vous tiens au courant.

toshubuntu utilisateur non connecté
Bonjour,

pour répondre à Kolt, voici les instructions données dans le README des drivers et les résultats donnés par le terminal à l'installation des drivers :

[+]

Il ne me semble pas y avoir d'erreur, et pourtant... Pour autant le périphérique est bien repéré mais pas installé.

Des conseils ?

kolt utilisateur non connecté
Effrectivement ça à l'air de jouer... y'a juste ceci peut-être:
checking for udev rules directory... not found; assuming /etc/udev/rules.d
ce qui pourrait indiquer qu'il ne crée pas une règle correcte... Du coup, tout ce passe bien sauf que udev ne ferait pas son travail lorsque tu plug l'usb.

Le hic, c'est que je ne connais pas bien udev et la façon de faire des rules... je l'avais fait pour mon graveur une fois... il y a bien longtemps. Peut-être peut tu vérifier via la doc de ubuntu si la règle a été fait corectement. Je crois qu'il y a deux fichier à modifier pour une règle, celui qui indique toutes les règles, et un spécifique à chaque règle...

Je suppose que la doc de ubuntu devrait pouvoir t'aider!

Bonne chance.

kolt utilisateur non connecté
Par hasard je suis tombé sur cette page:

http://homepage3.nifty.com/StudioBreeze/software/usbmidi-e.html

Et il y est écrit:
Citation :
This driver is now included in latest Linux kernel (2.5.x, 2.4.x) tree.


Donc tu n'as pas besoin d'installer tout ça... par contre, es-tu sur que ton kernel contient les options nécessaires (concernant l'usb et le midi)? Quel noyau as-tu?

toshubuntu utilisateur non connecté
Bonsoir,

ta réponse : 2.6.20-16-lowlatency

Quant à savoir si le kernel a les options nécessaires, c'est trop flou pour moi...

toshubuntu utilisateur non connecté
Bonjour,

Après quelques recherches, j'ai découvert que udev sous Ubuntu pouvait avoir des ratés

Du coup un petit :
$ sudo /etc/init.d/udev restart
 * Loading additional hardware drivers...                                                [ OK ]

et la petite lumière s'allume enfin !

Mais au redémarrage même cirque. Pas de lumière même si je laisse le Midi-Uno branché dès le départ. Suis-je condamné à taper éternellement ce "restart" ?

Citation :
Mais au redémarrage même cirque.




Peut-être un soucis dans l'ordre de démarrage des différents services au boot ?
si tu restart udev, ça règle systématiquement le problème ?

leyoy utilisateur non connecté France
Bonjour,

J'ai strictement le même problême que toi, et la commande que tu as trouvé marche pour moi aussi.
J'ai essayé la même chose sur ma debian etch et je n'ai eu aucun problème.
Alors merci pour la commande, mais dommage s'il faut se la retaper à chaque fois!

à plus

leyoy utilisateur non connecté France
Par contre maintenant impossible de lancer jack que le driver soit lancé ou non !
Est ce que c'est la même chose pour toi toshubuntu ?

j'ai:

[+]

Je travaille sous WindowMaker.
Qu'est ce qui peut clocher ?
dois lancer une autre discussion ?
Merci pour votre aide.

toshubuntu utilisateur non connecté
Pour te répondre, leyoy, je dois dire que mon Jack part en live fréquemment mais que tout reprend son bon fonctionement après un reboot. J'ai pu relancer UDEV et démarrer Jack après sans problème. Tente un reboot, lance Jack, ferme-le, relance UDEV et lance JACK. Vois le résultat, pour moi ça a fonctionné.

Trinine a peut-être la solution pour l'UDEV en changeant l'ordre des services au démarrage : mais comment fait-on sur Ubuntu Studio ?

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]


mager

Mégaphone [Afficher / Cacher]

sub26nico, 10:25, dim. 09 mai 2021: Salut et bienvenue à ZatGuy et Xdl :-)
r1, 21:23, jeu. 06 mai 2021: Les zigotos de l'édito sont vraiment de super héros !
allany, 07:38, jeu. 06 mai 2021: Héoooo, du bateau ! C'est l'édito, matelots ! [Lien]
eric_p, 21:54, mar. 04 mai 2021: News glanée à l'instant: "Audacity has just joined Muse Group, a collection of brands that includes another popular open source music app called MuseScore" [Lien]
Samuel, 13:56, mar. 04 mai 2021: Dernières 24h pour proposer des idées de thèmes pour les prochaines joutes musicales de linuxmao. C'est par ici [Lien]
sub26nico, 23:09, dim. 02 mai 2021: Salut et bienvenue à citronvert :-)
sub26nico, 16:52, dim. 02 mai 2021: Bonjour et bienvenue à midve :-)
youki, 16:34, ven. 30 Apr 2021: Je ne sais pas si ça a déjà été évoqué. Je regardais par hasard cette vidéo : A et surprise, il y a une version vst3 Linux de ce compresseur gratuit. [Lien]
olinuxx, 12:01, mar. 27 Apr 2021: Bonjour et bienvenue à ThM cool
sub26nico, 23:51, lun. 26 Apr 2021: Salut et bienvenue à prederour, jchmsq et caster33 :-)
olinuxx, 13:48, sam. 24 Apr 2021: Bonjour et bienvenue à astroblush cool
calixtus06, 14:45, ven. 23 Apr 2021: Bienvenue à toi miko974 :-)