Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

Dernier post

QJack ne veut plus se lancer

bluedid29 utilisateur non connecté France
Bonsoir, cool

Voici le message quand je lance le serveur jack :

[+]

Quelque soient les réglages cela ne change rien, c'est mon ordi "partage" qui fonctionnait bien il y a quelques semaines, à priori rien n'a été touché; je suis sur Ubuntu Studio, j'ai comme l'impression qu'il faut arrêter un processus mais lequel ? je ne vois pas... eek

Dur, dur la reprise rolleyes (non, je rigole, fait beau et chaud ici depuis... ...ce matin mrgreen)

Norrin_Radd utilisateur non connecté France
Citation :
the capture device "default" is already in use. Please stop the application using it and run JACK again


+
Citation :
Quelque soient les réglages cela ne change rien, c'est mon ordi "partage" qui fonctionnait bien il y a quelques semaines, à priori rien n'a été touché; je suis sur Ubuntu Studio, j'ai comme l'impression qu'il faut arrêter un processus mais lequel ? je ne vois pas...


Si j'en crois la sortie de jack, en effet il dit qu'une autre application squatte la capture ALSA.

C'est étrange si tu n'as rien touché, que cela peut-il donc être ? eek

C'est là où un logiciel pour observer les processus se révèle utile. Il y en a plusieurs, certains en mode graphique. J'ai tendance à utiliser principalement la commande " ps ax " qui te liste tous les process en cours.

Ta mission à présent est de recopier la sortie de cette commande qu'on puisse dénicher le fautif.

Si c'est pas artsd, c'est pê esd... Enfin nous verrons bien.

bluedid29 utilisateur non connecté France
Voici ce que donne la commande ps ax

[+]

bluedid29 utilisateur non connecté France
2614 ? S

Il ne veut pas prendre en compte la totalité du message confused

Je t'envoie par messagerie cool

Utilise les balises ~pp~ et ~/pp~ pour contourner la mise en forme automatique par tikiwiki des symboles spéciaux.

bluedid29 utilisateur non connecté France
Oups, désolé, j'ai essayé mais je sais pas trop en fait.... ...ou et comment insérer ces balises mrgreen

Norrin_Radd utilisateur non connecté France
Bon j'ai eu le message en privé. J'ai vu deux lignes susceptibles de correspondre:

Citation :
5581 ? Ss 0:00 /bin/sh -c /usr/bin/esd -terminate -nobeeps -as 1 -sp
5582 ? S 2:45 /usr/bin/pulseaudio --log-target=syslog -Lmodule-esou


Solution immédiate:
(Attention les numéros des process ont pê changer si tu a rebooté, refaire un ps ax)
kill -9 5581
kill -9 5582


tu peux aussi killer en utilisant les noms des process:
killall -9 esd
killall -9 pulseaudio


J'ai appris que pulseaudio soit une sorte de remplaçant préssenti pour esd, je n'en sais pas plus.

La méthode durable pour pas être ennuyé par ces deux logiciels serait de regarder dans les écrans de configuration de gnome s'il n'a pas moyen de désactiver esd.

bluedid29 utilisateur non connecté France
C'est toujours pareil malgré les différentes commandes... confused

Norrin_Radd utilisateur non connecté France
Est-tu sûr que la démarche a été effective. Il se pourrait que esd ou pulseaudio se soient relancés automatiquement, j'avoue que ce n'est qu'une pure hypothèse mais je ne serais pas surpris de la part de gnome.

Est-ce que tu as la possibilité de mettre un autre bureau comme XFCE ou fluxbox par défaut et de rebooter pour voir si le pbm vient bien de gnome et d'esd ?

bluedid29 utilisateur non connecté France
Je suis sur Kubuntu Studio !, je vais essayer tout à l'heure pour voir... (je ne suis pas sur le bon ordi)

bluedid29 utilisateur non connecté France
Merci Norrin !

Après plusieurs manipulations (kill -9 5581 , kill -9 5582 , killall -9 esd, killall -9 pulseaudio ) et passage (bref) sur Xfce, cela fonctionne

En repassant sur Kde, j'ai changé les paramètres de QjackCtrl pour pouvoir lancer correctement Ardour 2.0.3 et surprise, je peux changer le thème (en light) dans fenêtre / theme Manager, il y a du y avoir un ajout au cours de la version 2.0.3 (en version svn)

Bon, ben c'est génial, je vais pourvoir ré-écouter tranquillement les différents projets audio dans mon lit (j'aime bien écouter à tête reposée avant d'enregistrer smile

Allez, bon Ouik, j'ai une animation mariage ce soir et il me faut me concentrer wink

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 11:35, lun. 27 Sep 2021: Bonjour et bienvenue à Vincentb63fr et à pub69250@tutanota.com cool
olinuxx, 12:30, ven. 24 Sep 2021: Bonjour à et bienvenue à kitty32, beldic2, et à Carlos54 cool
olinuxx, 21:29, mer. 22 Sep 2021: Bonjour et bienvenue à tezere cool
funroad34, 15:50, lun. 20 Sep 2021: c est surtout lors de la connection que ça rame sinon c 'est correct niveau timming a l'ouverture des pages..
funroad34, 15:43, lun. 20 Sep 2021: slt Oui patience et perseverence...
Houston4444, 11:17, lun. 20 Sep 2021: Ici on apprend la patience, bientôt la cafetière aura terminé sa mission avant que la page soit chargée...
sub26nico, 17:50, dim. 19 Sep 2021: pas de souci ici
funroad34, 14:14, dim. 19 Sep 2021: Bonjour idem chez moi
Geis007, 18:03, sam. 18 Sep 2021: binjch, c'est très lent, en effet !
binjch, 22:51, ven. 17 Sep 2021: Salut c'est hyper lent chez tout le monde là? Ou c'est moi qui ai un problème?
olinuxx, 18:46, jeu. 16 Sep 2021: Bonjour et bienvenue à pierre2 cool
zicstef, 22:40, mer. 15 Sep 2021: Hello, il y a bien longtemps que je n'ai pas eu la joie de passer. Découvert au détour d'un surf: /