Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [Contourné] Edirol FA101, mise en service
Dernier post

[Contourné] Edirol FA101, mise en service

siscard06 utilisateur non connecté
Bonjour à tous,

Je reviens après plusieurs jours de recherches et d'essais infructueux pour la mise en service de ma FA101 (achetée d'occasion pas trop cher).

Côté matos, tout semble bon, mais jack refuse de démarrer quand je lui indique d'utiliser Firewire, par contre, il fonctionne très bien avec la carte interne et pilote Alsa

FFado-mixer : Edirol FA101 présente

lspci : (je résume)
02:03.0 Multimedia audio controller: ESS Technology ES1983S Maestro-3i PCI Audio Accelerator (rev 10)
02:0f.2 FireWire (IEEE 1394): Texas Instruments PCI4451 IEEE-1394 Controller


lsmod | grep fire
firewire_ohci          35488  0 
firewire_core          57689  1 firewire_ohci
crc_itu_t              12627  1 firewire_core


ffado-test LisDevices
Cannot create thread 1 Operation not permitted


ffado-diag
FFADO diagnostic utility 2.1.9999-
============================
(C) 2008 Pieter Palmers
    2009-2010 Arnold Krille


=== CHECK ===
 Base system...
  kernel version............ 3.13.0-32-lowlatency
    Preempt (low latency)... True
    RT patched.............. False
  old 1394 stack present.... False
  old 1394 stack loaded..... False
  old 1394 stack active..... False
  new 1394 stack present.... True
  new 1394 stack loaded..... True
  new 1394 stack active..... True
  /dev/raw1394 node present. False
  /dev/fw* permissions:
crw-------  1 root root  251, 0 août   9 13:55 /dev/fw0
crw-rw----+ 1 root audio 251, 1 août   9 13:55 /dev/fw1
  User IDs:
uid=1000(alain) gid=1000(alain) groupes=1000(alain),4(adm),20(dialout),21(fax),24(cdrom),25(floppy),26(tape),27(sudo),29(audio),30(dip),44(video),46(plugdev),102(netdev),105(fuse),108(lpadmin),109(scanner),124(sambashare)
 Prerequisites (dynamic at run-time)...
   gcc ............... gcc (Ubuntu 4.8.2-19ubuntu1) 4.8.2
   g++ ............... sh: 1: g++: not found
   PyQt4 (by pyuic4) . sh: 1: pyuic4: not found
   jackd ............. Cannot create thread 1 Operation not permitted
     path ............ /usr/bin/jackd
     flags ........... Package jack was not found in the pkg-config search path.
Perhaps you should add the directory containing `jack.pc'
to the PKG_CONFIG_PATH environment variable
No package 'jack' found
   libraw1394 ........ Package libraw1394 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libraw1394.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libraw1394' found
     flags ........... Package libraw1394 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libraw1394.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libraw1394' found
   libavc1394 ........ Package libavc1394 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libavc1394.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libavc1394' found
     flags ........... Package libavc1394 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libavc1394.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libavc1394' found
   libiec61883 ....... Package libiec61883 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libiec61883.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libiec61883' found
     flags ........... Package libiec61883 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libiec61883.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libiec61883' found
   libxml++-2.6 ...... Package libxml++-2.6 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libxml++-2.6.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libxml++-2.6' found
     flags ........... Package libxml++-2.6 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libxml++-2.6.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libxml++-2.6' found
   dbus-1 ............ Package dbus-1 was not found in the pkg-config search path.
Perhaps you should add the directory containing `dbus-1.pc'
to the PKG_CONFIG_PATH environment variable
No package 'dbus-1' found
     flags ........... Package dbus-1 was not found in the pkg-config search path.
Perhaps you should add the directory containing `dbus-1.pc'
to the PKG_CONFIG_PATH environment variable
No package 'dbus-1' found
 Prerequisites (static at compile-time)...
   gcc ............... gcc (Ubuntu/Linaro 4.8.2-1ubuntu1) 4.8.2
   g++ ............... g++ (Ubuntu/Linaro 4.8.2-1ubuntu1) 4.8.2
   PyQt4 (by pyuic4) . Python User Interface Compiler 4.10.3 for Qt version 4.8.4
   jackd ............. sh: 1: jackd: not found
     path ............ 
     flags ........... Package jack was not found in the pkg-config search path.
   libraw1394 ........ 2.1.0
     flags ...........  -lraw1394  
   libavc1394 ........ Package libavc1394 was not found in the pkg-config search path.
     flags ........... Package libavc1394 was not found in the pkg-config search path.
   libiec61883 ....... 1.2.0
     flags ...........  -liec61883 -lraw1394  
   libxml++-2.6 ...... 2.36.0
     flags ........... -I/usr/include/libxml2 -I/usr/include/glibmm-2.4 -I/usr/lib/i386-linux-gnu/glibmm-2.4/include -I/usr/include/sigc++-2.0 -I/usr/lib/i386-linux-gnu/sigc++-2.0/include -I/usr/include/glib-2.0 -I/usr/lib/i386-linux-gnu/glib-2.0/include -I/usr/include/libxml++-2.6 -I/usr/lib/libxml++-2.6/include  -lxml++-2.6 -lxml2 -lglibmm-2.4 -lgobject-2.0 -lsigc-2.0 -lglib-2.0  
   dbus-1 ............ 1.6.12
     flags ........... -I/usr/include/dbus-1.0 -I/usr/lib/i386-linux-gnu/dbus-1.0/include  -ldbus-1  
 uname -a...
   Linux alain 3.13.0-32-lowlatency #57-Ubuntu SMP PREEMPT Tue Jul 15 04:23:12 UTC 2014 i686 i686 i686 GNU/Linux
 Hardware...
   Host controllers:
02:0f.2 FireWire (IEEE 1394) [0c00]: Texas Instruments PCI4451 IEEE-1394 Controller [104c:8027] (prog-if 10 [OHCI])
	Subsystem: Dell Latitude C810 [1028:00e5]
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 32 (500ns min, 1000ns max), Cache Line Size: 32 bytes
	Interrupt: pin A routed to IRQ 10
	Region 0: Memory at f8ffc800 (32-bit, non-prefetchable) [size=2K]
	Region 1: Memory at f8ff8000 (32-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: firewire_ohci

   CPU info:
Architecture:          i686
Mode(s) opératoire(s) des processeurs :32-bit
Byte Order:            Little Endian
CPU(s):                1
On-line CPU(s) list:   0
Thread(s) par cœur : 1
Cœur(s) par socket : 1
Socket(s):             1
Identifiant constructeur :GenuineIntel
Famille de processeur :6
Modèle :             11
Révision :           1
Vitesse du processeur en MHz :1133.000
BogoMIPS:              2259.24
 Configuration...
  IRQ information
Hardware Interrupts:
--------------------
 IRQ    0: PID:  None, count:           [878611], Sched None (priority None), drivers: ['timer']
 IRQ    1: PID:  None, count:             [2600], Sched None (priority None), drivers: ['i8042']
 IRQ    2: PID:  None, count:                [0], Sched None (priority None), drivers: ['cascade']
 IRQ    3: PID:  None, count:                [3], Sched None (priority None), drivers: ['']
 IRQ    4: PID:  None, count:                [3], Sched None (priority None), drivers: ['']
 IRQ    5: PID:  None, count:              [317], Sched None (priority None), drivers: ['snd_maestro3']
 IRQ    6: PID:  None, count:                [3], Sched None (priority None), drivers: ['floppy']
 IRQ    7: PID:  None, count:                [1], Sched None (priority None), drivers: ['parport0']
 IRQ    8: PID:  None, count:                [0], Sched None (priority None), drivers: ['rtc0']
 IRQ    9: PID:  None, count:                [0], Sched None (priority None), drivers: ['acpi']
 IRQ   10: PID:  None, count:           [417885], Sched None (priority None), drivers: ['uhci_hcd:usb1', 'firewire_ohci', 'yenta', 'yenta', 'eth0']
 IRQ   11: PID:  None, count:             [2826], Sched None (priority None), drivers: ['nouveau']
 IRQ   12: PID:  None, count:             [1911], Sched None (priority None), drivers: ['i8042']
 IRQ   14: PID:  None, count:            [74876], Sched None (priority None), drivers: ['ata_piix']
 IRQ   15: PID:  None, count:                [0], Sched None (priority None), drivers: ['ata_piix']

Software Interrupts:
--------------------


=== REPORT ===
FireWire kernel drivers:

The new FireWire kernel stack is loaded. 
If running a kernel earlier than 2.6.37 and problems are experienced, either 
try with the old Firewire kernel stack or upgrade to a newer kernel 
(preferrably 2.6.37 or later).


Paramètres jack
Image

Au Démarrage : Messages :
- DBUS : impossible de démarrer le serveur JACK. Désolé
puis
- Impossible de connecter le serveur JACK comme client.
- L'opération a échoué.
- Incapable de se connecter au serveur.
Veuillez consulter la fenêtre des messages pour plus d'informations.


Détails :
14:27:37.100 Baie de brassage désactivée.
14:27:37.219 Réinitialisation des statistiques.
14:27:39.965 Changement des connexions ALSA.
14:27:41.942 DBUS : le service est disponible (org.jackaudio.service soit jackdbus).
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
14:27:42.077 Changement du graphique des connexions ALSA.
(qjackctl:2653): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
(qjackctl:2653): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
(qjackctl:2653): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
(qjackctl:2653): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
14:59:57.991 DBUS : impossible de démarrer le serveur JACK. Désolé
Sat Aug  9 14:59:56 2014: Starting jack server...
Sat Aug  9 14:59:56 2014: JACK server starting in realtime mode with priority 70
Sat Aug  9 14:59:56 2014: ERROR: Cannot lock down 82274202 byte memory area (Cannot allocate memory)
Sat Aug  9 14:59:57 2014: ERROR: firewire ERR: FFADO: Error creating virtual device
Sat Aug  9 14:59:57 2014: ERROR: Cannot attach audio driver
Sat Aug  9 14:59:57 2014: ERROR: JackServer::Open failed with -1
Sat Aug  9 14:59:57 2014: ERROR: Failed to open server
Sat Aug  9 14:59:58 2014: Saving settings to "/home/alain/.config/jack/conf.xml" ...
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
(qjackctl:2653): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
(qjackctl:2653): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
15:01:20.179 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Incapable de se connecter au serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
(qjackctl:2653): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
(qjackctl:2653): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed


PC portable DELL Latitude C850 motorisé par un P3 (12 ans d'age...) 1100 Mhz, DD 20 Go et beaucoup de connecteurs en tous genres dont PCMCIA et IEE 1394 (j'ai une carte PCMCIA FW dispo mais non testée)

Ca tourne en Xubuntu Low Latency 14.04 LTS (Choix tout à fait criticable...)

J'ai testé toutes les suggestions disponibles ici et ailleurs, sans succès, y compris tuer pulseaudio et jackdbus.
Si quelqu'un a une idée, pour ma part, je pense qu'il manque quelque chose, mais quoi ?

D'avance grand merci

PS Précision, l'user Alain est bien membre des groupes Audio et Admin

olinuxx utilisateur non connecté France
Salut siscard06,

2 pistes :
  • pourquoi utiliser jackdbus ? Si tu n'en as pas besoin : dans Qjackctl -> "Réglages" -> 4eme onglet "Divers" -> décoche "Activer l'interface Dbus"
  • ton ffado-dialog dit
    /dev/raw1394 node present. False

    du coup, peut être qu'une lecture de ffado_configuration peut t'aider.

Bon courage,
Olivier

siscard06 utilisateur non connecté
Merci Olivier,

Pour ta première suggestion, résultat négatif :
15:58:27.957 JACK démarre...
15:58:27.959 /usr/local/sbin -P70 -dfirewire -dplughw:0 -r44100 -p1024 -n3
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
(qjackctl:3083): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
(qjackctl:3083): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
15:58:28.175 Impossible de démarrer JACK. Désolé.
15:58:30.611 JACK a été arrêté avec statut de sortie=255.


J'étudie la 2° et je te tiens au jus.
A+

Essais plutot une latence de 512 ...
PS: et augmente ton nombre de port maxi sans quoi tu va vite te retrouver coincé avec le nombre de pistes ...

siscard06 utilisateur non connecté
Bonjour, et Merci utilisateur_anonyme,

Tu voulais dire remettre le nombre de ports maxi à 512 ? Mais ça donne rien de mieux.

Ce qui m'inquiète plus c'est
/dev/raw1394 node present. False

Thunar m'indique effectivement qu'il n'y a pas de fichier /dev/raw1394

J'ai fait une réinstallation par Synaptic en ajoutant les fichiers doc et tools, mais toujours pareil. Je me demande si les fichiers nécessaires pour firewire ne sont pas déposés ailleurs que l'endroit ou jack les recherche (à côté de ceux d'Alsa), voire tout simplement absents.

La recherche par Catfish sur raw1394 sur tout le système fait apparaître des fichiers libraw1394*-* dans :
/var/lib/dpkg/info
/var/cache/archives/
/usr/share/doc
/usr/lib/i386-linux-gnu
rien dans /dev

Bizarre, non ?

A votre avis : Dois-je faire une réinstallation complète de jackd2 ? ou ajouter jackd1 ?

Encore merci

olinuxx utilisateur non connecté France
Je pense que si tu n'as pas /dev/raw1394 , c'est que tu as un souci avec les modules-noyau concernant le firewire.
Il me semble me souvenir que /dev/raw1394 est créé par l'un de ces modules-noyau.

Regarde attentivement la doc concernant FFADO, je suis 95% sûr que c'est dedans.

a+
Olivier

siscard06 utilisateur non connecté
J'ai installé Juju et son pote juju-core, Jack n'es plus en grève quand je lui donne du Firewire
Mais toujours pas de son sur ma FA101, il sort toujours par la carte interne, et toujours pas de /dev/raw1394...

Je m'arrache les tifs (pourtant assez longs)

La nuit porte conseil, alors à demain...

Si idées nouvelles, je suis preneur, Grand Merci
Sinon, je dois avoir un iso de Tango Studio qque part (mais je sais pas trop comment ça marche autant pour l'install que pour la maintenance après)...

Citation :
Tu voulais dire remettre le nombre de ports maxi à 512 ? Mais ça donne rien de mieux.


Oas du tout le nombre de port maxi (bien que de façon secondaire) à 1024
Je parlai de "Échantillon/période" lui faut le passer à 512
Ensuite il faut aussi que tu regarde sur ta FA 101 que le bouton en face arrière ne soit pas sur "bus" et vérifier qu'en face avant que le bouton SOFT CTRL soit en position "relachée".
Verifie ta FS que ce soit bien la même dans jack que sur celle de ta carte (face avant itou)

[HS]
Aussi la première mise en marche de cette carte est assez heu farfelue et donne du fil à retordre mais par exemple j'ai vu le cas ou je la branche et walou : personne ou bout du fil
Je lance la commande ffado-mixer rien je reboot je relance ffado mixer et hop c'est parti ensuite je lance jack et tout roule. [/HS]

Par contre là je vient de faire le test là en directe (cad) j'ai tout branché à l'instant j'ai rappelé ma config qjackctl et la voici :

Image
Image
En d'autre terme je pense que ton problème est le choix de "Période/tampon" il faut qu'elle soit à 2 (enfin essais tu sera vite fixé je crois)

Et pour info dans /dev/ je n'ai pas de /dev/raw1394 par contre j'ai ceci fw0 et fw1 ...
Le tout sous debian wheezy.

olinuxx utilisateur non connecté France
@siscard06 : si utilisateur_anonyme en possède une, je te laisse dans ses mains car moi, je n'ai jamais utilsé de carte son firewire.
Bon débusquage !
a+
Olivier

siscard06 utilisateur non connecté
Bonjour tous,

Deux jours de boulot pour installer TS2.1, je voulais le mettre en dual-boot avec Xubuntu, mais pas moyen, donc install complète, et finition en cours pour récupérer mes fichiers et connexions diverses, mais ça marche au premier coup : la FA101 fait son boulot et Jack aussi, et le tout sort sur la chaine Hifi, via la table de mixage DJ... Waouhh...

Désagrément, la carte son interne n'est plus reconnue, l'écran est pris de malaises (instabilité permanente de l'image avec zébrures vacillantes, mais un écran externe branché sur la prise vidéo, convient par contre), et le gestion de l'énergie est plus que douteuse (c'est un portable, je le rappelle).

Si quelqu'un a des idées pour contrer ces inconvénients, je suis preneur.

Grand merci

Citation :
je voulais le mettre en dual-boot avec Xubuntu, mais pas moyen,

?????

Citation :
et le gestion de l'énergie est plus que douteuse (c'est un portable, je le rappelle).


Bin non: Tu as un applet que tu peux ajouter à ton tableau de bord pour pouvoir passer d'un mode à un autre sachant que si jack est lancé il faut que tu sois sur "gouvernor"sans quoi certains programme (comme jack) se fermeront s'ils consomment trop d'énergie ...

Par contre je t'invite à ouvrir un fil dédié Pour tenter élucider tes problèmes d'écran...

siscard06 utilisateur non connecté
Bonjour,

Bon, j'ai remis mon Xubuntu 14.04 LTS en dual boot avec TS2
Ainsi, suivant mes activités je peux choisir celui que je vais utiliser :

- Pour une démo simple lecture de sons avec la carte interne, ou bureautique en déplacement -> Xub
- Pour un bœuf avec FA101 -> Tango studio s'impose, à condition de corriger les pbs cités plus haut.

Merci utilisateur_anonyme, you can close the thread.

Ok!

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 09:25, mar. 15 Jun 2021: Bonjour et bienvenue à Hexaal :-)
Ubuntu_Studio_User, 02:29, lun. 14 Jun 2021: Salut à tous...
allany, 12:12, sam. 12 Jun 2021: @tourneriff : merci pour le signalement, c'est fait !
tourneriff, 07:52, sam. 12 Jun 2021: Bonjour à tous ☺ ! Avis aux modos : pourrait-on voir la "joute 16" en cours à l'accueil du site plutôt que l'antique "joute 15"
sub26nico, 14:56, jeu. 10 Jun 2021: Salut et bienvenue à jamesonmount, freerawsound et Loop :-)
ycollet, 10:28, mer. 09 Jun 2021: Cool, un revival de rakarrak ! [Lien]
sub26nico, 22:08, lun. 07 Jun 2021: Bonjour et bienvenue à ArchLinux59, Djobi et gakgakgak :-)
olof, 09:27, lun. 07 Jun 2021: ardour 6.7 build tourne chez moi, mais pas le package 6.6
allany, 14:46, dim. 06 Jun 2021: @r1 : t'as raison : trop c'est trop, ça sature du goulot !
r1, 22:54, sam. 05 Jun 2021: Mon cerveau a bobo à force de faire le gogo sur l'annonce de l'édito !
allany, 11:49, sam. 05 Jun 2021: Z'ont encore abattu un sacré boulot, les poulbots de l'édito ! [Lien]
ycollet, 20:37, ven. 04 Jun 2021: Un article intéressant sur un truc à venir sur USB audio: [Lien]