Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [Résolu] Problème de lancement QjackCtl avec une 18i20
Dernier post

[Résolu] Problème de lancement QjackCtl avec une 18i20

sri_raoul utilisateur non connecté
Bonjour tout le monde!

Voici comment je procéde:
  • je lance mon Ubuntu 14.04
  • j'allume ma 18i20
  • je lance QjackCTL et celui-ci me répond:

15:44:08.622 Baie de brassage désactivée.
15:44:08.626 Réinitialisation des statistiques.
15:44:08.631 Changement des connexions ALSA.
15:44:08.642 DBUS : le service est disponible (org.jackaudio.service soit jackdbus).
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
15:44:11.118 DBUS : impossible de démarrer le serveur JACK. Désolé
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
Sat Jul  4 15:44:11 2015: Starting jack server...
Sat Jul  4 15:44:11 2015: JACK server starting in realtime mode with priority 10
Sat Jul  4 15:44:11 2015: ERROR: Cannot lock down 82274202 byte memory area (Cannot allocate memory)
Sat Jul  4 15:44:11 2015: ERROR: cannot register object path "/org/freedesktop/ReserveDevice1/Audio1": A handler is already registered for /org/freedesktop/ReserveDevice1/Audio1
Sat Jul  4 15:44:11 2015: ERROR: Failed to acquire device name : Audio1 error : A handler is already registered for /org/freedesktop/ReserveDevice1/Audio1
Sat Jul  4 15:44:11 2015: ERROR: Audio device hw:USB cannot be acquired...
Sat Jul  4 15:44:11 2015: ERROR: Cannot initialize driver
Sat Jul  4 15:44:11 2015: ERROR: JackServer::Open failed with -1
Sat Jul  4 15:44:11 2015: ERROR: Failed to open server
Sat Jul  4 15:44:12 2015: Saving settings to "/home/cyril/.config/jack/conf.xml" ...
15:44:14.949 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Incapable de se connecter au serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started


Donc, est-ce que quelqu'un pourrait me guider pour m'aider à débloquer la situation?

Merci d'avance!

allany utilisateur non connecté
Salut !

Peux-tu nous communiquer les paramètres passés à Qjack ?
Un lsusb ?
Si tu lances alsamixer en terminal et que tu sélectionnes la Focusrite avec F6, as-tu accès à des réglages ?

A+

Samuel utilisateur non connecté Allemagne
Essaie de lancer Qjackctl sans avoir lancé d'autres applications, surtout si elles utilisent de l'audio, dès fois ça bloque jack car il ne peut pas locker la carte son.

sri_raoul utilisateur non connecté
Re,

Merci de vos premières réponses.
J'ai aussi trouvé ça sur le site:
Citation :
ADAT et SPDIF non testé, config du DSP mixer faite depuis un mac, une fois configuré analog in et out utilisé avec Jack sans souci


Les paramètres passés à Qjack sont les suivants:
Image

Le lsusb donne ceci:
cyril@Petit:~$ lsusb
Bus 002 Device 003: ID 04f2:b2f4 Chicony Electronics Co., Ltd 
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 1235:800c Novation EMS <--- il s'agit de la 18i20 je pense
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Voila ce que renvoie le alsamixer:
Image

J'ai aussi trouvé plusieurs post sur des forum en anglais où il est question de recompiler alsa, de commenter une ligne de code et a priori cela fonctionne pour la 18i6. Par contre il n'est pas dit que cela roule avec Jack...

allany utilisateur non connecté
OK !

Bon. La carte est reconnue, ouf !

Essaie déjà de mettre 85 dans priorité. Tu es à 10 et ce n'est pas suffisant en temps réel.
Tu sembles également avoir un problème d'allocation de mémoire. As-tu bien configuré ton P.A.M. ?
A ce propos : tu tournes sur Ubuntu standard ou sur UbuntuStudio ?

A+

Citation :
JACK server starting in realtime mode with priority 10

t'as un prob avec le temps réel non ?

olinuxx utilisateur non connecté France
Salut sri_raoul,
où en es-tu avec ce soucis ?

+1 avec ce que t'as dis utilisateur_anonyme dans le message juste au dessus de celui-ci : tu sembles avoir un problème. Tes applications audio ne semblent pas avoir accès au temps-réel. Pour essayer de corriger cela, va voir la page PAM.
Dis nous ce qu'il en est.

olinuxx utilisateur non connecté France
Remontée, tu en es où sri_raoul ?

olinuxx utilisateur non connecté France
Je fermerai ce fil de discussion à mon prochain passage (3 ou 4 semaines environ) si je n'ai pas de nouvelle de ta part.

olinuxx utilisateur non connecté France
sujet ré-ouvert suite à la demande de sri_raoul.

sri_raoul utilisateur non connecté
Yep!

Effectivement, suite à pas mal de changements dans ma vie et notamment une naissance (Youhou!!!!), j'avais dû mettre ce topic de côté. Désolé de ne le reprendre que maintenant.

Donc, pour faire un point de là où j'en suis:
  • la 18i20 fonctionne très bien
  • je suis passé sous Kxstudio, mais j'ai aussi testé AVlinux sur un Eeepc et la carte fonctionnait aussi
  • je descend à 2.9ms de latence
  • le logiciel de gestion de la Scarlett n'est pas utilisable via Wine car, même en spécifiant le lecteur USB dans winecfg, le logiciel ne détecte pas la carte. Visiblement cela vient de wine, problème récurrent entre lui et les ports usb. Si j'en ai le temps et l'envie, j'essaierai peut être avec une machine virtuelle...
  • j'ai fait un enregistrement avec pas loin d'une quinzaine de pistes (dont 8 en simultanées pour la batterie) le week-end passé et tout roule parfaitement

Donc; conclusion plutôt heureuse. Bonne surprise aussi que d'utiliser Kxstudio...le bureau KDE me faisait un peu peur en terme de consommation CPU, mais finalement tout roule tranquille...

Voilà pour le moment et encore merci pour vos coups de mains!

zebassprophet utilisateur non connecté
Felicitation au passage ;)

C'est bien tu vas pouvoir bosser la musique la nuit (je faisais ca quand on se relayait pour les biberons, j'avais le creneau 10h-3h du matin)

olinuxx utilisateur non connecté France
Super pour ce retour et pour le [RÉSOLU] !

sri_raoul utilisateur non connecté
Merci, merci... :-)

olinuxx utilisateur non connecté France
Ce fil est donc prêt à être fermé maintenant que le [RÉSOLU] est mis, ce que je ferai à mon prochain passage de maintenance d'ici environ 3 ou 4 semaines.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

Geis007, 18:03, sam. 18 Sep 2021: binjch, c'est très lent, en effet !
binjch, 22:51, ven. 17 Sep 2021: Salut c'est hyper lent chez tout le monde là? Ou c'est moi qui ai un problème?
olinuxx, 18:46, jeu. 16 Sep 2021: Bonjour et bienvenue à pierre2 cool
zicstef, 22:40, mer. 15 Sep 2021: Hello, il y a bien longtemps que je n'ai pas eu la joie de passer. Découvert au détour d'un surf: /
olinuxx, 18:30, lun. 13 Sep 2021: [INFO] nouveau compte Diaspora pour linuxmao : [Lien] Venez nous y rejoindre cool
Samuel, 02:44, dim. 12 Sep 2021: [Lien] C'est la video de présentation du futur de VCV RACK, un synthé modulaire
olinuxx, 18:55, jeu. 09 Sep 2021: @dugalandco : utilises le forum pour mener des discussions. Le mégaphone n'est pas utilisé pour des discussions, mais pour informer de façon rapide.
dugalandco, 17:20, jeu. 09 Sep 2021: merci à olinuxx et sri raoul. Je vais donc tenter d'installer Ubuntu studio. Si je ne me trompe , il s'agit bien d'un système de distribution linux en son entier ? pas seulement la partie musique ?
sub26nico, 12:44, jeu. 09 Sep 2021: Bonjour et bienvenue à Jha :-)
sub26nico, 12:41, jeu. 09 Sep 2021: @Jha: ouvres un fil de forum pour que l'on puisse te répondre.
Jha, 11:12, jeu. 09 Sep 2021: bonjour j'arrive pas a telecharger ubuntustudio-audio klk un peut m'aider?
olinuxx, 20:41, mer. 08 Sep 2021: Les nouveautés LibraZiK des 5 derniers mois : [Lien]