Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

6 - Le MIDI

> Forums de discussion > 6 - Le MIDI > connecter un clavier midi avec une TASCAM US-122 MKII
Dernier post
Page : 2/3   -   Aller directement à la page : 1  2  3 

connecter un clavier midi avec une TASCAM US-122 MKII

quentic utilisateur non connecté France
Bonjour,

Je débute en MAO sous Linux mais la chose dont j'aurais besoin dans l'immédiat, c'est de connecter mon clavier numérique en MIDI à mon PC via une carte son USB TASCAM US-122 MKII. L'idée est de piloter MuseScore pour la saisie des partitions.

  • J'ai installé une distri Librazik toute fraîche.
  • Le piano (MIDI OUT) est connecté à la TASCAM (MIDI IN) et la carte est reliée en USB au PC.
  • Le PC semble détecter la carte son :

$ cat /proc/asound/cards
 0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfebfc000 irq 17
 1 [MKII           ]: USB-Audio - US122 MKII
                      TASCAM US122 MKII at usb-0000:00:13.5-1, high speed


  • Le serveur Jack est configuré avec dans les réglages avancés de QjackCtl :
périphérique d'entrée : hw:MKII
périphérique de sortie: hw:MKII

La carte TASCAM prend le contrôle pour les sorties audio :
une petite boucle sous Hydrogen et je récupère bien le son va sur la sortie casque de la TASCAM.

Bref, y'a des bouts qui marchent mais :
quand je joue une note au clavier numérique, la led MIDI s'allume sur la carte son mais malgré quelques tatonnements, je n'arrive pas à récupérer l'événement MIDI sur le PC.

Quels tests puis-je faire pour avancer ?
Merci.

PS : j'ai tenté de dérouler la procédure Fixer l ordre des cartes-son mais il est indiqué de modifier le fichier /etc/modprobe.d/alsa-base.conf et il ne semble pas exister dans ce dossier sur mon système. Est-ce normal ? Faut-il le créer ?

quentic utilisateur non connecté France
yes :-)
C'est où le meilleur endroit pour discuter avec les types d'ALSA ?

Au fait, il y a un article sur cette carte son : Tascam US-122 MKII
Ça a donc dû déjà marcher pour quelqu'un. Il y aurait eu une régression ?

olinuxx utilisateur non connecté France
Citation :
C'est où le meilleur endroit pour discuter avec les types d'ALSA ?


Tu peux commencer par aller discuter sur le canal IRC #ALSA (serveur freenode.net)

olinuxx utilisateur non connecté France
Par rapport à la liste chez alsa-project, c'est une indication, mais les informations ne sont pas exhaustives. Autrement dit : elle n'est pas à jour. Si la page sur linuxmao affirme et détaille que c'est possible, alors c'est possible (ou alors, ça l'a était).

Tu as des nouvelles quentic ?

quentic utilisateur non connecté France
Je n'ai pas eu le temps d'avancer. Mon prochain essai serait de tenter le coup avec une des 2 distro testées citées dans l'article pour voir si ça fonctionne. Dans ce cas, on pourrait essayer de voir ce qui manque à la Librazik actuelle pour que je puisse utiliser ma carte.

Je te tiens au courant.

olinuxx utilisateur non connecté France
OK

quentic utilisateur non connecté France
Premier essai avec Tango Studio :
après avoir relancé alsa par
sudo alsa reload

plus la modification du fichier .asoundrc, je vois bien apparaître la carte TASCAM dans QjackCtl (onglet ALSA en port de sortie et d'entrée).
Pour info, quand je relance alsa, la liste des modules contient snd-usb-us122l

Sans aller plus loin, je me dis : je pourrais peut-être tenter la même manip sous Librazik pour voir si le même module apparaît dans la liste mais quand j'essaie de relancer alsa, j'ai comme réponse "alsa not found".
Suspect, non ? La commande aurait changé de nom ?

Si ça vous dit qqch, je suis preneur !

olinuxx utilisateur non connecté France
quentic écrit :
Suspect, non ? La commande aurait changé de nom ?


Pas suspect non. La gestion d'ALSA a changée entre Debian Wheezy et Debian Jessie.
Tu peux redémarrer la machine en remplacement.

quentic utilisateur non connecté France
Et pour voir si le module snd-usb-us122l a bien été chargé après redémarrage, il suffit de regarder dans /proc/modules ?

olinuxx utilisateur non connecté France
Oui, ou "lsmod |grep snd".

quentic utilisateur non connecté France
Avec Librazik, lsmod |grep snd m'indique que le module snd-usb-us122l est bien chargé (tout comme dans Tango Studio).
A priori, le problème n'est pas là.
En revanche, je me demande s'il n'y a pas un truc du côté du fichier ~/.asoundrc

Ce fichier décrit l'interface de la carte Tascam sous le nom usb_stream.
  • Dans Tango Studio, c'est bien usb_stream que j'utilise comme nom d'interface dans QjackCtl et Jack démarre.
  • Dans Librazik,
    • si j'utilise usb_stream (je tape usb_stream:1 dans mon cas) comme interface dans QjackCtl, le serveur Jack ne démarre pas.
    • si j'utilise hw:MKII US122 MKII (hw:1) qui est dans la liste déroulante des interfaces, Jack démarre bien mais avec toujours l'avertissement :
hw:MKII|hw:MKII|1024|2|48000|0|0|nomon|swmeter|-|32bit
ALSA: Cannot open PCM device alsa_pcm for capture. Falling back to playback-only mode

Du coup, je me demande si le fichier ~/.asoundrc est bien pris en compte.

Comment vérifier ça ?

olinuxx utilisateur non connecté France
Je ne sais pas.

Un truc qui m'attire l'oeil, c'est que dans le retour de cat /proc/asound/cards , tu as :
1 [MKII           ]: USB-Audio - US122 MKII
                      TASCAM US122 MKII at usb-0000:00:13.5-1, high speed


Alors que dans la page de la Tascam US-122 MKII, il y a :
1 [US122L         ]: USB US-122L - TASCAM US-122L
                      TASCAM US-122L (644:8021 if 0 at 001/002)


Ça semble indiquer qu'il y a eu du changement quelque part (peut être au niveau du pilote qui reconnaîtrait plus précisément l'interface ? ).
Du coup, tu peux vérifier ceci chez toi en donnant ici le retour d'un cat /proc/asound/cards sur la TangoStudio, puis sur la LibraZiK.

Si mon intuition se confirme, il faudra alors aller chercher du côté d'ALSA pour essayer d'y trouver des infos sur les nouveautés.

quentic utilisateur non connecté France
C'est exactement ça !
Le retour de cat /proc/asound/cards est bien différent dans les 2 distributions

olinuxx utilisateur non connecté France
OK, alors à ce niveau là, je te suggère de rédiger un long courriel très descriptif de la problématique et de l'envoyer chez alsa-devel. Mon conseil est de prendre le temps nécessaire pour qu'il soit exhaustif et qu'il explique tout, tout bien. Si tu veux, tu peux mettre un premier jet ici et je te filerai des commentaires.

quentic utilisateur non connecté France
In english, je présume ?

olinuxx utilisateur non connecté France
œuf corse

quentic utilisateur non connecté France
Que s'est-il passé ? Où est passé mon superbe texte ? Tu as utilisé mon message pour me répondre ??

quentic utilisateur non connecté France
Que s'est-il passé ? Où est passé mon superbe texte ? Tu as utilisé mon message pour me répondre ??

****************
Et là je viens d'écraser ton message en tentant de te répondre. Y'aurait un problème avec le fonctionnement du forum ?

olinuxx utilisateur non connecté France
Non, il n'y a pas de problème ici avec le fonctionnement du forum je pense.
Ce qui semble s'être passé ici, c'est que tu as édité ton message du 5 novembre et donc l’originel a disparu, étant remplacé.

PS : d'ailleurs, tu n'as pas écrasé mon message, mais le tiens.

quentic utilisateur non connecté France
Il me semble avoir écrasé ton message dans lequel tu disais "ça semble assez complet. il faudrait ajouter la version des noyaux, etc."
ce message était sous l'identité quentic comme si tu avais édité mon message en anglais...

Bref, je crois qu'il va falloir le ré-écrire. A tout hasard, il n'y a pas d'historique des modifications dans l'administration du forum ?

Page : 2/3  [Suivant]
1  2  3 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 15:36, mar. 07 Jul 2020: Bonjour et bienvenue à Moona cool
olinuxx, 15:42, lun. 06 Jul 2020: Bonjour et bienvenue à smellycat cool
allany, 21:11, dim. 05 Jul 2020: Trop fort, R-oooouane !
r1, 20:56, dim. 05 Jul 2020: Ce ne sont pas des nigauds, la bande de l'édito \o/ !
allany, 18:09, dim. 05 Jul 2020: C'est pas la bande à Bonnot, c'est la bande de l'édito ! [Lien]
GypsyPlayer, 10:33, ven. 03 Jul 2020: Merci Olinuxx ! J'épluche le site depuis maintenant 2-3 jours, y a plein plein d'infos c'est top !
olinuxx, 10:57, jeu. 02 Jul 2020: Bonjour et bienvenue à GypsyPlayer cool
olinuxx, 13:34, mer. 01 Jul 2020: Bonjour et bienvenue à nevastech cool
farvardin, 10:29, mer. 01 Jul 2020: @Sahaathyva original comme outil ! Un piano roll pour du chiptune à la place du traditionnel tracker. Pas mal du tout !
pierrotlo, 09:12, mer. 01 Jul 2020: Salut tous. Pour les nostalgiques ou les curieux. Quasar Beach a développé un clone du mythique Fairlight CMI IIx. [Lien] ça tourne sous Linux
r1, 23:49, mar. 30 Jun 2020: @Sahaathyva merci pour le tuyau et c'est sous license MIT : [Lien] par contre du c# :-D
Sahaathyva, 23:02, mar. 30 Jun 2020: Pour les amateurs de Chiptune (R1?) , voici : https://famistudio.org/ Première version compatible linux(cool!)