Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [RÉSOLU] Roland Rubix24 sous Ubuntu Studio 16.04
Dernier post

[RÉSOLU] Roland Rubix24 sous Ubuntu Studio 16.04

jjs95 utilisateur non connecté France
Bonjour,
j'ai récemment acheté une interface audio Roland Rubix24 pour faire de la MAO (enregistrement audio voix et saisie MIDI avec mon clavier principalement) sur mon ordinateur de bureau sous Ubuntu Studio 16.04 (à jour) et sur mon Macbook. La carte fonctionne sans problème et sans aucune installation particulière sous Mac OSX 10.11, mais je n'arrive pas à l'utiliser avec Ubuntu, bien que j'ai lu que cette carte son était compatible (ici par exemple : https://www.mixxx.org/wiki/doku.php/hardware_compatibility ).

La carte Rubix24 est détectée mais le système semble ne pas réussir à charger le pilote (brancher la carte son avant ou après le démarrage de l'ordinateur ne change rien) :
$ cat /proc/asound/cards
 0 [MID            ]: HDA-Intel - HDA Intel MID
                      HDA Intel MID at 0xfbaf8000 irq 31
 1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfbbfc000 irq 32
 2 [Rubix24        ]: USB-Audio - Rubix24
                      Roland Rubix24 at usb-0000:00:1a.0-1.2, high speed

$ aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: MID [HDA Intel MID], périphérique 0: VT1828S Analog [VT1828S Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: MID [HDA Intel MID], périphérique 2: VT1828S Alt Analog [VT1828S Alt Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: MID [HDA Intel MID], périphérique 3: VT1828S Digital [VT1828S Digital]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: HDMI [HDA ATI HDMI], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 2: Rubix24 [Rubix24], périphérique 0: USB Audio [USB Audio]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0

Jusqu'ici ça va, mais plusieurs erreurs apparaissent quand le périphérique est branché, la dernière ligne retournée par la commande ci-dessous est répétée un grand nombre de fois, et s'affiche également dans le premier terminal tty1 avant même de se connecter :
$ dmesg | grep "usb 1-1.2:"
[    1.660298] usb 1-1.2: new high-speed USB device number 3 using ehci-pci
[    2.144162] usb 1-1.2: device not accepting address 3, error -71
[    2.217206] usb 1-1.2: new high-speed USB device number 4 using ehci-pci
[    2.303624] usb 1-1.2: New USB device found, idVendor=0582, idProduct=01e0
[    2.303631] usb 1-1.2: New USB device strings: Mfr=1, Product=3, SerialNumber=0
[    2.303634] usb 1-1.2: Product: Rubix24
[    2.303638] usb 1-1.2: Manufacturer: Roland
[   52.135105] usb 1-1.2: parse_audio_format_rates_v2(): unable to find clock source (clock -71)
[   52.153376] usb 1-1.2: parse_audio_format_rates_v2(): unable to find clock source (clock -71)
[  258.751328] usb 1-1.2: USB disconnect, device number 4
[  259.627410] usb 1-1.2: new high-speed USB device number 5 using ehci-pci
[  259.713905] usb 1-1.2: New USB device found, idVendor=0582, idProduct=01e0
[  259.713912] usb 1-1.2: New USB device strings: Mfr=1, Product=3, SerialNumber=0
[  259.713916] usb 1-1.2: Product: Rubix24
[  259.713919] usb 1-1.2: Manufacturer: Roland
[  259.733979] usb 1-1.2: parse_audio_format_rates_v2(): unable to find clock source (clock -71)
[  259.823014] usb 1-1.2: 1:1: usb_set_interface failed (-71)


Lorsque pulseaudio est lancé :
- la carte n'apparaît pas dans le contrôle du volume, quel que soit l'onglet, même en affichant tous les périphériques audio
- aucune ligne mentionnant "ControlC2" dans le retour de la commande `lsof | grep /snd/`
(Pour pulseaudio j'ai par ailleurs essayé la carte son sans succès avec un liveDVD d'une version plus récente d'Ubuntu Studio (17.10))

Les logiciels permettant la sélection de la carte son :
- Rubix24 n'apparaît ni dans audacity, ni dans mixxx.
- vlc affiche une erreur d'entrée/sortie pour "default:CARD=Rubix24"
- ardour4 refuse de lancer une session avec le message "Failed to open audio device".
- alsamixer ne propose aucun réglage : "ce périphérique n'a pas de commandes".

Le serveur de sons Jack affiche Rubix24 mais ne démarre pas sur cette carte :
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock
10:57:37.148 Script de démarrage terminé avec statut de sortie=256.
10:57:37.238 DBUS : impossible de démarrer le serveur JACK. Désolé
Fri Nov 24 10:57:37 2017: Starting jack server...
Fri Nov 24 10:57:37 2017: JACK server starting in realtime mode with priority 70
Fri Nov 24 10:57:37 2017: self-connect-mode is "Don't restrict self connect requests"
Fri Nov 24 10:57:37 2017: Acquired audio card Audio2
Fri Nov 24 10:57:37 2017: creating alsa driver ... hw:Rubix24|hw:Rubix24|256|2|48000|0|0|nomon|swmeter|-|32bit
Fri Nov 24 10:57:37 2017: configuring for 48000Hz, period = 256 frames (5.3 ms), buffer = 2 periods
Fri Nov 24 10:57:37 2017: ERROR: ALSA: no playback configurations available (Invalid argument)
Fri Nov 24 10:57:37 2017: ERROR: ALSA: cannot configure capture channel
Fri Nov 24 10:57:37 2017: ERROR: Cannot initialize driver
Fri Nov 24 10:57:37 2017: ERROR: JackServer::Open failed with -1
Fri Nov 24 10:57:37 2017: ERROR: Failed to open server
Fri Nov 24 10:57:38 2017: Saving settings to "/home/js95/.config/jack/conf.xml" ...
10:57:51.556 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Incapable de se connecter au serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.


J'espère que vous pourrez m'aider à faire fonctionner ma carte son sous linux.
Merci d'avance
jjs95

olinuxx utilisateur non connecté France
jjs95 écrit :
La carte Rubix24 est détectée mais
La carte Rubix24 est détectée mais le système semble ne pas réussir à charger le pilote (brancher la carte son avant ou après le démarrage de l'ordinateur ne change rien) : (brancher la carte son avant ou après le démarrage de l'ordinateur ne change rien) :


Qu'est-ce qui te fait dire que "...le système semble ne pas réussir à charger le pilote..." ? Si tu dis que la carte est reconnue directement sous macOS, c'est probablement parce qu'elle est class compliant. Si c'est le cas, alors le module chargé correspond est (ou devrait être) le "snd_usb_audio". Tu peux vérifier qu'il est chargé grâce à la commande "lsmod".

Le résultat de "cat /proc/asound/cards" nous dit qu'ALSA communique avec le périphérique ce qui est déjà un bon signe. Le résultat de "aplay -l" semble aller dans la même direction.

Comme tu l'as deviné, le soucis semble être donné par "parse_audio_format_rates_v2(): unable to find clock source (clock -71)". Ceci pourrait signifier que le pilote a des difficultés à se synchroniser avec l'interface. Et les messages de jack semblent signifier la même chose.

Réflexion : ce produit semble relativement récent Image , il lui manque peut être un "quirk" dans ALSA (et donc, dans le noyau que tu utilises) pour pouvoir fonctionner.

Question : quel noyau utilises-tu ? (commande : "uname -a").

jjs95 utilisateur non connecté France
$ uname -a
Linux jsb-pc 4.4.0-101-lowlatency #124-Ubuntu SMP PREEMPT Fri Nov 10 19:25:08 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

$ lsmod | grep snd
snd_seq_dummy          16384  0
snd_usb_audio         176128  0
snd_usbmidi_lib        36864  1 snd_usb_audio
snd_hrtimer            16384  2
snd_hda_codec_via      24576  1
snd_hda_codec_hdmi     53248  1
snd_hda_codec_generic    77824  1 snd_hda_codec_via
snd_hda_intel          40960  0
snd_hda_codec         135168  4 snd_hda_codec_hdmi,snd_hda_codec_via,snd_hda_codec_generic,snd_hda_intel
snd_hda_core           69632  5 snd_hda_codec_hdmi,snd_hda_codec_via,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_hwdep              16384  2 snd_usb_audio,snd_hda_codec
snd_pcm               106496  5 snd_usb_audio,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            32768  2 snd_usbmidi_lib,snd_seq_midi
snd_seq                69632  8 snd_seq_midi_event,snd_seq_dummy,snd_seq_midi
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              32768  3 snd_hrtimer,snd_pcm,snd_seq
snd                    81920  16 snd_usb_audio,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_via,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_usbmidi_lib,snd_hda_codec,snd_hda_intel,snd_seq_device
soundcore              16384  1 snd


J'ai testé la carte sur un autre pc sous ubuntu 14.04 où elle a fonctionné (le seul problème était que pulseaudio ne détecte pas la sortie audio, mais pas grave puisque je l'ai testée avec audacity par ALSA sans passer par pulseaudio et ça a marché, je n'ai pas testé avec jackd qui n'était pas installé sur cet ordinateur). (J'aurais dû l'an dernier installer une version plus vieille d'Ubuntu Studio frown ) En effet le modèle de la carte est récent (elle n'existait pas en 2016) et il y a des chances que ça fonctionne très bien avec la prochaine version 18.04 d'ubuntu...


Maintenant que je rebranche ma Rubix24 sur mon pc sous Ubuntu studio 16.04, c'est bizarre mais j'ai une ligne de plus (il y a du mieux) dans la sortie de dmesg :
[  429.912485] usbcore: registered new interface driver snd-usb-audio

et jackd ne me donne plus tout à fait les mêmes messages d'erreur :
Fri Nov 24 15:55:07 2017: ERROR: cannot register object path "/org/freedesktop/ReserveDevice1/Audio2": A handler is already registered for /org/freedesktop/ReserveDevice1/Audio2
Fri Nov 24 15:55:07 2017: ERROR: Failed to acquire device name : Audio2 error : A handler is already registered for /org/freedesktop/ReserveDevice1/Audio2
Fri Nov 24 15:55:07 2017: ERROR: Audio device hw:Rubix24 cannot be acquired...
Fri Nov 24 15:55:07 2017: ERROR: Cannot initialize driver
Fri Nov 24 15:55:07 2017: ERROR: JackServer::Open failed with -1
Fri Nov 24 15:55:07 2017: ERROR: Failed to open server
Fri Nov 24 15:55:09 2017: Saving settings to "/home/js95/.config/jack/conf.xml" ...
15:55:11.069 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Incapable de se connecter au serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.

"usb_set_interface failed (-71)" semble ne pas apparaître tant que pulseaudio n'a pas été lancé une première fois après le démarrage de l'ordinateur

Il y a toujours "Cannot initialize driver" pour Jack et le "parse_audio_format_rates_v2(): unable to find clock source (clock -71)" pour dmesg qui semble en effet être le principal problème.

jjs95 utilisateur non connecté France
J'ai visiblement des ports USB défectueux sur mon ordinateur. J'ai changé de port usb pour la Rubix24.
Amélioration : la carte fonctionne avec pulseaudio.
Mais toujours pas de commandes dans alsamixer, les mêmes messages d'erreur au lancement de jackd et en sortie de dmesg.
Le problème est donc maintenant de faire fonctionner la carte en temps réel avec jackd. Je vais aussi tester l'entrée midi dès que j'aurais le temps.

olinuxx utilisateur non connecté France
jjs95 écrit :
Mais toujours pas de commandes dans alsamixer


Toutes les interfaces n'ont pas forcément de contrôle ALSA. C'est donc peut être tout simplement normal. Fais un test de branchement sur l'autre distribution où elle fonctionne (ubuntu 14.04) et vérifies-y si tu as des contrôles accessibles dans alsamixer. Mets nous des captures d'écran de alsamixer sur ces 2 systèmes également.

olinuxx utilisateur non connecté France
Des nouvelles ici jjs95 ?

Pour info : page Roland Rubix24 créée avec un lien vers ici.

olinuxx utilisateur non connecté France
Des nouvelles ici @jjs95 ?

PS : si pas de nouvelle de ta part d'ici à mon prochain passage de maintenance de cette section du forum, je fermerai le fil avec un [RÉSOLU].

jjs95 utilisateur non connecté France
Actuellement j'utilise les fonctionnalités de ma carte Rubix24 avec mon Mac.

Sur mon pc de bureau, j'attends les premiers correctifs de la nouvelle version d'Ubuntu (la 18.04.1) avant de mettre le système à niveau au mois d'août.
Je configurerai à la carte son avec le nouveau système d'exploitation.
Il n'y aura peut-être pas le bug avec la nouvelle version.

Dans un mois et demi je saurai alors si le problème est résolu.

olinuxx utilisateur non connecté France
OK, merci pour la réponse rapide. Tiens nous au jus alors, ça nous intéresse puisque tu es le premier à nous parler de ce matériel et de sa compatibilité avec GNU-linux.

olinuxx utilisateur non connecté France
Du nouveau depuis 2 ans jjs95 ?

Si pas de nouvelle, je fermerai lors d'un prochain passage de maintenance.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]


Ubuntu_Studio_User

Mégaphone [Afficher / Cacher]

sub26nico, 09:25, mar. 15 Jun 2021: Bonjour et bienvenue à Hexaal :-)
Ubuntu_Studio_User, 02:29, lun. 14 Jun 2021: Salut à tous...
allany, 12:12, sam. 12 Jun 2021: @tourneriff : merci pour le signalement, c'est fait !
tourneriff, 07:52, sam. 12 Jun 2021: Bonjour à tous ☺ ! Avis aux modos : pourrait-on voir la "joute 16" en cours à l'accueil du site plutôt que l'antique "joute 15"
sub26nico, 14:56, jeu. 10 Jun 2021: Salut et bienvenue à jamesonmount, freerawsound et Loop :-)
ycollet, 10:28, mer. 09 Jun 2021: Cool, un revival de rakarrak ! [Lien]
sub26nico, 22:08, lun. 07 Jun 2021: Bonjour et bienvenue à ArchLinux59, Djobi et gakgakgak :-)
olof, 09:27, lun. 07 Jun 2021: ardour 6.7 build tourne chez moi, mais pas le package 6.6
allany, 14:46, dim. 06 Jun 2021: @r1 : t'as raison : trop c'est trop, ça sature du goulot !
r1, 22:54, sam. 05 Jun 2021: Mon cerveau a bobo à force de faire le gogo sur l'annonce de l'édito !
allany, 11:49, sam. 05 Jun 2021: Z'ont encore abattu un sacré boulot, les poulbots de l'édito ! [Lien]
ycollet, 20:37, ven. 04 Jun 2021: Un article intéressant sur un truc à venir sur USB audio: [Lien]