Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

Dernier post

AKAI MPK mini mkII [RÉSOLU]

Ubuntu_Studio_User utilisateur non connecté
Salut la communauté !

Je viens vous voir car j'ai un souci de "détection" avec mon AKAI MPK mini mkII (sous Ubuntu Studio)...

Je m'explique... La carte fonctionne sous Windows 10 (PC fixe Fruity Loops), ainsi que sous Debian (PC fixe LMMS). Aucun problème de détection.

Par contre, quand je passe sur Ubuntu Studio (il s'agit là d'un ordi portable je précise), il n'est pas reconnu par LMMS.

Alors voici ce que me retourne les commandes suivantes :

lsusb
Bus 001 Device 003: ID 13d3:5702 IMC Networks UVC VGA Webcam
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 2011:0715  
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


et

sudo lshw
        *-usb:0
             description: USB controller
             produit: NM10/ICH7 Family USB UHCI Controller #1
             fabriquant: Intel Corporation
             identifiant matériel: 1d
             information bus: pci@0000:00:1d.0
             version: 02
             bits: 32 bits
             horloge: 33MHz
             fonctionnalités: uhci bus_master
             configuration: driver=uhci_hcd latency=0
             ressources: irq:23 portE/S:d400(taille=32)
           *-usbhost
                produit: UHCI Host Controller
                fabriquant: Linux 4.13.0-32-lowlatency uhci_hcd
                identifiant matériel: 1
                information bus: usb@2
                nom logique: usb2
                version: 4.13
                fonctionnalités: usb-1.10
                configuration: driver=hub slots=2 speed=12Mbit/s
              *-usb
                   description: Périphérique d'interface homme/machine
                   produit: MPKmini2
                   fabriquant: AKAI
                   identifiant matériel: 2
                   information bus: usb@2:2
                   version: 0.00
                   numéro de série: 0001
                   fonctionnalités: usb-1.10
                   configuration: driver=usbhid maxpower=500mA speed=12Mbit/s


(je me suis permis d'écourter le retour de la dernière commande)

Alors, je ne sais pas quoi dire et quoi faire...
Alimenté, non reconnu ?
Alimenté, reconnu ?

Y aurait-il quelqu'un qui pourrait m'aider à régler mon souci s'il vous plaît ?
Merci d'avance.

Cordialement.

Ubuntu_Studio_User utilisateur non connecté
Salut à tous !


J'apporte une information...


Dans mon listing lsusb il y a cette ligne :

Bus 002 Device 003: ID 2011:0715


Elle correspond à mon matériel (Akai MPK mini)


Aussi, je retrouve cette ligne également sur les différentes distributions que j'ai essayées (Debian sur PC fixe, Ubuntu, Ubuntu Studio, et Xubuntu en machine virtuelle).

Je n'ai aucun soucis sur ces distributions, étant donné que dans LMMS le matériel est reconnu...


Alors, quelques questions se posent...

Serait-il possible que le matériel ne soit reconnu que sous PC fixe ?

Serait-ce lié à un paquet manquant ? ou alors une insuffisance de courant au niveau de la batterie ?



J'espère que ça aidera...

Cordialement.

sub26nico utilisateur non connecté France
Si tu utilises Jack, il y a peut être un réglage du MIDI qui diffère.
Essayes de mettre ça dans un terminal et dis nous si ton clavier est reconnu ou non :
a2j -e


Ubuntu_Studio_User utilisateur non connecté
Salut sub26nico,

Merci pour ta réponse.

Non, je n'utilise pas Jack... (Enfin, pas encore)

Voici ce que me retourne le terminal :

hardware ports export
--- enable export of hardware ports
--- start
DBus exception: org.gna.home.a2jmidid.error.generic: a2j_start() failed.


Voilà, j'espère que ça aidera...

Cordialement.

Ubuntu_Studio_User utilisateur non connecté
Merci olinuxx.

sub26nico... J'ai refais un test avec la commande que tu m'as donnée.
a2j -e


ça me retourne ceci :
hardware ports export
--- enable export of hardware ports
--- start


C'est tout, le curseur est présent, et rien ne se passe en apparence...

sub26nico utilisateur non connecté France
Donc le retour de commande indique qu'Alsa Midi est bien lancé
avec l'export matériel.

Citation :
C'est tout, le curseur est présent, et rien ne se passe en apparence...

Là, je ne suis pas sûr de comprendre, que veux tu dire ?

Ubuntu_Studio_User utilisateur non connecté
Salut sub26nico,

je réponds à ta question...
Eh bien, après le curseur je n'ai pas le prompt (le $, c'est ça ?)

Par contre, j'ai des nouvelles...

J'ai fais un test sur Raspberry Pi, ça fonctionne avec LMMS sans problème.

J'ai effectué un test sur un PC (Windows) avec LMMS... Pas de problèmes non plus.

Sur ce même PC (Windows) j'ai lancé Ubuntu Studio en Live USB... Le clavier a été reconnu dans LMMS.

Je me suis donc dit que j'allais effectué le même test (Live USB), mais sur mon PC portable... Eh bien, surprise !!!

Il est reconnu dans LMMS ! :-)

Alors, je suis tenté de réinstaller afin de faire une installation complète, étant donné que j'avais fait une installation personnalisée...

Donc, à tout "hasard" y aurait-il un (ou des) paquet(s) qui résoudrait(aient) mon "souci" ? Ce qui m'éviterait de "réinstallation" complète... :-)

Cordialement.

Ubuntu_Studio_User utilisateur non connecté
Salut à tous !

Eh bien une "bonne" nouvelle...

ça y est j'arrive à faire fonctionner mon Akai !

J'ai malheureusement dû réinstaller.
Impossible de savoir l'origine du désagrément. Peut-être était-ce dû à mon installation personnalisée...

Au moins plus de doutes, ça fonctionne :-) (y)

Merci à ceux qui m'ont répondu.

A bientôt.

olinuxx utilisateur non connecté France
Super et merci pour le retour ici. Bonne musique à toi.

Note modération : le sujet étant résolu, merci d'ajouter un [RÉSOLU] (ou un [CONTOURNÉ], ou bien encore un [ABANDONNÉ]) dans le titre de ton premier message. Voir ce paragraphe du manuel du site pour davantage d'informations.



Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

calixtus06, 18:36, jeu. 22 Feb 2024: Bonjour et bienvenue à nikartri et rckloar :-)
calixtus06, 10:15, mer. 14 Feb 2024: Bonjour et bienvenue à smonff, Alphascorpii, tadumtss et letoII :-)
calixtus06, 11:14, lun. 12 Feb 2024: Bonjour et bienvenue à Lenaye, laiqh :-)
olinuxx, 20:32, mar. 06 Feb 2024: À l'ombre du poêle, bonne lecture de l'éditorial !
allany, 16:12, lun. 05 Feb 2024: Pas de trêve hivernale pour l'éditorial ! [Lien]
olinuxx, 22:47, sam. 03 Feb 2024: Bonjour et bienvenue à GTof cool
olinuxx, 20:25, jeu. 01 Feb 2024: Bonjour et bienvenue à krisden cool
calixtus06, 22:06, ven. 26 Jan 2024: bonjour et bienvenue à Darknours :-)
bluedid29, 19:34, mar. 23 Jan 2024: Meilleur voeux et grand merci Olinuxx, top distribution MAO LibraZiK :-)
pierrotlo, 15:20, sam. 20 Jan 2024: Meilleurs voeux à toute l'équipe. Je ne suis pas très présent parce qu'en préparation de ma retraite. Ça arrive à tout le monde, eh oui !
olinuxx, 11:22, jeu. 18 Jan 2024: [ANNONCE] LibraZiK-4 dispose à présent d'un live ! [Lien] cool
olinuxx, 11:21, jeu. 18 Jan 2024: Bonjour et bienvenue à thomasl cool