Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

6 - Le MIDI

> Forums de discussion > 6 - Le MIDI > [résolu] Initialisation des controleurs dans rosegarden 16.06
Dernier post

[résolu] Initialisation des controleurs dans rosegarden 16.06

ardoisebleue utilisateur non connecté France
J'utilisais Rosegarden version 12.04 avec Debian 7, je suis passé à Debian 9, avec Rosegarden 16.06.

J'ai un problème avec la réinitialisation des codes contrôles quand je joue un morceau.
exemple :
j'utilise le Code Contôle 7 (volume) sur une piste qui contient une série de notes. Au début le CC7 est initialisé à 53, en fin de piste, je termine par un abaissement du son en appliquant une suite de valeur, de 52 à 0.

Avec la version 16.06 :
La première fois que je joue le morceau jusqu'au bout tout va bien j'obtiens bien un "shunt", Si je replace le curseur de la grille au milieu de la piste, plus de son, le CC7 reste initialisé à 0.

Avec la version 12.04, il n'y avait pas ce problème car un paramètre d'exécution dans la configuration:
editer->configuration->MIDI->général->Emettre tous les contrôleurs Midi au début de chaque exécution
replaçait les CC à la valeur la plus proche de la position du curseur.

Avec la version 16.06 : étrangement, ce paramètre n'existe plus et il est remplacé par :
Editer->configuration->MIDI->général->autorise la réinitialisation de tous les contôleurs (CC121)
qui semble ne pas avoir ce même effet. A noter aussi que dans le standard MIDI le code 121 : Reset All Controllers, remet les contrôleurs à leur valeur de base (ex: code 10 (balance) sera remis à 63 (centre)).

J'ai pu constater que dans le fichier de configuration de la 12.04 : la variable "alwayssendcontrollers=true" disparaissait dans la version 16.06 et qu'elle est remplacée par "allowresetallcontrollers=true".

Dans les versions intermédiaire y-a-t-il eu observation de ce problème et résolution ?

J'ai écumé le site rosegarden de sourceforce.net mais il n'y a pas de post sur ce problème.

Avant que je n'envoie un mail à l'équipe de Rosegarden, quelqu'un a-t-il un avis sur ce souci ou une solution ?

ardoisebleue utilisateur non connecté France
J'ai téléchargé et compilé la version Rosegarden 16.02 elle ne contient pas le bug.

olinuxx utilisateur non connecté France
Joli dégottage de bogue !
Bien vu et bien joué ardoisebleue wink

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 12:35, sam. 28 Nov 2020: Nouvelles du mois de novembre pour LibraZiK : [Lien]
olinuxx, 12:34, sam. 28 Nov 2020: Bonjour et bienvenue à diogene et à klopkloc cool
olinuxx, 19:45, mer. 25 Nov 2020: Bonjour et bienvenue à endymion93 cool
calixtus06, 07:13, mar. 24 Nov 2020: Bonjour et bienvenue à Noxanera ! :-)
sub26nico, 10:40, lun. 23 Nov 2020: Ardour 6.5 est disponible, le bogue d'export a été corrigé
Houston4444, 20:35, dim. 22 Nov 2020: Ardour 6.4 a de serieux soucis selon robin gareus lui-même. Attendez la 6.5 !
sub26nico, 18:00, dim. 22 Nov 2020: Ardour 6.4 est disponible :[Lien]
olinuxx, 14:48, dim. 22 Nov 2020: Bonjour et bienvenue à ykrons cool
olinuxx, 14:47, dim. 22 Nov 2020: @diigitae : [Lien]
diigitae, 02:54, dim. 22 Nov 2020: comment faire pour cloturer mon compte de linuxmao diigitae
olinuxx, 11:40, sam. 21 Nov 2020: LibraZiK-3 dispose à présent d'un live ! [Lien]
Sahaathyva, 20:42, jeu. 19 Nov 2020: Hey!