Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

4 - Toutes les autres applications, les émulateurs...

> Forums de discussion > 4 - Toutes les autres applications, les émulateurs... > Compilation d'aubio 0.3.2 : erreur au « make »
Dernier post

Compilation d'aubio 0.3.2 : erreur au « make »

Ejis Articles : 165 utilisateur non connecté
Salut,

Ardour 2.5 vient de sortir, et j'aimerais le compiler. Je suis sous Zenwalk, distribution basée sur Slackware.
J'ai cherché des .tgz de la librairie aubio demandée par le nouvel Ardour, mais il n'y a que la version 0.3.1.
J'aimerais donc compiler aubio 0.3.2.
La configuration se passe bien, mais au make, j'ai une erreur :

Citation :
make1: entrant dans le répertoire « /home/aymeric/InstallLogiciels/MAO/Ardour/aubio-0.3.2/aubio-0.3.2/ext »
if /bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../src -I../src -Wall -Wextra -I/usr/local/include -I/usr/include/alsa -g -O2 -MT midi_alsa_seq.lo -MD -MP -MF ".deps/midi_alsa_seq.Tpo" -c -o midi_alsa_seq.lo `test -f 'midi/midi_alsa_seq.c' || echo './'`midi/midi_alsa_seq.c; \
then mv -f ".deps/midi_alsa_seq.Tpo" ".deps/midi_alsa_seq.Plo"; else rm -f ".deps/midi_alsa_seq.Tpo"; exit 1; fi
gcc -DHAVE_CONFIG_H -I. -I. -I../src -I../src -Wall -Wextra -I/usr/local/include -I/usr/include/alsa -g -O2 -MT midi_alsa_seq.lo -MD -MP -MF .deps/midi_alsa_seq.Tpo -c midi/midi_alsa_seq.c -fPIC -DPIC -o .libs/midi_alsa_seq.o
In file included from /usr/include/bits/errno.h:25,
from /usr/include/errno.h:36,
from /usr/include/alsa/asoundlib.h:39,
from midi/midi_alsa_seq.c:37:
/usr/include/linux/errno.h:4:23: error: asm/errno.h: No such file or directory
midi/midi_alsa_seq.c: In function 'aubio_alsa_seq_run':
midi/midi_alsa_seq.c:345: error: 'EAGAIN' undeclared (first use in this function)
midi/midi_alsa_seq.c:345: error: (Each undeclared identifier is reported only once
midi/midi_alsa_seq.c:345: error: for each function it appears in.)
make1: *** midi_alsa_seq.lo Erreur 1
make1: quittant le répertoire « /home/aymeric/InstallLogiciels/MAO/Ardour/aubio-0.3.2/aubio-0.3.2/ext »
make: *** all-recursive Erreur 1


Pourriez-vous me dire comment régler ce problème ?

Merci d'avance.

Ejis Articles : 165 utilisateur non connecté
Problème résolu : y'a un .tgz  ...

Désolé du dérangement.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 13:05, lun. 02 Aug 2021: @CyrilRos, ton lien ci-bas ne fonctionne pas
CyrilRos, 22:59, dim. 01 Aug 2021: Tux|N|Mix 21.1 disponible [Lien]
sub26nico, 14:33, dim. 01 Aug 2021: Salut et bienvenue à Youplala, Cant' et Bluetak :-)
CyrilRos, 21:45, mar. 27 Jul 2021: [Lien]
olinuxx, 20:54, mar. 27 Jul 2021: Bonjour et bienvenue à nick cool
olinuxx, 20:47, dim. 25 Jul 2021: Bonjour et bienvenue à GrosRems et à paulisaak cool
olinuxx, 20:05, jeu. 22 Jul 2021: Bonjour et bienvenue à labeyte07 cool
olinuxx, 21:03, mar. 20 Jul 2021: Bonjour et bienvenue à tv cool
Nolwen, 19:33, lun. 19 Jul 2021: Hola,À propos de la création de pattern (motifs) MIDI pour batterie, quelqu'un sait-il où en est la discussion ?
olinuxx, 01:28, lun. 19 Jul 2021: Lolo-Rosso : l'adresse courriel que tu as renseignée lors de ton inscription n'est pas fonctionnelle. Contacte moi pour corriger le soucis : [Lien]
calixtus06, 18:07, ven. 16 Jul 2021: Bonjour et bienvenue à titicplusplus :-)
calixtus06, 11:35, ven. 16 Jul 2021: Bonjour et bienvenue à toi lablonde ! :-)