Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

Genpo (GENeral Purpose Organ) est une console d'orgue virtuelle : une interface graphique pour faciliter l'utilisation de synthétiseurs logiciels, en particulier les émulateurs d'orgue.

Genpo : cliquez pour agrandir
Genpo : cliquez pour agrandir






Informations


Site web officiel : http://genpo.sourceforge.net/ Image .
Version actuelle : 0.9.8 du 2008 11 26.
Licence : GNU GPL v3.
Support : Alsa.
Développeur : S.Merrony.


Installation


Genpo nécessite :
  • le noyau Linux - au moins version 2.4
  • les bibliothèques QT - au moins la version 3 (KDE n'est pas requis)
  • ALSA - au moins la version 0.9

L'installation proprement dite se fait par :
tar xzvf genpo-0.9.6.tar.gz
cd genpo-0.9.6
./build.sh




Description


Genpo : GENeral Purpose Organ.

Ce logiciel joue le rôle de la console de l'orgue, et uniquement cela. Il faut le coupler à fluidsynth par exemple pour que l'on obtienne un instrument, et du son.
À l'entrée du logiciel se trouve(nt) le ou les claviers midi, et en sortie se trouvent les mêmes informations transmises par les claviers midi, + les informations des instruments utilisés. Tout ceci est envoyé à un synthétiseur.

Pour la définition des instruments, il faut au préalable connaître la bibliothèque utilisée. Dans un banque de son contenant des jeux d'orgues, nous pouvons avoir 15 jeux facilement (flûtes, trompettes, quintes, tierces, plein jeu ...). Après cette étape un fichier .org est à éditer, il contient :
- la définition de l'interface, la disposition des boutons, leur nombre ... (exemple de bouton : "plein jeu")
- la banque et l'instrument se rapportant à chaque bouton
- le clavier qui est en relation avec ce bouton (un petit orgue contient classiquement 2 claviers et un pédalier)
Un exemple ici : http://genpo.sourceforge.net/userGuide.shtml
Ce fichier est chargé par Genpo ; c'est d'ailleurs la seule option possible lorsque le logiciel s'ouvre.

L'utilisation est ensuite la suivante :
Après avoir connecté les claviers midi à Genpo (via Jack), puis Genpo à Fluidsynth, et Fluidsynth aux haut-parleurs, le musicien choisi les jeux à utiliser pour chaque clavier en utilisant les boutons précédemment configurés.

PS : rien n'empêche d'utiliser ce logiciel pour des instruments autres que des orgues. Le clavecin contenant 2 claviers, avec la possibilité de les accoupler, est également concerné.

Compatibilité avec Fluidsynth


La dernière version de fluidsynth (1.1.1-2) n'est pas entièrement compatible, et les différentes banques ne sont pas correctement reconnues. Pour remédier à ce problème, il est nécessaire de revenir à la version 1.0.8-1.1.
Paquets deb ici et  .
Pour ne pas que ces paquets soient mis à jour, ajouter ces lignes dans /etc/apt/preferences (créer éventuellement le fichier) :
Package: libfluidsynth1
Pin: version 1.0.8-1.1
Pin-priority: 1001

Package: fluidsynth
Pin: version 1.0.8-1.1
Pin-priority: 1001


Liens



Logiciels similaires :
? Doc > Le live > Les orgues virtuels
? Portail des Logiciels > Synthétiseurs


Collaborateur(s) de cette page : olinuxx , pianolivier , utilisateur_anonyme et Mezzo .
Page dernièrement modifiée le Mercredi 26 décembre 2018 20:29:21 par olinuxx.
Le contenu de cette page est licencié sous les termes licence.

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

Sahaathyva, 23:49, lun. 25 mai 2020: ok pour la 1.3 , celle qui est censée supporter l'audio ;) @r1: lmms est mis de coté pour ma part à l'heure actuelle. là j'essaie d'aider Alex pour ZRythm mais dans la mesure de mes simples compétences
r1, 22:47, lun. 25 mai 2020: @Sahaathyva : Pour accélérer le mouvement, tu peux aussi participer au développement de lmms ! :-)
r1, 22:45, lun. 25 mai 2020: Excellente nouvelle pour lmms ! Et pour Ardour aussi d'ailleurs :-D
sub26nico, 21:21, lun. 25 mai 2020: ardour.org semble être redevenu fonctionnel, mais pas encore le forum
ycollet, 20:44, lun. 25 mai 2020: Aucune idée ... J'imagine plutôt une 1.3.0
Sahaathyva, 18:01, lun. 25 mai 2020: Desole pour les fautes de frappe je hais les claviers tactiles. Sinon ycollet c est annonce pour la 1.2.2 les lv2?
Sahaathyva, 15:40, lun. 25 mai 2020: C est possible sue le srv deconne leur forumme fait des blagues. Sinonycollet tres bonne nouvelle pout lmms il est quand meme temps pour un soft parti de linux de travailler avec des greffons linux natifs autres que ladspa
ycollet, 14:48, lun. 25 mai 2020: Le support LV2 vient d'être mergé dans la branche master de LMMS ...
Samuel, 13:57, lun. 25 mai 2020: @minimoineau. Ouais, c'est fatiguant, le serveur ne doit probablement pas bien tenir la charge en téléchargement
minimoineau, 13:14, lun. 25 mai 2020: Aaarf! Le site d'Ardour déconne... Hâte de l'essayer!
Sahaathyva, 23:54, dim. 24 mai 2020: Hello! Ardour 6 vient d'être laché dans la nature!!! [Lien]
olinuxx, 16:13, dim. 24 mai 2020: Bonjour et bienvenue à Becane cool