Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Le site : philosophie, organisation, problèmes...

Dernier post

Https

Armageddon utilisateur non connecté France
Hello !

Firefox va bientôt intégrer une option "https only" .. et de toute façon, il est recommandé d'utiliser le chiffrement.

Est-il envisagé de passer le site en https ?

olinuxx utilisateur non connecté France
Modéro forum : ce fil de discussion a été ouvert dans la section "''La documentation et les nouvelles de LinuxMAO'" du forum, ce qui n'est pas la bonne section du forum pour ce genre de question.

En tant que modéro des forums, je l'ai déplacé ici.


Réponse courte : c'est envisagé oui. Pour quand ? Aucune idée, à priori, puisqu'il n'y a que moi qui m'occupe de ce genre de choses depuis des années, la réponse la plus honnête à faire ici est : "quand j'aurai de la motivation et du temps pour ça, et que je m'y collerai". Probablement lors d'une prochaine mise à jour du CMS.

Armageddon utilisateur non connecté France
Ah, toutes mes confuses, pour le mauvais emplacement.. j'ai cherché un peu, et voyant qu'on pouvait y parler du site, je me suis dit que l'aspect technique pouvait coller :-)

Sans vouloir t'embêter, si tu veux un coup de main sur le sujet, tu me dis :-)

olinuxx utilisateur non connecté France
Si tu souhaites et à les capacités d'aider à cela, alors tu peux probablement installer la même version de Tiki que celle qui tourne actuellement ici (une 12.10) et regarder comment régler le https.

Si quelqu'un peut faire la recherche dans la documentation de Tiki, tester sur un Tiki de test, et me donner une méthode pas à pas, alors ça aiderait à accélérer le mouvement.

Pour info, j'ai déjà essayé plusieurs fois, lu des pages de doc de Tiki, essayé d'appliquer des choses, mais n'y suis pas parvenu.

Armageddon utilisateur non connecté France
Il semblerait que le https soit déjà là, en fait, et réponde normalement. (j'ai vu ça en paramétrant le "https only" dans la dernière version de firefox)

Par contre, la redirection http -> https, elle, ne se fait pas.

Et pour moi, c'est au niveau du serveur http que ça se joue, pas au niveau du CMS.

Armageddon utilisateur non connecté France
Pour info :

Image

olinuxx utilisateur non connecté France
L'identification sur le site ne fonctionne qu'en http.

rainbowalice utilisateur non connecté
Le https ca s'installe au niveau du serveur web, pas au niveau du CMS.

De nos jour il est tres facile d'obtenir un certificat HTTPS grace au project Let's Encrypt qui offre des certificats gratuit et simple d'utilisation : https://letsencrypt.org/

Ici il y a une list de web hosts qui offre un support pour Let's Encrypt:

https://community.letsencrypt.org/t/web-hosting-who-support-lets-encrypt/6920

Tu peut vérifier si ton host est sur cette liste, et dans ce cas je suppose qu'il y aura une option pour installer un certificat dans le paneau de controle.

Si n'il y a pas d'option dans le paneau de controle, c'est assez simple d'utiliser Let's Encrypt si tu as access SSH a ton serveur.

Si tu a access SSH, les étapes a suivre vont dépendre de:

1. La distribution Linux qui est utilisée (Debian, CentOS, etc.) ;
2. Le serveur web qui est utilisé (Apache, Nginx).

Si tu a cette information, je peut envoyer des instructions !

Si ton web hosts n'a pas Let's Encrypt dans le paneau de controle, et que tu n'as pas access SSH a ton serveur ... euh, alors il faudra que tu demande a ton host de le faire pour toi.

:-)
Alice

jujudusud utilisateur non connecté France
Bonjour tout le monde,

On en est où de cette problématique ?

il y a des doublons de ce sujet et les discussions sont centralisées ici apparemment : forumthread91888

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 09:25, mar. 15 Jun 2021: Bonjour et bienvenue à Hexaal :-)
Ubuntu_Studio_User, 02:29, lun. 14 Jun 2021: Salut à tous...
allany, 12:12, sam. 12 Jun 2021: @tourneriff : merci pour le signalement, c'est fait !
tourneriff, 07:52, sam. 12 Jun 2021: Bonjour à tous ☺ ! Avis aux modos : pourrait-on voir la "joute 16" en cours à l'accueil du site plutôt que l'antique "joute 15"
sub26nico, 14:56, jeu. 10 Jun 2021: Salut et bienvenue à jamesonmount, freerawsound et Loop :-)
ycollet, 10:28, mer. 09 Jun 2021: Cool, un revival de rakarrak ! [Lien]
sub26nico, 22:08, lun. 07 Jun 2021: Bonjour et bienvenue à ArchLinux59, Djobi et gakgakgak :-)
olof, 09:27, lun. 07 Jun 2021: ardour 6.7 build tourne chez moi, mais pas le package 6.6
allany, 14:46, dim. 06 Jun 2021: @r1 : t'as raison : trop c'est trop, ça sature du goulot !
r1, 22:54, sam. 05 Jun 2021: Mon cerveau a bobo à force de faire le gogo sur l'annonce de l'édito !
allany, 11:49, sam. 05 Jun 2021: Z'ont encore abattu un sacré boulot, les poulbots de l'édito ! [Lien]
ycollet, 20:37, ven. 04 Jun 2021: Un article intéressant sur un truc à venir sur USB audio: [Lien]