Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

> Forums de discussion > 5 - Les serveurs son : Jack, PulseAudio et autres... > Reaper - Jack /ubuntu studio 20.04 + Focusrite 2i4 [RESOLU]
Dernier post

Reaper - Jack /ubuntu studio 20.04 + Focusrite 2i4 [RESOLU]

kmchen utilisateur non connecté
Bonjour

Sous ubuntu 20.04 studio + Reaper fonctionne bien avec pulseaudio mais latence monitoring...j'essaie donc jack

Je lance qjackd, démarre Jack
Dans Reaper je définis Jack comme Audio system

J'ai bien le son de la focusrite en entrée de REaper mais sa sortie audio va sur la carte son interne du portable.
Par contre firefox sort bien sur la focusrite...

Voici copie écran des réglages que j'ai (par défaut).
Image
J'ai à peu près tout tripoté sans succés
Notamment le kit de connexion jack propose la scarlet 2i4 usb (la focusrite) dans les interfaces mais ça change rien.

Autre anomalie: que j'arrête ou démarre le Jack audio connexion kit rien ne change, tout continuer à fonctionner comme avant sans interruption (Firefox vers la focusrite et Reaper vers l'audio interne)

kmchen utilisateur non connecté
Débrancher / rebrancher le cable usb a fait apparaitre les 4 sorties de la focusrite dans jackD

et le son fut !

...au bout de 4h de tripotages
rolleyes

piratebab utilisateur non connecté
pense à passer le sujet en résolu, je viens de te répondre sur IRC!

kmchen utilisateur non connecté
J'ajoute que le message IRC m'a dirigé vers la table de routage qui permet effectivement de controller très précisément les entrées et sorties de Reaper.
On peut ainsi choisir les entrées sorties des différentes cartes son présentes. Je peux maintenant sortir à la fois sur la focusrite et l'ordi ou l'un des deux. Même chose pour les prises de son.
Vu que ça a tendence à se mettre en place tout seul j'avais oublié l'existence de cette matrice.

MAIS
Tous ces bo réglages ne sont accessible que si la carte son apparait dans la fameuse matrice...chez moi elle apparait (ou pas) comme usb0,0 outplayba. Faut comprendre que c'est la scarlett 2i4.
Et pour ça faut que jack soit lancé avant reaper et si la scarlett usb n'est pas vue par Jack il faut débrancher/rebrancher le câble USB.

Donc :
1/ lancer jack
2/ débrancher/rebrancher la carte son /USB
3/ lancer Reaper

Si jack plante faut tout arrêter et recommencer depuis le début.

Si vous n'avez pas d'impératifs de latence inutile de s'embarrasser avec tout ce micmac. Pulseaudio fait tout marcher de manière automatique.

Si quelqu'un sait comment faire découvrir la carte son USB à Jack quand elle est déjà branchée je suis preneur ! eek

piratebab utilisateur non connecté
c'st curieux ton truc. Fait le test suivant.
tu éteins la machine et tu branches la carte externe
tu démarre l'ordi.
Et avant de faire quoique ce soit, tu ouvres un terminal et tu tapes
$ cat /proc/asound/cards


Et pour mieux retrouver tes entrées sorties:
QJackctl - renommer les ports

kmchen utilisateur non connecté
Curieux ? Depuis 20 ans que j'utilise Linux sur des machines différentes je n'ai jamais vu le système son marcher correctement. Je pense que c'est lié à l'architecture même du système qui rend difficiles les échanges entre les process. Ici, entre tous les projets indépendants Reaper, Firefox, Alsa, Pulseaudio et jack, sans parler des drivers c'est très complexe.
La sortie demandée:

~$ cat /proc/asound/cards 
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0x67710000 irq 151
 1 [USB            ]: USB-Audio - Scarlett 2i4 USB
                      Focusrite Scarlett 2i4 USB at usb-0000:00:14.0-4, high speed


Les deux cartes sont toujours visibles à la sortie du boot. C'est après un suspend/resume ou arrêt de jack que ça se complique.

piratebab utilisateur non connecté
Est-ce que tu as essayé une règle udev pour figer la façon donc la carte est reconnue ?
Je n'utilise pas de suspend, et j'ai aussi des choses bizarre lorsque j'arrête et je redémarre jack, en particulier pulseaudio-sink
Je suis d'accord avec toi, le son sous linux , c'est complexe, un vrai mille feuille.
Mais sous windows ce n'est pas mieux, pour le temps réel, ça aussi un peu bricolo. C'est pour ça que beaucoup passent sur Apple, mais je ne connais pas leur système de son

olinuxx utilisateur non connecté France
@kmchen :

Note modération : merci d'utiliser la balise CODE lorsque tu copies/colles du code sur le site. Celles-ci permettent un meilleur affichage.
Image
Voir également cette page.


kmchen utilisateur non connecté
piratebab écrit :
règle udev pour figer la façon donc la carte est reconnue

Pourrais tu me renvoyer vers de la doc simple à ce sujet ?

kmchen utilisateur non connecté
Merci.

J'ai regardé la première doc. Ca commence mal. Pas de date de dernière modification et la première commande donnée n'existe plus sous UBUNTU 20.04:
~$ sudo ls /etc/init.d/alsasound
ls: impossible d'accéder à '/etc/init.d/alsasound': Aucun fichier ou dossier de ce type
~$


Les docs périmées sont un des premiers problèmes de Linux.

Si la première commande est fausse, que vaut le reste ? Je n'ai pas eu envie de continuer. Je passe à la 2eme doc

kmchen utilisateur non connecté
Même chose pour l'autre doc qui vient du même site.

Alsa opensrc Org écrit :
if you use a 2.4 kernel or can't use udev


Sous Ubuntu 20.04 on en est au kernel 5.4 ! init.d n'est plus utilisé au profit de systemd, ...

Le dernier commentaire que j'ai vu sur ce site date de 2013...

Il ressort du survol de lecture que j'ai fait que beaucoup est basé sur le nommage des interfaces USB qui de fait est dynamique. Peut-on poser que si la même carte est toujours branchée sur le même port USB son nom reste stable et ainsi s'éviter toute cette histoire sur les noms de devices ?

Moi ça ne me pose pas de problème de brancher ma carte toujours sur le même port. Mon problème est quand je suspend/resume mon ordi il retrouve ses cartes qui ne sont pas supposées avoir bougé.

piratebab utilisateur non connecté
En théorie, tu ne retrouves pas forcément les mêmes noms, dans la pratique, tu as la carte interne en hw0, et l'externe en hw1. Si tu as plusieurs cartes en USB, rien ne te garantit que tu les auras dans le même ordre. Mais comme expliqué dans la doc, il y a 2 niveaux de nommage;
- udev avec les devices dans /dev
- ALSA qui renomme les cartes en hw0, hw1 ..

Je ne pense pas que le suspend relance tout le cycle, il doit se contenter de reprendre l'ancienne config.
Perso j'ai renoncé au suspend (en RAM) et hybernate (sur disque), je n'ai eu que des problèmes.
Je me contente des options d'économie d'énergie agressives.,

olinuxx utilisateur non connecté France
kmchen écrit :
Les docs périmées sont un des premiers problèmes de Linux.

Si la première commande est fausse, que vaut le reste ? Je n'ai pas eu envie de continuer. Je passe à la 2eme doc


Ça n'est pas un problème spécial à linux, c'est la même chose pour tout le ouèbe en général, et c'est la même chose également avec des docs en version papier. C'est au lecteur des documentations d'avoir un peu de jugeote et d'essayer de savoir qui a écrit la doc ? pourquoi l'a t'il écrit ? quand l'a t'il écrit ? etc.

piratebab utilisateur non connecté
Alsa opensrc est un site de doc non officiel sur ALSA, trés complet. Sur le site d'ALSA, c'est beaucoup moins bien fourni.
Comme le dit olinuxx, même si ce n'est pas applicable via un copié collé de commandes, ça ne veux pas dire que tu ny trouveras pas des infos qui vont te mettre sur une piste.
La seule chose à jour, c'est la commande man (et encore, il y a parfois des erreurs)

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 09:25, mar. 15 Jun 2021: Bonjour et bienvenue à Hexaal :-)
Ubuntu_Studio_User, 02:29, lun. 14 Jun 2021: Salut à tous...
allany, 12:12, sam. 12 Jun 2021: @tourneriff : merci pour le signalement, c'est fait !
tourneriff, 07:52, sam. 12 Jun 2021: Bonjour à tous ☺ ! Avis aux modos : pourrait-on voir la "joute 16" en cours à l'accueil du site plutôt que l'antique "joute 15"
sub26nico, 14:56, jeu. 10 Jun 2021: Salut et bienvenue à jamesonmount, freerawsound et Loop :-)
ycollet, 10:28, mer. 09 Jun 2021: Cool, un revival de rakarrak ! [Lien]
sub26nico, 22:08, lun. 07 Jun 2021: Bonjour et bienvenue à ArchLinux59, Djobi et gakgakgak :-)
olof, 09:27, lun. 07 Jun 2021: ardour 6.7 build tourne chez moi, mais pas le package 6.6
allany, 14:46, dim. 06 Jun 2021: @r1 : t'as raison : trop c'est trop, ça sature du goulot !
r1, 22:54, sam. 05 Jun 2021: Mon cerveau a bobo à force de faire le gogo sur l'annonce de l'édito !
allany, 11:49, sam. 05 Jun 2021: Z'ont encore abattu un sacré boulot, les poulbots de l'édito ! [Lien]
ycollet, 20:37, ven. 04 Jun 2021: Un article intéressant sur un truc à venir sur USB audio: [Lien]