Forum : 5 - Les serveurs son : Jack, PulseAudio et autres...

Jack: surcharge anormale du serveur

odelaeid utilisateur non connecté
Bonjour,
j'expose ici un probleme rencontré dans une configuration Jack/Ardour/Jamin sur Ubuntu Studio 8.04.1 avec Ardour 2.5 (mais c'était pareil en 2.4, je viens d'installer la dernière version pour voir si ca changeait qqchose), je précise que je suis dans le cas où le CPU n'est pas surchargé, j'ai une carte Edirol FA-66.

Je lance Jack avec les paramétrages habituels (ceux décrits sur ce même site sur la page de la FA-66/freebob).

Lorsque je lance Jamin, l'occupation de Jack passe directement à 26%. Lorsque je lance Ardour, il passe à 99% (projet avec une dizaine de piste et qq plugins sur chaque piste). Je précise que les fonctions "flushtoZero" activées ou désactivées ne changent rien.

Je ne détaille pas mon Hardware ici puisqu'il ne s'agit manifestement pas d'un pb hardware:
-mes 2 CPU sont à 80% chacun avec Jack/ardour/jamin de lancé, sachant qu'auparavant ils montaient facilement à 100% (j'avais un pb de plugin).

Je précise que limits.conf est paramétré de la sorte, et que j'apartiens bien au groupe "audio":

@audio - rtprio 99
@audio - memlock unlimited
@audio - nice -10

J'ai essayé en changeant les frames/period sous Jack, mais ca ne change rien.

Auriez vous des idées sur la cause possible de mon pb ?

Merci

odelaeid utilisateur non connecté
J'ai trouvé l'origine de mon problème: j'avais mis le timeout à 2000 pour évoiter les plantages de jack avec ardour. je l'ai remis à 500 du coup ma charge sur Jack est redescendue à 26%.