Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > Demande d'aide pour paramétrer Motu Ultralite mk4 avec audacity bitwig musescore
Dernier post

Demande d'aide pour paramétrer Motu Ultralite mk4 avec audacity bitwig musescore

jeronath utilisateur non connecté France
Hello,

Nouveau membre, voir ma présentation dans le forum dédié et je continue ici pour exposer mon problème.
Voilà c'est simple j'ai besoin d'utiliser une carte Motu ultralite mk4 class compliant avec Bitwig ou avec audacity ou avec musescore et peut-être d'autres softs comme pure data ensuite et je n'arrive pas à faire fonctionner alsa avec jack, jack avec x ou y, etc...
J'aurais besoin d'une feuille de route simple pour configurer une chose après l'autre sans me mélanger complétement les pinceaux et m'arracher les cheveux... j'en ai déjà plus trop...

Impossible de faire fonctionner audacity avec la carte, avec bitwig çà fait les sons mais pas possible d'enregistrer... Je suis sur xps13 9360 avec xubuntu 18.04 et des adaptations ubuntu studio noyau low-latency.

Merci d'avance de l'aide précieuse que les balaises en mas linux ici présents pourront m'apporter.
Je sais et autour de moi on me dit reprend un mac ou un windows et je reponds "à Dieu ne plaise !" je suis en résistance par rapport à tout ce développement odieux d'un internet marchand qui ne respecte plus rien.
Exemple j'ai passé mon android sous graphene os mais c'est franchement moins compliqué que linux et la mao !!

Amitiés

minimoineau utilisateur non connecté
Salut jeronath!

Je ne suis pas familier avec l'Ultralite, mais la mk4 semble poser des problèmes avec les pilotes alsa d'après ce que j'ai pu lire ici et  ...

Sais-tu si tu utilises le même firmware que dans ce dernier lien?

bda utilisateur non connecté France
Bonjour,
Trois premières choses, pour commencer en douceur. Dans un terminal, tape les commandes suivantes et fais nous un copié-collé ici (dans une balise code pour la lisibilité):
aplay -l
arecord -l

Ensuite, lance alsamixer (toujours dans le terminal), puis choisi ta carte son avec F6, ensuite F5 (pour afficher les entrées ET les sorties). Fais nous une capture d'écran.

PS: la MAO sou Linux peut être assez facile si on a les bons outils, à commencer par la distribution.

jeronath utilisateur non connecté France
Bonsoir,

Merci à minimoineau et bda pour votre réactivité !

Pour bda :

aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: PCH [HDA Intel PCH], périphérique 0: ALC3246 Analog [ALC3246 Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 7: HDMI 1 [HDMI 1]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 8: HDMI 2 [HDMI 2]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 9: HDMI 3 [HDMI 3]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 10: HDMI 4 [HDMI 4]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: Loopback [Loopback], périphérique 0: Loopback PCM [Loopback PCM]
  Sous-périphériques: 8/8
  Sous-périphérique #0: subdevice #0
  Sous-périphérique #1: subdevice #1
  Sous-périphérique #2: subdevice #2
  Sous-périphérique #3: subdevice #3
  Sous-périphérique #4: subdevice #4
  Sous-périphérique #5: subdevice #5
  Sous-périphérique #6: subdevice #6
  Sous-périphérique #7: subdevice #7
carte 1: Loopback [Loopback], périphérique 1: Loopback PCM [Loopback PCM]
  Sous-périphériques: 8/8
  Sous-périphérique #0: subdevice #0
  Sous-périphérique #1: subdevice #1
  Sous-périphérique #2: subdevice #2
  Sous-périphérique #3: subdevice #3
  Sous-périphérique #4: subdevice #4
  Sous-périphérique #5: subdevice #5
  Sous-périphérique #6: subdevice #6
  Sous-périphérique #7: subdevice #7
carte 2: UltraLitemk4 [UltraLite-mk4], périphérique 0: USB Audio [USB Audio]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0


arecord -l
**** Liste des Périphériques Matériels CAPTURE ****
carte 0: PCH [HDA Intel PCH], périphérique 0: ALC3246 Analog [ALC3246 Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: Loopback [Loopback], périphérique 0: Loopback PCM [Loopback PCM]
  Sous-périphériques: 8/8
  Sous-périphérique #0: subdevice #0
  Sous-périphérique #1: subdevice #1
  Sous-périphérique #2: subdevice #2
  Sous-périphérique #3: subdevice #3
  Sous-périphérique #4: subdevice #4
  Sous-périphérique #5: subdevice #5
  Sous-périphérique #6: subdevice #6
  Sous-périphérique #7: subdevice #7
carte 1: Loopback [Loopback], périphérique 1: Loopback PCM [Loopback PCM]
  Sous-périphériques: 8/8
  Sous-périphérique #0: subdevice #0
  Sous-périphérique #1: subdevice #1
  Sous-périphérique #2: subdevice #2
  Sous-périphérique #3: subdevice #3
  Sous-périphérique #4: subdevice #4
  Sous-périphérique #5: subdevice #5
  Sous-périphérique #6: subdevice #6
  Sous-périphérique #7: subdevice #7
carte 2: UltraLitemk4 [UltraLite-mk4], périphérique 0: USB Audio [USB Audio]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0


Pour alsamixer F6 l'affiche et me donne le choix de la motu que je choisis avec F5 et çà m'affiche "ce périphérique n'a pas de commandes".

Pour minimoineau : je vais chercher comment trouver quelle version du firmware il y a sur mon exemplaire... ça ne présage rien de bon...

bda utilisateur non connecté France
Pourquoi est-ce qu'il y a une pseudo carte "loopback" ?
Dans un premier temps, il serait judicieux de la désactiver. Soit avec:
sudo rmmod snd-aloop

Soit la désactiver au démarrage en créant un fichier:
sudo nano /etc/modprobe.d/alsa.conf
blacklist snd_aloop

Puis CTRL+o pour sauvegarer et CTRL+x pour quitter. Redémarrer le PC.

Ensuite il faut peut être configurer pulseaudio pour choisir l'interface motu et essayer les applications habituelles (genre lecteur de musique, vidéo, navigateur, ...).

jeronath utilisateur non connecté France
Bon j'ai fait la manipulation et j'ai réglé dans controle de pulseaudio le peripherique d'entree et sortie sur la motu. C'est reconnu par un playback dans le navigateur, dans vlc avec un fichier audio mais le son crache, apparait, disparait alors que le vu-metre se comporte normalement dans pulseaudio mais dans audacity il ne trouve que alsa ou oss.

bda utilisateur non connecté France
Aïe! J'ai bien peur que tu sois face au problème cité par minimoineau. Mais il y a peut être une solution.
Malheureusement tu devras faire la mise à jour de la carte depuis un PC/Mac mais ça vaut le coup d'essayer.
ici  Image tu peux trouver les mises à jour. La dernière, 1.3.5+241, corrige un problème avec les PC équipés du chipset Intel x99. Apparemment celui de ton PC.

Tiens nous au courant car si ça fonctionne, il faudra l'ajouter dans le wiki.

jeronath utilisateur non connecté France
En connectant la Motu sur un usb classique et non usb-c comme je l'avais fait avant çà marche mieux.
Mais de manière aléatoire au bout de quelques minutes les fréquences basses disparaissent et le son devient distordu, je dois arrêter le serveur jack avec qjackCtl et le redémarrer pour retrouver le son. Il doit donc y avoir un réglage à faire par là ?
Sinon côté firmware c'est déjà la version 1.3.5+241.

bda utilisateur non connecté France
J'ai bien peur qu'il n'y ait pas de solution. Seul Motu peut résoudre ça.
Peut être un dernier espoir, essayer les anciens firmwares si c'est possible. Ou peut être sur un port USB 2.0.

jeronath utilisateur non connecté France
En fait si j'arrête jack et que j'utilise uniquement pulseaudio en configuration sortie ultralite multicanal (c'est ce qu'il trouve) et audio interne éteint pour écouter sur bandcamp ou visualiser video sur youtube ou fichiers audio ou video sur l'ordi le son reste parfait.
Dans ce cas Audacity est sur alsa et je n'ai pas de son même en réglant pulseaudio avec motu et audio interne actifs.
Si je démarre jackd j'ai un jack sink qui se rajoute dans pulseaudio et j'ai le playback dans audacity si je choisis pulse en sortie mais toujours impossible d'enregistrer et si j'essaie de choisir la motu en enregistrement tout se bloque...

bda utilisateur non connecté France
Pulseaudio vient en surcouche d'Alsa et en prend le contrôle. Jack aussi. Ils sont antagonistes. jack-sink fait office de pont entre les deux.
Donc il faut bien configurer la sortie "jack-sink" dans pulseaudio.
Dans audacity, il faut le régler sur jack et non pulseaudio ou alsa. Comme pour toutes applications MAO, il faut privilégier jack.

Pour plus de détail je te renvoi vers les pages PulseAudio et pulseaudio vers jack. Perso je n'ai pratiquement jamais utilisé pulseaudio donc si c'est lui qui pose problème, je passe la main.

jeronath utilisateur non connecté France
J'avance tout doucement. Je suis allé voir plus dans le détail Jack. Après lecture j'ai tenté de démarrer le serveur jack après avoir fait pulseaudio --kill. Ci-dessous la ligne de commande avec le résultat :

jackd -Rd alsa -d hw:1 -r 48000 -p 1024 -n 3
jackdmp 1.9.12
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2016 Grame.
Copyright 2016-2017 Filipe Coelho.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
no message buffer overruns
no message buffer overruns
no message buffer overruns
JACK server starting in realtime mode with priority 10
self-connect-mode is "Don't restrict self connect requests"
audio_reservation_init
Acquire audio card Audio1
creating alsa driver ... hw:1|hw:1|1024|3|48000|0|0|nomon|swmeter|-|32bit
configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 3 periods
ALSA: final selected sample format for capture: 24bit little-endian in 3bytes format
ALSA: use 3 periods for capture
ALSA: cannot set hardware parameters for capture
ALSA: cannot configure capture channel
Released audio card Audio1
audio_reservation_finish
Cannot initialize driver
JackServer::Open failed with -1
Failed to open server


Je ne comprends pas ce qui se passe. J'ai tenté cela après avoir réussi à récupérer jack dans audacity et la possibilité d'enregistrer et de lire vaec la motu mais j'ai au bout de 5-6 minutes des grésillements et "xruns" ? J'ai donc voulu suivre les conseils ici :
https://doc.ubuntu-fr.org/jackd#optimisation

mais dba tu sembles être un bon connaisseur de jack as-tu une idée du problème ?
Merci d'avance.

jeronath utilisateur non connecté France
Supplément d'info : si je fais la même commande que ci-dessus sans la demande de temps réel soit :
jackd -d alsa -d hw:1 -r 48000 -p 1024 -n 3
tout se bloque après ALSA: use 3 periods for capture

bda utilisateur non connecté France
Le problème est qu'aujourd'hui, pulseaudio est activé automatiquement. Même avec un --kill il se relance tout seul (enfin il me semble).

Il peut y avoir une solution simple. Est-ce que tu peux essayer la live de LibraZiK? Ça peut être depuis un DVD ou une clé USB. Ça ne coûte rien et peut aider. LibraZiK est vraiment bien, 200% MAO. Comme elle repose sur Debian, elle est bien pour à peu près tout. ici
L'avantage serait d'avoir une distribution optimisée MAO "neuve" et donc propre.

Une autre solution mais qui peut ne pas fonctionner, c'est de créer un nouvel utilisateur sur ta distribution actuelle. Activer jack (et seulement lui) puis audacity. 1 par 1. Avec des fichiers de configuration utilisateur "neufs". Seulement ça ne résoudra pas un problème au niveau du système (soucis dans la fusion xubuntu+studio par exemple).

Ubuntu Studio et Xubuntu, je ne connais que de nom. Je ne sais pas comment le noyau est configuré, avec quelles options, la latence (basse ou temps réel). Ni même si ton installation est "propre". Pas facile de savoir sans être devant la machine.

Là, comme ça, j'ai l'impression qu'une application (ou pulseaudio) prend les entrées de ta Motu sans passer par jack (ce qui pourrait expliquer cette erreur "ALSA: cannot set hardware parameters for capture").

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 11:06, dim. 24 Oct 2021: @lootre : contacte moi via IRC si tu vois ce message
olinuxx, 10:48, dim. 24 Oct 2021: Bonjour et bienvenue à JSNGZN, B_Beun, salamrouba, et Iwanael cool
Shangri-l, 17:39, sam. 23 Oct 2021: Bienvenue à white-wolf ! J'ai cotoyé un temps sur d'autres lieux des réseaux un White Wolf, si tu es lui, tu te souviendras de moi. Si tu n'es pas lui, tu pars avec un bon point positif pour avoir ma sympathie, vu que tu me le rappelles :-)
sri_raoul, 13:11, jeu. 21 Oct 2021: Un avant-goût de ce que sera Ardour 7: [Lien]
olinuxx, 17:20, lun. 18 Oct 2021: Bonjour et bienvenue à white-wolf cool
olinuxx, 16:23, sam. 16 Oct 2021: Bonjour et bienvenue à didremi, TiFred et à Cecile43 cool
bluedid29, 12:40, dim. 10 Oct 2021: A titre d'info, test interface audio Audient Di14 en cours sur Debian, Ubuntu... ...pour l'instant, que du bon ;-) Je tiens au courant pour plus de précisions dès que que possible...
bluedid29, 12:38, dim. 10 Oct 2021: Merci pour l'édito et bon dimanche sous le soleil :-)
sub26nico, 22:05, mer. 06 Oct 2021: Bien joué les potos, qu'il est bien, qu'il est beau l'édito !
r1, 15:33, mer. 06 Oct 2021: Les rhinos comme les chameaux, tous sont accros à l'édito !
allany, 09:06, mer. 06 Oct 2021: Pas besoin d'otorhino, c'est juste l'édito ! [Lien]
olinuxx, 20:38, mar. 05 Oct 2021: Bonjour et bienvenue à Turtlebass6 et à FalCT60 cool