Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Forum dédié Ardour

> Forums de discussion > 3 - Forum dédié Ardour > Pas de son sur Ardour en synchro avec blender
Dernier post

Pas de son sur Ardour en synchro avec blender

Ciereve utilisateur non connecté
Bonjour à tou-te-s,
Je suis sur debian buster et je travaille sur blender 2.83 (LTS) dont j'ai exporté un projet ARDOUR 5.12 afin de retravailler le son. Pour pouvoir faire ça, j'ai donc installé jackd et jackd 2, J'ai installé un noyau RT et j'ai mis l'utilisateur courant dans groupe audio.

- Mettre utilisateur courant dans groupe audio :
pour connaître les groupes, dans un simple shell tapper  
$ groups

pour vérifier que audio y est bien
puis mettre l'utilisateur courrant dans groupe audio dans un shell root en tappant
$ su -

puis
# gpasswd -a nomutilisateur audio



Ensuite, pour pouvoir utiliser la fonction « temps reel » installer un noyau RT (temps reel).
Regarder les noyaux rt disponibles en entrant dans un shell simple :
apt search linux-image rt

puis, en root, installer :
apt install linux-image-rt-amd64 linux-headers-rt-amd64


Redémarrer pour que cela prenne effet et choisissez dans grub sur le noyau rt.

En continuant mes recherches, je suis tombé sur cette proposition : PAM, sur ce lien https://linuxmao.org/PAM
Je l’ai donc suivis et j’ai dons mis la prio au RT en faisant :
sudo dpkg-reconfigure jackd2

mon fichier audio.conf trouvé dans /etc/security/limits.conf contient

@audio - rtprio 95
@audio - memlock unlimited
  1. @audio - nice -19

ou la commande
ulimit -l -r


max locked memory       (kbytes, -l) unlimited
real-time priority              (-r) 95



En démarrant qjeckctl, je reçois la notification new sink Jack sink PulseAudio JACK sink, et dans réglages/Paramètres, le pilote est Alsa

j'ai fait attention à ce que les réglages soient les mêmes entre logiciels, je pense que c'est bon... Mais je n'ai toujours pas de son qui sort d'Ardour, même si la barre défile, quand j'essaye d'enregistrer, le bouton record rouge clignotte.
Quand ardour est lancé, la vidéo dans blender ne bouge pas. Elle ne reprend qu'une fois celui-ci fermé.

Si c'était possible de se servir d'Ardour, je serai vraiment très très content de pouvoir avancer sur mon projet :-)
Merci merci merci!!!

sub26nico utilisateur non connecté France
Il faut activer la synchro JACK dans Ardour. D'abord dans les préférences :
Image
puis ensuite dans l'interface graphique :
Image

Ciereve utilisateur non connecté
Ok, merci, sur l'interface graphique, c'est bon, en revanche je n'ai pas "transport" dans mes préférences...
Image

sub26nico utilisateur non connecté France
Quelle version d'Ardour ?
De mémoire, ça s'appelait Synchro dans la V5 d'Ardour. À vérifier.

Ciereve utilisateur non connecté
Oui, c'est la V5, dans synchro, j'ai effectivement ça:
Image

Mais du coup, leprobleme ne vient pas de là.
Est-ce que le fait que le pilote dans jack audio connexion soit ALSA, ça ne pose pas de probleme?

sub26nico utilisateur non connecté France
Citation :
Est-ce que le fait que le pilote dans jack audio connexion soit ALSA, ça ne pose pas de probleme?
Non c'est normal, ALSA c'est la couche de pilotes qui permet de communiquer avec le matériel.
Est ce que Blender est configuré sur JACK ?

Ciereve utilisateur non connecté
Je ne sais pas, comment est-ce qu'on configure blender avec jack...?

sub26nico utilisateur non connecté France
Je n'ai pas trouvé d'option JACK dans Blender, je ne sais pas non plus.
Ardour peut lire des fichiers vidéos, peut être que cela peut suffire pour ce que tu veux faire.

Ciereve utilisateur non connecté
Surement, mais je n'ai quand même pas de son sur ardour, le probleme peut-il venir d'autre chose que mes reglages? D'ailleurs, on n'a pasparlé des reglages de QjackCtl

sub26nico utilisateur non connecté France
Peux tu mettre des captures d'écran des fenêtres de réglages de Qjackctl ?

Ciereve utilisateur non connecté
Image

Image

sub26nico utilisateur non connecté France
Essayes avec les réglages suivant :
  • Fréquence d'échantillonnage : 48kHz (c'est déjà ton réglage donc pas besoin d'y toucher)
  • Échantillons/période : 1024
  • Périodes/tampon : 2

Ciereve utilisateur non connecté
Sur blender ainsi qu'ardour, je suis à 4096 le format d'échantillonnage est à 32 bits... Dans l'immédiat je ne vais pas pouvoir éssayer car je suis entrain de faire un export sur blender, je n'ai pas envi de le planter, je devrais donc essayer demain, car ce soir je ne pourrai pas (oui, c'est un export qui va durer 5 heures, c'est pour rebosser dessus avant de pouvoir retravailler le son ;-)

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

funroad34, 15:50, lun. 20 Sep 2021: c est surtout lors de la connection que ça rame sinon c 'est correct niveau timming a l'ouverture des pages..
funroad34, 15:43, lun. 20 Sep 2021: slt Oui patience et perseverence...
Houston4444, 11:17, lun. 20 Sep 2021: Ici on apprend la patience, bientôt la cafetière aura terminé sa mission avant que la page soit chargée...
sub26nico, 17:50, dim. 19 Sep 2021: pas de souci ici
funroad34, 14:14, dim. 19 Sep 2021: Bonjour idem chez moi
Geis007, 18:03, sam. 18 Sep 2021: binjch, c'est très lent, en effet !
binjch, 22:51, ven. 17 Sep 2021: Salut c'est hyper lent chez tout le monde là? Ou c'est moi qui ai un problème?
olinuxx, 18:46, jeu. 16 Sep 2021: Bonjour et bienvenue à pierre2 cool
zicstef, 22:40, mer. 15 Sep 2021: Hello, il y a bien longtemps que je n'ai pas eu la joie de passer. Découvert au détour d'un surf: /
olinuxx, 18:30, lun. 13 Sep 2021: [INFO] nouveau compte Diaspora pour linuxmao : [Lien] Venez nous y rejoindre cool
Samuel, 02:44, dim. 12 Sep 2021: [Lien] C'est la video de présentation du futur de VCV RACK, un synthé modulaire
olinuxx, 18:55, jeu. 09 Sep 2021: @dugalandco : utilises le forum pour mener des discussions. Le mégaphone n'est pas utilisé pour des discussions, mais pour informer de façon rapide.