Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > Problème de son avec micro via carte USB (voix "robotisée")
Dernier post

Problème de son avec micro via carte USB (voix "robotisée")

Unik90 utilisateur non connecté
Bonjour,

Je viens ici comme on me l'a conseillé sur un autre forum (ubuntu-fr.org)...

Comme je l'écrivais là-bas, je rencontre des problèmes de son lorsque j'utilise un micro XLR connecté à une carte son USB. Tout fonctionne bien au lancement, mais assez régulièrement, au bout d'un certain temps, sans que je ne lance un logiciel ou fasse une action en particulier, le son se dégrade, la voix semble robotisée et c'est quasiment inaudible. Voici un exemple de ce que ça donne quand le problème survient (avec une comparaison avant/après) : Lien vers extrait

J'ai fait des tests avec 2 micros différents et avec 2 interfaces USB différentes (Zoom H4N Pro et Xenyx Q502USB) et j'ai le même problème, j'ai donc tendance à croire que ça ne vient pas du matériel. Le fait de brancher / débrancher la carte son USB ou l'éteindre électriquement ne résout pas le problème.
Ce qui est surprenant, c'est que je n'ai jamais rencontré ce problème avec le micro de ma webcam (elle aussi en USB) que j'ai pourtant utilisé pendant des heures.

Voici ce que me renvoient certaines commandes :

1."cat /proc/asound/cards" :
0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfc080000 irq 96
 1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfc800000 irq 98
 2 [CODEC          ]: USB-Audio - USB Audio CODEC
                      Burr-Brown from TI USB Audio CODEC at usb-0000:01:00.0-9.2, full speed
 3 [C525           ]: USB-Audio - HD Webcam C525
                      HD Webcam C525 at usb-0000:01:00.0-4, high speed


2. "aplay -l" renvoie cela :
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: NVidia [HDA NVidia], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: NVidia [HDA NVidia], périphérique 7: HDMI 1 [HDMI 1]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: NVidia [HDA NVidia], périphérique 8: HDMI 2 [HDMI 2]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: NVidia [HDA NVidia], périphérique 9: HDMI 3 [HDMI 3]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: NVidia [HDA NVidia], périphérique 10: HDMI 4 [HDMI 4]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: NVidia [HDA NVidia], périphérique 11: HDMI 5 [HDMI 5]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: Generic [HD-Audio Generic], périphérique 0: ALC1220 Analog [ALC1220 Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: Generic [HD-Audio Generic], périphérique 1: ALC1220 Digital [ALC1220 Digital]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 2: CODEC [USB Audio CODEC], périphérique 0: USB Audio [USB Audio]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0



Merci pour vos lectures et conseils !

Samuel utilisateur non connecté Allemagne
Salut,

tu es sur une version d'ubuntu récente ?
On dirait de l'aliasing extreme, mais c'est assez étrange.
si tu installes/ouvres le logiciel pavucontrol (controle de pulseaudio), est ce que plusieurs flux jouent en meme temps vers la sortie ?

Un autre truc `a investiguer serait de voir si un micro interne pourrait etre mixé avec ton micro USB. On devrait pouvoir voir ça avec alsamixer

Unik90 utilisateur non connecté
Salut,

Merci Samuel pour ta réponse. Je suis sur Ubuntu Mate 20.4.
Il n'y a pas plusieurs flux qui jouent en sortie quand le problème survient, tout semble normal de ce côté là.
Je ne comprends pas ce que tu me conseilles de faire avec Alsamixer.

Par contre, je viens de remarquer une chose étrange : quand le problème se produit et que je connecte un casque au Xenyx Q502, j'ai en sortie un son hyper fort et complètement saturé, ce qui n'est pas normal du tout. Et si je débranche le câble USB du Xenyx, tout redevient normal et je n'ai pas de voix robotisée au casque de la carte son USB. D'autre part, après avoir rencontré le problème, la carte son est un peu tiède au bout d'une demi-heure à une heure d'utilisation, je ne sais pas si c'est normal (je mets un peu de gain et j'amplifie un peu le signal).

Tout cela pourrait donner à croire que le problème vient de mon Xenyx Q502USB, sauf que j'ai eu le problème de la voix robotisée avec un Zoom H4NPro ; j'ai donc tendance à penser que le problème vient du côté de la gestion du pilote des cartes son USB côté Ubuntu.
Du coup, pour tenter d'identifier plus précisément la source du problème, je vais faire des essais sous Windows et essayer de voir ce qui se passe lorsque je sors en RCA sur la carte son USB et que j'entre en jack sur l'ordinateur (hormis un son avec plein de parasites a priori...).

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 11:06, dim. 24 Oct 2021: @lootre : contacte moi via IRC si tu vois ce message
olinuxx, 10:48, dim. 24 Oct 2021: Bonjour et bienvenue à JSNGZN, B_Beun, salamrouba, et Iwanael cool
Shangri-l, 17:39, sam. 23 Oct 2021: Bienvenue à white-wolf ! J'ai cotoyé un temps sur d'autres lieux des réseaux un White Wolf, si tu es lui, tu te souviendras de moi. Si tu n'es pas lui, tu pars avec un bon point positif pour avoir ma sympathie, vu que tu me le rappelles :-)
sri_raoul, 13:11, jeu. 21 Oct 2021: Un avant-goût de ce que sera Ardour 7: [Lien]
olinuxx, 17:20, lun. 18 Oct 2021: Bonjour et bienvenue à white-wolf cool
olinuxx, 16:23, sam. 16 Oct 2021: Bonjour et bienvenue à didremi, TiFred et à Cecile43 cool
bluedid29, 12:40, dim. 10 Oct 2021: A titre d'info, test interface audio Audient Di14 en cours sur Debian, Ubuntu... ...pour l'instant, que du bon ;-) Je tiens au courant pour plus de précisions dès que que possible...
bluedid29, 12:38, dim. 10 Oct 2021: Merci pour l'édito et bon dimanche sous le soleil :-)
sub26nico, 22:05, mer. 06 Oct 2021: Bien joué les potos, qu'il est bien, qu'il est beau l'édito !
r1, 15:33, mer. 06 Oct 2021: Les rhinos comme les chameaux, tous sont accros à l'édito !
allany, 09:06, mer. 06 Oct 2021: Pas besoin d'otorhino, c'est juste l'édito ! [Lien]
olinuxx, 20:38, mar. 05 Oct 2021: Bonjour et bienvenue à Turtlebass6 et à FalCT60 cool