Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

4 - Toutes les autres applications, les émulateurs...

> Forums de discussion > 4 - Toutes les autres applications, les émulateurs... > MIDI : pas de réponse à mon clavier depuis la dernière version de qjackctl
Dernier post

MIDI : pas de réponse à mon clavier depuis la dernière version de qjackctl

Ejis Articles : 165 utilisateur non connecté
Bonjour,

j'ai récemment mis à jour JACK et qjackctl.
Depuis lors, mon clavier MIDI USB est détecté et connecté à n'importe-quel synthé, comme d'habitude, mais quand je joue, aucun son ne sort. J'ai vérifié avec deux claviers différents.
J'ai remarqué qu'il y avait une nouvelle option « MIDI driver » dans qjackctl. Est-ce que ç'aurait quelque-chose à voir ?

Merci d'avance.

Ejis Articles : 165 utilisateur non connecté
Bon, j'ai toujours le même problème.

Parfois, JACK n'est pas stoppé, et le killall ne marche pas quand je veux l'arrêter. Je suis alors obligé de redémarrer. Ensuite, il arrive que les applications plantent quand je « déconnecte » le clavier.

Mysth-R Articles : 649 utilisateur non connecté France
Citation :
Bon, j'ai toujours le même problème.

Parfois, JACK n'est pas stoppé, et le killall ne marche pas quand je veux l'arrêter. Je suis alors obligé de redémarrer. Ensuite, il arrive que les applications plantent quand je « déconnecte » le clavier.


Tu n'aurais pas fait une mise à jour de ton kernel ? Il me semble qu'il y a des problèmes de ce genre avec la version 2.6.26 ou la .27

Ejis Articles : 165 utilisateur non connecté
Ben j'ai eu ces problèmes depuis les dernières versions d'ALSA, JACK et qjackctl, et j'ai l'impression que ça vient du driver MIDI...

Mysth-R Articles : 649 utilisateur non connecté France
Citation :
Ben j'ai eu ces problèmes depuis les dernières versions d'ALSA, JACK et qjackctl, et j'ai l'impression que ça vient du driver MIDI...


As tu réinstaller une version plus ancienne de Alsa ?
Quelle version du kernel as tu ?

Ejis Articles : 165 utilisateur non connecté
ALSA 1.0.18
JACK 0.116.1
kernel 2.6.26.8 RT

Je réessaierai en dowgradant ALSA...

Ejis Articles : 165 utilisateur non connecté
Bon, même problème avec la version antérieure d'ALSA.
Et toi, de ton côté, si ton système est à jour, tu arrives à utiliser un clavier MIDI ? Si c'est le cas, je serais intéressé par ta config' de JACK, au cas où...

Mysth-R Articles : 649 utilisateur non connecté France
Citation :
Bon, même problème avec la version antérieure d'ALSA.
Et toi, de ton côté, si ton système est à jour, tu arrives à utiliser un clavier MIDI ? Si c'est le cas, je serais intéressé par ta config' de JACK, au cas où...

J'ai pas mal bidouillé dernièrement. Pour le moment j'utilise :

kernel : 2.6.25.8-rt7
Alsa 1.0.16rc2 patché avec de nouveau driver pour ma carte son
JACK 0.116.1

Voila et je n'ai aucun problèmes de clavier midi. Enfin moi j'utilise un clavier en USB principalement et je n'ai pas retesté avec mon autre sur port Midi. Je testerais....

Ejis Articles : 165 utilisateur non connecté
Bon, ça vient du kernel.

J'ai testé avec le kernel officiel de Zenwalk, 2.6.27.10, et ça fonctionnait. Par contre, sous mes kernel RT ça ne fonctionne plus. Va falloir que j'aille leur demander ce qu'ils ont trafiqué avec ALSA quand ils l'ont mis à jour, parce-que ça fonctionnait très bien sous le kernel RT précédent.

Mysth-R Articles : 649 utilisateur non connecté France
Citation :
Bon, ça vient du kernel.

J'ai testé avec le kernel officiel de Zenwalk, 2.6.27.10, et ça fonctionnait. Par contre, sous mes kernel RT ça ne fonctionne plus. Va falloir que j'aille leur demander ce qu'ils ont trafiqué avec ALSA quand ils l'ont mis à jour, parce-que ça fonctionnait très bien sous le kernel RT précédent.

Normalement il y a un nouveau kernel RT qui vient de sortir : 2.6.26.8-rt12
Peut etre que tu auras plus de chance.

Ejis Articles : 165 utilisateur non connecté
C'est exactement celui-ci que j'utilise. Je suis par ailleurs le mainteneur de ce kernel pour cette distribution.
Mais en fait, ça me faisait déjà ça avant que je ne mette ce kernel à jour. Et apparemment, ça vient bien de leur upgrade d'ALSA, puisqu'avant, ça fonctionnait.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 09:25, mar. 15 Jun 2021: Bonjour et bienvenue à Hexaal :-)
Ubuntu_Studio_User, 02:29, lun. 14 Jun 2021: Salut à tous...
allany, 12:12, sam. 12 Jun 2021: @tourneriff : merci pour le signalement, c'est fait !
tourneriff, 07:52, sam. 12 Jun 2021: Bonjour à tous ☺ ! Avis aux modos : pourrait-on voir la "joute 16" en cours à l'accueil du site plutôt que l'antique "joute 15"
sub26nico, 14:56, jeu. 10 Jun 2021: Salut et bienvenue à jamesonmount, freerawsound et Loop :-)
ycollet, 10:28, mer. 09 Jun 2021: Cool, un revival de rakarrak ! [Lien]
sub26nico, 22:08, lun. 07 Jun 2021: Bonjour et bienvenue à ArchLinux59, Djobi et gakgakgak :-)
olof, 09:27, lun. 07 Jun 2021: ardour 6.7 build tourne chez moi, mais pas le package 6.6
allany, 14:46, dim. 06 Jun 2021: @r1 : t'as raison : trop c'est trop, ça sature du goulot !
r1, 22:54, sam. 05 Jun 2021: Mon cerveau a bobo à force de faire le gogo sur l'annonce de l'édito !
allany, 11:49, sam. 05 Jun 2021: Z'ont encore abattu un sacré boulot, les poulbots de l'édito ! [Lien]
ycollet, 20:37, ven. 04 Jun 2021: Un article intéressant sur un truc à venir sur USB audio: [Lien]