Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

Dernier post

[résolu] jack ne veut pas d'alsa

huit_six utilisateur non connecté
Bonjour tout le monde,
Je suis nouveau sur ce forum, j'ai déja posé ma question sur le forum d'ubuntu, mais n'ayant pas eu de réponse et ayant découvert ce site récemment, je me suis dit que c'était plus aproprié de poser ma question ici:
Je viens d'installer une dapper sur un vieux pc avec lequel je comptais faire un peu de MAO, seulement voila, le serveur jack ne veut pas charger alsa, seul oss fonctionne et avec un grésillement qui rend tout le bastringue inutilisable, voila le message d'insultes de qjackctl:

loading driver ..
apparent rate = 44100
creating alsa driver ... hw:0|hw:0|1024|2|44100|0|0|nomon|swmeter|-|32bit
control device hw:0
ALSA lib confmisc.c:1107:(snd_func_refer) Unable to find definition 'defaults.pcm.device'
ALSA lib conf.c:3493:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib confmisc.c:242:(snd_func_getenv) error evaluating default
ALSA lib conf.c:3493:(_snd_config_evaluate) function snd_func_igetenv returned error: No such file or directory
ALSA lib conf.c:3951:(snd_config_expand) Args evaluate error: No such file or directory
ALSA lib pcm.c:2102:(snd_pcm_open_noupdate) Unknown PCM hw:0
ALSA lib confmisc.c:1107:(snd_func_refer) Unable to find definition 'defaults.pcm.device'
ALSA lib conf.c:3493:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib confmisc.c:242:(snd_func_getenv) error evaluating default
ALSA lib conf.c:3493:(_snd_config_evaluate) function snd_func_igetenv returned error: No such file or directory
ALSA lib conf.c:3951:(snd_config_expand) Args evaluate error: No such file or directory
ALSA lib pcm.c:2102:(snd_pcm_open_noupdate) Unknown PCM hw:0
17:31:20.722 Could not connect to JACK server as client. Please check the messages window for more info.
could not attach as JACK client (server has exited)
ALSA: Cannot open PCM device alsa_pcm for playback. Falling back to capture-only mode
cannot load driver module alsa
17:31:21.353 JACK was stopped successfully.


Au passage je ne savais pas jack aussi grossier...

On dirait qu'il y a un truc de pas installé genre alsa ou un truc comme ça or, dans synaptic, alsa-base est bien installé et un sudo dpgk-reconfigure alsa-base n'a rien donné. Je me suis dit que c'était peut-etre un module qui ne serait pas installé, j'ai fait un lsmod | grep alsa, qui n'a rien donné, j'ai donc tenté un sudo module-assistant pour installer le module alsa, et je me fais engueuler lors de la compilation comme quoi gcc 4 ne peut pas créer d'exécutable, le comble, qu'est-ce que j'y peux moi? (je précise que je ne maitrise pas du tout compilation etc et que la seule utilisation de module-assistant que j'ai faite était pour compiler le module temps réel)
Voila où j'en suis

Pour info, je peux lire des fichiers son avec vlc, et j'entend le micro dans les enceintes, et enfin ma carte son (une SB live! 5.1) fonctionne normalement puisque je n'avais pas de problème sous breezy.

Si quelqu'un peut m'aider, ou au moins si quelqu'un a vécu la même galère que moi, parce que là je frise la dépression (marre de me faire avoiner par des logiciels...). Et enfin mes deux seules solutions sont d'utiliser audacity (qui marche nickel) ou de repasser sous breezy... Mais ça me fait du mal d'apeller ça des solutions... help!!

jezeus utilisateur non connecté France
Salut,

C'est vrai que jack est bien grossier.

Ça, c'est dit ;). Sérieusement, faire de la MAO sans système de rack (jack), bah ça limite vachement.

Essaye de "modprober" les modules snd-seq*. Ce sont ces modules qu'y vont pouvoir servir à initialiser le système alsa. Attention ,alsa n'est pas un module.

Jack aussi ne veut pas se lancer avec alsa chez moi sans ces module, ce qui est logique. Si ça marche, (normalement oui), ajoute les dans le fichier /etc/modules pour les charger à chaque boot.

Bonne chance.

PS: tous les modules snd-seq* ne sont pas tous utile, si tu utilises un noyau ubuntu par défaut. Genre les snd-seq*oss* .....

huit_six utilisateur non connecté
Merci de ta réponse Jezeus mais voilà, comme le titre l'indique, mon problème est résolu, je suis allé à cette adresse:
http://www.alsa-project.org/alsa-doc/doc-php/template.php?company=Creative+Labs&card=Sound+Blaster+Live+5.1.&chip=emu10k1&module=emu10k1
et j'ai appliqué ce qui était dit là:

Note to debian users: You need to save this information into a file in the /etc/modutils/ directory (Eg. /etc/modutils/alsa) and run update-modules

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-emu10k1
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss


sans trop (du tout) comprendre ce que je faisais, d'ailleurs au passage si quelqu'un peut m'expliquer ce que j'ai fait... en gros j'ai dit à alsa ma carte c'est celle-là c'est ça? Bon je pense que je vais pas trop me prendre la tête, et je vais savourer le fait que ça marche enfin :-D

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]


funroad34

Mégaphone [Afficher / Cacher]

olinuxx, 12:30, ven. 24 Sep 2021: Bonjour à et bienvenue à kitty32, beldic2, et à Carlos54 cool
olinuxx, 21:29, mer. 22 Sep 2021: Bonjour et bienvenue à tezere cool
funroad34, 15:50, lun. 20 Sep 2021: c est surtout lors de la connection que ça rame sinon c 'est correct niveau timming a l'ouverture des pages..
funroad34, 15:43, lun. 20 Sep 2021: slt Oui patience et perseverence...
Houston4444, 11:17, lun. 20 Sep 2021: Ici on apprend la patience, bientôt la cafetière aura terminé sa mission avant que la page soit chargée...
sub26nico, 17:50, dim. 19 Sep 2021: pas de souci ici
funroad34, 14:14, dim. 19 Sep 2021: Bonjour idem chez moi
Geis007, 18:03, sam. 18 Sep 2021: binjch, c'est très lent, en effet !
binjch, 22:51, ven. 17 Sep 2021: Salut c'est hyper lent chez tout le monde là? Ou c'est moi qui ai un problème?
olinuxx, 18:46, jeu. 16 Sep 2021: Bonjour et bienvenue à pierre2 cool
zicstef, 22:40, mer. 15 Sep 2021: Hello, il y a bien longtemps que je n'ai pas eu la joie de passer. Découvert au détour d'un surf: /
olinuxx, 18:30, lun. 13 Sep 2021: [INFO] nouveau compte Diaspora pour linuxmao : [Lien] Venez nous y rejoindre cool