Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

Dernier post

[CONTOURNÉ] alsa record

jamin utilisateur non connecté France
Bonjour,

J'ai acquis une M-audio 1010LT dans le but de faire du son sous Linux.
La première étape, que j'essaie désespéremment de franchir, est d'enregistrer
un son.
J'ai donc branché une source sur les entrées 3 et 4.
Avec envy24control, je perçois bien un signal sur les entrées H/W In 3
et H/W In 4.

Ensuite, j'utilise arecord?, mais il y a une erreur à la relecture.
Est-ce que quelqu'un a une idée ?!?
Merci d'avance.



[+]

gilles utilisateur non connecté France
Déjà c'est une bonne carte !

As tu essayé avec ardour ou avec rezound par exemple ?
Peut être que tu as deux cartes sons et que sous aplay? il faut spécifier la carte son..

jamin utilisateur non connecté France
J'ai essaye avec ardour et rezound sans succes et j'arrive a faire fonctionner aplay? avec un fichier .wav quelconque (j'ai desactive la 1ere carte son dans le bios).
Je prefere reussir a enregistrer avec la couche alsa avant de rajouter jackd, ardour ...

A noter egalement qu'avec audacity (donc directement avec alsa), lorsque j'enregistre, mon système se fige. Est t-il possible qu'il y ait un conflit dans les interruptions systeme ?!?

Salut,
Citation :
J'ai essaye avec ardour et rezound sans succes et j'arrive a faire fonctionner aplay avec un fichier .wav

Et lire le wav enregistré avec un autre soft (xmms ou autre) pour vérifier si c'est bien l'enregistrement qui foire ? (vu que arecord ne donne pas de message d'erreur).

Citation :
A noter egalement qu'avec audacity (donc directement avec alsa), lorsque j'enregistre, mon systeme se fige. Est t-il possible qu'il y ait un conflit dans les interruptions systeme ?!?

Ca, c'est toi qui va nous le dire biggrin
"cat /proc/interrupts" pour vérifier !

Trinine


jamin utilisateur non connecté France
Ca devient interessant. Je ne savais pas ou aller chercher les infos sur les interruptions, mais voila ce que j'ai vu dans /var/log/messages :
/var/log/messages:Jun  5 20:21:00 localhost kernel: ACPI: PCI interrupt 0000:01:06.4[C] -> GSI 18 (level, high) -> IRQ 217
/var/log/messages:Jun  5 20:21:00 localhost kernel: ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[217]  MMIO=[df003000-df0037ff]  Max Packet=[2048]


Et l'interuption correspond au driver ice1712 de la carte + ohci1394 que je ne connais pas.



[+]

ohci1394 c'est pour le firewire/IEEE1394. Faudrait essayer de le désactiver pour voir si la carte son marche mieux sans. S'il est intégré dans la carte mère, regardes dans le bios, si c'est une carte PCI, enlèves-là juste le temps des essais !

T.

jamin utilisateur non connecté France
J'ai enleve la carte PCI firewire. Il n'y a plus de conflit dans /proc/interrupts.

% cat /proc/interrupts |grep 1712
209:        130   IO-APIC-level  ICE1712


Par contre, je n'arrive toujours pas a enregistrer avec arecord? et audacity plante encore !

Citation :
% arecord -D plughw : 0 , 3 -f cd -t wav test.wav
Recording WAVE ':' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo

Attends, j'ai un doute : y'a pas des espaces en trop là ? (c'est le WAVE ':' qui me paraît louche)
C'est pas plutôt "plughw:0,3" ? (ou "plughw:0,0", ça dépend de tes branchements)
Sinon, lance "audacity" dans un terminal des fois qu'il y ait des messages d'erreurs.

T

jamin utilisateur non connecté France
J'avais essaye, mais sans succes. Par contre, j'ai reussi a enregistrer avec
- qjackctl pour lancer jackd avec la carte hw:0 en E/S
- rezound
Donc a la rigueur, etant donné que je vais utiliser jackd, c'est pas tres grave si j'arrive pas a enregistrer directement depuis ((alsa)0.
En tout cas, merci beaucoup pour votre aide et a bientot.

% arecord -D plughw:0,0  -f cd -t wav  > test.wav
Recording WAVE '(null)' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
Aborted by signal Interruption...


%  arecord -D plughw:0,3  -f cd -t wav  > test.wav
arecord: main:547: audio open error: Aucun périphérique de ce type


Juste pour savoir ... cui-là :
Citation :
% arecord -D plughw:0,0 -f cd -t wav test.wav
Recording WAVE '(null)' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
Aborted by signal Interruption...

Il a marché et c'est toi qui l'a stoppé, non ? aplay? a pu le lire ?

T.

jamin utilisateur non connecté France
aplay? a pu le lire, mais y'a pas de son. Le 'null' indique peut etre que c'est la mauvaise entrée. Je réessayerai ce soir en me penchant de plus près sur la sortie de 'arecord? -L'. A suivre ...

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 12:30, ven. 24 Sep 2021: Bonjour à et bienvenue à kitty32, beldic2, et à Carlos54 cool
olinuxx, 21:29, mer. 22 Sep 2021: Bonjour et bienvenue à tezere cool
funroad34, 15:50, lun. 20 Sep 2021: c est surtout lors de la connection que ça rame sinon c 'est correct niveau timming a l'ouverture des pages..
funroad34, 15:43, lun. 20 Sep 2021: slt Oui patience et perseverence...
Houston4444, 11:17, lun. 20 Sep 2021: Ici on apprend la patience, bientôt la cafetière aura terminé sa mission avant que la page soit chargée...
sub26nico, 17:50, dim. 19 Sep 2021: pas de souci ici
funroad34, 14:14, dim. 19 Sep 2021: Bonjour idem chez moi
Geis007, 18:03, sam. 18 Sep 2021: binjch, c'est très lent, en effet !
binjch, 22:51, ven. 17 Sep 2021: Salut c'est hyper lent chez tout le monde là? Ou c'est moi qui ai un problème?
olinuxx, 18:46, jeu. 16 Sep 2021: Bonjour et bienvenue à pierre2 cool
zicstef, 22:40, mer. 15 Sep 2021: Hello, il y a bien longtemps que je n'ai pas eu la joie de passer. Découvert au détour d'un surf: /
olinuxx, 18:30, lun. 13 Sep 2021: [INFO] nouveau compte Diaspora pour linuxmao : [Lien] Venez nous y rejoindre cool