Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

Dernier post

[ABANDONNÉ] problème ADAT

pwmarcus utilisateur non connecté
Bonjour à tous,

J'essaye de transférer 8 cannaux (24 bits/48khz) de mon Yamaha AW4416 relié à l'entrée ADAT de ma RME RME HDSP 9632.

Tout se passe bien, Ardour enregistre tout, sauf que le son est "pourri !" , il y a plein de clicks audio. J'ai beau changer les "Frames/period" de Jack, rien y fait.

Est ce que quelqu'un aurait une expérience (heureuse) dans ce domaine ?

Malheureusement, la seule config qui donne de bons résultats, c'est avec samplitude sous wz redface

Merci de votre aide

ps: Ma config

Debian testing + noyau 2.6.18 maison compilé temps réel
proc: XP 3000+
ram: 1 Go
disques durs scsi + contrôleur ADAPTEC 29160
carte graphique: NVIDIA Geforce 6600GT accélération 3D opérationnelle

jdlv utilisateur non connecté
Bonjour,

est-ce que jackd tourne bien en priorité temps réel? Que donne :

# ps -C jackd -cmL


pwmarcus utilisateur non connecté
La commande donne:

[+]

Merci de votre réponse, cordialement

Norrin_Radd utilisateur non connecté France
Tu as bien réglé jack en 48khz ? Regarde quand tu le lance s'il ne donne pas des informations, ou avec qjackctl clique sur le bouton "Messages"...

jdlv utilisateur non connecté
Et avec un kernel full Debian non patché temps réel? Si possible un 2.6.17?

pwmarcus utilisateur non connecté
Ok, je vais essayer, mais avec un kernel full Debian non patché temps réel, jackd ne pourra pas tourner en priorite temps reel !

pwmarcus utilisateur non connecté
De ce coté la, c'est bon, 48khz est affiché, une fois jack lancé.

Norrin_Radd utilisateur non connecté France
Si c pas le buffer, ni la fréquence, c'est ? wink

Ah et si c'etait bien finallement une histoire de buffer ?

Ici des infos a propos d'une autre RME mais qui pourrait s'appliquer a ton modèle (?). Notamment le passage sur les combinaisons possibles au niveau frame/buffer:

http://alsa.opensrc.org/rme96

As tu essayer de régler le device sur plughw au lieu de hw ? Le premier étant une abstraction plus tolérante que l'autre (accès direct).

Bonne chance !

PS: au fait rien dans les logs de qjackctl ?

jdlv utilisateur non connecté
Si si ça peut le faire! Petit à petit des petits bouts des patchs RT sont integrés dans le noyau officiel. J'ai testé avec un 2.6.17 de chez mandriva et 2.6.18 Debian. Ca le fait.
Bien sur les performances de latences ne sont pas les mêmes, mais c'est mieux que rien.
Et dans certains cas un peu difficiles il est possible que ça marche mieux. Il reste encore pas mal de problèmes à résoudre dans ces patchs...

Ce n'est peut être pas la solution a ton problème, les causes possibles sont bien plus nombreuses qu'on le voudrait.

Pour voir, aurais-tu la possibilité de reboucler une sortie analogique sur une entrée analogique de la carte audio si elle possède des E/S analogiques sinon après des convertisseurs externes.
Puis dans Ardour insérer le plugin " Sine Oscillator ", celui a 0 entrée 1 sortie dans une tranche.
Regler le plugin a 1000Hz 0Db.
Envoyer la sortie de cette tranche sur la sortie analogique.

Inserer un plugin d'egaliseur parametrique dans jack-rack. Regler l'egaliseur sur 1000Hz et -70dB (au plus bas possible) et la largeur de bande vers 0.1 octave.
Connecter l'entrée de Jack-rack sur l'entrée analogique, la sortie de Jack-rack sur une autre entrée d'Ardour.
Puis dans Ardour, menu Fenetre, Editeur d'options, Divers, Activer les greffons pendant l'enregistrement.
Puis lancer un enregistrement de cette dernière piste.
Si tout se passe bien le signal enregistré devrait être proche de zéro. Les éventuels pics correspondent à des "cliks" audio.

Des exemples avec une variante consistant à enregistrer aussi l'entré analogique avant Jack-rack. L'enregistrement est visualisé dans Audacity qui possède un plus beau zoom qu'Ardour.

http://perso.orange.fr/jsilvestre/freebob/full.png
http://perso.orange.fr/jsilvestre/freebob/5-46-3085.png
http://perso.orange.fr/jsilvestre/freebob/5-55-795.png

Aucun Xrun ne fut détecté durant ces enregistrements... Test faits sur 3 machines différentes et 3 cartes son différentes ( Firewire, USB PCI)... 1 seule combinaison a donné un résultat correct!

Cette vérification permet de savoir si le problème se situe aux alentours d' l'Adat ou est plus géneral à la carte.
Au fait Jackd signal t'il des Xruns???

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

calixtus06, 07:48, jeu. 06 Oct 2022: Bonjour et bienvenue à CapuDZ :-)
malt, 20:02, dim. 02 Oct 2022: [Lien]
malt, 20:02, dim. 02 Oct 2022: livestream avec le créateur de Ardour en direct maintenant
Samuel, 23:03, sam. 01 Oct 2022: zrythm beta 3.5.1 est sorti. Il commence à être sacrément bon...
calixtus06, 10:26, ven. 30 Sep 2022: Bonjour et bienvenue à pampete :-)
calixtus06, 21:38, dim. 25 Sep 2022: Bonjour et bienvenue à Dom44 :-)
calixtus06, 10:14, ven. 23 Sep 2022: Bienvenue à Chantegrave et à Michael Alex :-)
calixtus06, 08:11, mer. 21 Sep 2022: Bonjour et bienvenue à BernArd ! :-)
dlb, 11:49, sam. 17 Sep 2022: Mes messages remarchent ... Youpi !
calixtus06, 10:22, jeu. 15 Sep 2022: Bonjour et bienvenu à bobphils et à Hugopierrel :-)
calixtus06, 09:24, mer. 14 Sep 2022: Bonjour et bienvenue à tis :-)
tis, 22:51, mar. 13 Sep 2022: qui est-ce qui zone a st'heuuure ?