Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

4 - Toutes les autres applications, les émulateurs...

Dernier post

band in a box désacordé

papymusic Articles : 296 utilisateur non connecté
bonjour,

J'utilise Timidity comme serveur pour produire mes sons MIDI à l'aide de la soundfont PC51f.sf2. J'arrive à le faire fonctionner sans erreur.

j'utilise Band in a box avec Wine. Il se lance et génère des sons. Cependant, lorsque je lis des fichiers que j'ai créé lorsque que j'étais sous Windows, il joue un demi ton au-dessus de ce qui est écrit : au lieu de jouer un do, il joue un do dièse. Est-ce que quelqu'un a déjà rencontré ce genre de problème ?

pianolivier Articles : 3938 utilisateur non connecté France
Citation :
lorsque je lis des fichiers que j'ai créé lorsque que j'étais sous Windows

euh excuse c'est pas très clair :
un fichier "band-in-a-box" ou un fichier sf2 ?

dans le cas du fichier sf2, quel logiciel a servi à sa création ? il est possible qu'il te faille modifier la fréquence d'échantillonnage pour obtenir la bonne hauteur de note. (même fréquence pour l'enregistrement et la lecture du fichier)

oliv'

papymusic Articles : 296 utilisateur non connecté
Bonjour
pianolivier écrit :
euh excuse c'est pas très clair :
un fichier "band-in-a-box" ou un fichier sf2 ?


C'est un fichier Band in a Box.
À bientôt.

leyoy Articles : 359 utilisateur non connecté France
Cela m'est déjà arrivé en ayant une mauvaise fréquence d'échantillonnage.

papymusic Articles : 296 utilisateur non connecté
Peut-on m'envoyer un fichier MIDI avec un Do (si c'est une autre note me le dire), pour que je puisse l’écouter avec Timidity et vérifier la tonalité.

La soundfont que j’utilise est PersonalCopy 5.1f (PC51f.sf2), que l’on peut trouver à cette adresse .

papymusic Articles : 296 utilisateur non connecté
bonjour,


Band in a box est toujours désaccordé.

Après pas mal de recherches j'ai fait le test avec Rosegarden j'ai enregistré un do et ensuite écouté et comme avec Band in a box le do devient do dièse, donc plus un demi ton,
dans cette manip j'ai utilisé timidity et rosegarden seulement

voici le fichier /etc/timidity/timidity.cfg :


/etc/timidity/timidity.cfg
Instrument configuration file for timidity
# $Id: timidity.cfg,v 1.7 2005/09/03 19:26:03 hmh Exp $

# You can change just about every option in TiMidity++ using
# This config file.  Please refer to the timidity.cfg(5) manpage
# for more details

## If you have a slow CPU, uncomment these:
#opt EFresamp=d		#disable resampling
#opt EFvlpf=d		#disable VLPF
#opt EFreverb=d		#disable reverb
#opt EFchorus=d		#disable chorus
#opt EFdelay=d		#disable delay
#opt anti-alias=d	#disable sample anti-aliasing
#opt EWPVSETOZ		#disable all Midi Controls
#opt p32a		#default to 32 voices with auto reduction
#opt s32kHz		#default sample frequency to 32kHz
#opt fast-decay		#fast decay notes

## If you have a moderate CPU, try these:
#opt EFresamp=l
#opt EFreverb=g,42
#opt EFchorus=s
#opt s32kHz
#opt p64a

# Disabling some of the Midi Controls can help with the CPU usage a lot.
# The same goes to the VLPF, sample anti-aliasing and effects such as
# reverb and chorus

# By default, try to use the instrument patches from freepats:
# source /etc/timidity/freepats.cfg

# alternatively, you can use the fluid-soundfont:
#source /etc/timidity/fluidr3_gm.cfg
#source /etc/timidity/fluidr3_gs.cfg

soundfont /etc/soundfonts/PC51f.sf2


et mon fichier /etc/default/timidity:

/etc/default/timidity
# Defaults for TiMidity++ scripts
# sourced by /etc/init.d/timidity
# installed at /etc/default/timidity by the maintainer scripts
# $Id: timidity.default,v 1.3 2004/08/07 14:33:26 hmh Exp $

#
# This is a POSIX shell fragment
#

SERVER_HOME=/etc/timidity
SERVER_USER=timidity
SERVER_NAME="TiMidity++ MIDI sequencer service"
SERVER_GROUP=timidity
ADDGROUP=audio

# Enable MIDI sequencer (ALSA), if timidity-deamon is installed

# uncomment to override enabling triggered by availability of timidity-deamon
TIM_ALSASEQ=true

# Setting overrides (of /etc/timidity.conf) for the ALSA sequencer daemon
# TIM_ALSASEQPARAMS="-Os"
TIM_ALSASEQPARAMS="-iA -B2,8 -Os1l -s 44100"


pianolivier Articles : 3938 utilisateur non connecté France
utilises-tu jack ?

papymusic Articles : 296 utilisateur non connecté
pianolivier écrit :
utilises-tu jack ?

Bonjour
Hé bien non, je n'utilise pas jack, parce que je n'arrive pas à le configurer.
Hé oui, j'ai plusieurs problèmes !
Je pensais poser ce problème ultérieurement, après avoir réglé le premier.

Voici comment je lance Timidity :

timidity -iA -B2,8 -Os -EFreverb=0 &


pianolivier Articles : 3938 utilisateur non connecté France
pour modifier la fréquence d'échantillonnage avec timidity (sous alsa) :
-s freq, --sampling-freq=freq
    Sets the resampling frequency (Hz or kHz). Not all sound devices are capable of all frequencies -- an approximate frequency may be selected, depending on the implementation.

essaye avec 48kHz par exemple

papymusic Articles : 296 utilisateur non connecté
pianolivier écrit :
pour modifier la fréquence d'échantillonnage avec timidity (sous alsa) :


De retour d'un séjour en bretagne j'ai essayé avec plusieurs valeurs entre 30 000 et 60 0000 aucun changement

papymusic Articles : 296 utilisateur non connecté
bonjour,
j'ai mis un cd audio, qui lui aussi c'est décalé d'un demi ton.
Il semble que cela provient de ma carte son E-MU 1820.
quelqu'un sait-il configurer cette carte pour LINUX

olinuxx Articles : 17743 utilisateur non connecté France
coucou,

ca a l'air d'être fait pour ta carte (et donc pour toi) : emutrix, tu connais ?

Olivier

papymusic Articles : 296 utilisateur non connecté
bonjour,
j'ai compilé et installé Emutrix mais il ne reconnait pas ma carte son (pour l'instant il ne fonctionne que pour E-mu 1010)
autrement j'ai installé Alsa-root: il y a un 'assembleur' pour E-MU mais comment l'utiliser?

pianolivier Articles : 3938 utilisateur non connecté France
alsa comporte un module emu10k1 pour ta carte son.

pour vérifier qu'il n'est (pas) chargé, dans un terminal :
lsmod | grep emu10k1

pour le charger temporairement (en super utilisateur) :
modprobe snd_emu10k1

pour le charger automatiquement à chaque démarrage :
ça dépend de ta distribution

oliv'

papymusic Articles : 296 utilisateur non connecté
Bonjour,

J'ai l'impression que le module est déja chargé :

$ lsmod | grep emu10k1
snd_emu10k1_synth      12880  0 
snd_emux_synth         32122  1 snd_emu10k1_synth
snd_emu10k1           130392  3 snd_emu10k1_synth
snd_ac97_codec         96311  2 snd_intel8x0, snd_emu10k1
snd_util_mem           12624  2 snd_emux_synth, snd_emu10k1
snd_hwdep              12908  2 snd_emux_synth, snd_emu10k1
snd_pcm                69374  3 snd_intel8x0, snd_emu10k1, snd_ac97_codec
snd_rawmidi            22402  3 snd_seq_virmidi, snd_emu10k1, snd_seq_midi
snd_timer              26343  4 snd_hrtimer, snd_emu10k1, snd_pcm, snd_seq
snd_seq_device         12953  5 snd_emu10k1_synth, snd_emu10k1, snd_seq_midi, snd_rawmidi, snd_seq
snd                    46088  20 snd_emux_synth, snd_seq_virmidi, snd_intel8x0, snd_emu10k1, snd_ac97_codec, snd_hwdep, snd_pcm, snd_rawmidi, snd_seq, snd_timer, snd_seq_device
snd_page_alloc         12878  3 snd_intel8x0, snd_emu10k1, snd_pcm

Au revoir

pianolivier Articles : 3938 utilisateur non connecté France
Citation :
J'ai l'impression que le module est déja chargé

en effet tu as raison

on peut peut-etre regarder du coté des réglages supportés par alsa pour ta carte son.
En supposant que la carte ai le numéro 1 (voir le resultat de la commande cat /proc/asound/cards)
envoi le résultat obtenu avec la commande :
amixer -c__1__


oliv'

papymusic Articles : 296 utilisateur non connecté
Bonjour.

pianolivier écrit :
envoi le résultat obtenu avec la commande :
amixer -c__1__


Le résultat est un peu long, je l'ai collé sur Pastebin .

Salut.

pianolivier Articles : 3938 utilisateur non connecté France
Citation :
Le résultat est un peu long, je l'ai collé sur Pastebin

bien vu wink

j'ai trouvé quelque chose (lignes 302 et suivantes)
Simple mixer control 'Clock Internal Rate',0
Items: '44100' '48000' 'SPDIF' 'ADAT'
Item0: '48000'


je ne sais plus trop ou tu en es (ce fil commence a etre long et j'ai la flemme de le relire entierement), donc supposont que tu utilises Timidity sans jack comme au début, il a l'air d'etre réglé sur 44100 Hz (fréquence d'échantillonnage). Ton soundfont est surement échantillonné à la meme fréquence (pour gain de place), donc 44100 Hz c'est bien pour toi.
(avec jack il faudrai aussi sélectionner 44100 Hz)

mais ta carte est en mode 48000 Hz (Item0). Par chance elle propose aussi 44100 Hz (Items), il faut donc modifier cela avec alsamixer : une fois la bonne carte sélectionnée, navigue jusqu'au "control" Simple mixer control 'Clock Internal Rate',0 et sélectionne 44100

oliv'

papymusic Articles : 296 utilisateur non connecté
bonjour
Ma situation se dégrade!
Mon impression est que ma carte son n'est plus détectée.
je ne trouve plus que la carte son interne à la carte mère:
{CODE}
$ cat /proc/asound/cards
0 ICH5 : ICH4 - Intel ICH5
Intel ICH5 with ALC850 at irq 17
{CODE}
Au revoir

papymusic Articles : 296 utilisateur non connecté
papymusic écrit :
bonjour,

Après beaucoup de malheur j'ai enfin retrouvé ma carte son (voir sur autre rubrique).
J'ai modifié avec ALSA la fréquence hélas pas de changement, toujours le défaut.
Par contre quand je suis sur le module interne du son pas de problème la tonalité est correcte
A+


pianolivier Articles : 3938 utilisateur non connecté France
mmm j'ai perdu le fil, on en est ou ici ?

oliv'

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 21:29, mer. 22 Sep 2021: Bonjour et bienvenue à tezere cool
funroad34, 15:50, lun. 20 Sep 2021: c est surtout lors de la connection que ça rame sinon c 'est correct niveau timming a l'ouverture des pages..
funroad34, 15:43, lun. 20 Sep 2021: slt Oui patience et perseverence...
Houston4444, 11:17, lun. 20 Sep 2021: Ici on apprend la patience, bientôt la cafetière aura terminé sa mission avant que la page soit chargée...
sub26nico, 17:50, dim. 19 Sep 2021: pas de souci ici
funroad34, 14:14, dim. 19 Sep 2021: Bonjour idem chez moi
Geis007, 18:03, sam. 18 Sep 2021: binjch, c'est très lent, en effet !
binjch, 22:51, ven. 17 Sep 2021: Salut c'est hyper lent chez tout le monde là? Ou c'est moi qui ai un problème?
olinuxx, 18:46, jeu. 16 Sep 2021: Bonjour et bienvenue à pierre2 cool
zicstef, 22:40, mer. 15 Sep 2021: Hello, il y a bien longtemps que je n'ai pas eu la joie de passer. Découvert au détour d'un surf: /
olinuxx, 18:30, lun. 13 Sep 2021: [INFO] nouveau compte Diaspora pour linuxmao : [Lien] Venez nous y rejoindre cool
Samuel, 02:44, dim. 12 Sep 2021: [Lien] C'est la video de présentation du futur de VCV RACK, un synthé modulaire