Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : JACK, PulseAudio et autres...

> Forums de discussion > 5 - Les serveurs son : JACK, PulseAudio et autres... > [Sujet déplacé, et résolu...!] Problème Jack "Cannot connect to server socket err = No such file or directory"
Dernier post
Page : 1/4   -   Aller directement à la page : 1  2  3  4 

[Sujet déplacé, et résolu...!] Problème Jack "Cannot connect to server socket err = No such file or directory"

Benbo utilisateur non connecté
Bonjour,
Je suis nouveau pour la MAO sur Linux.
Je suis sur fedora 17, j'ai installé un noyau temps réel CCRMA, et tout se passe bien jusqu'à présent.
En installant le QjackCTL, je m'aperçois que jack ne marche pas.
J'ai juste ma carte son intégrée à mon ordi portable, mais je crois que l'entrée hw:1 est correcte.

Merci beaucoup pour votre aide.

Voilà ce qu'il me dit en parallèle de son message d'erreur :

[+]

Édition olinuxx 15 septembre 2012 : la suite de ce sujet se trouve dans le sujet : Fedora/Jack/Pulse ...


olinuxx utilisateur non connecté France
Salut,
donne nous le résultat d'un aplay -l également.
Olivier

Benbo utilisateur non connecté
Salut Olivier,
voilà :
# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: SB [HDA ATI SB], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0


olinuxx utilisateur non connecté France
Yop Benbo,

quel(s) choix as-tu dans qjackctl, "Réglages...", "Interface :" si tu cliques sur le symbole supérieur (>) ?

Olivier

olinuxx utilisateur non connecté France
PS: Essaies egal ement de lancer Jack a 44100Hz et pas 48Khz. Je ne suis pas certain que toutes les puces-son puissent faire du 48Khz.
Olivier

Benbo utilisateur non connecté
Donc j'ai :
hw:0    HD-Audio Generic
v hw:1    HDA ATI SB
  hw:1,0  ALC269VB Analog
  (default)


J'ai essayé à 44100Hz sans succès...

allany utilisateur non connecté
Hello,

Excuse, Benbo, ce petit aparté avec olinuxx :
- hey, ne dirait-on pas notre ami HDMI, Oli' ? cool

@benbo : sur Fedora, existe-t-il un répertoire /etc/modprobe.d et, si oui, quel en est le contenu (par ls) ?

A+

Benbo utilisateur non connecté
Salut !
voilà dans mon dosier :
/etc/modprobe.d/blacklist.conf
/etc/modprobe.d/openfwwf.conf
/etc/modprobe.d/udlfb.conf

allany utilisateur non connecté
OK, pareil que sur la plupart des distrib's.

Ce que je te propose, alors, c'est de blacklister (désactiver) le module/driver pour la HDMI.
Ca n'est pas irréversible et, pour une utilisation purement MAO, je constate depuis plusieurs mois, ici, que ça fiche le souk quasi systématiquement.

Il faudrait donc repérer quel module est en cause.
Pour ce faire, peux-tu nous poster le résultat de :
lsmod | grep hdmi (avec un peu de bol)

ou, sinon :
lsmod | grep snd

histoire de voir ça de plus près ?...

A+

Benbo utilisateur non connecté
# lsmod | grep hdmi 
snd_hda_codec_hdmi     36103  1 
snd_hda_codec         126728  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_pcm                97292  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd                    79242  11 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec,snd_hda_intel


...voilà pr le premier, je viens de lancer jack, c'est pareil, j'execute la deuxième commande ?

Benbo utilisateur non connecté

[+]

--> c'est plus clair comme ça !

allany utilisateur non connecté
Non, non !
Ces commandes ne servent qu'à lister les modules mais n'ont aucun autre effet.

La première me suffit.
L'opération de blacklistage sert à "mettre de côté" un module d'un pilote.
Le HDMI semble être reconnu par Alsa (pilotes), dans tous les cas, comme une carte-son indépendante.
Ca perturbe l'ordre des cartes-son et c'est pourquoi le aplay que t'as demandé olinuxx liste deux cartes au lieu d'une.
C'est un souci récurrent depuis que le HDMI est intégré aux cartes internes...

Alors, le blacklistage.
Ca consiste à créer, dans /etc/modprobe.d; un fichier blachlist-hdmi.conf.
Pour ce faire :
cd /etc/modprobe.d
sudo gedit blacklist-hdmi.conf
(mot de passe)

entre, dans l'éditeur, la ligne suivante :
blacklist snd_hda_codec_hdmi

et enregistre.
Pour réactiver ton HDMI, il te suffira de refaire la manip' en commentant cette ligne (# au début).

Une fois ceci fait, reboote et re-poste le résultat de :
lsmod | grep snd

A+

Benbo utilisateur non connecté
voilà :
$ lsmod | grep snd

[+]

allany utilisateur non connecté
Note modérateur :
les lsmod et quelques autres commandes ont tendance à bouffer la mise en page de par leur largeur.
Dans ce cas, tu sélectionnes le pavé, tu le mets en "code" (icône "inf/sup") et tu fais précéder la première balise "code" des deux caractères "*-".
Ca te mettra l'ensemble en "box" et ne s'étalera plus au-delà des marges...

Je me suis permis de le faire sur ton dernier post, d'ailleurs.

Merci, à+ cool

allany utilisateur non connecté
Tu es certain d'avoir fait la manip' point à point car là, ça n'a rien donné, visiblement.
As-tu bien rebooté ?

Envoie quand même un :
cat /etc/modprobe.d/blacklist-hdmi.conf


A+

Benbo utilisateur non connecté
ok!

Benbo utilisateur non connecté
Oui oui j'ai rebooté et il y a bien un nouveau fichier ds le dossier
$ cat /etc/modprobe.d/blacklist-hdmi.conf
blacklist snd_hda_codec_hdmi


allany utilisateur non connecté
... et un :
aplay -l

sans grandes illusions... confused

Benbo utilisateur non connecté
]$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: SB [HDA ATI SB], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


allany utilisateur non connecté
OK !
Ca ne marche donc pas comme sous Debian...

Peux tu nous poster, alors :
cat /etc/modprobe.d/blacklist.conf
car c'est peut-être là qu'il faut mettre en quarantaine le HDMI ?

A+

Benbo utilisateur non connecté

[+]

Page : 1/4  [Suivant]
1  2  3  4 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

calixtus06, 07:16, mer. 30 Nov 2022: Bonjour et bienvenue à Ikben Zogroot :-)
olinuxx, 18:07, lun. 28 Nov 2022: Bonjour et bienvenue à NicolasJ cool
calixtus06, 07:55, sam. 26 Nov 2022: Bonjour et bienvenue à Bob33 :-)
calixtus06, 08:54, mar. 22 Nov 2022: Bonjour et bienvenue à gadeu :-)
olinuxx, 10:02, dim. 20 Nov 2022: Bonjour et bienvenue à Neandertahl cool
sub26nico, 13:39, mer. 16 Nov 2022: Merci Samuel ;-)
Samuel, 21:17, lun. 14 Nov 2022: [Lien] C'est de la balle et c'est enregistré avec librazik
olinuxx, 18:53, dim. 13 Nov 2022: @christorbec : le mégaphone ne sert pas à se faire dépanner. Ouvre un fil dans le forum.
christorbec, 15:22, dim. 13 Nov 2022: changer de soundfont dans ToneLib-jam ?
calixtus06, 06:59, dim. 13 Nov 2022: Bonjour et bienvenue à Djefux :-)
calixtus06, 11:59, sam. 12 Nov 2022: Bonjour et bienvenue à zardoz45 :-)
calixtus06, 07:10, mer. 09 Nov 2022: Bonjour et bienvenue à majneb :-)