Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

4 - Toutes les autres applications, les émulateurs...

Dernier post

à propos d'Ardour 2, pb compil

bluedid29 Articles : 2795 utilisateur non connecté France
Bonsoir, cool

Sur 64 Studio 1.2.0

Ayant compilé Ardour 2 rc2, (tout fonctionne bien) j'ai essayé de faire la même chose avec la version 2 finale mais j'ai le message suivant:

scons
scons: Reading SConscript files ...
Checking for pkg-config version >= 0.8.0... (cached) yes
Checking for cairo... yes
Checking for gthread-2.0... yes
Checking for lrdf... yes
Checking for libgnomecanvas-2.0... yes
Checking for gtk+-2.0... no
gtk+-2.0 >= 2.10.0 not found.
You do not have the necessary dependencies required to build ardour
Please consult http://ardour.org/building for more information

J'ai essayé d'installer tout ce qui avait un rapport avec gtk+ mais sans succès

Sur ce site, j'ai donc essayé d'installer directement Ardour 2
ttp://gorfou.fr/contrib/ardour/ardour_2.0-1gorfou_i686.deb

mais j'ai la réponse suivante:
dpkg -i ardour_2.0-1gorfou_i686.deb
dpkg-deb: fin de fichier inattendue dans numéro de version dans ardour_2.0-1gorfou_i686.deb
dpkg : erreur de traitement de ardour_2.0-1gorfou_i686.deb (--install) :
le sous-processus dpkg-deb --control a retourné une erreur de sortie d'état 2
Des erreurs ont été rencontrées pendant l'exécution :

Je suppose que cette version ne fonctionne qu'avec Debian Etch

Bon, pour l'instant, je me contente de la version 2 rc2, c'est déjà bien wink

Mysth-R Articles : 649 utilisateur non connecté France
Citation :
Bonsoir, cool

Checking for gtk+-2.0... no
gtk+-2.0 = 2.10.0 not found.


salut !
il doit forcément rester une librairie ou quelques chose en rapport avec GTK à installer cherche bien. Sinon si tu va voir sur le site d'ardour il me semble qu'ils mettent la liste de toutes les dépendances. Tu as peut etre oublier quelques chose...
Bon courage :-)


----------------
{^_^} Mysth-R {^_^}

Mon Blog

jdlv Articles : 371 utilisateur non connecté
J'ai l'impression que tu essaye de compiler la version 2.01 et non la 2.0...
La nouvelle version va effectivement poser quelques problèmes aux distributions un peu anciennes...

joël

bluedid29 Articles : 2795 utilisateur non connecté France
Merci pour vos réponses rapides wink

Je l'ai installé à partir de la version communautaire et effectivement la librairie libgtk2.0-dev ne fonctionne qu'avec une version 2.10 au minimum.

Je vais essayer avec la version 2.0 d'Ardour

Sinon, j'attendrai ensuite la sortie prochaine de 64 Studio qui devrait normalement intégrer cette version 2.0.1

Norrin_Radd Articles : 960 utilisateur non connecté France
Citation :
dpkg-deb: fin de fichier inattendue dans numéro de version dans ardour_2.0-1gorfou_i686.deb


C'est curieux comme erreur. Le paquet a peutetre été mal généré.. Erreur de telechargement ?

Pour la compilation, Paul Davis a changé les branches
TRUNK refere maintenant à la future version 2.1
Si l'on veut compiler la version stable il faut donc telecharger l'archive 2.0 et non trunk.
Je pense qu'il doit yavoir une archive tar.gz de la derniere version 2.0 finale, plus besoin de passer par SVN, bien qu'il doit etre possible encore d'utiliser SVN, suffit de savoir comment referer a la version 2.0 et non la 2.1.

C'est en effet la version 2.1 qui demande gtk > 2.10.0


Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]


Mégaphone [Afficher / Cacher]

sub26nico, 22:38, dim. 23 Feb 2020: Salut et bienvenue à maxxbt92 et csvg :-)
sub26nico, 23:14, sam. 22 Feb 2020: Salut et bienvenue à icarius, Cernunos et BD :-)
sub26nico, 22:21, ven. 21 Feb 2020: Salut et bienvenue à math49 et Nov13 :-)
locutor99, 15:31, ven. 21 Feb 2020: I am working in / and https://www.locutortv.es
sub26nico, 11:32, jeu. 20 Feb 2020: @Sahaathyva, merci, fil de forum effacé
Sahaathyva, 10:07, jeu. 20 Feb 2020: On s est fait spammer? Pub de vente de yescards dans la section 2 forum toutes les applications . Pas légal non?
sub26nico, 22:15, mer. 19 Feb 2020: Salut et bienvenue à berangerla7 :-)
sub26nico, 08:40, mar. 18 Feb 2020: Salut et bienvenue à Mehu :-)
olinuxx, 21:44, dim. 16 Feb 2020: [ANNONCE] Une possibilité de se rencontrer autour d'une table ronde et/ou d'un atelier : [Lien]
olinuxx, 19:49, ven. 14 Feb 2020: Bonjour et bienvenue à mbj335 cool
olinuxx, 13:40, ven. 14 Feb 2020: Bonjour et bienvenue à metaalex cool
bda, 21:33, mer. 12 Feb 2020: Un générateur de grosse caisse, un générateur lo-fi et une station granulaire avec csound [Lien]