Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

> Forums de discussion > 5 - Les serveurs son : Jack, PulseAudio et autres... > [résolu]midi ALSA/JACK+problème de carte son
Dernier post

[résolu]midi ALSA/JACK+problème de carte son

WorkInProgress utilisateur non connecté France
Salut,
Je suis WorkInProgress et je suis nouveau sur le forum. Je me presente ici et j'ai créer ce topic pour répondre à mes questions au cours de mon apprentissage de la mao sous linux.
Pour résumer ma presentation j'utilise un carte audiobox usb et je fait de la batterie avec une DTXplorer brancher en midi à la carte, jutilise ubuntu studio et je découvre la mao en générale (mais je connais asser bien Ubuntu).
Pour mieux comprendre la mao je fait aussi des test avec le clavier virtuel.

Premières questions:

-J'essais de piloter Foo YC20 (simulateur d'orgue) avec le clavier virtuel seulemnt dans QJackCtl Foo apparait dans l'onglet midi uniquement et le clavier seulement dans l'onglet ALSA.
Comment faire pour connecter ces deux programmes, existe il des progammes "pont" ou une méthode pour mélanger midi et midi ALSA?
Cette question et d'autant plus importante pour moi que à l'instare du clavier virtuel, les entrée/sortie midi de ma carte sons n'apparaissent que dans l'onglet ALSA.

-Ma carte sons possede en plus des entrée/sortie midi deux entrées analogique et deux sortie ligne (L et R) ainsi qu'une sortie casque qui fait fait sortie les entrée et le son destiné aux lignes en meme temps. Pourtant je n'ai pas réussi à la faire apparaitre dans QJackCtl. Je n'arrive pas à faire sortir le sons des logiciels qui passent par JACK par cette carte alors que je peut faire sortir le sons du navigateur ou de Audacity par exemple.
Comment utiliser ma carte et ses entrées/sorties audio avec JACK ?

Salut
Citation :
je peut faire sortir le sons du navigateur ou de Audacity par exemple.


Alors c'est que jack n'est pas configuré correctement ou pas configuré du tout.
Essais de désactiver l'éventuelle carte son intégrée à la carte mère
puis dans jackctl -> réglages -> tu sélectionne juste interface ta carte son
echantillon parpériodes 256 vu que tu fait du midi
Fréquence d'échantillonnage à toi de voir... (44100 ou 48000 c'est pas mal)
période par tampon 2
le nombre de port maxi au moins 512
tu sauve tu ferme et tu rouvre jack que tu démarre puis tu ouvre Foo YC20

WorkInProgress utilisateur non connecté France
Salut et merci de ta réponse. Malheuresement ça n'as pas suffit. Tu avais raison sur le fait que je n'avais pas paramettrer JACK. Ne sachant pas quoi faire j'avais tous laisser par défaut.
Cependant j'ai mit interface à hw:1 (ma carte son) et ça n'as pas mieux marché. Le sons sort par les haut-parleurs de l'ordi alors que d'après le controlleur de volume la carte est éteinte.
Du coup j'ai aussi essayer de mettre ma carte son dans les champ "péripherique d'entrée" et "périphérique de sortie" mais c'est pas ça non plus.

Je creuse encore...

EDIT: Autant pour moi je sais pas ce qui s'est passer mais maintenant ça marche. Merci beaucoup.
Et en ce qui concerne le problème midi ALSA/JACK j'ai trouvé la solution : a2jmidid !

Bon ok on peut fermer? (un petit [résolut] en éditant ton sujet stp wink
merci!

WorkInProgress utilisateur non connecté France
Ben en fait j'ai d'autre questions comme l'indique le titre. Comme je suis en apprentissage et que je suis curieux je risque d'en avoir pas mal. Je me suis dit qu'un gros topic pour les rassembler se serait mieux que plein de petit mais si c'est pas la pratique locale alors y a pas de problème.

allany utilisateur non connecté
En tant que modérateur, je serais assez d'accord pour isoler les questions une à une.
Ca permet aux autres lecteurs, quand il voient un "résolu" devant un titre qui les questionne également, de ne pas se taper un topic en entier avec plein de sujets qui ne les branchent pas forcément.
Si ça ne t'ennuie pas, WIP, bien que ton idée soit logique, alors procédons plutôt comme ça, si tu es en accord...
A bientôt, alors ?...

WorkInProgress utilisateur non connecté France
Ok sa marche pas de problème. Par contre du coup je vais trouver un titre plus explicite sinon ça n'a aucun sens.

allany utilisateur non connecté
Cool, merci !

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

funroad34, 15:50, lun. 20 Sep 2021: c est surtout lors de la connection que ça rame sinon c 'est correct niveau timming a l'ouverture des pages..
funroad34, 15:43, lun. 20 Sep 2021: slt Oui patience et perseverence...
Houston4444, 11:17, lun. 20 Sep 2021: Ici on apprend la patience, bientôt la cafetière aura terminé sa mission avant que la page soit chargée...
sub26nico, 17:50, dim. 19 Sep 2021: pas de souci ici
funroad34, 14:14, dim. 19 Sep 2021: Bonjour idem chez moi
Geis007, 18:03, sam. 18 Sep 2021: binjch, c'est très lent, en effet !
binjch, 22:51, ven. 17 Sep 2021: Salut c'est hyper lent chez tout le monde là? Ou c'est moi qui ai un problème?
olinuxx, 18:46, jeu. 16 Sep 2021: Bonjour et bienvenue à pierre2 cool
zicstef, 22:40, mer. 15 Sep 2021: Hello, il y a bien longtemps que je n'ai pas eu la joie de passer. Découvert au détour d'un surf: /
olinuxx, 18:30, lun. 13 Sep 2021: [INFO] nouveau compte Diaspora pour linuxmao : [Lien] Venez nous y rejoindre cool
Samuel, 02:44, dim. 12 Sep 2021: [Lien] C'est la video de présentation du futur de VCV RACK, un synthé modulaire
olinuxx, 18:55, jeu. 09 Sep 2021: @dugalandco : utilises le forum pour mener des discussions. Le mégaphone n'est pas utilisé pour des discussions, mais pour informer de façon rapide.