Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Forum dédié à Ardour

Dernier post

compiler ardour 2.x

seal20 utilisateur non connecté Portugal
Bonjour,

je vais certainement poser une question crétine, mais ... j'ai installé toutes les dépendences necessaires et là, au moment de lancer l'installation d'ardour 2.0.2, je ne vois pas les commandes à lancer.
j'ai récuperé ardour-2.0.2.tar.bz2, mais je ne trouve rien dedans pour lancer l'instalation ...eek
./configure ? ... make ?...

joseph_desiré utilisateur non connecté France
scons à installer... faut lire le README.

joseph_desiré utilisateur non connecté France
pis compile la 2.0.3

seal20 utilisateur non connecté Portugal
bin oui, ça me renvoie à build, qui me renvoie à la page sur ardour.org

"scons", je pensais que c'etait un passage d'install pour mac ... bon, j'ai fait, et j'obtiens :
scons
scons: *** No SConstruct file found.
File "/usr/lib/scons/SCons/Script/init.py", line 870, in _main

...

joseph_desiré utilisateur non connecté France
ah... euh bizarre. Tu essaies de compiler quelle version de Ardour ? Quelle version de Scons ? (quel OS aussi pendant qu'on y est ?).

bluedid29 utilisateur non connecté France
Sur Ubuntu Studio, j'ai donc téléchargé avec ce lien :
svn co http://subversion.ardour.org/svn/ardour2/branches/2.0-ongoing

Puis installé ces paquetages via synaptic

* esvn (0.6.11+1-2) (pour le téléchargement via svn)
* scons (0.96.95-2) (pour l'installation)
* automake (1:1.10+nogfdl-1)
* automake 1.9 (1.9.6+nogfdl-3)
* bison-1.35 (1.35-4.1)
* byacc (20050813-1)
* libboost-dev (1.33.1-10)
* libdmalloc4 libdmalloc-dev (5.4.2-5)
* libflac-dev (1.1.2-5)
* libgnomecanvas (2.14.0-2)
* libjack-dev (0.102.20-2)
* liblo0 liblo0-dev
* liblrdf0 liblrdf0-dev (0.4.0-1)
* libraptor1 libraptor1-dev (1.4.13-1)
* libsamplerate0-devel (0.1.2-2)
* libsndfile1 libsndfile1-dev (1.0.16-1)
* libtool (1.5.22-4)
* libusb-dev (2:0.1.11-2)
* libxml2 libxml2-dev (2.6.27.dfsg-1)
* pkg-config (0.21-1)

J'ai rajouté libasound2-dev (qui manquait par rapport aux anciennes compilations d'Ardour 2)

Puis ;
sudo scons
et enfin ;
sudo scons install

Le dernier ardour 2.0.3 est tout frais sur mon ordi ! (faut juste que je le lance en mode console, j'ai oublié de désinstaller l'ancienne version rolleyes

Elle est pas belle la vie wink

Bonne journée cool

seal20 utilisateur non connecté Portugal
j'essaie d'installer la version ardour 2.02, avec scons-0.96.1-1mdk.noarch, sur une mandriva 2006 ...

bluedid29 utilisateur non connecté France
J'ai des doutes sur l'installation d'Ardour 2 sur Mandriva 2006 à cause des dépendances demandées, il est peut être préférable de passer sur Mandriva 2007.1 Spring qui est bien meilleure et comme j'ai déjà compilé / installé Ardour 2 dessus, cela devrait le faire (voir tuto compiler ardour) ! wink

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

calixtus06, 07:55, sam. 26 Nov 2022: Bonjour et bienvenue à Bob33 :-)
calixtus06, 08:54, mar. 22 Nov 2022: Bonjour et bienvenue à gadeu :-)
olinuxx, 10:02, dim. 20 Nov 2022: Bonjour et bienvenue à Neandertahl cool
sub26nico, 13:39, mer. 16 Nov 2022: Merci Samuel ;-)
Samuel, 21:17, lun. 14 Nov 2022: [Lien] C'est de la balle et c'est enregistré avec librazik
olinuxx, 18:53, dim. 13 Nov 2022: @christorbec : le mégaphone ne sert pas à se faire dépanner. Ouvre un fil dans le forum.
christorbec, 15:22, dim. 13 Nov 2022: changer de soundfont dans ToneLib-jam ?
calixtus06, 06:59, dim. 13 Nov 2022: Bonjour et bienvenue à Djefux :-)
calixtus06, 11:59, sam. 12 Nov 2022: Bonjour et bienvenue à zardoz45 :-)
calixtus06, 07:10, mer. 09 Nov 2022: Bonjour et bienvenue à majneb :-)
olinuxx, 10:34, lun. 07 Nov 2022: C'est légal, c'est génial, lève toi, met ton futal et lit l'éditorial ! cool
r1, 22:22, dim. 06 Nov 2022: Cet éditorial tombe pil-poil ! Merci de ne pas luj réserver un accueil glacial :-)