Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

4 - Toutes les autres applications, les émulateurs...

> Forums de discussion > 4 - Toutes les autres applications, les émulateurs... > [contourné] partition jazz avec lilypond
Dernier post

[contourné] partition jazz avec lilypond

papymusic Articles : 296 utilisateur non connecté
bonjour,
Après avoir réussi a ecrire une premiere partition avec lilypond, c'est pas mal mai, je voudrais ecrire une partition façon Jazz.
J'ai trouvé sur internet un document qui traite de ce sujet: lilyPond french user- lilyjazz ou l'on trouve le code a rentrer dans frescobaldi ce que j'ai fait cela n'a pas été couronné de succès voir ma photo:
Image
tout dabord il est dit version de lilypond 2.16 mais moi sous DEBIAN j'ai 2.14 est-ce un problème?
la compile plante sur la commande jazzOn.
voila mes déboires
Par avance merci

romain_bar Articles : 104 utilisateur non connecté France
Bonjour,

La première étape c'est d'installer les deux polices de caractère LilyJAZZ.otf et LilyJAZZText.otf dans un endroit où LilyPond les trouvera. Le plus simple c'est de les mettre dans ~/.fonts/otf/, ou sinon dans le système : /usr/share/lilypond/current/fonts/otf

Ensuite il mettre LilyJAZZ.ily à disposition de LilyPond, dans /usr/share/lilypond/2.14/ly/

Maintenant Frescobaldi devrait marcher avec le fichier d'exemple.

Romain

papymusic Articles : 296 utilisateur non connecté
merci Romain pour ta réponse.

bon je dois encore oublier quelque chose:
j'ai mis le fichier LilyJAZZ.otf et lilyJAZZ.ext.otf
dans mon dossier personnel.
et sur le terminal j'ai lancé la copie mais bon cela ne va pas voila la photo :
Image
A+

romain_bar Articles : 104 utilisateur non connecté France
Pour les polices il faut d'abord vérifier le répertoire d'installation de lilpyond dans la console :
ls /usr/share/lilypond/

Pour moi ça donne 2.16.2

Du coup la commande sera :
sudo cp LilyJAZZ.otf LilyJAZZText.otf /usr/share//lilypond/2.16.2/fonts/otf/

C'est-à-dire qu'on le met dans le même répertoire que les polices de base de Lilypond (emmentaler-*).

Même principe pour le fichier LilyJAZZ.ily qu'il faut mettre (toujours dans mon cas) dans /usr/share//lilypond/2.16.2/ly/
Pour toi ce sera un 2.14 (ou 2.14.1 ou ...) au lieu de 2.16.2.

papymusic Articles : 296 utilisateur non connecté
Merci Romainlol
Je viens de graver l'exemple JAZZ, il me reste donc a écrire une partition en jazz.

Cependant je voudrais te demander encore une chose, j'aimerai pouvoir ne faire que 4 mesure par ligne
a tu une solution? j'ai n'ai rien vu dans la documentation ou je ne sais pas lire

romain_bar Articles : 104 utilisateur non connecté France
La commande \break permet de passer à la ligne quand tu as envie. Il faut la rajouter toutes les 4 mesures.
Sinon tu peux aussi ajouter une deuxième voix où rassembler tous les retours à la ligne :

\version "2.14"

   \score {
   <<
      \new Staff {
        a'1 a' a' a'  a' a' a' a'
        a' a' a' a'  a' a' a' a'
        a' a' a' a'  a' a' a' a'
      }

      \new Voice {
        s1*4 \break
        s1*4 \break
        s1*4 \break
        s1*4 \break
        s1*4 \break
      }
    >>
    }


La doc est ici : http://lilypond.org/doc/v2.16/Documentation/notation/explicit-staff-and-system-positioning.fr.html

papymusic Articles : 296 utilisateur non connecté
bonjour,
Merci de m'avoir donner la commande, je m'aperçoie que la doc que tu me recommande, j'étais passé dessus mais j'avais pas compris que c'était la doc que je cherchais. confused

Conclusion: je dois lire d'abord la doc et je pense en avoir pour un petit moment.

je suis capable de créer des partitions en présentation standard

Par contre quand je veux me servir de la version JAZZ j'obtiens bien un pdf complet,quand je grave, mais dans le journal je suis en erreur il me réclame la version:2.16 et je suis en 2.14 . deux photo pour expliquer cela:
Image
et un extrait du journal:
Image

Ma question est: peut-on charger la version 2.16 sans dommage? je suis sous DEBIAN version 7.0 wheezy

Flo Articles : 430 utilisateur non connecté
Tu es sûr que c'est 2.14.2 qui est indiqué comme version au début du fichier .ly ?

Sinon c'est toujours possible d'installer une version plus récente sans toucher au système avec le scirpt disponible sur le site de lilypond.

Flo

papymusic Articles : 296 utilisateur non connecté
Salut Flo,
non c'est la 2.16.0 qui est indiqué, j'ai modifié a la main la version mais chaque fois que je compile la version revient en 2.16.0
donc il me faut au moins la version 2.16. Mais manque de pot je suis sous Débian wheezy et lilypond est encore en 2.14.2 ,
donc il va falloir que j'attende,
je vais devoir inscrire un abandon dans le titre de mon message
merci et A+

Flo Articles : 430 utilisateur non connecté
C'est bizarre, normalement Fresobaldi ne doit pas modifier ton fichier à la compilation.

Sinon comme je l'ai écrit plus haut, tu peux installer une version plus récente de Lilypond avec l'installeur : http://lilypond.org/unix.fr.html

papymusic Articles : 296 utilisateur non connecté
Bonjour,
Effectivement je ne comprend pas cette modification.
Je pense donc comme toi qu'il faille installer une version plus récente de LilyPond.

mMon problème est, que je ne voudrais pas casser tout mon environement car se fut pour moi un long parcourt.
Peut etre existe-il un moyen pour faire cohabiter deux version de lylipond? qui me permeterai de revenir en arriere.

De toute façon je peux vivre avec une présentation classique des partitions, en attendant l'intégration de lilypond 2.16
A+

papymusic Articles : 296 utilisateur non connecté
bonjour,
j'ai sur un autre PC sous LMDE installé Lilypond 2.16.2
et installé les fichiers Jazz cités plus haut
et maintenant j'ai de belles partitions Jazz.

j'attends donc la prochaine version de DEBIAN pour
installer Lilypond sur mon PC habituel (celui qui me sert pour la MAO)

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 21:29, mer. 22 Sep 2021: Bonjour et bienvenue à tezere cool
funroad34, 15:50, lun. 20 Sep 2021: c est surtout lors de la connection que ça rame sinon c 'est correct niveau timming a l'ouverture des pages..
funroad34, 15:43, lun. 20 Sep 2021: slt Oui patience et perseverence...
Houston4444, 11:17, lun. 20 Sep 2021: Ici on apprend la patience, bientôt la cafetière aura terminé sa mission avant que la page soit chargée...
sub26nico, 17:50, dim. 19 Sep 2021: pas de souci ici
funroad34, 14:14, dim. 19 Sep 2021: Bonjour idem chez moi
Geis007, 18:03, sam. 18 Sep 2021: binjch, c'est très lent, en effet !
binjch, 22:51, ven. 17 Sep 2021: Salut c'est hyper lent chez tout le monde là? Ou c'est moi qui ai un problème?
olinuxx, 18:46, jeu. 16 Sep 2021: Bonjour et bienvenue à pierre2 cool
zicstef, 22:40, mer. 15 Sep 2021: Hello, il y a bien longtemps que je n'ai pas eu la joie de passer. Découvert au détour d'un surf: /
olinuxx, 18:30, lun. 13 Sep 2021: [INFO] nouveau compte Diaspora pour linuxmao : [Lien] Venez nous y rejoindre cool
Samuel, 02:44, dim. 12 Sep 2021: [Lien] C'est la video de présentation du futur de VCV RACK, un synthé modulaire