Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Le site : philosophie, organisation, problèmes...

> Forums de discussion > 3 - Le site : philosophie, organisation, problèmes... > Bogue concernant les formulaires de création de page (était : "Bug sur plugin ~hs~")
Dernier post

Bogue concernant les formulaires de création de page (était : "Bug sur plugin ~hs~")

Salut

Y'a un joli bug avec le plugin ~hs~ arrow CdrTools

olinuxx utilisateur non connecté France
Je suppose que tu as créé la page à l'aide du formulaire. (C'est dans ce cas que ce bogue apparait).
Pour le corriger il faut, lors de l'édition de la page, cliquer sur l'onglet "propriétés" et décocher l'option "permettre le HTML".
J'en ai déjà fait part à pianolivier.

olinuxx utilisateur non connecté France
Pianolivier, je ne crois pas que l'on se serve de cette option quelque part sur le site ? Si j'ai bien raison, alors on peut tout simplement désactiver cette option dans le panel d'admin. Dites moi.

Oui c'est en utilisant le formulaire mais la fonction permettre le html fonctionnait déjà à l'époque de tiki 9 et on avait déja le formulaire. La fonction permettre le html on en a besoin pour certains plugin comme l'affichage des vidéos dailymotion youtube des chose comme ça quoi ...

pianolivier utilisateur non connecté France
On doit pouvoir désactiver et utiliser le plugiciel HTML là où il y a besoin.

Oliv'

olinuxx utilisateur non connecté France
Bon, j'ai désactivé la fonction "Permettre le html" qui se trouve dans le premier onglet de tiki-admin.php?page=wiki.
J'ai créé une page-logiciel bidon à l'aide de Créer une page.
Le bogue est toujours présent.

Du coup, j'ai ré-activé la fonction "Permettre le html" puis j'ai édité la page-bidon en question et là, j'ai vu que dans l'onglet "Propriétés", la case "Permettre le html" était cochée.

À noter, que si :
  • j'utilise le formulaire de création d'une page "non-logiciel" de la page Créer une page, le bogue se produit aussi.
  • je crée une page en insérant ((trucmuche)) puis en cliquant sur le point d'interrogation ainsi créé après la publication, alors le bogue ne se produit pas.

Conclusion, on dirait donc que c'est l'utilisation du formulaire qui d'une façon ou d'une autre "force" cette option à être cochée.

J'ai lu un peu la doc sur les trackers de doc.tiki.org et je n'ai rien trouvé. J'ai les yeux qui tombent. Si vous avez une idée, c'est à vous.

Moi je dirait que le bug est dans le tracker lui même et que il faudrait en refaire un nouveau à l'identique puis tester voir ce qu'il dit ?

Citation :
À noter, que si :

j'utilise le formulaire de création d'une page "non-logiciel" de la page Créer une page, le bogue se produit aussi.
je crée une page en insérant trucmuche? puis en cliquant sur le point d'interrogation ainsi créé après la publication, alors le bogue ne se produit pas.


Par contre si on utilise la fonction créer une page à partir de la liste des pages pas de soucis ...(testé je ne sais plus quand ça marchait très bien ...)

pianolivier utilisateur non connecté France
J'ai regardé de mon coté, et n'ai rien trouvé à faire du coté du formulaire pour régler ce problème.

Ajouté à la liste des bugs

oliv'

olinuxx utilisateur non connecté France
Merci pour ça pianolivier.

olinuxx utilisateur non connecté France
Note modération : (remontée de maintenance pour ne pas perdre le fil).


Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 09:25, mar. 15 Jun 2021: Bonjour et bienvenue à Hexaal :-)
Ubuntu_Studio_User, 02:29, lun. 14 Jun 2021: Salut à tous...
allany, 12:12, sam. 12 Jun 2021: @tourneriff : merci pour le signalement, c'est fait !
tourneriff, 07:52, sam. 12 Jun 2021: Bonjour à tous ☺ ! Avis aux modos : pourrait-on voir la "joute 16" en cours à l'accueil du site plutôt que l'antique "joute 15"
sub26nico, 14:56, jeu. 10 Jun 2021: Salut et bienvenue à jamesonmount, freerawsound et Loop :-)
ycollet, 10:28, mer. 09 Jun 2021: Cool, un revival de rakarrak ! [Lien]
sub26nico, 22:08, lun. 07 Jun 2021: Bonjour et bienvenue à ArchLinux59, Djobi et gakgakgak :-)
olof, 09:27, lun. 07 Jun 2021: ardour 6.7 build tourne chez moi, mais pas le package 6.6
allany, 14:46, dim. 06 Jun 2021: @r1 : t'as raison : trop c'est trop, ça sature du goulot !
r1, 22:54, sam. 05 Jun 2021: Mon cerveau a bobo à force de faire le gogo sur l'annonce de l'édito !
allany, 11:49, sam. 05 Jun 2021: Z'ont encore abattu un sacré boulot, les poulbots de l'édito ! [Lien]
ycollet, 20:37, ven. 04 Jun 2021: Un article intéressant sur un truc à venir sur USB audio: [Lien]